
1ESA UNCLASSIFIED - For ESA Official Use Only 1

SNAP - Sentinel Application Platform

Magdalena Fitrzyk – RSAC c/o ESA



2

SNAP – Sentinel Application Platform

✓ Free and open source software 

✓ Common Java core framework 

✓ Joint development of SNAP platform for Sentinels and other 

satellite data

✓ Interchangeable Java/Python plugins

✓ Portable engine to Cloud infrastructure

✓ User friendly: single installation, intuitive GUI, online help, 

tutorials, active user forum

SNAP
SeNtinel Application 

Platform

Sentinel-1 Toolbox

Sentinel-2 Toolbox

Sentinel-3 Toolbox

SMOS Toolbox

Download it at

step.esa.int
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SNAP downloads

SNAP downloads exceeded 1˙725˙000 from June 2015 until today 
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SNAP Microwave Toolbox

Main features: 

➢ Data calibration, Multilooking, Speckle filtering, Precise orbits handling (auto download) 

➢ Coregistration of detected and complex products

➢ Full support of Sentinel-1 TOPS interferometry, debursting, slice assembly

➢ ETAD correction (Extended Timing Annotation Dataset)

➢ Terrain Correction

➢ SAR simulation and Layover and shadow masks

➢ Applications: offset tracking, oil spill detection, ship detection, wind field estimation etc.

➢ Compatibility with PolSARpro Toolbox (Polarimetric tool)

➢ Integrated Export to SNAPHU (interferometric phase unwrapping) and STAMPS (PS 

InSAR)

Sentinel-1 ENVISAT ERS-1 TerraSAR-X ALOS 1&2KOMPSAT-5RADARSAT ICEYE COSMO-SkyMed

Coming soon in
SNAP 13
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Sentinel-1 characteristics 

Radar imaging mission, constellation of two polar-orbiting satellites 

providing continuous all-weather, day and night imagery for Land and 

Maritime Monitoring

Main features:

→ C-band (5.4 GHz) SAR 

→ Daily coverage of high priority areas;

→ Bi-weekly global coverage;

→ 12 days repeat cycle (6 days with both Sentinels 1A and 1C 
operational);Sentinel 1B ended operations in 2022

→ 7 years design life time (consumables for 12 years).

Applications: 

→ Land, Ice and marine monitoring

→ Mapping in support of humanitarian aid in crisis situations
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Sentinel-1 A & C Data 

Sentinel-1 products available for users

Level 1

➢ Ground Range Detected (GRD) SAR data that 

has been detected, multi-looked and projected 

to ground range

➢ Single Look Complex (SLC) images in the slant 

range by azimuth imaging plane, in the image 

plane of satellite data acquisition. Each image 

pixel is represented by a complex number

Level 2

➢ The OCN (Ocean) products are specifically 

processed radar data products for 

oceanographic applications.
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SNAP  Optical Toolbox

Main features:

➢ Tools for manipulation and processing of raster data

➢ Reflectance to Radiance Processor 

➢ L2B biophysical processor (LAI, fAPAR, …)

➢ Radiometric Indices

➢ Vegetation indices: DVI, RVI, PVI, IPVI, WDVI, TNDVI, GNDVI, GEMI, ARVI, NDI45, MTCI, MCARI, REIP, S2REP, IRECI, 

PSSRa

➢ Soil indices: SAVI, TSAVI, MSAVI, MSAVI2, BI, BI2, RI, CI

➢ Water indices: NDWI, NDWI2, MNDWI, NDPI, NDTI

➢ Sen2Cor and i-Cor for Atmospheric Correction 

➢ IdePix Processor: pixel classification

➢ Processors specific for S3 OLCI products: Optical water type classification based on atmospherically corrected 

reflectances, FU (Forel-Ule) Classification and many more

Sentinel-2 and 3 SPOT Pleiades Landsat ALOS AVNIR RapidEye Kompsat Ikonos Worldview

……
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Sentinel-2 characteristics 

Optical mission for the monitoring of land and coastal regions

Main features:

→ Constellation of two identical satellites

→ Each satellite carries an innovative wide swath high-resolution 
multispectral imager with 13 spectral bands 

→ 10 days repeat cycle (5 days with both Sentinels 2B and 2C; Sentinel 2C 
replaced Sentinel 2A in January 2025)

→ Swath of 290km



9

Sentinel-2 products

SENTINEL-2 products available for users are:

Level-1B
➢ Radiometrically corrected Top-Of-Atmosphere (TOA) radiance 

in sensor geometry
➢ Includes refined geometric model used to generate Level 1C 

products

Level-1C
➢ Top-Of-Atmosphere reflectances in cartographic geometry
➢ Systematic generation and online distribution

Level-2A
➢ Botton-Of-Atmosphere reflectances in cartographic geometry
➢ Systematic and on-User side (using SNAP)

.
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Sentinel-2 applications

Band 11B11

Regional to Urban Applications

Geology

Emergency management

Global Land use

& change

Coastal zones/bathymetry

Glaciers & Ice

Land cover classification, high 
resolution layers & change.

Agriculture, Forests & Carbon, 
Vegetation monitoring

Water quality
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Sentinel-3 is an ocean and land mission and provides data continuity for the ERS, ENVISAT and SPOT-VGT satellites.

SENTINEL-3 makes use of multiple sensing instruments to accomplish its objectives:

➢ SLSTR (Sea and Land Surface Temperature Radiometer)

➢ OLCI (Ocean and Land Colour Instrument)

➢ SRAL (SAR Altimeter)

➢ DORIS (Doppler Orbitography and Radiopositioning Integrated by Satellite)

➢ MWR (Microwave Radiometer)

Sentinel-3 products
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Optical data processing in SNAP for 

Agricultural applications
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Sentinel-2 pre-processing

Essential pre-processing steps:

Resampling

The S2 products are multi-size
• B2, B3, B4 and B8 @ 10m
• B5, B6, B7, B8A, B11 and B12 @ 20m
• B1, B9 and B10 @ 60m

Needed if the user wants to combine bands with different 

spatial resolution

Subset (spatially/spectrally)

The S2 data are distributed in tiles 100x100 km2 ortho-images in UTM/WGS84 projection.

Needed if the AOI covers a portion of the S2 scene or if only a subset of bands are useful in the next step (this will reduce the 
computation time)

Re-projection

If the AOI covers more than one S2 tile in different UTM zones the user needs to re-project in a common CRS before to mosaic 
them.

If the user wants to merge different data sources projected in different CRS.

To export the view in KMZ and visualise your output in Google Earth.
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Open a Sentinel-2 data

Click on ‘File’ → ‘Open Product…’ → select the .SAFE file
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Visualize Sentinel-2 data

S2 L1C (Refl TOA) S2 L2A (surface Refl BOA)
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Resampling

1) Select the product in the Product Explorer window.

2) Click on ‘Raster’ → ‘Geometric Operations’ → ‘Resampling’

In the pop-up window set up the 
parameters as shown in the Figures:

✓ Unselect ‘Save as:’

✓ ‘10m’ as pixel resolution

✓ ‘Nearest’ as Upsampling method

✓ Click on ‘Run’
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Subset (spatially/spectrally)

1) Select the new product in the Product Explorer window.

2) Click on ‘Raster’ → ‘Subset…’

In the pop-up window set up the 
parameters as shown in the Figures:

✓ Define the X and Y pixels range or 
the X and Y geo-coordinates to 
crop the input product

✓ Define which bands you want to 
export

✓ Click on ‘Run’
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Band Maths (e.g. NDVI)

1) Select the product in the Product Explorer window.

2) Click on ‘Raster’ → ‘Band Maths…’

In the pop-up window set up the 
parameters as shown in the Figures:

✓ Change the Name: ‘NDVI’

✓ Unselect ‘Virtual’ box

✓ Click on ‘Edit Expression…’

✓ Create your expression using ‘@’ 
and after replace them with the 
bands

✓ (@ - @) / (@ + @)

✓ (B8 – B4) / (B8 + B4)

✓ Click on ‘Run’



19

Output Visualization

When the processing is finished the output will be automatically opened in the ‘Product Explorer’ of SNAP Select the 
product in the Product Explorer window.

Using the Colour Manipulation (bottom left) you can modify the colour palette.
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Radiometric Indices

Vegetation indices Soil indices Water indices

SAVI, TSAVI, MSAVI, MSAVI2

DVI, RVI, PVI

NDVI, WDVI, TNDVI, GNDVI

GEMI

ARVI

NDI45

MTCI, MCARI, PSSRa

S2REP, REIP, IRECI

RI

BI

BI2

GEMI

MNDWI

NDWI

NDWI2

NDPI

NDTI

Radiometric indices are quantitative measures of features that are obtained by combining 

several spectral bands
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Radiometric Indices (e.g. NDVI)

𝐵8 − 𝐵4

(𝐵8 + 𝐵4)

𝑁𝐼𝑅 − 𝑅𝑒𝑑

(𝑁𝐼𝑅 + 𝑅𝑒𝑑)
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Biophysical processor (L2B)

1) Select the new product in the Product Explorer window.

2) Click on ‘Optical’ → ‘Thematic Land Processing’ → ‘Biophysical processor (LAI, fAPAR, …)’

In the pop-up window set up the 
parameters as shown in the Figures:

✓ Unselect ‘Save as:’

✓ Select only ‘LAI’

✓ Click on ‘Run’

Top-of-canopy normalized 
reflectance data -> set of 
biophysical variables

• LAI: Leaf Area Index
• fAPAR: Fraction of Absorbed 

Photosynthetically Active Radiation
• FVC: Fraction of vegetation cover
• Cab: Chlorophyll content in the leaf
• CWC: Canopy Water Content
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GraphBuilder

The Graph Builder allows the user to assemble graphs from a list of available operators and connect operator nodes to their sources.

Right click on the top panel to add an Operator.
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GraphBuilder

We can create our processing chain adding to the default 
blocks ‘Read’ and ‘Write’:

‘Rempling’

‘Raster’ → ‘Geometric’ → ‘Resample’

‘Subset’

‘Raster’ → ‘Geometric’ → ‘Subset’

‘Band Maths’

‘Raster’ → ‘BandMaths’

‘S2rep’ (S2 Red-Edge Position Index)

‘Optical’ → ‘Them. Land Proc.’ → ‘Veg. Rad. Ind.’ → ‘S2repOp’

‘Biophysical Processor’

‘Optical’ → ‘Thematic Land Processing’ → ‘BiophysicalOp’

‘Band Merge’

‘Raster’ → ‘BandMerge’
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GraphBuilder (Resample module)
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GraphBuilder (Subset module)



27

GraphBuilder (BandMaths module)
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GraphBuilder (S2repOp module)

The Sentinel-2 Red-Edge Position Index algorithm is based on linear interpolation, as presented by Guyot and Baret (1988).
Red edge, as the inflection point of the strong red absorption to near infrared reflectance, includes the information of both crop (chlorophyll content) N and 
growth status.

705 + 35 ×

𝑅𝑒𝑑 + 𝑁𝐼𝑅
2

− 𝑅𝑒𝑑2

(𝑅𝑒𝑑3 − 𝑅𝑒𝑑2)

705 + 35 ×

𝐵4 + 𝐵7
2

− 𝐵5

(𝐵6 − 𝐵5)
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GraphBuilder (BiophysicalOp module)

The Biophysical Processor computes Level-2B Biophysical products 
from Sentinel-2 reflectances.
From Bottom Of Atmosphere normalized reflectance data, it derives a 
set of biophysical variables, namely:

✓ LAI: Leaf Area Index
✓ fAPAR: Fraction of Absorbed Photosynthetically Active Radiation
✓ FVC: Fraction of vegetation cover
✓ Cab: Chlorophyll content in the leaf
✓ CWC: Canopy Water Content
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GraphBuilder (Band Merge module)
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GraphBuilder (Save the graph)
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Batch Processing

The Batch Processing tool allows you to execute a single reader/writer graph for a set of products. Select the Batch Processing tool 
from the Graphs menu and then press the "Load" button to browse for a previously saved graph. Next, add products in the I/O tab 
by pressing the "Add" button. Set the target folder where the output will be written to and then press "Run“.
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Time Series

Open them in SNAP and then open the Time Series Window. ‘View’ → ‘Tool Windows’ → ‘Radar’ → ‘Time Series’ 
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Time Series

To populate the time series you can add all the products opened in SNAP or browsing from your disk.
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Time Series
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Radar data processing in SNAP for 

Agricultural applications
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Introduction

Input data: time series of Sentinel-1 GRDH images

Output: temporal backscatter signatures for various crops
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Sentinel-1 level 1 GRDH – what’s that?

Available products
•Level 0 (L0-RAW) 
•Level 1 Ground Range Detected, Multi-Looked, projected to ground range using Earth ellipsoid model WGS84-
Medium Resolution (L1-GRDM) and High Resolution (L1-GRDH) 
•Level 1 Single-Look Complex (L1-SLC) 
•Level 2 Ocean (L2-OCN)

REMEMBER 

In GRD data

➢ Ground range coordinates are the slant range coordinates projected onto the ellipsoid of the Earth. 

➢ Pixel values represent detected amplitude – the power of reflected signal which depends on the surface 

scattering characteristics

➢ Phase information is lost. 

➢ The resulting product has approximately square resolution pixels and square pixel spacing with reduced 

speckle at a cost of reduced spatial resolution.
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Scattering mechanisms
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Data processing

➢ Creating a subset of S1 GRDH images

Spatial subset depending on the AOI
➢ Radiometric calibration

Conversion of image intensity to sigma0 providing the radar backscatter
➢ Terrain correction

 Compensate for geometric distortions caused by topographical variations of a 
scene and the tilt of satellite sensor

➢ Creating a multitemporal stack

Collocation spatially overlapping products (based on geolocation)
➢ Speckle filtering

Filtering the inherent salt and pepper like texturing called speckles
➢ Linear to dB conversion

Compensate for very high dynamic range in visualisation
➢ Stack statistics 

Analysis of temporal backscatter signatures
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Data preparation

Opening the S1 data
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Data preparation
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Spatial subset
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Spatial subset - parameters
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Data check
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Data processing

➢ Creating a subset of S1 GRDH images

Spatial subset depending on the AOI
➢ Radiometric calibration

Conversion of image intensity to sigma0 providing the radar backscatter
➢ Terrain correction
 Compensate for geometric distortions caused by topographical variations of a scene and 
the tilt of satellite sensor
➢ Creating a multitemporal stack

Collocation spatially overlapping products (based on geolocation)
➢ Speckle filtering

Filtering the inherent salt and pepper like texturing called speckles
➢ Linear to dB conversion

Compensate for very high dynamic range in visualisation
➢ Stack statistics 

Analysis of temporal backscatter signatures
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Radiometric Calibration

Pixel values can be directly related to the radar backscatter 
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Data processing

➢ Creating a subset of S1 GRDH images

Spatial subset depending on the AOI
➢ Radiometric calibration

Conversion of image intensity to sigma0 providing the radar backscatter
➢ Terrain correction

 Compensate for geometric distortions caused by topographical variations of a 
scene and the tilt of satellite sensor

➢ Creating a multitemporal stack
Collocation spatially overlapping products (based on geolocation)

➢ Speckle filtering
Filtering the inherent salt and pepper like texturing called speckles

➢ Linear to dB conversion
Compensate for very high dynamic range in visualisation

➢ Stack statistics 
Analysis of temporal backscatter signatures
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Geocoding
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Geocoding
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Data check
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Spatial subset – batch processing with automatic 

processing graph
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Spatial subset - automatic processing graph

Parameters of the subset 
(e.g. spatial extent)
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Spatial subset – batch processing

Adding data products
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Spatial subset – batch processing
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Data check



57

Automatic Processing Graph – Calibration, Terrain 

Correction

save as e.g. Cal_TC.xml
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Batch processing

Open previously saved graph  Cal_TC.xml
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Time series analysis

Add your data products
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Time series analysis

Bands filter

Show plot at 
cursor position

Choose your 
processed 
data products
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Time series analysis

One of the plottet 
bands has to be 
opened
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Data processing

➢ Creating a subset of S1 GRDH images

Spatial subset depending on the AOI
➢ Radiometric calibration

Conversion of image intensity to sigma0 providing the radar backscatter
➢ Terrain correction

 Compensate for geometric distortions caused by topographical variations of a 
scene and the tilt of satellite sensor

➢ Creating a multitemporal stack

Collocation spatially overlapping products (based on geolocation)
➢ Speckle filtering

Filtering the inherent salt and pepper like texturing called speckles
➢ Linear to dB conversion

Compensate for very high dynamic range in visualisation
➢ Stack statistics 

Analysis of temporal backscatter signatures
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Creating multitemporal stack

• Product geolocation (if terrain 
corrected)

• Orbits (if not terrain corrected)

Collocating spatially 
overlapping images
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Data processing

➢ Creating a subset of S1 GRDH images

Spatial subset depending on the AOI
➢ Radiometric calibration

Conversion of image intensity to sigma0 providing the radar backscatter
➢ Terrain correction

 Compensate for geometric distortions caused by topographical variations of a 
scene and the tilt of satellite sensor

➢ Creating a multitemporal stack

Collocation spatially overlapping products (based on geolocation)
➢ Speckle filtering

Filtering the inherent salt and pepper like texturing called speckles
➢ Linear to dB conversion

Compensate for very high dynamic range in visualisation
➢ Stack statistics 

Analysis of temporal backscatter signatures
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Multitemporal speckle filtering

Spatial filtering with weighted average of selected filter across the images of the time series
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Multitemporal speckle filtering

Not filtered Filtered
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Data processing

➢ Creating a subset of S1 GRDH images

Spatial subset depending on the AOI
➢ Radiometric calibration

Conversion of image intensity to sigma0 providing the radar backscatter
➢ Terrain correction

 Compensate for geometric distortions caused by topographical variations of a 
scene and the tilt of satellite sensor

➢ Creating a multitemporal stack

Collocation spatially overlapping products (based on geolocation)
➢ Speckle filtering

Filtering the inherent salt and pepper like texturing called speckles
➢ Linear to dB conversion

Compensate for very high dynamic range in visualisation
➢ Stack statistics 

Analysis of temporal backscatter signatures
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Conversion from linear to dB
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Conversion from linear to dB
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Linear vs dB comparison
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Scatterplots

Select your data stack

Select bands that 
you want to plot
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Data processing

➢ Creating a subset of S1 GRDH images

Spatial subset depending on the AOI
➢ Radiometric calibration

Conversion of image intensity to sigma0 providing the radar backscatter
➢ Terrain correction

 Compensate for geometric distortions caused by topographical variations of a 
scene and the tilt of satellite sensor

➢ Creating a multitemporal stack

Collocation spatially overlapping products (based on geolocation)
➢ Speckle filtering

Filtering the inherent salt and pepper like texturing called speckles
➢ Linear to dB conversion

Compensate for very high dynamic range in visualisation
➢ Stack statistics 

Analysis of temporal backscatter signatures
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RGB Composite

Right click on the 
product

Band selection
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RGB Composite
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Stack averaging
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Stack averaging – RGB Composite
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Image statistics

Choose your band
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Image statistics - polygon

Draw the polygon
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Looking for more advanced applications?

➢ Crop growth
➢ Harvest event
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Looking for more advanced applications?
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Looking for more advanced applications?

➢ Vegetation growth through different phenological phases . The DpRVI follows the advancement of 
plant growth until full canopy development with the accumulation of the Plant Area Index (PAI) and 
biomass (vegetation water content (VWC) and dry biomass (DB))
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