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1 Introduction to RUS 

The Research and User Support for Sentinel core products (RUS) service provides free and open 

scalable platforms in a powerful computing environment, hosting a suite of open source toolboxes pre-

installed on virtual machines, to handle and process data acquired by the Copernicus Sentinel satellites 

constellation.  

In this tutorial, we will map Sargassum rafts in the Caribbean Sea on June 20th 2018 based on Sentinel-

3 OLCI products. We will carry out this study in the SNAP software on RUS virtual machines. 

2 Sargassum Mapping - Background 

Pelagic Sargassum seaweed is a large 

brown alga floating at the ocean 

surface thanks to its gas-filled 

bladders. When present in 

reasonable amounts, it provides a 

safe habitat to many marine species 

such as the threatened loggerhead 

sea turtle. A large panel of fish 

species like mahi-mahi, jacks and 

amberjacks also use this floating 

vegetation as a nursery. 

In the North Atlantic, pelagic 

Sargassum floats and grows at the 

sea surface during its entire lifetime, aggregating and forming mats carried by winds, waves and 

currents over very long distances. Since 2011, Sargassum algae have been aggregating in rafts several 

kilometres wide. Massive stranding episodes have increased in periodicity and intensity in the 

Caribbean Sea, summer 2018 being the historical record so far.  Once on the beaches, the rafts rot and 

decompose, leading to dramatic consequences on the environment, the tourism economy and human 

health.  

It has hence become of prime importance to monitor these disastrous events, but their irregularity 

makes their forecasting complex. Moreover, the mechanisms at stake in the apparition and arrival of 

the rafts on shores still need more studies. In situ observations from drones or boats constitute key 

tools to quantify the algae amount available for stranding, but their coverage in space and time 

remains limited. 

With their high spatial and temporal resolution and coverage, ocean colour satellites can help to fill in 

the gaps. For example, the satellite-based Sargassum Watch System (SaWS) provides monthly reports 

on the Sargassum situation based on MODIS, VIIRS and Landsat 8 images. It has not incorporated data 

from OLCI so far. This case study demonstrates a simple and powerful way of detecting Sargassum rafts 

with the Sentinel-3 OLCI instrument on June 20th 2018. The methodology presented here is inspired 

from Ody et. al (2019). 

Credits: Romel Hall/Barbados Today 
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3 Training 

The approximate duration of this training session is one hour.  

The Training Code for this tutorial is OCEA08. If you wish to practice the exercise described below 

within the RUS Virtual Environment, register on the RUS portal to request a Virtual Machine. Go to 

Your RUS Service → Your training activities and Request a Webinar Training. 

3.1 Data used 

• 1 Sentinel-3A and 1 Sentinel-3B images acquired on June 20th 2018 

[downloadable @ https://scihub.copernicus.eu/] 
S3A_OL_1_EFR____20180620T135849_20180620T140149_20180621T175740_0179_032_281_2700_LN1_O_NT_002.zip 

S3B_OL_1_EFR____20180620T135828_20180620T140128_20200114T081656_0179_009_281_2700_MR1_R_NT_002.zip 

3.2 Software in RUS environment 

Internet browser, SNAP+Sentinel-3 Toolbox+IdePix Plugin, QGIS 

4 Register to RUS Copernicus 

To repeat the exercise using a RUS Copernicus Virtual Machine (VM), you will first have to register as 

a RUS user. For that, go to the RUS Copernicus website (www.rus-copernicus.eu) and click on 

Login/Register in the upper right corner.  

 

Select the option Create my Copernicus SSO account and then fill in ALL the fields on the Copernicus 

Users’ Single Sign On Registration. Click Register. 

https://rus-copernicus.eu/
https://scihub.copernicus.eu/
http://www.rus-copernicus.eu/
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Within a few minutes, you will receive an e-mail with an activation link. Follow the instructions in the 

e-mail to activate your account.  

You can now return to https://rus-copernicus.eu/, click on Login/Register, choose Login and enter 

your chosen credentials. 

  

Upon your first login you will need to enter some details. You must fill all the fields.   

 

https://rus-copernicus.eu/
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5 Request a RUS Copernicus Virtual Machine to repeat a Webinar 

Once you are registered as a RUS user, you can request a RUS Virtual Machine to repeat this exercise 

or work on your own projects using Copernicus data. For that, log in and click on Your RUS Service  → 

Your training activities. 

 

Select OCEA08 – Sargassum Mapping in the Caribbean Sea with Sentinel-3, check the field “I have 

read and agree to the Terms and conditions of RUS Service” and then click on Request Webinar 

Training to request your RUS Virtual Machine. 

 

Further to the acceptance of your request by the RUS Helpdesk, you will receive a notification email 

with all the details about your Virtual Machine. 

To access it, go to Your RUS Service → Your Dashboard and click on Access my Virtual Machine. 

OCEA08 – Sargassum Mapping in the Caribbean Sea with Sentinel-3 
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NOTE: If the “Access my Virtual Machine” is greyed out, please access your VM from the direct link 

you have received at the email informing you about the creation of your VM. 

 

Fill in the login credentials that have been provided to you by the RUS Helpdesk via email to access 

your RUS Copernicus Virtual Machine. 

This is the remote desktop of your Virtual Machine. 
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6 Step by step  

6.1 Data download – ESA SciHUB 

In this step, we will download the Sentinel-3 scenes used for the exercise, from the Copernicus Open 

Access Hub using the online interface. 

Go to Applications  Network  Firefox Web Browser or click the link below. 

Go to https://scihub.copernicus.eu/ 

Before starting the exercise, make sure you are registered in the Copernicus Open Access Hub so that 

you can access the free data provided by the Sentinel satellites. 

 

 

https://scihub.copernicus.eu/


9 
 

  
 

 

Go to “Open Hub”. If you do not have an account, sign up in the upper right corner, fill in the details 

and click register. 

You will receive a confirmation email at the e-mail address you have specified: open the email and click 

on the link to finalize the registration. 

Once your account is activated – or if you already have an account – LOGIN. 
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In this guide, we describe the procedure to download the Sentinel-3 images for June 20th 2018. Drag 

the map to the Caribbean Sea and define the study area using the  button (approximate area – 

orange rectangle). Then, open the search menu by clicking on the left part of the search bar (  ) and 

specify the parameters below. Press the search button (  ) after that. 

Sensing period: From 2018/06/20 to 2018/06/20 

Check mission: Sentinel-3 

Product type: OL_1_EFR  
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In this case, the search returns 2 results (blue tiles). There is one S3A_OL_1_EFR product and one 

S3B_OL_1_EFR product, almost entirely overlapping. 

As you can see, both products appear Offline. Hitting the download icon  will trigger the offline 

product retrieval: 
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This will automatically add the product to the “Cart” . In case an error  message appears, try again a 

bit later – you can request for one offline  product per account per hour. (See  NOTE 1 and  

NOTE 2). The product will be online within a few hours. Once online, the product will remain 

available for download for at least 3 days before it is moved back offline. 

 

You need to repeat the same process for both images. The products will be downloaded to /home/rus/ 

as zip archive. Move them to the below path and unzip the archives: Right-click on the product → 

Extract Here . 

Path: /shared/Training/OCEA08_SargassumMapping_Caribbean/Original/ 

6.2 SNAP – Open and Explore data 

Once you have extracted the archives, open the SNAP software from the icon  located on the 

desktop. Hit the Open Product icon , browse to the Original/ folder and open both Sentinel-3 

products by selecting the xfdunmanifest.xml file of each product. You can also navigate to the product 

folder from a product browser and drag and drop the xfdunmanifest.xml file in the Product Explorer 

Tab. 

     NOTE 2: You can find more information about the retrieval of offline/long term archive products here:  

 https://scihub.copernicus.eu/userguide/DataRestoration. Most Sentinel products remain online for a 

month after they are published. They are then moved offline and need to be requested back online as 

previously shown. In a more general way, the scihub user guide is a very useful resource to check. 

     NOTE 1: Please keep in mind that you cannot download more than 2 products at the same time, per 

account from SciHub. 

https://scihub.copernicus.eu/userguide/DataRestoration
https://scihub.copernicus.eu/userguide/


13 
 

  
 

 

The products are now open in the Product Explorer Tab of the SNAP software. Feel free to expand the 

product trees by hitting the key  button located left of each open product. Unfold the product 

content and appreciate how SNAP conveniently gathers the data into several folders.  

The main data of interest (top of atmosphere radiances in the 21 spectral bands of OLCI) is stored in 

the Bands → Oa*_radiance folder. The other folders contain data that give additional information on 

the context of the measurements. For example, the Mask folder encloses very useful information on 

the quality of the retrieval. MetaData contains static information about the product such as the 

timestamp, the platform name, the observation mode, etc… 

If you want to check the properties of a band, right-click on the band and hit Properties. 
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6.2.1 Create RGB Image – Natural Colours Oa08, Oa06, Oa04 

Right click on the S3A product and select Open RGB Image Window. Select Oa08 for Red, Oa06 for 

Green and Oa04 for Blue. Hit OK and the RGB view will open in the View Window 

Repeat the operation for the S3B product. Then go to Window → Tile Horizontally to have a 

simultaneous view of both RGB images. 

When on each view, select the Hand  button to drag the view to your area of interest. Simply use 

the centre wheel of your mouse to zoom in and out. You can go to the World View tab and zoom in to 

see the location of the opened product(s) on the globe. 

 TIP 1: $1 Refers to the index number of the product in the Product Explorer Tab 
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In the Navigation tab, click on the two icons shown within the blue rectangle below, to synchronize 

the views and the cursor position across the views. 

You probably noticed that the images are a bit dark and not much is visible on them. We are going to 

improve the visualisation. For this go to the Colour Manipulation panel and for each Red, Green and 

Blue component, drag the sliders to the below values. You need to repeat the operation for both 

images 

 

 

 

 

 

 

Product Explorer 
View Window 

Synchronize views 

Colour Manipulation  

~54 ~72 ~103 
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You can also hit a slider value to change its defined value. 

Once the views are clearer, we now distinguish different elements on our images. 

 

First, we notice that both OLCI-A and OLCI-B sensors show very similar patterns. This is normal as the 

products were acquired 20 seconds apart and roughly cover roughly the same area. The S3A product 

name indicates that the measurements were collected between 13:58:49 and 14:01:49 UTC on June 

20th 2018 whereas S3B measurements were collected between 13:58:28 and 14:01:28 UTC on June 

20th 2018. On both views, we find the following elements: 

 Wide areas covered in clouds at the upper left and lower right corners 

 Sun glint on the right of the images (see  NOTE 3). 

 Caribbean Islands at the centre 

     NOTE 3: Sun glint occurs when sunlight reflects off the surface of the ocean at the same angle that a 

sensor is viewing the surface 
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From these RGB views, it is very hard to distinguish where the potential Sargassum rafts are located. 

Zooming in on particular areas gives us a hint. As shown on the image below, subtle dark green 

patterns appear but they are not easy to spot with a bare eye on the RGB views. 

6.2.2 The ocean colour spectrum 

Another useful tool in SNAP is the Optical→  Spectrum View that allows you to check the spectrum 

of the ocean colour signal per pixel.  

 

 

 

 

 

 

 

 

 

 

When hovering over the image, you will see how the ocean colour signal evolves from a pixel to 

another. Holding the shift key will automatically adapt the scale of the spectrum view. For example, 

on a dark blue pixel the spectrum will have a strong component in the blue part (short wavelengths) 

and a weaker component in the red and infrared parts. 
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When the cursor is located over a dark green pixel, the ocean colour spectrum has a much stronger 

component in the Near Infrared (NIR) and Infrared part of the spectrum compared to a ‘clear water’ 

pixel: 

 

 

 

 

 

 

 

 

 

To better assess the spectrum differences between our pixels, it would be nice to plot both spectra 

on the same view. Good news: SNAP also has a functionality for this. We first need to place pins on 

our images. Select the Pin Placing tool button  and add one pin (Pin 1) over a dark blue water 

pixel and one pin (Pin 2) over a dark green water pixel. In your Spectrum View graph, select the 
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Show spectra for all pin button . Right clicking anywhere on the graph will display a selection of 

choices for: 

 Setting your graph properties (Title, axes, labels etc) 

 Export your graph as a PNG file (Save as…). It is also possible to export the spectra as a csv 

file with the  button at the bottom right of the spectrum window. 

To manage your pin colour and name or to delete a pin, go to View→Tool Windows→Pin manager. 

There you will be able to control your pin options. Changing a pin colour/name will also change the 

colour/name of its curve in the Spectrum view! 
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Analysing the ocean colour spectrum collected by OLCI can tell us a great deal about the ocean 

optical constituents content. We just saw that the spectrum collected by OLCI in the various bands 

varies a lot from one pixel to another.  

It is this shift in the ocean colour spectrum that the Maximum Chlorophyll Index (MCI) exploits to 

highlight the areas where the probability of presence of Sargassum rafts is maximized (see  NOTE 

4). 

 

 

 

 

 

 

 

 

 

 

 

 

 

NOTE 4: The Maximum Chlorophyll Index (MCI) is an algae index based on the red-edge effect of floating 

vegetation. As highlighted before, there is an increase of the Sargassum radiometric signal in the NIR 

part of the spectrum (650-1200nm). 

The MCI is computed from the difference between the Top of Atmosphere (TOA) radiances in the 

central waveband 𝜆2, where the red-edge effect of the floating algae signal is at a maximum, and a 

linear baseline drawn between the two surrounding bands 𝜆1and 𝜆3 : 

𝑀𝐶𝐼 = 𝑟ሺ𝜆2ሻ − [𝑟ሺ𝜆1ሻ + ሺ𝑟ሺ𝜆3ሻ − 𝑟ሺ𝜆1ሻሻ ∗
𝜆2−𝜆1

𝜆3−𝜆1
]- 

Where 𝑟ሺ𝜆𝑥ሻ are the OLCI L1 EFR TOA radiances for bands: 

 𝜆1 = 681 𝑛𝑚 → Oa10  

 𝜆2 = 709 𝑛𝑚 → Oa11 

 𝜆3 = 754 𝑛𝑚 → Oa12 

For more details on MCI for OLCI, see Ody et al. (2019). 

 

 

 

 

 

 

 

           ‘Clear water’ spectrum 

           High Chlorophyll spectrum 

MCI 𝜆1 

𝜆2 
𝜆3 
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6.2.3 The quality flags 

Alongside the TOA radiances in the 21 spectral bands, the OLCI L1 products contain a set of flags that 

give contextual elements around the measures. To display the different masks, as for the Pin Manager, 

go to View→Tool Windows→Mask manager. From there, you can activate/deactivate a particular 

mask by ticking/unticking the boxes, change the colour of a mask or set its transparency. 

For this study, we would like to ignore land pixels (quality_flags_land) and cloudy pixels. However, 

there is no cloud flag in the OLCI L1 product. We will hence need to compute our own cloud mask using 

the SNAP Idepix for OLCI Processor. 

6.3 SNAP – Idepix Processor 

The Idepix processor for OLCI retrieves a set of pixel classification attributes such as clear/cloudy, 

land/water, snow/ice, etc. The implementation of the features calculation is instrument specific 

meaning there is an Idepix processor per supported instrument (including but not limited to: MSI on 

board Sentinel-2, OLCI on board Sentinel-3, MERIS on board ENVISAT, OLI on board Landsat 8, etc.). 

For cloud detection, the following features are used: brightness, whiteness, height, temperature, 

spatial pattern, temporal consistency, Neural Network probability. 

If this is your first use of the Idepix processor, the plugin needs to be downloaded and installed in SNAP 

beforehand. Go to Tools→Plugins and select IdepPix OLCI & IdePix Core and hit Install. Then hit Next 

and agree to the terms and conditions. After the installation, hit Finish and SNAP will restart. You will 

need to import the OLCI products again following the beginning of section 6.2. 
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6.4 SNAP – Sentinel-3 Processing 

We are going to apply several processing steps to both products: 

 Cloud identification with IdePix 

 Spatial subset to crop the products to our area of interest 

 MCI Computation in a new Band (BandMath) 

 Addition of the new MCI band to the output product (BandMerge) 

 Reprojection of the product to define a Coordinate Reference System (CRS) 

Repeating these steps for every image one by one would be very time consuming. For this reason, we 

can create a graph containing all the steps of our methodology and use the batch processing option of 

SNAP to run bulk processing.  

6.4.1 Graph Builder 

We will use the GraphBuilder tool, to create a chain with the processing steps we want to apply and 

at the end, only the final product will be physically saved (this way we will also save disk space since 

the products of the intermediate steps will not be stored). To create an empty graph, go to Tools → 

GraphBuilder. At the creation, the graph only has two operators: Read (to read the input) and Write 

(to write the output). To avoid any confusion, right click on the Write operator and delete it. 
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In the Graphbuilder, we will not define any parameters in the tabs (they will be defined in the Batch 

Processing step where we will apply this processing for both of the images we have downloaded, at 

once). We will only create and save the graph. 

First, we compute the cloud mask out of the OLCI bands. To add the IdePix operator (be sure the plugin 

is installed first, see section 6.3), right click and go to Add→Optical→Pre-Processing→IdePix.Olci. 

 

Immediately after adding the operator, make sure to UNTICK the Compute cloud Shadow option in 

the IdePix.Olci Tab as this option makes the SNAP software crash. Then, connect the Read operator to 

the IdePix Processor. To connect two blocks, start from the right of the block to create a red arrow and 

drag it to the following block 

Right-click anywhere on 
the blank tab to make 
the Add option appear 
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We then need to create a Subset of the image, since we want to focus only over a defined area and 

we do not need the whole extent of the products. To add the Subset operator, go to 

Add→Raster→Geometric→ Subset. Connect the IdePix.Olci operator to it. 

 

The next processing step will be to derive the MCI for the pixels that are not flagged as cloudy by the 

IdePix processor (IDEPIX_CLOUD flag) and that are not land pixels (quality_flags_land). For this task, 

we will use Band Math. To add the Band Math operator, right-click and go to 

Add→Raster→BandMath. Connect the operators as shown below. 

 

In batch processing mode, the output of the BandMaths operator is the computed band (MCI) only. In 

our output product, we would like to save some additional data such as reflectances and product flags. 

To merge the MCI band with the subsetted product bands we will use the Add→Raster→BandMerge 

operator.  
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Then let’s set a CRS to our product. We will use Add→Raster→Geometric→ Reproject. 

 

Finally, we just need to properly save the output. Right click and navigate to Add→Input-

Output→Write. Your final graph should be similar to the one shown below: 

 

Finally, click on Save in the lower part of the panel and save the graph in the following path as 

’MCI_Graph.xml’ without setting any parameter. 

Path: /shared/Training/OCEA08_SargassumMapping_Caribbean/AuxData/ 

6.4.2 Batch Processing 

If the same processing scheme is applied to multiple images, the Batch Processing tool is what you are 

looking for. To use the Batch Processing tool go to Tools→Batch Processing. First, you need to Load 

the Graph you want to run. Hit Load Graph, browse to 

/shared/Training/OCEA08_SargassumMapping_Caribbean/AuxData/ and load MCI_graph.xml. New 

tabs corresponding to our operators appear at the top of the window. 

 

 TIP 2: If you did not succeed to create the processing graph, you will find a backup version in  

/shared/Training/OCEA08_SargassumMapping_Caribbean/AuxData/Backup 
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In the I/O Parameters tab, unselect the “Keep source product name” option. In the same tab, we will 

add all opened products from the Product Explorer window by clicking Add Opened button at the 

right and then hit Refresh . In our case, we have loaded the S3A and S3B images from June 20th 2018. 

 

6.4.2.1 IdePix Olci Processor 

In the IdePix.Olci tab, select the Oa10, Oa11 and Oa12_radiance bands (needed to compute the MCI). 

Select also the Oa04, Oa06 and Oa08 reflectance bands (to generate a RGB view later if you wish to) 

as shown below (see  NOTE 5). To select multiple bands, hold the Ctrl key. Keep the Compute cloud 

buffer ticked and leave the default value of 2 for the width of cloud buffer. This option dilates the 

IdePix cloud mask with a 2-pixel buffer to deal with cloud edges and cloud shadows. 

 

 NOTE 5: Radiance is the variable directly measured by remote sensing instruments. It is the amount of 

light seen by instrument from a surface of an object. In the OLCI products, it is given as 10-3 W.m-2.sr-

1.μm-1 

Reflectance is the ratio (percentage) of the amount of light leaving a target to the amount of light 

arriving at the target. It has no units. It is the property of the observed object/material. 
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6.4.2.2 Subset 

In the Subset tab, first select all Source Bands. Then select Geographic Coordinates, copy and paste 

the following Well-Known Text (WKT) in the box beneath the map, hit Update to define the area and 

then hit the button in the top righthand corner of the map to zoom-in. 

 

 

6.4.2.3 BandMath – MCI 

Click now on the BandMaths tab, set the target band name to MCI set the No-Data value to NaN, click 

on Edit Expression and copy and paste the following expression into the box. Click OK afterwards.  

This expression means that the MCI gets computed only over clear-sky water pixels. Over land and/or 

cloudy pixels, the value will be set to NaN. You will also find the MCI expression in 

/shared/Training/OCEA08_SargassumMapping_Caribbean/AuxData/MCI.txt 

POLYGON ((-65 19, -58 19, -58 12, -65 12, -65 19)) 

 

if quality_flags_land==False and IDEPIX_CLOUD==False and IDEPIX_CLOUD_BUFFER==False then 

Oa11_radiance-(Oa10_radiance+(Oa12_radiance- Oa10_radiance)*(709-681)/(754-681)) else 

NaN 
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6.4.2.4 BandMerge 

In the BandMerge Tab, select all source bands. You can select all source bands by selecting one band 

and then using the Ctrl+A keyboard shortcut. 

 

6.4.2.5 Reproject 

In the Reproject Tab, you can choose from a wide variety of CRS, for example the UTM/ WGS 84 

(Automatic) towards the bottom of the list. Unselect the Reproject tie-point grids option. 
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6.4.2.6 Write 

In the Write tab, under Name keep the default name (Projected, Subset and IDEPIX will be added). At 

the Directory set the path to /shared/Training/OCEA08_SargassumMapping_Caribbean/Processing/  

Finally Hit Run! The processing may take up to 15mn on a RUS VM. It might take more time if you are 

practicing on your own computer. The processed products will automatically open in the Product 

Explorer Window when the processing is completed ((see  NOTE 6). 

 

 NOTE 6: When executing the graph on a RUS VM, it may happen that SNAP suddenly closes without 

any warning because of a RAM shortage. If this happens, first go to 

/shared/Training/OCEA08_SargassumMapping_Caribbean/Processing/ and delete the written 

output(s) as they will only be partial. Then restart SNAP and open both Sentinel-3 products again 

(section 6.2). Then open the batch processing tool again and repeat all the steps of section 6.4.2. 
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6.5 Analysis of the processed products 

Both products now contain an MCI band. Let’s open the MCI band from each product. The first view is 

black and white. To add a colour ramp, go to Colour manipulation → Basic → Colour Ramp. There, 

you will find a set of pre-defined colour bars.  

 

To correctly visualize the MCI, we are going to use a colour ramp created ahead if this webinar. For 

this, hit the Import colour palette from text file button  and navigate to 

/shared/Training/OCEA08_SargassumMapping_Caribbean/AuxData/ and select MCI_OLCI.cpd. When 

opening the file, a window will appear, hit No. 

 

 TIP 3: The SNAP default colour ramps are in /home/rus/.snap/auxdata/color_palettes/. You can 

copy the MCI_OLCI.cpd file to this folder and have it appeared as a default colour ramp. Once in the 

home/rus/ folder, go to View→Show Hidden Files to make the .snap/ folder appear. 
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You need to repeat the operation for the second view. 

 In the product the light blue areas correspond to the dark water regions. The Sargassum rafts are 

easily identified by the yellow stripes. The black pixels are the ones that were either flagged as land, 

or cloud/cloud_buffer by the IdePix processor and set to NaN in the BandMath operation.  

 TIP 4: Once you have defined a convenient style for a view, you can apply this style to other views 

by hitting the  button from the Colour Manipulation tab. Then you just need to select the 

opened band you wish to apply the colour ramp to. 
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To further enhance the view, you can activate the IDEPIX_CLOUD and IDEPIX_CLOUD_BUFFER masks 

by selecting the check box to the left of the name of each mask in the Mask Manager and set their 

colour to light grey. You can also activate the quality_flags_land mask on both images. 

If you want to export an interesting view, right-click anywhere on the view and select Export View as 

Image. 

You can see how some rafts seem to mark current meanders and eddies borders and centres. 

 

We also observe that most Sargassum rafts present east-west thin filament structures most probably 

caused by wind. 
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7 Conclusions 

Satellite imagery is widely used to detect and map floating vegetation. Space-borne technologies offer 

a frequent and global coverage of our oceans. As this exercise highlighted, simple index computations 

based on the red-edge spectral properties of the Sargassum in the near infrared part of the spectrum 

allow for a relatively easy detection of large rafts. The Sentinel-3 constellation constitutes a valuable 

asset to map Sargassum distribution at large scales on a frequent basis. Furthermore, the OLCI 

products could be combined with other sensors to create multi-sensor products and hence ensure a 

gap-free coverage of the Caribbean Sea. 

However, satellite data present some drawbacks and in situ data remain essential to create a reliable 

Sargassum monitoring system. OLCI spatial resolution (300m) limits the detection of smaller 

aggregations. The tropical Atlantic Ocean also often experiences Saharan dust plumes that may 

decrease the Sargassum signature in the near infrared and hence make the MCI computation 

unreliable. In addition to these dust episodes, sun glint, clouds and haze that are typical to tropical 

regions create further gaps in the observations. OLCI captures very well the floating algae at the very 

surface of the ocean but Sargassum located a few centimeters (10-15cm) below the surface are not 

well detected. It is also very challenging to discriminate Sargassum from other floating vegetation or 

even from other floating material such as plastic and oil that have a similar spectral signatures in the 

NIR. 

Finally, detecting rafts is not equivalent to accurately quantifying the Sargassum biomass available for 

strandings on coasts. MCI is not a concentration measure but an indicator to highlight the areas 

covered by potential Sargassum rafts. A pixel flagged by the MCI may be composed of several sub-pixel 

sized aggregations which can reach a depth of half a meter. 

As a conclusion, the MCI computed out of OLCI products is a very efficient tool for detecting the 

position of floating material rafts under relatively clear sky conditions, but complementary information 

is needed to fill in the gaps in satellite ocean colour data and quantify the biomass available for 

stranding. Moreover, monitoring and forecasting these disastrous aggregations requires that other sea 

state parameters such as the wind strength and direction, wave height or currents be taken into 

account. For more explanation, do not forget to read the article from Ody et al. (2019) which inspired 

this exercise. 
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8 Extra steps – Export to QGIS 

8.3 Export as a GeoTIFF 

SNAP allows the user to export the outputs as GeoTIFF for further analysing and processing in a GIS 

software such as QGIS. To do this, make sure to select the output product in the Product Explorer 

Tab. Then from File→Export, choose the GeoTIFF option. In the dialog tab that opens, hit Subset.  

 

At the Band Subset (second tab) use the Select none button to unselect them all first and then select 

only the MCI band. Then go to the Metadata Subset tab and click Select none. Finally, hit OK and hit 

No in both dialog tabs that open. 

 

Define your export folder thanks to the Save in option and hit Export Product. 
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8.4 Opening the File in QGIS 

Your GeoTIFF is now ready to be opened in QGIS (  icon from your VM desktop)! First open the 

software. From the left panel, expand the XYZ Tiles and drag the OpenStreetMap and drop it to the 

layer panel. 
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Then, from a file browser, drag and drop your generated GeoTIFF in QGIS and zoom in to the Caribbean 

Sea using the central wheel of your mouse. A black and white view of the MCI has opened. 

Double-click on the GeoTIFF layer. This will open the properties of your layer. In the Symbology section, 

set the Render Type as Singleband pseudocolor. Then with the  button, navigate to 

/shared/Training/OCEA08_SargassumMapping_Caribbean/AuxData/ and open the 

MCI_colour_QGIS.txt file which is a pre-defined colour ramp. Then simply hit OK. 

 

Enjoy the result! 
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THANK YOU FOR FOLLOWING THE EXERCISE! 

9 Further reading and resources 

Sentinel-3 OLCI User Guide  
https://sentinel.esa.int/web/sentinel/user-guides/sentinel-3-olci 

Sentinel-3 OLCI Technical Guide  
https://sentinel.esa.int/web/sentinel/technical-guides/sentinel-3-olci 

Sentinel-3 Marine User Handbook  
https://earth.esa.int/eogateway/documents/20142/1564943/Sentinel-3-OLCI-Marine-User-Handbook.pdf 

Sargassum Side Event, All Atlantic 2021 workshop  
https://www.eu4oceanobs.eu/all-atlantic-2021/sargassumsideevent/ 

Satellite-based Sargassum Watch System (SaWS)  
https://optics.marine.usf.edu/projects/saws.html 

High quality Sargassum Mapping in the W-Atlantic with OLCI 
https://people.mio.osupytheas.fr/doglioli.andrea/Ody_etal_IOCS17_OLCI.pdf 
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