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1 Introduction to RUS 

The Research and User Support for Sentinel core products (RUS) service, provides a free and open 

scalable platform in a powerful computing environment, hosting a suite of open source toolboxes pre-

installed on virtual machines, to handle and process data derived from the Copernicus Sentinel 

satellites constellation.   

2 Ocean colour monitoring – background 

Ocean colour refers to the hue of the water 

caused by the presence of tiny plants that 

containing the pigment chlorophyll, 

sediments and coloured dissolved organic 

material.  

From satellite observations in the optical 

part of the spectrum we can estimate the 

concentrations of different constituents 

(pure water, chlorophyll, sediments, 

coloured dissolved organic matter) provided 

we know their effect on the spectral 

response of the water (inherent optical 

properties - IOPs).   

      Chlorophyll concentrations are perhaps of 

most interest to us as they are indicators of 

algal blooms. Phytoplankton blooms occur 

naturally in areas with high nutrient 

concentrations (coastal areas – nutrient 

runoff from land). When phytoplankton cells 

die, they sink to the seabed where they are 

decomposed by bacteria requiring oxygen.  

In extreme cases (eutrophication), this 

process can result in oxygen depletion 

(hypoxia) and the creation of “dead zones” 

where all marine life either died or left the 

area.  While the occurrence of such zones on 

periodic basis is natural, they have been 

observed more often and affecting larger 

areas in the past few decades. This is mainly 

attributed to nitrogen and phosphorous from agricultural runoff, but sewage, vehicular and industrial 

emissions play a role.  

The study area for this exercise will be the southern part of the North Sea. Eutrophication and hypoxia 

have been increasingly observed in the coastal areas and the countries surrounding the North Sea have 

been working together for the past few decades to reduce pollution runoff. Monitoring of the 

chlorophyll concentrations is an important input to assessing these efforts.  

Source: NASA  - Algal bloom  

Source: Teach Ocean Science 
(http://www.teachoceanscience.net) 
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3 Training 

Approximate duration of this training session is 1 hour.  

3.1 Data used 

• One Sentinel-3A level 1 image that had been acquired on 9 July 2017 [downloadable @ 

https://codarep.eumetsat.int] 

S3A_OL_1_EFR____20170709T095656_20170709T095856_20171021T033004_0119_019_350______MR1_R_NT_002 

• One Sentinel-3A level 2 image that had been acquired on 9 July 2017 [downloadable @ 

https://codarep.eumetsat.int]   

S3A_OL_2_WFR____20170709T095656_20170709T095856_20171110T054242_0119_019_350______MR1_R_NT_002 

3.2 Software in RUS environment 

Internet browser, SNAP + Sentinel-3 Toolbox  

4 Sentinel-3 OLCI 

Sentinel-3 is a multi-sensor mission comprising of two satellites (Sentinel-3A and Sentinel-3B) in 

identical orbit with a phase shift of approximately 140°. Sentinel-3A has been in orbit since February 

2016 and Sentinel-3B since 25 April 2018. The mission’s main objective is to measure with accuracy 

sea-surface topography, sea- and land-surface temperature and ocean- and land-surface colour, in 

support of ocean forecasting systems, and for environmental and climate monitoring. It provides Near-

real time data for ocean forecasting, sea-ice charting, and maritime safety services on the state of the 

ocean surface, including surface temperature, marine ecosystems, water quality and pollution 

monitoring. 

 
Sentinel-3 sensors (Credits: Sentinel-3 SLSTR User Guide, ESA) 

The Ocean and Land Colour Instrument (OLCI) is a medium-resolution imaging spectrometer that uses 

five cameras to provide a wide field of view (swath width: 1270 km). It provides 21 bands, ranging from 

the visible to the near infrared (400 – 1020 nm), acquired simultaneously with approximately 300 m 

spatial resolution.  

https://codarep.eumetsat.int/
https://codarep.eumetsat.int/
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5 Register to RUS Copernicus 

To repeat the exercise using a RUS Copernicus Virtual Machine (VM), you will first have to register as 

a RUS user. For that, go to the RUS Copernicus website (www.rus-copernicus.eu) and click on 

Login/Register in the upper right corner.  

 

Select the option Create my Copernicus SSO account and then fill in ALL the fields on the Copernicus 

Users’ Single Sign On Registration. Click Register. 

 

Within a few minutes you will receive an e-mail with activation link. Follow the instructions in the e-

mail to activate your account.  

You can now return to https://rus-copernicus.eu/, click on Login/Register, choose Login and enter 

your chosen credentials. 

 

http://www.rus-copernicus.eu/
https://rus-copernicus.eu/
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Upon your first login you will need to enter some details. You must fill all the fields.   

 

6 Request a RUS Copernicus Virtual Machine 

Once you are registered as a RUS user, you can request a RUS Virtual Machine to repeat this exercise 

or work on your own projects using Copernicus data. For that, log in and click on Your RUS Service → 

Your Dashboard.  

 



 

7 
 

Click on Request a new User Service to request your RUS Virtual Machine. Complete the form so that 

the appropriate cloud environment can be assigned according to your needs. 

 
If you want to repeat this tutorial (or any previous one) select the one(s) of your interest in the 

appropriate field. 

 

 
 

Complete the remaining steps, check the terms and conditions of the RUS Service and submit your 

request once you are finished. 
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Further to the acceptance of your request by the RUS Helpdesk, you will receive a notification email 

with all the details about your Virtual Machine. To access it, go to Your RUS Service → Your Dashboard 

and click on Access my Virtual Machine. 
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Fill in the login credentials that have been provided to you by the RUS Helpdesk via email to access 

your RUS Copernicus Virtual Machine.  

 

This is the remote desktop of your Virtual Machine. 

 

7 Step by step  

7.1 Data download – CODARep 

In this step, we will download the Sentinel-3A Level-1 EFR product (TOA radiances at Full Resolution) 

and a corresponding Level-2 WFR product (Full Resolution: Ocean Colour, Water and atmosphere 

parameters), from the EUMETSAT Copernicus Online Data Access (REProcessed) using the online 

interface.  
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Go to https://codarep.eumetsat.int and click OK at the dialog that appears. 

 

You will be redirected to a login page. If you do not have an account, please register through the “NEW 

USER – CREATE NEW ACCOUNT” as shown below and then log-in. 

 

TIP: All Sentinel-3 products are available in the EUMETSAT Copernicus Online Data Access 

(https://coda.eumetsat.int/) only for 1 year from the acquired date. After 1 year, they are only 

available in the CODA REProcessed portal (https://codarep.eumetsat.int). 

https://codarep.eumetsat.int/
https://coda.eumetsat.int/
https://codarep.eumetsat.int/
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Once you are logged-in, switch the “rectangle-drawing mode” to “pan mode” by clicking on the icon 

in the upper right corner of the map and navigate to the northern part of the English Channel. 

Then switch to “drawing mode” and draw a rectangle approximately as indicated below.  

Open search menu by clicking at the left of the search bar. 

Specify the following parameters and then search: 

Sensing period: From 2017/07/09 to 2017/07/09  

Check Mission: Sentinel-3  

Instrument: OLCI  

 

The search returns 4 results for the period we defined over our area of interest.  
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We need to download the 2 scenes that are of Full Resolution (always download the products of larger 

size – full resolution / EFR and WFR) by clicking the download icon  on each product:  

S3A_OL_1_EFR____20170709T095656_20170709T095856_20171021T023004_0119_019_350____MR_1_NT_002 

S3A_OL_2_WFR____20170709T095656_20170709T095856_20171021T023004_0119_019_350____MR_1_NT_002 

 

Once the scenes are downloaded, move them from /home/rus folder to 

/shared/Training/OCEA04_OceanColour_S3_TutorialKit/Original folder. 

Then right-click on each of the zipped products in turn and go to “Extract Here”.  

 

 

In this case, make sure that once the scenes are downloaded, you will move them from /home/rus 

folder to /shared/Training/OCEA04_OceanColour_S3_TutorialKit/Original folder. 

Then right-click on each of the zipped products in turn and go to “Extract Here”.  

 NOTE 1: There might be a case that you may are not allowed to draw a rectangle at CODA using the 

browser at your Virtual Machine. Open the website at another browser out of your VM, find the products 

you need, add them to cart by clicking at this    icon and then connect to your CODA account through 

the browser in the VM and download them from your cart. 
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7.2 SNAP – open and explore data 

Open SNAP Desktop from your desktop or search it in Applications → Processing. 

Click on the “Open product” icon  or go to “File → Open Product” and find the: 

/shared/Training/OCEA04_OceanColour_S3_TutorialKit/Original folder. 

Navigate to both folders of the extracted products and open in each one the “xfdumanifest.xml” file 

to load the products to SNAP. 

The opened products will appear at the Product Explorer tab in the upper left part of the window.  

Right click on the Level-1 product (S3A_OL_1_EFR____20170709T095656_20170709T095856_201710 

21T023004_0119_019_350____MR_1_NT_002) and select Open RGB Image Window to create and 

visualize an RGB composition image. 

Set: Red: 0a08_radiance, Green: 0a06_radiance, Blue: 0a04_radiance. 

 

  
Click OK and the RGB image will appear in the “View Window”. 

The view of the image is very dark and for that reason we will enhance it a bit. Go to the Colour 

Manipulation tab in the lower left corner of the SNAP window. Here we have to change the histogram 

stretch for each of the RGB component bands.  

Check that the Red histogram is shown, click on the right-hand slider below the histogram and move 

it leftwards to approximately 70.  

Change the histogram to Green at the top of the tab and set the right-hand slider to approximately 90.  

Last, change the histogram to Blue and set the right-hand slider to approximately 100. 

   

 TIP: $1. Refers to the index number of the product at the Product Explorer tab.  
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As we can see, the majority of our image is covered by land or clouds and does not contain any valuable 

information for our purposes, so let’s subset it to a smaller area of interest.  

 

7.3 Subset 

Make sure the Level-1 EFR product is selected (highlighted) in the Product Explorer tab, if needed click 

once on it even if it is highlighted.  

Go to Raster → Subset.  

At the Spatial Subset tab go to Pixel Coordinates tab and set the following coordinates: 

Scene start X:   600 Scene start Y:   50 Scene end X: 2800 Scene end Y:   2250 

 
The subset area is indicated by the blue 

rectangle on the left of the dialog window.  

Click OK. 

A subset product will be created and will appear 

at the Product Explorer tab with index number 

[3].  

Let’s open the RGB view in the same way we 

have done for the full product and enhance the 

histogram. 

 

 

Right click on the [3] subset_0_of_S3A_OL_1_EFR____20170709T095656_20170709T095856_2017 

1021T023004_0119_019_350____MR_1_NT_002 product and select Open RGB Image Window to 

create and visualize an RGB composition image. 

Set: Red: 0a08_radiance, Green: 0a06_radiance, Blue: 0a04_radiance. 

Set again the Red histogram to approximately 70, the Green to 90 and the Blue to 100. 
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7.4 C2RCC Processor 

The Case 2 Regional Coast Colour processor had originally been developed by Doerffer and Schiller for 

the MERIS sensor, and then it was improved through the ESA DUE CoastColour project (Brockmann et 

al., 2016). It is applicable to all past and current ocean colour sensors (such as Sentinel-3) as well as 

Sentinel-2. It has been validated in various studies and is available through ESA’s Sentinel toolbox 

SNAP. It is also used in the Sentinel-3 OLCI ground segment processor of ESA for the generation of the 

Case 2 water products. We will use it here to reproduce the Level-2 Water product that we have also 

downloaded.  

To run the processor, go to Optical → Thematic Water Processing → C2RCC Processors → OCLI.  

You can see that the C2RCC processor is available for a variety of different sensors.  

  

In the I/O Parameters tab, make sure that the subset product with index number [3] is selected as 

source OLCI L1b product. 

The original name of the S3 product is quite long so let’s replace it with something more manageable.  
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In the Target Product section under “Name”, 

the “C2RCC” ending will be added 

automatically.  

Rename the product and keep it as: 

“Subset_S3A_OL_1_EFR_20170709T095656 

_C2RCC”. 

Below the Directory, set as output: /shared/ 

Training/OCEA04_OceanColour_S3_Tutorial/ 

Processing. 

In the Processing Parameters tab, we will define 

the values about “salinity” and “temperature” 

that correspond to our area of interest for that 

certain date, 8th of July 2017. 

These variables among others are used to 

determine the absorption and scattering of pure 

water.  

You can find and download the dataset for the 

specific date we need at the following link: 

https://opendap.jpl.nasa.gov/opendap/SalinityDensity/smap/L3/JPL/V3/8day_running/2017/185/co

ntents.html  

Instructions how to use it can be found here: https://www.youtube.com/watch?v=npOKkLtXE0w 

Alternatively, you can find the values for salinity and sea surface temperature, as shown below (note 

that this dataset might not be available anymore): 

 

Sea Surface Salinity SST (Dataset: JPL SMAP Level 3 CAO Sea Surface Salinity Standard Mapped Image 8-Day Running mean 
V3.0 Validated dataset) for 8 July 2017. Left: spatial variability; Right: study area SST average value; Source: JPL Climate 
Oceans and Solid Earth group. 2017) 

https://opendap.jpl.nasa.gov/opendap/SalinityDensity/smap/L3/JPL/V3/8day_running/2017/185/contents.html
https://opendap.jpl.nasa.gov/opendap/SalinityDensity/smap/L3/JPL/V3/8day_running/2017/185/contents.html
https://www.youtube.com/watch?v=npOKkLtXE0w
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For “Salinity”, set value of 34.6 PSU and for 

“Temperature” of 15°C.  

We will keep the default values for Ozone and 

Air Pressure, while the total ozone and sea level 

pressure grids that are available in the OLCI L1b 

products (ECMWF auxiliary met data) will be 

used.  

This option below must be ticked (  Use 

ECMWF aux data of source product).  

The other parameters define the arithmetic 

relationship between inherent optical 

properties (IOPs) of the water constituents 

(absorption by pure water, phytoplankton 

pigments, yellow matter, etc.) and the actual 

concentrations of chlorophyll and total 

suspended matter. We will leave all default 

values as these have been widely tested and 

validated and are also used to derive the S-3 

Level 2 product.  

The only parameter we will change in the Processing Parameters tab will be the Valid-pixel expression. 

To edit the default expression, click on the three dots at the upper right corner.  

Based on the default expression, pixels are valid if: the invalid flag is false, and the land flag is false as 

well, with the exception of inland water bodies. (! equals to not) (&& equals to and). 

 

We will change the expression: we will remove from the expression the inland waterbodies and we 

will add the sun glint risk flag because we want to also exclude these pixels from our calculations. To 

achieve this, the final expression will be set as: 



 

18 
 

 

 

Click OK and then click Run to execute the C2RCC processor. This might take up to 10 minutes 

depending on your VM/PC.  

Once the processing has finished and notification window will appear, click OK.  

Close the C2RCC OLCI Processor dialog window. 

In your Product Explorer tab, you will find a new product with index number [4].  

7.5 Visualization 

Now let’s see our outputs. Expand the new product in the Product Explorer tab and then expand the 

Bands folder. In the Bands folder, you will find 7 folders and 2 additional bands.  

The 1st folder “iop” contains the absorption coefficient bands for different water constituents at 443 

nm.  

The 2nd folder “conc” contains the absolute concentration bands for total suspended matter dry weight 

(conc_tsm [g*m-3]) and chlorophyll concentration (conc_chl [mg*m-3]).  

The next folder we are interested in is the 5th one, “rhown” containing the Normalized water-leaving 

reflectances for each original radiance band (See  NOTE 2).  

Lastly, we need to pay attention to the 7th, “unc” folder that contains uncertainty estimates for the 

IOPs and the concentration bands.  

 

Let’s expand the “conc” folder and double click on “conc_chl” band to open it in view window.  

!quality_flags.invalid && !quality_flags.land && 

!quality_flags.sun_glint_risk 

 NOTE 2: Radiance is the variable directly measured by remote sensing instruments. It is the amount of 

light seen by instrument from a surface of an object. In the SLSTR products is given as radiance of a 

surface per wavelength unit [mW*m-2*sr-1*nm-1 = watt per square meter per nanometer]. Reflectance 

is the ratio (percentage) of the amount of light leaving a target to the amount of light arriving to the 

target. It has no units. It is the property of the observed object/material.  
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We can see that all the land areas have been removed but clouds appeared are misclassified as high 

concentration. We can use the masks included in the product to eliminate them.  

Firstly, go to “Colour Manipulation” tab and import/open the colour palette named “cc_chl.cpd”. At 

the dialog that will appear at the bottom left, click NO to keep the predefined colour classes. 
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Then go to View → Tool Windows → Mask Manager.  The Mask Manager window should appear 

docked at the right side of the SNAP window (if not already there).  

There you can enable flags indicating land (quality_flags_land - green) and clouds (Cloud_risk - gray). 

You may need to zoom-in and out to load the masks properly. 

IMPORTANT! The masks do not remove the values corresponding to clouds from the histogram; they 

only hide them from view.   

 

You can also inspect the uncertainty of these concentration estimates.  

Go to the “unc” folder and open the “unc_chl” band. Then, go to “Colour Manipulation” tab and open 

the colour palette named “spectrum”. You can again use the masks (quality_flags_land - green) and 

(Cloud_risk - gray) to mask out the land and cloud values.  

 

You can also explore the total suspended matter estimates.  

Open the “conc_tsm” band, the go to “Colour Manipulation” tab and import/open the colour palette  
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named “cc_tsm.cpd” and click again NO at the dialog that will appear at the bottom left, to keep the 

predefined colour classes. Finally, investigate the “unc_tsm” band as well and at the “Colour 

Manipulation” tab, open the colour palette named “spectrum”. 

  
Close all views except the “conc_chl” view.  

7.6 Comparison to the Level-2 WFR product 

In the beginning of the exercise, we have downloaded two products, Level-1 EFR product (that we have 

processed) and Level-2 WFR product. Now let’s compare our output to the operationally generated. 

In the Product Explorer tab, highlight the Level-2 product (index number 2). 

Go to Raster → Subset and subset the product using the same pixel coordinates as for the Level-1. 

At the Spatial Subset tab go to Pixel Coordinates tab and set the following coordinates: 

Scene start X:   600 Scene start Y:   50 Scene end X: 2800 Scene end Y:   2250 

Expand the subset with index number [5] in the Product Explorer tab and expand the Bands folder. 

Expand the “CHL” folder and double click on “CHL_NN” band. Again, go to the “Colour Manipulation” 

tab and load the “cc_chl.cpd” colour palette. At the dialog that will appear at the bottom left, click NO 

to keep the predefined colour classes. 

 

“conc_tsm” band “unc_tsm” band 
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Open the Mask Manager and turn on the “WQSF_lsb_LAND” mask as well as all the cloud related 

masks (“WQSF_lsb_CLOUD”, “WQSF_lsb_CLOUD_AMBIGUOUS”, “WQSF_lsb_CLOUD_MARGIN”). 

In the Transparency column, change the transparency to 0 for those 4 masks.  

 

Go to Window → Tile Horizontally; in Navigation tab select Zoom all. 

 

You can also open the uncertainty bands and compare them. You will see some minor differences 

mostly due to the additional pre-processing applied during the generation of the Level-2 WFR product 

by the ground segment. These pre-processing steps are not applied to the Level-1 product we have 

processed and are not part of the C2RCC algorithm.  

7.7 Export as GeoTIFFs 

Close all view windows. In Product Explorer, expand the Subset of the Level-1 processed product with 

index number [4]. Expand “Bands” folder. Then expand “conc” folder. Right-click on the “conc_chl” 

band and select Convert Band (this converts the band from virtual to physical, so we can export it).  
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Do the same for the “unc_chl” band. Right-click the product name and select Save Product.  

 

Go to File → Export → GeoTiff (NOT! Geotiff/Big Tiff). In the dialog, that opens click Subset. 

At the Band Subset (second tab) use the Select none button to deselect them all first and then select 

only bands “conc_chl” and “unc_chl”. 

Then go to the Metadata Subset tab and click Select none.  

  

Then click OK. In the dialogs (one or two), that appear, click NO. 

Save the file to the “Processing” folder as: Chlorophyll_conc_20170709.tif and press “Export Product”. 

Repeat the same for the TSM bands (save as TSM_20170709.tif).  

Now, we can import the image to another GIS/ Remote sensing software for further processing or map 

creation. In the extra steps of this tutorial, we will use QGIS. To download the results to your local 

computer, see section 6.1 Downloading the outputs from VM.  

 

 

THANK YOU FOR FOLLOWING THE EXERCISE! 
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8  Extra steps  

8.1 Downloading the outputs from VM 

Press Ctrl+Alt+Shift. A pop-up window will appear on the left side of the screen. Click on bar below 

Devices, the folder structure of your VM will appear. Navigate to your Processing folder and double 

click any file you want to download.  
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