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1 Introduction 

The Research and User Support for Sentinel core products (RUS) service provides a free and open 

scalable platform in a powerful computing environment, hosting a suite of open source toolboxes 

pre-installed on virtual machines, to handle and process data derived from the Copernicus Sentinel 

satellites constellation. 

As the world population grows so does the demand for food, fuel, and raw materials provided by 

agriculture. However, the Earth stubbornly stays the same size and so the growing needs must be 

satisfied on increasingly smaller area of arable land per capita 

while taking into account environmental sustainability and 

climate change effects and their mitigation. We need to make 

our agricultural production increasingly more effective – using 

less resources to grow more. Remote sensing is an ideal tool 

to assist the evolution of agricultural practices in order to face 

this major challenge, by providing repetitive information on 

crop status throughout the season at different scales and for 

different actors. 

There is a large number of remote sensing sensors used today for monitoring of crops, from precision 

farming to large scale food security assessments. In this webinar we will introduce the use of 

Sentinel-2 multi spectral data to derive high resolution information on crop biophysical parameters 

such as Leaf Area Index (LAI),  fraction of Absorbed Photosynthetically Active Radiation (fAPAR), 

Fraction of Vegetation Cover (FVC), and the Canopy chlorophyll  and Water content (CCC, CWC). 

These parameters provide information on vegetation/crop status such as health, water/nutrient 

stress, etc. and serve as input for estimation of more complex variables such as yield. 

For theoretical introduction please watch: https://youtu.be/xEwy8UMGu7M on RUS Copernicus 

Training channel.  

2 Training 

Approximate duration of this training session is two hours.  

2.1 Data used 

• 10 low-cloud Sentinel-2A Level 2A tile (Tile ID: T32TQN) acquired from  29 January to 15 

November 2018 [downloadable @ https://scihub.copernicus.eu/] 

1. S2A_MSIL2A_20180129T101251_N0206_R022_T32TQM_20180129T135502.zip 

2. S2B_MSIL2A_20180213T101119_N0206_R022_T32TQM_20180213T135340.zip 

3. S2A_MSIL2A_20180406T100031_N0207_R122_T32TQM_20180406T110023.zip 

4. S2A_MSIL2A_20180416T100031_N0207_R122_T32TQM_20180416T120852.zip 

5. S2B_MSIL2A_20180421T100029_N0207_R122_T32TQM_20180421T120642.zip 

6. S2A_MSIL2A_20180426T100031_N0207_R122_T32TQM_20180426T120750.zip 

7. S2A_MSIL2A_20180526T100031_N0208_R122_T32TQM_20180526T161700.zip 

8. S2B_MSIL2A_20180531T100029_N0208_R122_T32TQM_20180531T125926.zip 

9. S2B_MSIL2A_20180620T100029_N0208_R122_T32TQM_20180620T182958.zip 

10. S2B_MSIL2A_20180630T100029_N0208_R122_T32TQM_20180630T144100.zip 

2.2 Software in RUS environment 

Internet browser, SNAP + Sentinel-2 Toolbox, QGIS, (Extra steps: Sen2Cor, Google Earth) 

https://youtu.be/xEwy8UMGu7M
https://scihub.copernicus.eu/


4 
 

3 Register to RUS Copernicus 

To repeat the exercise using a RUS Copernicus Virtual Machine (VM), you will first have to register as 

a RUS user. For that, go to the RUS Copernicus website (www.rus-copernicus.eu) and click on 

Login/Register in the upper right corner.  

 

Select the option Create my Copernicus SSO account and then fill in ALL the fields on the Copernicus 

Users’ Single Sign-On Registration. Click Register. 

 

Within a few minutes you will receive an e-mail with activation link. Follow the instructions in the e-

mail to activate your account.  

You can now return to https://rus-copernicus.eu/, click on Login/Register, choose Login and enter 

your chosen credentials. 

http://www.rus-copernicus.eu/
https://rus-copernicus.eu/
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Upon your first login you will need to enter some details. You must fill all the fields.   

 

4 Request a RUS Copernicus Virtual Machine 
Once you are registered as a RUS user, you can request a RUS Virtual Machine to repeat this exercise 

or work on your own projects using Copernicus data. For that, log in and click on Your RUS Service → 

Your Dashboard.  
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Click on Request a new User Service to request your RUS Virtual Machine. Complete the form so that 

the appropriate cloud environment can be assigned according to your needs. 
  

 
 

If you want to repeat this tutorial (or any previous one) select the one(s) of your interest in the 

appropriate field. 

 

 
 

Complete the remaining steps, check the terms and conditions of the RUS Service and submit your 

request once you are finished. 
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Further to the acceptance of your request by the RUS Helpdesk, you will receive a notification email 

with all the details about your Virtual Machine. To access it, go to Your RUS Service → Your 

Dashboard and click on Access my Virtual Machine.  
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Fill in the login credentials that have been provided to you by the RUS Helpdesk via email to access 

your RUS Copernicus Virtual Machine.  

 

This is the remote desktop of your Virtual Machine. 

 

5 Step by step  

5.1 Data download – ESA SciHUB 

In this step we will download the Sentinel-2 scenes from the Copernicus Open Access Hub using the 

online interface (Applications → Network → Web Browser or click the link below). 

Go to https://scihub.copernicus.eu/   

https://scihub.copernicus.eu/
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Go to “Open HUB”, if you do not have an account please register by going to “Sign-up” in the LOGIN 

menu in the upper right corner. 

 

After you have filled in the registration form, you will receive an activation link by e-mail. Once your 

account is activated or if you already have an account, “LOGIN”.  

 

Switch the rectangle-drawing mode to pan mode by clicking on the “Pan” icon in the lower left 

corner of the map (Green arrow) and navigate over Italy (approximate area – blue rectangle). 
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Switch to drawing mode and draw a search rectangle over the lake approximately as indicated below 

(yellow). Open the search menu (red arrow) and specify the following parameters: 

Sensing period:  From 2018/01/29 to 2018/06/30 

Check Mission:   Sentinel-2  

Product Type:   S2MSIL2A 

Press “Search” (red arrow below). 

 

In our case, the search returns four results depending on the exact search area defined. Using the 

icon, import only the following products to Cart:  

S2A_MSIL2A_20180129T101251_N0206_R022_T32TQM_20180129T135502.zip 

S2B_MSIL2A_20180213T101119_N0206_R022_T32TQM_20180213T135340.zip 

S2A_MSIL2A_20180406T100031_N0207_R122_T32TQM_20180406T110023.zip 

S2A_MSIL2A_20180416T100031_N0207_R122_T32TQM_20180416T120852.zip 

S2B_MSIL2A_20180421T100029_N0207_R122_T32TQM_20180421T120642.zip 

S2A_MSIL2A_20180426T100031_N0207_R122_T32TQM_20180426T120750.zip 

S2A_MSIL2A_20180526T100031_N0208_R122_T32TQM_20180526T161700.zip 

S2B_MSIL2A_20180531T100029_N0208_R122_T32TQM_20180531T125926.zip 

S2B_MSIL2A_20180620T100029_N0208_R122_T32TQM_20180620T182958.zip 

S2B_MSIL2A_20180630T100029_N0208_R122_T32TQM_20180630T144100.zip 

Then click on the Profile icon in the upper left corner (marked with green circle above) and go to 
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Cart. You should now have six products in your cart. Click on the arrow to Download the Cart.  

 

The grey products are currently placed in an Offline archive: to learn how to request them please 

follow the steps outlined here: https://scihub.copernicus.eu/userguide/LongTermArchive  

 

A products.meta4 file will be downloaded to your /home/rus folder. To download our data, we will 

use aria2 tool. To use the tool, we first need to place the products.meta4 file to the folder where we 

wish our data to be downloaded to: 

/shared/Training/LAND11_VegetationMonitoring4Agri_Italy/Original 

First, let’s test our aria2 installation. To do this we open the Command Line  (in the bottom of 

your desktop window) and type: 

 

The correct response should be as follows: 

 

 

If the response is “-bash aria2c: command not found” see  NOTE 1. If you have received the 

correct response, then we can run the tool by typing the following commands in the command line 

(replace <username> and <password> with your login credentials for Copernicus Open Access Hub):  

TIP: Alternatively, you can try to retrieve the products from other repositories such as: PEPS 

(https://peps.cnes.fr/rocket/#/home) or ONDA DIAS Catalogue (https://catalogue.onda-

dias.eu/catalogue/) or others. Registering for a free account is usually necessary, but archived data 

retrieval will be faster than with Open Access Hub. 

 

aria2c 

 NOTE 1: If (and only if) the response is “-bash aria2c: command not found”. Then we have to install the 

tool, to do this in command line type: sudo apt-get install aria2 

When requested type: Y 

Then you can test your installation again.  

https://scihub.copernicus.eu/userguide/LongTermArchive
https://peps.cnes.fr/rocket/#/home
https://catalogue.onda-dias.eu/catalogue/
https://catalogue.onda-dias.eu/catalogue/
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The first line changes our directory to the target directory. The second line runs the download tool 

(Type the red text all in a single line). All twelve products will be downloaded to the Original folder, 

two products in parallel automatically.  

(Note that the constraint of maximum 2 parallel downloads at a time is imposed by the Copernicus 

Access Hub, if you increase the number, your download will fail). This might take some time. 

5.2 Data exploration 

Launch SNAP (icon on desktop ). When the SNAP window opens click Open product  and 

navigate to:   /shared/Training/LAND11_VegetationMonitoring4Agri_Italy/Original/  

Open the first S2 product (from 29 January 2018). We can first investigate the structure of the 

Sentinel-2 Level 2A products (see  NOTE 2). Click on the dot next to the product name to expand 

the structure. The L1C products contain (among others): 

• 13 TOA (top-of-atmosphere) reflectance bands 

• Quality flags 

Now, let’s visualize the product. We will visualize it in true (natural) colours and as a false color 

composite which is better for distinguishing water surfaces. Right-click the product and click Open 

RGB image window, a new window will open. From the drop-down menu select:  

Profile : Sentinel 2 MSI Natural Colors 

Click OK. 

When the image opens, repeat the same but choose the false 

colour Profile. 

Profile : Sentinel 2 MSI False-color Infrared 

Finally, go to Window → Tile Horizontally.  

 

cd /shared/Training/LAND11_VegetationMonitoring4Agri_Italy/Original  
 

aria2c --http-user='<username>' --http-passwd='<password>' --check-

certificate=false --max-concurrent-downloads=2 -M products.meta4 
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5.3 STEP 1 – Pre-Processing 

Processing the data one by one would not be very time effective. However, we can use either the 

Batch Processing tool available in SNAP or the GPT tool (command line) to process all images 

automatically.  

To use either method, we first need to define the process we want to apply and all its steps. We can 

do this using the GraphBuilder tool. Another advantage of the GraphBuilder is that only the final 

product will be physically saved, and we save valuable disk space.   

So, let’s build our graph. First, in the Product Explorer select the first loaded product (so it is 

highlighted), then go to Tools → GraphBuilder.  

 

At the moment, the graph only has two operators: Read (to read the input) and Write (to write the 

output).  

The 13 bands in Sentinel-2 products do not all have the same resolution (therefore size) as 

mentioned in  NOTE 3. Many operators do not support products with bands of different sizes so 

first we need to resample the bands to equal resolution.   

To add the appropriate operator, right-click the white space between existing operators and go to 

Add → Raster → Geometric → Resample. 

A new operator rectangle appears in our graph and a new tab appears below. Now connect the new 

Resample operator with the Read operator by clicking to the right side of the Read operator and 

 NOTE 2: The Sentinel-2 data are distributed as 100x100 km tiles resampled to a common grid in WGS84 

UTM projection at two levels of processing: 

• Level-1C – Top-Of-Atmosphere reflectances, systematically generated since the start of the mission. 

• Level-2A – Bottom-Of-Atmosphere reflectances (atmospherically and radiometrically corrected), 

systematically produced for products acquired over Europe since the spring of 2017, the coverage 

has increased through 2018 to reach global coverage in the beginning of 2019. It can be produced on 

user side by applying the Sen2Cor algorithm. 
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dragging the red arrow towards the Resample operator.  

 

 

Next step will be to subset the images to the area of interest, we do this by right-clicking the white 

space somewhere right of the resample operator and going to Add → Raster → Geometric → 

Subset. Connect the Subset operator with the Resample operator. 

 

Finally, connect the Subset operator to the Write operator.  

Now, let’s set the parameters. In the Resample tab, we set:   

Under Define size of resampled product: Select the “By reference band from source product” and 

choose the B2 band (we will resample all the bands to 10m resolution).  

 

Credits: ESA 2015 

 NOTE 3: The input product 

contains 13 spectral bands 

in three different spatial 

resolutions (The surface 

area measured on the 

ground and represented by 

an individual pixel).  When 

we open the RGB view all 

our input bands have 20 m 

resolution, however, the 

view is displayed in the full 

10 m resolution.  
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In the Subset tab, select Geographic Coordinates, in the text-window paste the subset polygon 

coordinates in Well-Known-Text format (WKT) from Expressions_WQ.txt file in:  

/shared/Training/LAND11_VegetationMonitoring4Agri_Italy/  

 

 

We can leave the Read and Write tabs unchanged. Now, save the graph as STEP1_Graph_Prep.xml 

to: /shared/Training/LAND11_VegetationMonitoring4Agri_Italy/Processing/ by clicking Save at the 

bottom of the window and then close the GraphBuilder window.  

In this tutorial, we will use the GPT and shell script to automatize the processing of our 10 products. 

To do this, we must first edit the saved graph file.  

To edit the file, leave SNAP and in the file explorer, navigate to the …/Processing folder and right-

click on the saved graph file. Select Open with -> Open with “Mousepad”. When the file is open, go 

to View -> Line Numbers for easier navigation.  

Now, we need to replace the input and output file path with a pattern that will allow the shell script 

(See  NOTE 4) to recognize and replace it with appropriate value for each file automatically.  

 

In line 7 (in the node with id=’Read’) replace the path to input file with (between <file> and </file>): 

$Input (“$” signifies that what follows is a parameter).  

POLYGON ((12.188833156432 41.90177193536, 12.248943376218 41.90008525013, 

12.246701805438 41.85586135019, 12.186632885123 41.857545435452, 12.188833156432 

41.90177193536) 

 NOTE 4: A shell script is a computer program designed to be run by the Unix shell, a command-line 

interpreter. The various dialects of shell scripts are considered to be scripting languages. The one used 

in this exercise is called Bash script (https://en.wikipedia.org/wiki/Bash_(Unix_shell)). Typical operations 

performed by shell scripts include file manipulation, program execution, and printing text.  

If you wish to run this exercise on Windows, you can replicate the steps in any programming language 

you are familiar with, such as Python or R.  

Zoom-in 

https://en.wikipedia.org/wiki/Bash_(Unix_shell)
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In line 51 (in the node with id=’Write’) replace the path to output file with (between <file> and 

</file>):  $Output 

 

Now, go to the to the …/Processing/Code/ folder and open the STEP1_script_gpt.sh  

 

On line 1, we specify that the script should be run with Bash scripting language. (See  NOTE 4) 

 

On line 3, 4 and 5, we specify our desired output folder path, and the pattern beginning and ending 

of the output name respectively.  

 

Line 7 signifies the start of the loop. The script will loop over all files in the specified folder ending 

with “.zip”. In each iteration, the path to one input file is denoted by “i”.  

“do” on line 8 and “done” on line 13 enclose the steps that should be performed on each input 

product.  
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On line 9, we extract the name of the input product; on line 10, we extract the date of the acquisition 

from the name.  

 

On line 11, we create the final path and name of our output, combining our specified output folder 

path, the beginning of the output name, the acquisition date and specified name end including the 

format suffix.  

 

On line 12, we call GPT and specify the path to our saved and edited graph file. Then with -P{variable 

name} we specify the parameters to be replaced in the graph file (marked with $ in the graph file). 

We have set the variables when we edited the .xml graph file – Input, Output. On line 13, the loop is 

closed.  

 

If your input and output folders are different you need to edit the file accordingly and save it. To run 

the script, we navigate to the folder where it is saved 

(/shared/Training/LAND11_VegetationMonitoring4Agri_Italy/Processing/Code/) and right-click on 

the white space and go to Open Terminal Here. In the terminal type: 

 

where STEP1_script_gpt.sh is the name of the Bash script file. Click ENTER to run the script.  

 
… 

 

The processing time will depend on your VM setup. (approx. 3 mins with 30GB ram). You can check 

the /shared/Training/LAND11_VegetationMonitoring4Agri_Italy/Processing/Pre-processed for the 

output products. Close the terminal window. 

sh STEP1_script_gpt.sh 

First product processed  

All products completed  
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Now, let’s have a look at them. Go back to SNAP and go to File → Session → Open session.. Navigate 

to /shared/Training/LAND11_VegetationMonitoring4Agri_Italy/ and open Pre-processed.snap 

Once all products are loaded, right-click the first and go to Open RGB image window. Select the 

Sentinel 2 MSI Natural Colors profile and click OK. You can repeat this step for all products and the 

go to Window → Tile Evenly.  

 

5.4 STEP 2 – Biophysical Parameter retrieval 

Now, we will extract the vegetation biophysical parameters. A different number of methods exist for 

this purpose. From simple empirical regression to complex radiative transfer model inversions. The 

S2 SNAP Toolbox biophysical variable retrieval algorithm belongs to the latter category. It was 

developed by Weiss and Baret (INRA) and it is implemented as a collection of backpropagation 

artificial neural networks (ANN) trained using a globally representative set of simulations from a 

canopy radiative transfer (RT) model (PROSAIL: PROSPECT (Jacquemoud and Baret, 1990) + SAIL 

(Verhoef, 1984)). The use of the radiative transfer models is always associated with strong 

assumptions, in this case, particularly regarding canopy architecture (turbid medium model). 

The algorithm is "generic", i.e. it should apply to any type of vegetation with reasonable 

performances. However, the assumption of canopy as turbid medium is more applicable to 

crops/grasses rather than for example forest canopies. This translates to better results for 

agricultural applications reported in literature. 

We can run the processor both in the SNAP Graphical interface and in the GPT. We will choose the 

GPT in this exercise. Since we will be applying a single operator, we do not need to create a graph 

first, we will however still use the shell script to run the operator in batch on all our inputs.  

Let’s first have look at the operator in GPT. Open the Terminal window from the panel at the bottom 

of your screen  and type: 

 

By default, all the biophysical parameters will be output. 

gpt BiophysicalOp -h   
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Now, we can go to the script we will use to run the processor on all the images automatically. It is 

similar to the one used previously for pre-processing. It is named STEP2_script_gpt_BioOp.sh and 

you can find it in: /shared/Training/LAND11_VegetationMonitoring4Agri_Italy/Processing/Code/ 

 

On lines 3 to 5 we specify input parameters, such as the path to out output directory and the input 

file end and output file end, respectively. Our output format will be GeoTIFF, therefore the output 

file end must reflect this. 

 

Line 7 signifies the start of the loop. The script will iterate over all files in the specified folder ending 

with “.dim”. In each iteration the path to one input file is denoted by “i”. “do” on line 8 and “done” 

on line 10 enclose the steps that should be performed on each input product.  

 

On line 9, we extract the input file name, on line 10 we compose the new output path and name.   

 

Finally, on line 11 we call GPT (SNAP command line utility) and the BiophysicalOp tool. Then we set 

the processing parameters, “done” at line 12 closes the loop. 
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To run the script, we navigate to the folder where it is saved 

(/shared/Training/LAND11_VegetationMonitoring4Agri_Italy/Processing/Code/) and right-click on 

the white space and go to Open Terminal Here. In the terminal type: 

 

where STEP2_script_gpt_BioOp.sh is the name of the script file. Click ENTER to run the script.  

 
… 

 

Note that the processing is quite time demanding and even for our small subset, the processing takes 

approximately 45 minutes (10 images, 30GB RAM VM).  

Go back to SNAP and go to File → Session → Open Session, then click Yes in the dialog that opens. 

Open: /shared/Training/LAND11_VegetationMonitoring4Agri_Italy/BioOp_processed.snap 

Now, let’s investigate the results. In Product Explorer, open the structure of one product and go to 

Bands. Here we choose the product #1 from 29 January 2018 and opened the Bands → lai. 

For each opened view you can go to the Colour Manipulation tab and click on Import colour palette 

from text file . In /shared/Training/LAND11_VegetationMonitoring4Agri_Italy/AuxData you can 

find the appropriate colour map for LAI.cpd. To keep the pre-set values, click No in the Import Colour 

Palette dialog. 

 

 

 

 

sh STEP2_script_gpt_BioOp.sh 
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Then go to the last product #11 and right-click on it. Select Open RGB Image Window and select the 

default RGB profile: Sentinel-2 MSI Natural Colours. Then, to visualize the images next to one 

another you can go to Window → Tile Horizontally. 

 

Compare the natural color composite and the LAI product side by side. Now go back also to product 

#1 and open also lai_cab, lai_cw, fapar and fcover band. For each band, apply the respective color 

palette from the AuxData folder.  

 

5.5 STEP 3 – Time series  

Now let’s see how the values develop throughout our observed period. To do this we will use the 

Time Series tool available in SNAP. You can find it in the top panel      .  

Open it and arrange windows as shown below. Then click on Settings.  
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Once the settings menu opens, click on Add Opened. This will add all our loaded products, however, 

remember that we need to close the last product as it does not contain the biophysical parameters. 

To do this, select it in the list and click on the minus symbol. Then click Apply and Close the dialog. 

 

A line will appear on the graph, but we don’t know 

which variable it corresponds to yet. So, the next step 

is to limit the bands. Click on the Filter Bands     tool       

and select the “lai” band and click OK.  

 Now you can move the cursor over the “lai” image 

and for each position the graph will show the 

development over our timeseries.  

 

 

Settings 

Add Opened 
Remove product 
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By selecting different bands, we can investigate various fields and the other variables. 

(Unfortunately, at the time of writing of this tutorial the pin and polygon told in the Time Series Tool 

do not function reliably for Optical data) 

 

 

 

LAI 
(147, 326) 

Cab 
(147, 326) 

Cw 
(147, 326) 

29-Jan 2018 

29-Jan 2018 

29-Jan 2018 
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Once you are done exploring, go to File → Session → Open Session.., then click Yes in the dialog that 

opens. Then open:  /shared/Training/LAND11_VegetationMonitoring4Agri_Italy/Validation.snap 

5.6 STEP 4 – Validation 

We have field data for 4 dates, three of which match perfectly with our Image acquisition dates. For 

the fourth date an image also exists but it is contaminated by clouds and therefore not used here. 

Instead we use image acquired 2 days later, this can also help us to comprehend what effect this 

time difference has on the agreement with the field data. 

Field data (date) # Points Image date 

29-Jan. 2018 9 29-Jan. 2018 

13-Feb. 2018 14 13-Feb. 2018 

06-Apr. 2018 13 06-Apr. 2018 

19-Apr. 2018 8 21-Apr. 2018 
 

In the newly opened SNAP session, we now have 4 images opened. Let’s have look at the image from 

13 February 2018 (product #2) which has the most corresponding in situ data points. 

First let’s load the in-situ data by selecting (highlighting) the product in the Product Explorer and 

going to Vector → Import → Vector from CSV. Navigate to: 

/shared/Training/LAND11_VegetationMonitoring4Agri_Italy/AuxData/   

And open: 13Feb2018 DurumWheat_Maccarese_GTSurvey.txt 

Then open the bands from product #2 (13 February 2018): lai, lai_cab, lai_cw, fapar and fcover 

You can also apply the respective color palettes as we have done on page 21. On the image, white 

crosses appear indicating the in-situ measurements. SNAP offers the Correlative Plot tool       , and 

you can open it from the top panel.  

fAPAR 
(147, 326) 

FCover 
(147, 326) 

29-Jan 2018 

29-Jan 2018 



25 
 

 

First, click into the (2) lai image view to link it to the graph (the graph will be minimised to the 

desktop taskbar – click on it to activate it again). Then set:  

Point data source:  13Feb2018 DurumWheat_Maccarese_GTSurvey 
Data field: LAIw_Mean 
Select option to Show regression line. 

 

Here we can see a very good agreement between our in-situ and our calculated Leaf Area Index with 

the coefficient of determination of 0.91. You can also investigate other dates and variables.  
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We can also export the values. Write the values for all the images into a csv for better comparison in 

Libre Office Calc, Office Excel or import it to QGIS for example. For this we can use a very convenient 

Extract Pixel Values tool.  

Go to Raster → Export → Extract Pixel Values. In the Input/Output tab, click on the + sign and select 

Add product(s)… in the dialog that opens select all. Then set: 

Time extraction:  
Time extraction pattern in filename: *${startDate}* 
Output directory: /shared/Training/LAND11_VegetationMonitoring4Agri_Italy/Processing/   

 

In the Parameters tab, in the Coordinates click on the + sign and select Add measurements from 

CSV file… the navigate to: 

/shared/Training/LAND11_VegetationMonitoring4Agri_Italy/AuxData/Field_data and open: 

Jan2018-April2018_DurumWheat_Maccarese_GTSurvey LATLONG.txt  

This text file contains all the in-situ observations for all dates and their appropriate coordinates, date 

of collection (in specific format: YYYY-MM-DDThh:mm:ss) and values for all the observed parameters.  

In the previous tab, we have extracted the date of acquisition from the name of each image product. 

Now we will use this date to match it with the in-situ data collection date. For each set of coordinates 

the pixel values will be extracted from the image that was acquired within 3 days of the in-situ data 

collection. To do this, set:   

Use time difference constraint:  

Allowed time difference: 3 Days  

Export:        Bands  

Match with original input:       Include original input 
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Now we can click Extract. We can open the file in Libre Office… and process it further.  

 

 

THANK YOU FOR FOLLOWING THE EXERCISE! 
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6 Extra steps 

6.1 Downloading the outputs from VM 

On your keyboard, press Ctrl+Alt+Shift. A pop-up window will appear on the left side of the screen. 

Click on the bar below Devices, the folder structure of your VM will appear. Navigate to your 

Processing folder and double click any file you want to download.  

 

7 Sources & References 

Weiss, M., Baret, F., 2016. S 2 ToolBox Level 2 products: LAI, FAPAR, FCOVER Version 1 (ATBD). INRA. 

https://step.esa.int/docs/extra/ATBD_S2ToolBox_L2B_V1.1.pdf  

Weiss, M., Jacob, F., Duveiller, G., 2020. Remote sensing for agricultural applications: A meta-review. Remote 

Sens. Environ. 236, 111402. https://doi.org/10.1016/j.rse.2019.111402  

Cui, B., Zhao, Q., Huang, W., Song, X., Ye, H., Zhou, X., 2019. A New Integrated Vegetation Index for the 

Estimation of Winter Wheat Leaf Chlorophyll Content. Remote Sens. 11, 974. 

https://doi.org/10.3390/rs11080974   

Kattenborn, T., 2019. Linking Canopy Reflectance and Plant Functioning through Radiative Transfer Models 

(PhD. Dissertation). The Karlsruhe Institute of Technology (KIT), Karlsruhe. 

https://doi.org/10.5445/IR/1000089168  

Pasqualotto, N., Delegido, J., Van Wittenberghe, S., Rinaldi, M., Moreno, J., 2019. Multi-Crop Green LAI 

Estimation with a New Simple Sentinel-2 LAI Index (SeLI). Sensors 19, 904. https://doi.org/10.3390/s19040904  

Upreti, D., Huang, W., Kong, W., Pascucci, S., Pignatti, S., Zhou, X., Ye, H., Casa, R., 2019. A Comparison of 

Hybrid Machine Learning Algorithms for the Retrieval of Wheat Biophysical Variables from Sentinel-2. Remote 

Sens. 11, 48 https://doi.org/10.3390/rs11050481  

Lecture by Dr. Weiss - LAI/fCover/fAPAR/Chlorophyll retrieval concepts and methods - 9th Advanced Training 

Course on Land Remote Sensing 

 

https://step.esa.int/docs/extra/ATBD_S2ToolBox_L2B_V1.1.pdf
https://doi.org/10.1016/j.rse.2019.111402
https://doi.org/10.3390/rs11080974
https://doi.org/10.5445/IR/1000089168
https://doi.org/10.3390/s19040904
https://doi.org/10.3390/rs11050481
https://eo4society.esa.int/resources/advanced-training-course-on-land-remote-sensing-with-the-focus-on-agriculture/
https://eo4society.esa.int/resources/advanced-training-course-on-land-remote-sensing-with-the-focus-on-agriculture/

