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1 Introduction to RUS 

The Research and User Support for Sentinel core products (RUS) service provides a free and open 

scalable platform in a powerful computing environment, hosting a suite of open source toolboxes 

pre-installed on virtual machines, to handle and process data derived from the Copernicus Sentinel 

satellites constellation.   

In this tutorial, we will employ RUS to monitor the urban heat island phenomenon in London (UK) 

using Sentinel-3 SLSTR sensor as source of information. 

2 Urban Heat Island – background 

Currently, more than half of the world’s population 

live in urban areas and this number is still rapidly 

increasing. Since settlements represent the centers 

of human activity, the environmental, economic, 

political and cultural impacts of urbanization are 

far-reaching. They include negative aspects like the 

loss of natural habitats, biodiversity and fertile soils, 

climate impacts, waste, pollution, etc., making 

urbanization one of the most pressing global 

challenges.  

The Urban Heat Island (UHI) phenomenon is one example of the effect of urban areas in the local 

climate. The effect mainly consists of the heating of urban zones in comparison to its non-urbanized 

surroundings. The atmospheric air temperature of densely urbanized areas is higher than the one of 

the nearby rural areas. Its relevance usually appears during the night because of the release of 

energy that has been stored by built-up surfaces during the day. Among the local impacts and 

negative effects of the UHI phenomenon, we can highlight thermal stress & deaths, higher energy 

consumption (due to air-conditioning), atmospheric chemistry (03 emissions from energy 

consumptions), increased water demand amongst others.  

3 Training 

Approximate duration of this training session is one hour.  

The Training Code for this tutorial is LAND09. If you wish to practice the exercise described below 

within the RUS Virtual Environment, register on the RUS portal and open a User Service request 

from Your RUS service > Your dashboard. 

3.1 Data used 

• 2 Sentinel-3A images acquired on 2nd August 2018 [downloadable at 

https://scihub.copernicus.eu/  

• Pre-processed data stored locally 

@/shared/Training/LAND09_UrbanHeatIsland_London/AuxData/ 

3.2 Software in RUS environment 

Internet browser, SNAP + S3 Toolbox 

https://scihub.copernicus.eu/
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4 Register to RUS Copernicus 

To repeat the exercise using a RUS Copernicus Virtual Machine (VM), you will first have to register as 

a RUS user. For that, go to the RUS Copernicus website (www.rus-copernicus.eu) and click on 

Login/Register in the upper right corner.  

 

Select the option Create my Copernicus SSO account and then fill in ALL the fields on the Copernicus 

Users’ Single Sign On Registration. Click Register. 

 

Within a few minutes you will receive an e-mail with activation link. Follow the instructions in the e-

mail to activate your account.  

You can now return to https://rus-copernicus.eu/, click on Login/Register, choose Login and enter 

your chosen credentials. 

http://www.rus-copernicus.eu/
https://rus-copernicus.eu/
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Upon your first login you will need to enter some details. You must fill all the fields.   

 

5 Request a RUS Copernicus Virtual Machine 

Once you are registered as a RUS user, you can request a RUS Virtual Machine to repeat this exercise 

or work on your own projects using Copernicus data. For that, log in and click on Your RUS Service → 

Your Dashboard.  
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Click on Request a new User Service to request your RUS Virtual Machine. Complete the form so that 

the appropriate cloud environment can be assigned according to your needs. 
 

 
 

If you want to repeat this tutorial (or any previous one) select the one(s) of your interest in the 

appropriate field. 

 
 

Complete the remaining steps, check the terms and conditions of the RUS Service and submit your 

request once you are finished. 
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Further to the acceptance of your request by the RUS Helpdesk, you will receive a notification email 

with all the details about your Virtual Machine. To access it, go to Your RUS Service → Your 

Dashboard and click on Access my Virtual Machine.  
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Fill in the login credentials that have been provided to you by the RUS Helpdesk via email to access 

your RUS Copernicus Virtual Machine.  

 

This is the remote desktop of your Virtual Machine. 
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6 Step by step  

6.1 Data download – ESA SciHUB 

Before starting the exercise, make sure you are registered in the Copernicus Open Access Hub so that 

you can access the free data provided by the Sentinel satellites.  

Go to https://scihub.copernicus.eu/   

 

Go to S-3 PreOps Hub. If you do not have an account, sign up in the upper right corner, fill in the 

details and click register.  

 

You will receive a confirmation email on the e-mail address you have specified: open the email and 

click on the link to finalize the registration. 

Once your account is activated – or if you already have an account – log in.  

https://scihub.copernicus.eu/
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6.2 Download data 

In this exercise, we will analyse 2 Sentinel-3A images acquired during August 2018. Navigate to the 

London area, switch the pan mode to drawing by clicking on the icon in the upper right corner of the 

map (Green arrow) and draw a rectangle as indicated below. Open search menu by clicking at the 

left of the search bar ( ), specify the following parameters and press the search button ( ): 

Sensing period: From 2018/08/02 to 2018/08/02 

Check Mission: Sentinel-3 | Product type: SL_2_LST__  

 

In our case, the search returns 2 results (day and night acquisitions). Download both products by 

clicking on the arrow icon . Note the different sensing times of the images: 

S3A_SL_2_LST____20180802T100213 and S3A_SL_2_LST____20180802T200809 

 

Once downloaded (@/home/rus/Downloads), move them to the following path and unzip them 

(right click -> Extract Here). 

Path: /shared/Training/LAND09_UrbanHeatIsland_London/Original/ 
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6.3 Sentinel-3 SNAP Processing 

Open SNAP Desktop from your desktop (or Applications -> Processing -> SNAP), click on the Open 

product icon ( ), navigate to the following path and open the day-time Sentinel-3 product from 

2018-08-02 (S3A_SL_2_LST____20180802T100213). Open the folder and select the file 

xfdumanifest.xml. Then, click OK.  

Path: /shared/Training/LAND09_UrbanHeatIsland_London/Original/ 

In the Product Explorer, expand the product by clicking in the left arrow. Expand now the Bands 

folder and double click on the band LST to visualize it. 

 

6.3.1 Subset 

The first step of the methodology will subset the image to reduce its original extent and number of 

bands. Select the Sentinel-3 SLSTR product in the Product Explorer and go to Raster -> Subset. In the 

Spatial Subset tab click on Geo Coordinates and introduce the following values: 

North latitude bound: 54.211 

West longitude bound: -6.362 

South latitude bound: 49.095 

East longitude bound: 3.312 

In the Tie-Point Grid Subset tab, select only the bands x_tx, y_tx, latitude_tx, longitude_tx.  

In the Band Subset tab, select only the bands NDVI, biome, fraction, LST, x_in, y_in, latitude_in, 

longitude_in. Then, click OK (click No in the pop-up flag dataset window). 

Once created, the subset product will appear in the Product Explorer. Do not forget to save it (right 

click on it -> Save Product) in the following path (click YES in the pop-up window): 

Path: /shared/Training/LAND09_UrbanHeatIsland_London/Processing/ 
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6.3.2 Reproject 

Once the product has been saved, we will reproject the Sentinel-3 SLSTR product to an appropriate 

map projection. Go to Raster -> Geometric operations -> Reprojection. In the I/O Parameters tab, 

make sure you select the subset product (index [2]) as input, change the output name to 

LST_20180802_day and make sure you set the output directory to the following path: 

Path: /shared/Training/LAND09_UrbanHeatIsland_London/Processing/ 

In the Reprojection Parameters tab, click on the Projection drop-down menu and select UTM / WGS 

84 (Automatic). Then, click Run. 
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6.3.3 Subset 

After reprojection, we will subset the product to its final extent. For that, select the reprojected 

product in the Product Explorer and go to Raster -> Subset. In the Spatial Subset tab click on Geo 

Coordinates and introduce the following values: 

North latitude bound: 52.372 

West longitude bound: -2.156 

South latitude bound: 50.64 

East longitude bound: 2.113 

Once created, the subset product will appear in the Product Explorer. Do not forget to save it (right 

click on it -> Save Product) in the following path (click YES in the pop-up window) with the name 

LST_20180802_day 

Path: /shared/Training/LAND09_UrbanHeatIsland_London/Processing/ 
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In the Product Explorer, expand the reprojected product (index [4]) by clicking in the left arrow. 

Expand the Bands folder and double click on the band LST to visualize it. 

Click on the Colour Manipulation tab (in the lower left corner), select Basic as Editor and click on the 

5_colors colour ramp. Set the Min and Max values to 300 and 325 respectively. Do not forget to save 

the product afterwards (right click on it -> Save Product). 

 

Once the product has been processed, we need to run the same steps (Subset + Reprojection + 

Subset) for the 2018-08-02 night product (S3A_SL_2_LST____20180802T200809). Click on the Open 

product icon ( ), navigate to the following path and open the night-time Sentinel-3 product from 

2018-08-02.  

Repeat the steps as explained before and named the final product LST_20180802_night. For the night 

product, set the Min and Max values to 285 and 300 respectively and do not forget to save the 

product afterwards (right click on it -> Save Product). 

Path: /shared/Training/LAND09_UrbanHeatIsland_London/Original/ 

Once both products are opened, go to Windows -> Tile Horizontally to combine both views and 

compared the temperatures (K). Click on the Pixel info tab and move the mouse over the images to 

analysis pixel values. To avoid confusion, close now (right click on the product -> Close product) all 

the products except the LST_20180802_day and LST_20180802_night. 

 



16 
 

 

6.3.4 Add Land Cover Band 

Once you have compared the different temperature (K) values between the day and night 

acquisition, close the LST_20180802_day product. To better identify the effect of an urban area in 

the temperature, we will subtract the average temperature of non-urban areas close to London. For 

that, we first add a land cover band to identify different land cover / land use. Right click on the 

LST_20180802_night product and select Add Land Cover Band. In the menu, go down, select 

CCILandCover-2015 (See  NOTE 1) and click OK. Do not forget to save to product afterwards. 

 

In the Bands folder of the LST_20180802_night product, double click on the land cover band 

(land_cover_CCILandCover-2015) to visualize it. Combine the visualization with the LST band by going 

to Windows -> Tile Horizontally. Use the Pixel info tab to identify the land cover code of each pixel.  

 

 NOTE 1: More information on the CCI Land Cover project can be found here - https://bit.ly/2MGSXdw 

  

  

 

   

https://bit.ly/2MGSXdw
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You can find the legend for the different classes in the color manipulation tab of the land cover band.  

6.3.5 Mean temperature  

Once the land cover band is added, the next step is to derive the mean temperature in the 

surroundings of London using specific pixel values identified using the Pin tool of SNAP. Instead of 

creating those pins from scratch, we will load them directly. In the Product Explorer, select the 

LST_20180802_night product and go to Vector -> Import -> ESRI Shapefile. Navigate to the following 

path and select the file pins_Point.shp. 

Path: /shared/Training/LAND09_UrbanHeatIsland_London/AuxData/ 

Once loaded, the pins are saved in the Vector folder of the LST_20180802_night product and can be 

visualized in the LST and Land Cover band (See  NOTE 2) (See  NOTE 3). Do not forget to save 

the product afterwards (right click -> Save Product). 

 

 

 

Once the pins are loaded in the image, we can derive the mean value for the pixels identified by the 

pins using the Statistics tool of SNAP. Close the land cover visualization and go to the menu Analysis -

> Statistics. Select the option Select ROI Mask(s), go down in the list and select pins. Finally, press the 

refresh button.  

From the right-side panel, we can extract the mean temperature value (292.2158) using as reference 

the pins we have just inserted in our image.  

 NOTE 2: If the pins are not loaded in the land cover band, close the visualization and open it again to 

refresh the view.  

 NOTE 3: To create your own Pins use the Pin placing tool (upper toolbar)         of SNAP. Click on the Pin 

tool and add 9 pins around the city where the land use is different from urban areas. Use the land 

cover band, the Pixel Info tab and the Color Manipulation tab to help you in the process. Do not forget 

to save the product afterwards (right click -> Save product). 
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We can now use the Band Math operator to subtract this value from the LST measurements. Right 

click on the LST_20180802_night product and select Band Math. Change the name to UHI, un-select 

Virtual and click on the Edit Expression button. Copy-paste the following expression and click OK: 

LST - 292.2 

 

Close all previous visualizations except for the newly created UHI band. Click on the Colour 

Manipulation tab, select Basic as Editor and click on the 5_colors colour ramp. Set the Min and Max 

values to 0 and 7 respectively. Do not forget to save the product afterwards (See  NOTE 4). 
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6.3.6 Export to QGIS 

Once the result is ready, we will export it as GeoTIFF and open it in QGIS. For that, go to File -> Export 

-> GeoTIFF. Click on the Subset tab, and in the Band Subset menu select only the band UHI. Save the 

file with the name UHI_20180802 in the following path and click Export Product:  

Path: /shared/Training/LAND09_UrbanHeatIsland_London/Processing/ 

 

6.4 QGIS Processing 

Once the images are processed in SNAP, we will visualize the results in QGIS. Minimize SNAP and 

open QGIS, (Applications -> Processing -> QGIS Desktop). Although it is possible to open each raster 

individually, for convenience we will open a pre-saved QGIS session containing all the files. Go to 

Project -> Open, navigate to the following path and open the file QGIS_UHI.qgs (See  NOTE 5). 

Path: /shared/Training/LAND09_UrbanHeatIsland_London/AuxData/ 

 

 NOTE 4: To remove the Pins from the visualization, open the Layer Manager (Layer -> Layer Manager) 

and unselect the option Vector data.  
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Once the products are opened in QGIS, we will clip the UHI_20180802 raster using as reference the 

shapefile of the extent of Greater London (London_area.shp). For this, go to Raster -> Extraction -> 

Clipper. Select UHI_20180802 as input file (raster) and set the output file to the following path:   

Path: /shared/Training/LAND09_UrbanHeatIsland_London/Processing/UHI_20180802_London.tif 

Select the option No data value and set it to -99. As clipping mode select Mask layer and select 

London_Area as mask. Select the option Crop the extent of the target dataset to the extent of the 

cutline and the option Keep resolution of input raster. Finally, click Ok. 

 

Once the raster is clipped, we have to change its visualization to match the original one. Right click on 

the raster file UHI_20180802 and go to Styles -> Copy Style. Next, right click on the clipped raster 

(UHI_20180802_London) and go to Styles -> Paste Style. 

 

 NOTE 5: A basemap from OpenStreetMap will be used in the QGIS visualization. In case the OpenLayers 

plugin is not installed (not visible in the menu Web -> OpenLayers plugin), click on Plugins -> Manage 

and Install Plugins. Select the ‘All’ tab on the right-side panel and write “OpenLayers plugin” on the 

search box. Select the plugin on the list and click ‘Install Plugin’. Restart QGIS to finalize the installation.  
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In the last step, we will derive the mean temperature (and other statistics) per boroughs due to the 

Urban Heat Island effect. For this, we will use the Zonal Statistics tool to combine the information of 

the clipped raster with the shapefile of London’s boroughs (Population_London_2018.shp). 

Go to Raster -> Zonal Statistics -> Zonal Statistics. Select UHI_20180802_London as raster layer, 

select, Population_London_2018 as Polygon layer containing zones, set _ as Output column prefix and 

select Mean, Minimum and Maximum as statistics to calculate.  

 

The statistics will be added to the attribute table of Population_London_2018. To visualize it, right 

click on the layer and select Open Attribute Table.  

 

We can now visualize the mean temperature per neighborhood due to the Urban Heat Island effect. 

For this, activate the Population_London_2018 layer on the Layers Panel, right click on it and go to 

Properties. In the right-side menu, go to Style. In the top part, select Graduated as display method, 

select mean as the column to be represented, set the precision parameter to 2 change the color 

ramp to Oranges, set the number of classes to 5 and click Classify. Finally, click Ok in the lower part.  
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To produce our final visualization, we first need to derive the population density. For this, we will use 

the Raster calculator tool available in QGIS to derive the area of each neighborhood (in km2) and 

divide the total population by this parameter. Right click on the Population_London_2018 and select 

Toggle Editing to start the edition of this layer. In the toolbar, click on the Open Field Calculator icon - 

 (See  NOTE 6). 

 

Make sure the option Create a new field is selected. Set the Output field name to Area_km2, change 

the Output field type to Decimal number (real) and set the Precision to 2. In the expression editor 

copy-paste the following expression and click OK. 

$area / 1000000 

 NOTE 6: If not visible, go to View -> Toolbars -> Attributes toolbar to active the tools. 
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Next, open again the Field Calculator. Make sure the option Create a new field is selected. Set the 

Output field name to Pp_den_km2 and leave the Output field type to Whole number (integer). In the 

expression editor copy-paste the following expression and click OK. 

"Total_Pop" / "Area_km2" 

 
The new fields have been added to the attribute table of Population_London_2018. To visualize it, 

right click on the layer and select Open Attribute Table. Before continuing, right click on the 

Population_London_2018 layer and click again in the Toggle Editing menu to stop the edition. Save 

the changes when asked.  
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For the final visualization, we will combine the information of the mean temperature with the 

population density per neighborhood. For this, we will first derive the centroids of each polygon. Go 

to Vector -> Geometry Tools -> Polygon Centroids. Select Population_London_2018 as input layer and 

save the output as Centroids.shp in the following path (click … and select Save to file). Then, click Run. 

Path: /shared/Training/LAND09_UrbanHeatIsland_London/AuxData/ 

 

 

A new point shapefile has been added now to the Layers Panel. We will know link the size of the 

points to the population density of each area.  

 

Right click on the Centroids layer and select Properties. In the right-side menu, go to Style. In the top 

part, select Graduated as display method, select Pp_den_km2 as the column to be represented and 

click on the Change icon to set the color to light blue. Next, set the precision parameter to 0, change 

the Method to Size and make sure the size ranges from 1 to 8. Finally, select Pretty intervals as Mode, 

set the number of classes to 5, click Classify and Ok. 
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Finally, for visualization purposes, change the name of the Centroids and Population_London_2018 to 

Population_Density_hab_skm and Mean_Temperature_kelvin 

  

 

THANK YOU FOR FOLLOWING THE EXERCISE! 
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7 Further reading and resources 

Sentinel-3 SLSTR User Guide 

https://sentinel.esa.int/web/sentinel/user-guides/sentinel-3-slstr 

Sentinel-3 SLSTR Technical Guide 

https://sentinel.esa.int/web/sentinel/technical-guides/sentinel-3-slstr 

 

FOLLOW US!!! 
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