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1 Introduction 

The Research and User Support for Sentinel core products (RUS) service provides a free and open 

scalable platform in a powerful computing environment, hosting a suite of open source toolboxes pre-

installed on virtual machines, to handle and process data derived from the Copernicus Sentinel 

satellites constellation. 

Our study area for this exercise will be the 

part of the Gran Chaco forest in Paraguay. 

The Gran Chaco is a sparsely populated, hot 

and semi-arid lowland region of the Río de la 

Plata basin, laying partly in Bolivia, Paraguay, 

Argentina and Brazil. What has once been 

the largest continuous tropical forest on our 

planet has become the hotspot of 

deforestation in the last decade due to 

industrial scale cattle farming and soy 

production. It is estimated that one 1 

hectare of forest is cleared every minute 

resulting in the destruction of this unique 

environment.  

There is number of methods used for monitoring deforestation with satellite data. However, visual 

interpretation by a human operator is still broadly used and most accurate, many semi-automatic and 

automatic methods exist. Vast majority of these methods is based on classification algorithms. In the 

previous webinar (LAND07), you have heard about supervised classification method called “Random 

Forest Classifier”, today we will use a very different method called “Support Vector Machine” (SVM).  

2 Training 

Approximate duration of this training session is two hours.  

The Training Code for this tutorial is LAND08. If you wish to practice the exercise described below 

within the RUS Virtual Environment, register on the RUS portal and open a User Service request from 

Your RUS service → Your dashboard. 

2.1 Data used 

• Three cloud-free Sentinel-2 Level-1C tile (Tile ID: T20KQB) [downloadable @ 

https://scihub.copernicus.eu/] 

• S2A_MSIL1C_20160813T141052_N0204_R110_T20KQB_20160813T141049 

• S2B_MSIL1C_20170823T141039_N0205_R110_T20KQB_20170823T141404 

• S2A_MSIL1C_20180813T141051_N0206_R110_T20KQB_20180813T174352 

2.2 Software in RUS environment 

Internet browser, SNAP + Sentinel-2 Toolbox, Sen2Cor, QGIS 

 

Deforested areas in Gran Chaco region, Credits: https://www.hu-

berlin.de 

https://scihub.copernicus.eu/
https://www.hu-berlin.de/
https://www.hu-berlin.de/
https://www.hu-berlin.de/
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3 Register to RUS Copernicus 

To repeat the exercise using a RUS Copernicus Virtual Machine (VM), you will first have to register as 

a RUS user. For that, go to the RUS Copernicus website (www.rus-copernicus.eu) and click on 

Login/Register in the upper right corner.  

 

Select the option Create my Copernicus SSO account and then fill in ALL the fields on the Copernicus 

Users’ Single Sign On Registration. Click Register. 

  

Within a few minutes you will receive an e-mail with activation link. Follow the instructions in the e-

mail to activate your account.  

You can now return to https://rus-copernicus.eu/, click on Login/Register, choose Login and enter 

your chosen credentials. 

http://www.rus-copernicus.eu/
https://rus-copernicus.eu/
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Upon your first login you will need to enter some details. You must fill all the fields.   

 

4 Request a RUS Copernicus Virtual Machine 

Once you are registered as a RUS user, you can request a RUS Virtual Machine to repeat this exercise 

or work on your own projects using Copernicus data. For that, log in and click on Your RUS Service → 

Your Dashboard.  

 



6 
 

Click on Request a new User Service to request your RUS Virtual Machine. Complete the form so that 

the appropriate cloud environment can be assigned according to your needs. 
 

 
 

If you want to repeat this tutorial (or any previous one) select the one(s) of your interest in the 

appropriate field. 

 
 

Complete the remaining steps, check the terms and conditions of the RUS Service and submit your 

request once you are finished. 
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Further to the acceptance of your request by the RUS Helpdesk, you will receive a notification email 

with all the details about your Virtual Machine. To access it, go to Your RUS Service → Your Dashboard 

and click on Access my Virtual Machine.  
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Fill in the login credentials that have been provided to you by the RUS Helpdesk via email to access 

your RUS Copernicus Virtual Machine.  

 

This is the remote desktop of your Virtual Machine. 

 

5 Step-by-step 

5.1 Data download - ESA SciHUB 

In this step, we will download a Sentinel-2 scene from the Copernicus Open Access Hub using the online 

interface (Applications → Network → Firefox Web Browser or click the link below). 

Go to https://scihub.copernicus.eu/   

https://scihub.copernicus.eu/
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Go to “Open HUB”, if you do not have an account please register by going to “Sign-up” in the LOGIN 

menu in the upper right corner. 

 

 
After you have filled in the registration form, you will receive an activation link by e-mail. Once your 

account is activated or if you already have an account, “LOGIN”.  
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Then navigate to the north of Paraguay, approximately as indicated on map below and switch the base 

layer to Sentinel-2 cloudless overlay.  

 

Now we have two options either we can switch to the rectangle-drawing mode (Green arrow) and 

draw search polygon over our study area (approximate area – orange rectangle) or we can specify the 

Sentinel-2 tile we are looking for in the Search text box (Purple arrow). The tile identification consists 

of UTM zone number and 3 letter code. We can find it in the name of any product from the same 

location we already have. For us the code is 20KQB. We enter it to the search filed as *20KQB*. 

Sensing period:  From 2016/08/13 to 2018/08/13 

Check Mission:   Sentinel-2 

Cloud Cover %:   [0 TO 10] 

 

Then click Search . In our case, the search returns 27 results as we are looking at long time period. 

Now let’s find following three products and add them to cart using the  symbol as shown below: 

S2A_MSIL1C_20160813T141052_N0204_R110_T20KQB_20160813T141049 

S2B_MSIL1C_20170823T141039_N0205_R110_T20KQB_20170823T141404 

S2A_MSIL1C_20180813T141051_N0206_R110_T20KQB_20180813T174352 
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Once all our data are in the cart, click on the Profile icon in the upper right corner (marked with green 

circle above) and go to Cart. You should now have three products in your cart. Click Download Cart.  

 

A products.meta4 file will be downloaded to your /home/rus/ folder. To download our data, we will 

use aria2 tool. To use the tool, we first need to place the products.meta4 file to the folder where we 

wish our data to be downloaded to:  

/shared/Training/LAND08_DeforestationMonitoring_S2_TutorialKit/Original/ 

Let’s test our aria2 installation. To do this we open the Command Line  (in the bottom of your 

desktop window), type the following and then press “Enter”:    

The correct response should be as follows: 

 

aria2c 
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If the response is “-bash aria2c: command not found” (see  NOTE 1). 

 

If you have received the correct response, then we can run the tool by typing following commands in 

the command line (replace <username> and <password> with your login credentials for Copernicus 

Open Access Hub):  

First type the following command and press “Enter”. It defines our target directory. 

 

Then type the following command and after having made the necessary changes press “Enter” to run 

the download tool (Type the red text all in single line). 

 

All three products will be downloaded to the Original folder two products in parallel automatically 

(Note that the constraint of maximum two parallel downloads at a time is imposed by the Copernicus 

Access Hub, if you increase the number the download will fail). This might take some time.  

Lastly, navigate to the folder where our data are saved: /shared/Training/LAND08_Deforestation 

Monitoring _S2_TutorialKit/Original and unzip all three products by right-clicking each and going to 

“Extract Here”.  

 

5.2 SNAP – open and explore data 

Launch SNAP (icon on desktop ). When the SNAP window opens click Open Product , navigate 

to: /shared/Training/LAND08_DeforestationMonitoring_S2_TutorialKit/Original and open the three 

zipped downloaded S2 products (SNAP can read .ZIP files).  

Right-click the product from 2018 and click Open RGB image window, a new window will open. From 

the drop-down menu select:   

Profile: Sentinel 2 MSI Natural Colors  

Click OK. The RGB image will be opened at the View window. 

 NOTE 1: If (and only if) the response is “-bash aria2c: command not found”. Then we have to install the 

tool, to do this in command line type: sudo apt-get install aria2 

When requested type: Y 

Then you can test your installation again.  

cd /shared/Training/LAND08_DeforestationMonitoring_S2_TutorialKit/Original/ 

aria2c --http-user='<username>' --http-passwd='<password>' --check-

certificate=false --max-concurrent-downloads=2 -M products.meta4 
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5.3 Atmospheric correction 

The “Level 1C” data we have downloaded are radiometrically and geometrically corrected (including 

orthorectification and spatial registration). However, atmospheric correction is applied only to the 

Level 2A data which are not available for our study site at this time.  

 

Solar radiation reflected by the Earth’s surface to satellite sensors is affected by its interaction with 

the atmosphere. The objective of applying an atmospheric correction is to determine true surface 

(Bottom-Of-Atmosphere, BOA) reflectance values from the Top-Of-Atmosphere (TOA) reflectance 

values, by removing atmospheric effects. (See  NOTE 1) Atmospheric correction is especially 

important in cases where multi-temporal images are compared and analysed as it is in our case. 1  

In this tutorial, we will use the Sen2Cor processor. Sen2Cor is a processor for Sentinel-2 Level 2A 

product generation and formatting; it performs the atmospheric, terrain and cirrus correction of Top-

Of-Atmosphere Level 1C input data. Sen2Cor creates Bottom-Of-Atmosphere, optionally terrain and 

cirrus corrected reflectance images; additional, Aerosol Optical Thickness, Water Vapour, Scene 

Classification Maps and Quality Indicators for cloud and snow probabilities.  

 

 TIP: Level 2A have been systematically produced for newly acquired products over Europe since the spring 

of 2017, the coverage has been increasing through 2018 to reach global coverage in the beginning of 

2019.  

 

 NOTE 1: The radiance reaching the sensor is a result of following components: 
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Go to Optical → Thematic Land Processing → Sen2Cor. 

In the I/O Parameters tab, click on “…” next to the product name and navigate to the Original folder. 

Open the “.SAFE” folder of the 2016 product. Then open the MTD_MSIL1C.xml file. In the Processing 

Parameters tab change the resolution to “ALL” and select “Display execution output”. Click Run.  

 

This is rather a time demanding process and requires approximately 30 minutes per image (with 8GB 

RAM). Repeat for products [2] and [3]. Close Sen2Cor window when all processing is completed. 

You will see three new products created at the Product Explorer window, named “Output Product”. 

Select them all, right click on them and select “Close 3 Products”. Click “No” to the following windows 

that will appear. 
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This process creates three new Level 2-A products in the .SAFE format in the Original folder. Move 

them to: /shared/Training/LAND08_DeforestationMonitoring_S2_TutorialKit/Original/Level-2A 

Now let’s load the results to SNAP.  

Click Open Product , navigate to:  

/shared/Training/LAND08_DeforestationMonitoring_S2_TutorialKit/Original/Level-2A and open 

the Level-2A product folder for 2016:  

S2A_MSIL2A_20160813T141052_N0204_R110_T20KQB_20160813T141049.SAFE  

Open the MTD_MSIL2A.xml. Repeat the same for the Level-2A products from 2017 and 2018.  

In the Product Explorer window, right-click the Level-2A product from 2018 and click Open RGB image 

window, a new window will open. From the drop-down menu select:   

Profile: Sentinel 2 MSI Natural Colors  

Then go to Window → Tile Horizontally to compare the L1C and L2A products side by side. 

 

In this case there is not much visible difference, but we can now be reasonably sure that the values in 

our three images are comparable and correspond to the reflectance of the objects on the ground.  

Now in the Product Explorer window, select the L1C products ([1] – [3]), right-click and go to “Close 3 

products”, as we will not need them anymore. Click “No” to discard changes to the products. 

5.4 Resample, subset & calculate 

To avoid processing the data step-by-step we will use the Graph Builder.  

Go to Tools → GraphBuilder. So far, the graph only has two operators: Read (to read the input) and 

Write (to write the output).  
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The 13 bands in Sentinel-2 products do not all have the same resolution (therefore size) as mentioned 

in  NOTE 2. Many operators do not support products with bands of different sizes, so we need to 

resample the bands to equal resolution first. To add the operator right-click the white space between 

the existing operators and go to Add → Raster → Geometric → Resample. 

 

A new operator rectangle appears in our graph and a new tab appears below. Now connect the new 

Resample operator with the Read operator by clicking to the right side of the Read operator and 

dragging the red arrow towards the Resample operator.  

 

Next step will be to subset the images to the area of interest. We do this by right-clicking the white 

space somewhere right of the resample operator and going to Add → Raster → Geometric → Subset. 

Connect the Subset operator with the Resample operator.  

 

Now, we will add the BandMerge operator from Add → Raster → BandMerge and connect it to the 

Subset operator.  

Credits: ESA 2015 

NOTE 2: The input product 

contains 13 spectral bands 

in three different spatial 

resolutions (The surface 

area measured on the 

ground and represented by 

an individual pixel).  When 

we open the RGB view all 

our input bands have 20 m 

resolution, however, the 

view is displayed in the full 

10 m resolution.  
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Then, we add the BandMaths operator from Add → Raster → BandMaths. Now connect the 

BandMaths operator with the Subset operator and then connect it to the BandMerge operator as well. 

Then connect the BandMerge operator with the Write operator.  

 

For each of our operators a tab has appended in the bottom of the graph. Do not change any 

parameters in the tabs at the moment. Click Save at the bottom of the window and save the graph as 

Graph_preprocess.xml in:  

/shared/Training/LAND08_DeforestationMonitoring_S2_TutorialKit/Processing 

Now, we can close the Graph Builder window and open the Batch Processing tool (Tools → Batch 

Processing). Now we will set our processing parameters for each operator.  

In the I/O Parameters tab, we will add all three opened products by clicking Add Opened  on the 

upper right (second from top). Click Refresh . Unselect the Keep source product name. Then, click 

Load Graph at the bottom of the window, navigate to our saved graph and open it. We see that new 

tabs have appeared at the top of window corresponding to our operators.  

 

Finally, we can set the parameters.  

In Resample tab we set:   

Define size of resampled product: By reference band from source product: B11 (we will resample all 

the bands to 20 m resolution).  

Downsampling method: Mean 
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In the Subset tab, we select bands: B4, B8, B11 and B12 (to select multiple hold Ctrl).  

Make sure the Pixel Coordinates option is selected and then set: 

Width: 5940   Height: 5940 

 

To create additional information for our classification we will calculate the Normalized Difference 

Vegetation Index (NDVI) – developed by Rouse2, the NDVI  algorithm exploits the strength and the 

vitality of the vegetation on the earth's surface. It indicates amount of vegetation, distinguishes 

vegetation from soil and minimizes topographic effects. NDVI is calculated as : 

𝑁𝐷𝑉𝐼 =  
𝑁𝐼𝑅 − 𝑅𝑒𝑑

𝑁𝐼𝑅 + 𝑅𝑒𝑑
=  

𝐵8 − 𝐵4

𝐵8 + 𝐵4
 

We define the expression for the calculation of NDVI in the BandMaths tab: 

Target band: NDVI 

No-Data Value: 0.0 

Click on Edit Expression and set:  (B8 – B4)/(B8 + B4)  
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Then click OK.  

Now we need to add the NDVI band to our original subset using the BandMerge. We will not change 

anything in the BandMerge tab, use the default settings.  

 

In the Write tab check that the name contains “20160813” (or the date of the first loaded image) but 

do not change anything. Then set Save as: GeoTIFF 

Set the output directory:  
/shared/Training/LAND08_DeforestationMonitoring_S2_TutorialKit/Processing 

 

Finally, let’s click Run. This might take a few minutes depending on your machine.  

Now, you should have three new products in the Product Explorer window. Close the Batch Processing 

window and all the View windows and expand the first new product [7]. In Bands folder, double-click 
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the NDVI band. Now do the same for the other two products ([8] and [9]) as well. Go to Window → 

Tile Horizontally and then in Navigation tab, click Zoom All .   

To be able to compare the images better, we can apply the same stretch to all Views. We can do this 

by applying the same histogram stretch. Select the first View [7] and go to Colour Manipulation tab, 

here we can see the histogram. Click  Apply to other bands, in the menu of the window that 

appears, select only [8] NDVI and [9] NDVI, then click OK. Click “No” in the next dialogs.  

 

Now we can move to QGIS to start the classification. Close SNAP and click “No” to the pop-up window. 

5.5 Classification in QGIS 

Let’s open QGIS . Go to Application → Processing → QGIS Desktop. In the Browser Panel we 

navigate to /shared/Training/LAND08_DeforestationMonitoring_S2_TutorialKit/Processing and load 

the three GeoTIFF products we have created in SNAP (hold CTRL, select all 3 layers and drag them to 

the Layers Panel).  
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A good training dataset is very important for the accuracy of any classification. Here it has already been 

created for you, using the image from 2016 to create training polygons for deforested areas and the 

image from 2018 to create training polygons for forest. If you wish to create your own see  NOTE 3.  

 

 NOTE 3: If you would like to create your own training dataset you can do this by inspecting the images 

closely and then using drawing polygons over the areas you identify as forested or deforested. In the 

attribute table you need to fill the Class of each polygon “forest”/”non-forest” and the Class ID “1”/ ”2”. 

 
Set the parameters of a new layer:  Type: Polygon 

Coordinate system: “32720” (Select it and click OK) 

Add two new fileds → New field:  Name:    Class (Type: Text data)  

Class_ID (Type: Whole number) 

Once you create each field, click on “Add to fields list”. 

  

Click OK. Finally, you will be asked to set the location and name of the layer. Save it as “Training data” in the 

/shared/Training/LAND08_DeforestationMonitoring_S2_TutorialKit/Processing folder. 
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In this way we have single training dataset for all three images as we can assume that that if an area 

was forest in 2018 it must have been forest also in 2016. Of course, training data created over high 

resolution imagery or even in situ training data would be invaluable and may improve the accuracy of 

our classification.   

Now we load the training dataset that is already provided. In the Browser panel navigate to: 

/shared/Training/LAND08_DeforestationMonitoring_S2_TutorialKit/AuxData  

Load: Training_data.shp 

Then, right-click the layer and go to Properties → Style to change the appearance. Click Style → Load 

Style, then navigate to the AuxData folder and select Training_data.qml. Then click OK.  

 

When the new empty layer is created you can right-click the layer and select “Toggle editing”, then select  

“Add feature”. You can then start drawing by clicking on the image and you can close polygon by right-click, 

then you must set the field values. When you are done with all polygons for both classes, click the “Toggle 

editing” again to save edits. (Remember: Class: forest – Class_ID: 1, Class: non-forest – Class_ID: 2). 

 

 

Add feature 
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Now we can start with the classification. We will be using the dzetsaka  tool to train our classifier 

(build a model) and classify our images. You can find it in the Processing Toolbox window on the right 

(See  NOTE 4). 

This plugin has by developed by Nicolas Karasiak, for work in the Amazon, it simplifies classification 

algorithms and automatically determined the best parameters to be used.  

 

5.5.1 Build Model 

First, we need to train our classifier using the vector training dataset. In our training data, we have 

defined 2 classes: Forest (Class_ID: 1) 

              Non-forest (Class_ID: 2)  

Go to the Processing Toolbox and expand the dzetsaka 

group. Double click on the Train algorithm tool. The tool 

menu will open, allowing us to process a single image. 

However, we have 3 images to process so we can select the 

Batch processing mode (Run as batch process…) at the top 

right side. Below you can see the menu pre-set for processing 

one of our images.  

We can choose from 4 classifiers, in this example we will be using the Support Vector Machine (SVM) 

classifier (See  NOTE 5). Generally, many settings are required to run SVM but dzetsaka is a 

simplified tool that estimates the best parameters for us and allows us to get good results without 

needing to have much knowledge of the algorithm. Note that we are keeping only 50% of the training 

samples (pixels within our training polygons) to train the model. The other 50% is used to generate a 

confusion matrix (See  NOTE 6). Click on “Run as batch process…”. 

  

 NOTE 4: In case the dzetsaka plugin is not installed, click on Plugins → Manage and Install Plugins. Select 

the “All” tab on the left side panel and write “dzetsaka” on the search box. Select the plugin on the list 

and click “Install Plugin”. You may need to restart QGIS to finalize the installation.  

To find out more about the plug-in go to https://github.com/lennepkade/dzetsaka  

A Scikit-learn library is also required to run the plug-in. It can be installed from command line by running 

following line:  python2.7 –m pip install scikit-learn --user 

We do not need to set 

any parameter in this 

window since we will 

use “Run as batch 

process…” where will 

set the parameters/load 

file containing pre-set 

parameters. 

https://github.com/lennepkade/dzetsaka
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Then click on  and load the prepared settings from QGIS_Batch_TrainModel.json in: 

 /shared/Training/LAND08_DeforestationMonitoring_S2_TutorialKit/AuxData   

Find the column called Select algorithm to train and set “Support Vector Machine” for all three 

instances. After the processing is completed, check that three new text files have been created in the 

/Processing/Classification/ folder (See  NOTE 7). 

 

Click Run. This may take up to 45 minutes. 

 

Close the Batch Processing and Train Algorithm windows. 

 

 NOTE 5: The Support Vector Machine (SVM) algorithm translates (plots) the data points to n-

dimensional space with the values of different input features/raster bands acting as coordinates. The 

objective of the support vector machine algorithm is to find a hyperplane in this N-dimensional space 

(N — the number of input features) that distinctly classifies the data points into two classes.  

To separate the classes of data points, there are many possible hyperplanes that could be chosen. Our 

objective is to find a plane that has the maximum margin, i.e the maximum distance between data 

points of both classes. The Support vectors are the data points close to the hyperplane that influence its 

position.  (Rohith Gandhi, https://towardsdatascience.com/) 

 
 NOTE 6: A confusion matrix is a table that is used to describe the performance of a classification model 

(or "classifier") on a set of test data for which the true values are known.  
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5.5.2 Classify image 

Next, we will apply the model to classify the images. Go to the Processing Toolbox and expand the 

dzetsaka group. Double-click on the Classify model tool. 

 

Go to Run as batch process… again and click on  and load the prepared settings from: 

/shared/Training/LAND08_DeforestationMonitoring_S2_TutorialKit/AuxData/QGIS_Batch_Classifi

cation.json  

 

 

Then click Run. This may take up to 10 minutes.  

NOTE! If QGIS fail to run the process, set in the Batch Processing all the parameters manually.  

Go to Run as batch process… and set: 

In the “Input raster” select the three .tif images from:  

shared/Training/LAND08_DeforestationMonitoring_S2_TutorialKit/Processing path: 

- Subset_S2A_MSIL2A_20160813T141052_N0204_R110_T20KQB_20160813T141049_resampled.tif 

- Subset_S2B_MSIL2A_20170823T141039_N0205_R110_T20KQB_20170823T141404_resampled.tif 

- Subset_S2A_MSIL2A_20180813T141051_N0206_R110_T20KQB_20180813T174352_resampled.tif 

 NOTE 7: Make sure that there is already created the /Classification folder in the /Processing folder. If no, 

create it by yourself and then continue with the following steps. 
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In the “Input model” select the three .txt files from:  

shared/Training/LAND08_DeforestationMonitoring_S2_TutorialKit/Processing/Classification path: 

- Model_SVM_2016.txt 

- Model_SVM_2017.txt 

- Model_SVM_2018.txt 

In the “Output raster (classification)” save each image in:  

shared/Training/LAND08_DeforestationMonitoring_S2_TutorialKit/Processing/Classification with 

the following names: 

- Classification_SVM_2016.tif 

- Classification_SVM_2017.tif 

- Classification_SVM_2018.tif 

Then click Run. 

Three new raster files have appeared in our Layers Panel tab. They are however all named Output … 

so we will close them and reload them again with the correct names. In the Browser Panel tab, 

navigate to the /Classification folder and open the three raster-layers.  

 

Then let’s visualize them better. Right-click on the first layer (classification from 2016) and go to 

Properties.  

In the Style tab select:   Render type: Singleband pseudocolor  

Band: Band 1 (Gray) 

Then in the bottom go to Load colour map from file, navigate to the Auxdata folder and select 

Classification_2016_colour_palette.txt. Click OK and do the same for the other two classified layers 

using the respective colour palettes.  
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Investigate the classifications visually compared to the natural composite images. You can turn the 

layers on and off in the Layers Panel. 

The dzetsaka tool has also produced a simple confidence matrix for each classification. We can open 

it from the file explorer when we go to: 

/shared/Training/LAND08_DeforestationMonitoring_S2_TutorialKit/Processing/Classification  

There you can find 3 files named CFMatrix_2016_SVM.csv, CFMatrix_2017_SVM.csv and 

CFMatrix_2018_SVM.csv   

Note that these confusion matrices are generated using the second half of our training data and 

therefore cannot be considered independent. If we truly want to assess the performance, we would 

have to create new independent validation dataset and compute additional statistics.  

Classification 2016 Classification 2017 Classification 2018 
True value Classified 

as forest 

Classified as 

non-forest 

True value Classified 

as forest 

Classified as 

non-forest 

True value Classified 

as forest 

Classified as 

non-forest 

forest 201404 9 forest 201402 3 forest 201395 12 

non-forest 0 30237 non-forest 2 30237 non-forest 9 30234 

 

 

  

THANK YOU FOR FOLLOWING THE EXERCISE! 
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6 Extra steps 

6.1 Downloading the outputs from VM 

On your keyboard, press Ctrl+Alt+Shift. A pop-up window will appear on the left side of the screen. 

Click on the bar below Devices, the folder structure of your VM will appear. Navigate to your Processing 

folder and double click any file you want to download. 3–5 
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