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1 Introduction to RUS 

The Research and User Support for Sentinel core products (RUS) service provides a free and open 

scalable platform in a powerful computing environment, hosting a suite of open source toolboxes 

pre-installed on virtual machines, to handle and process data derived from the Copernicus Sentinel 

satellites constellation.   

In this tutorial, we will employ RUS to analyze the temporal evolution of the Normalized Difference 

Vegetation Index (NDVI) over Cyprus using Sentinel-3 OLCI data.  

2 Land monitoring – background  

Land surface dynamics represent one of the key 

drivers to assess environmental change at 

different scales. Monitoring activities play a 

relevant role to detect and understand those 

patterns and to measure the resilience of 

ecosystems. 

Satellite based Earth observation methods are 

one of the best approaches to perform those 

tasks at local, regional and global scale. The 

Sentinel-3 Ocean and Land Color Instrument (OLCI) provides continuous and high frequency data that 

can be used to gather information about vegetation state. 

In this webinar, you will learn the basics of image processing for land dynamics monitoring. We will 

show you how to access the RUS Service and how to download, process, analyze and visualize the 

free data acquired by the Copernicus satellites. We will employ the ESA SNAP Sentinel-3 Toolbox to 

demonstrate the methodology for monitoring land surface dynamics. 

3 Training 

Approximate duration of this training session is one hour.  

The Training Code for this tutorial is LAND04. If you wish to practice the exercise described below 

within the RUS Virtual Environment, register on the RUS portal and open a User Service request 

from Your RUS service → Your dashboard. 

3.1 Data used 

• 7 Sentinel-3A images acquired during May 2017 downloadable at https://scihub.copernicus.eu/ 

• Pre-processed data stored locally @ 

/shared/Training/LAND04_LandMonitoring_Cyprus/AuxData/ 

3.2 Software in RUS environment 

Internet browser, SNAP + Sentinel-3 Toolbox 

  

Cyprus seen by Sentinel-2. Credits: RUS-Copernicus 

https://rus-copernicus.eu/
https://scihub.copernicus.eu/
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4 Register to RUS Copernicus 

To repeat the exercise using a RUS Copernicus Virtual Machine (VM), you will first have to register as 

a RUS user. For that, go to the RUS Copernicus website (www.rus-copernicus.eu) and click on 

Login/Register in the upper right corner.  

 

Select the option Create my Copernicus SSO account and then fill in ALL the fields on the Copernicus 

Users’ Single Sign On Registration. Click Register. 

 

Within a few minutes you will receive an e-mail with activation link. Follow the instructions in the e-

mail to activate your account.  

You can now return to https://rus-copernicus.eu/, click on Login/Register, choose Login and enter 

your chosen credentials. 

http://www.rus-copernicus.eu/
https://rus-copernicus.eu/
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Upon your first login you will need to enter some details. You must fill all the fields.   

 

5 Request a RUS Copernicus Virtual Machine 

Once you are registered as a RUS user, you can request a RUS Virtual Machine to repeat this exercise 

or work on your own projects using Copernicus data. For that, log in and click on Your RUS Service → 

Your Dashboard.  
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Click on Request a new User Service to request your RUS Virtual Machine. Complete the form so that 

the appropriate cloud environment can be assigned according to your needs. 
 

 
 

If you want to repeat this tutorial (or any previous one) select the one(s) of your interest in the 

appropriate field. 

 

 
 

Complete the remaining steps, check the terms and conditions of the RUS Service and submit your 

request once you are finished. 
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Further to the acceptance of your request by the RUS Helpdesk, you will receive a notification email 

with all the details about your Virtual Machine. To access it, go to Your RUS Service → Your 

Dashboard and click on Access my Virtual Machine.  
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Fill in the login credentials that have been provided to you by the RUS Helpdesk via email to access 

your RUS Copernicus Virtual Machine.  

 

 
 

This is the remote desktop of your Virtual Machine. 
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6 Step by step  

6.1 Data download – ESA SciHUB 

Before starting the exercise, we need to make sure that we are registered in the Copernicus Open 

Access Hub so that we can access the free data provided by the Sentinel satellites.  

Go to https://scihub.copernicus.eu/   

 

Go to “Open Hub”. If you do not have an account please sign up in the upper right corner, fill in the 

details and click register.  

 

You will receive a confirmation email on the e-mail address you have specified: open the email and 

click on the link to finalize the registration. 

Once your account is activated – or if you already have an account – log in.  

Switch the rectangle drawing mode to pan mode by clicking on the icon in the upper right corner of 

the map (Green arrow), navigate to Cyprus mode and draw a rectangle approximately as indicated 

below.  

https://scihub.copernicus.eu/
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Open search menu by clicking at the left of the search bar ( ), specify the following parameters 

press the search button ( ): 

Sensing period: From 2017/05/01 to 2017/05/31 

Check Mission: Sentinel-3 

Product type: OL_1_EFR__ 

Instrument: OLCI  

Product Level: L1 
 

 
In our case, the search returns 22 results depending on the defined search area. Download the 

following scenes (See  NOTE 1):  

Date S-3 Image name 

2017-05-05 S3A_OL_1_EFR____20170505T080458_20170505T080758_20180419T032733_0179_017_192_2340_LR2_R_NT_002 

2017-05-10 S3A_OL_1_EFR____20170510T073503_20170510T073803_20180419T173805_0179_017_263_2340_LR2_R_NT_002 

2017-05-13 S3A_OL_1_EFR____20170513T075729_20170513T080029_20180420T025347_0179_017_306_2340_LR2_R_NT_002 

2017-05-21 S3A_OL_1_EFR____20170521T075000_20170521T075300_20180421T065708_0179_018_035_2340_LR2_R_NT_002 

2017-05-24 S3A_OL_1_EFR____20170524T081227_20170524T081527_20180421T154649_0179_018_078_2340_LR2_R_NT_002 

2017-05-28 S3A_OL_1_EFR____20170528T080842_20170528T081142_20180422T032713_0179_018_135_2340_LR2_R_NT_002 

2017-05-29 S3A_OL_1_EFR____20170529T074232_20170529T074532_20180422T061843_0180_018_149_2340_LR2_R_NT_002 

 

Download the scenes by clicking the download icon on each product -  

Once downloaded (@/home/rus/Downloads), copy them to the following path and unzip them (right 

click -> Extract Here) 

Path: /shared/Training/LAND04_LandMonitoring_Cyprus/Original/May/ 
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6.2 SNAP – Open and explore data 

Open SNAP Desktop from your desktop (or Applications -> Processing -> SNAP), click on the Open 

product icon ( ), navigate to the following path and open the Sentinel-3 product from 2017-05-10. 

Open the folder and select the file xfdumanifest.xml. Then, click OK.  

Path: /shared/Training/LAND04_LandMonitoring_Cyprus/Original/May/ 

In Product Explorer tab, right click on the product and select Open RGB Image Window to create and 

visualize an RGB composition image. Select the following band combination to create a true color 

RGB composition and click OK.  

Red: Oa08_radiance | Green: Oa06_radiance | Blue: Oa04_radiance 

 

As the colors are distributed according to the image histogram, the view is very dark. To enhance it, 

we can change the color distribution for each RGB band in the Color Manipulation tab in the lower 

left corner of SNAP. Select the red channel, click on the right-hand slider below the histogram and 

move it to approx. 180. Change to the green channel at the top of the tab and set the slider to 

approx. 160. Last, change to blue and set the slider to approx. 150. 

 

 NOTE 1:  Copy-paste the S-3 Image name in the Search Criteria box (upper left corner) of the Copernicus 

Open Access Hub to find the images faster. 
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6.3 Graph Builder  

For this exercise, we will process several Sentinel-3 images. Repeating the analysis for every image 

one by one would be very time consuming. For this reason, we can create a graph containing all the 

steps of our methodology and use the batch processing option of SNAP to run bulk processing. First, 

we need to open an empty graph. Go to Tools -> GraphBuilder. At the moment, the graph only has 

two operators: Read (to read the input) and Write (to write the output). To avoid any confusion, right 

click on the Write operator and delete it.  

6.3.1 IdePix Processor 

The first step of our methodology will aim to remove cloudy pixels from the image. For that, we will 

use the IdePix processor (See  NOTE 2) available on SNAP, which provides a pixel classification into 

properties such as clear/cloudy, land/water, snow, ice etc. To add the operator, right-click on the 

white area and go to Add -> Optical -> Pre-processing -> IdePix.Sentinel3.Olci. Connect the new 

Idepix.Sentinel3.Olci operator with the Read operator by clicking to the right side of the Read 

operator and dragging the red arrow towards the Idepix.Sentinel3.Olci operator.  
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6.3.2 Band Math 

The next processing step will be to derive the Normalized Difference Vegetation Index (NDVI) for the 

pixels that are not flagged as cloudy by the IdePix processor and that are not water pixels. For this 

task, we will use Band Math. Add the Band Math operator. Right-click and go to Add -> Raster -> 

BandMaths. Connect the operators as shown below. 

 

6.3.3 Subset 

Next, we need to reduce the spatial extent to focus on our study area. For that, add the Subset 

operator. Right-click and go to Add -> Raster -> Geometric -> Subset. Connect the operators as shown 

below. 

 

6.3.4 Reproject 

The last step of the graph will consist of a reprojection. Sentinel-3 OLCI products are delivered 

georeferenced onto the Earth's surface. By reprojecting, we can assign a specific map projection and 

make sure all the inputs have the same spatial characteristics. Add the reproject operator by right- 

clicking Add -> Raster -> Geometric -> Reproject. Finally, Right click -> Connect Graph to connect all 

the operators. Connect the operators as shown below. 

 

6.3.5 Write 

Finally, we just need to properly save the output. For that, we first need to add the Write operator to 

our graph. Right click and navigate to Add -> Input-Output -> Write.  

 

Finally, click on Save in the lower part of the pannel and save the graph in the following path as 

’S3_Graph.xml’ without setting any parameter.  

Path: /shared/Training/LAND04_LandMonitoring_Cyprus/AuxData/ 

 

 NOTE 2:  The IdePix processor provided with the current SNAP version supports the following 

satellites/sensors: Sentinel-2 (MSI), Sentinel-3 (OLCI), Envisat (MERIS), Landsat-8 (OLI), Proba-V 

(Vegetation), SPOT (Vegetation), Terra/Aqua (MODIS), OrbView-2 (SeaWiFS), Suomi NPP (VIIRS). It 

calculates a certain set of physical features and a probabilistic combination of these features in order to 

calculate a set of pixel classification attributes. Only the implementation of how the features are 

calculated is instrument specific. For cloud detection, the following features are used: brightness, 

whiteness, height, temperature, spatial pattern, temporal consistency, Neural Network probability.  
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6.4 Batch processing 

Before using batch processing, we need to load all the images we want to analyse in SNAP. An option 

would be to open one by one, but for convenience, we will use a saved SNAP session that already 

contains all the products loaded. Click on File -> Session -> Open Session navigate to the following 

path and select the session file S3_May.snap 
 

Path: /shared/Training/LAND04_LandMonitoring_Cyprus/AuxData/May/ 

 
 

Click on Tools -> Bath Processing.  Press the Add Opened icon on the upper right side (second from 

top) and click refresh. Then, unselect the Keep source product name. Click Load Graph at the bottom 

of the window, navigate to the saved graph and open it. We see that new tabs have appeared at the 

top of window corresponding to the operators previously defined on the graph.  
 

  
 

In the Idepix.Sentinel3.Olci tab, make sure you select all the bands in the ‘Select TOA reflectances to 

write to the target product’. In that way, the IdePix processor output will contain already pixel values 

in reflectance and not radiance (See  NOTE 3). For demonstration, the image below shows this 
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intermediate output: a RGB true color composition and the binary cloud mask (‘IDEPIX_CLOUD’) 

created using IdePix. 

 

 
 

 

Click now on the BandMaths tab, set the target band name to NDVI, set the No-Data value to NaN, 

click on Edit Expression and copy-paste the following expression. Click Ok afterwards. For 

demonstration, the image below shows this intermediate output: a RGB true color composition and 

the NDVI calculated for land cloud-free pixels.  

if IDEPIX_CLOUD == TRUE or IDEPIX_LAND == FALSE then 0 else (Oa17_reflectan

ce-Oa08_reflectance)/(Oa17_reflectance+Oa08_reflectance) 

 NOTE 3: Radiance is the variable directly measured by remote sensing instruments. It is the amount of 

light seen by instrument from a surface of an object. In the OLCI products, it is given as 10-3 W.m-2.sr-

1.μm-1 

Reflectance is the ratio (percentage) of the amount of light leaving a target to the amount of light 

arriving to the target. It has no units. It is the property of the observed object/material.  
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In the Subset tab, remember to select Geographic Coordinates, copy-paste the following Well-Known 

Text (WKT) and click Update to define the area and click to Zoom-in.   

POLYGON ((32.401301 36.031754,34.667141 35.741352,34.374742 34.318205999999

996,32.149456 34.612776,32.401301 36.031754)) 
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For demonstration, the image below shows the output of the processing chain: the cropped area 

shown as RGB (for reference purposes) and the corresponding NDVI calculated for land free-cloud 

pixels. 

 

In the reproject tab, select Custom CRS to define the Coordinate Reference System. Select UTM / 

WGS 84 (Automatic) on the drop-down menu. 

  

Finally, in the Write tab, make sure you select the following path as output directory. Click Run after 

that. Path: /shared/Training/LAND04_LandMonitoring_Cyprus/Processing/May/ 
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6.5 Collocate (two images) 

The following step will aim at stacking all the NDVI outputs of the batch processing in a single 

product to allow further processing. For this task, we will use the Collocation tool, which allows 

collocating two spatially overlapping products. Collocating two products implies that the pixel values 

of one product (the slave) are resampled into the geographical raster of the other (the master). Click 

on Raster -> Geometric Operations -> Collocation.  

Unfortunately, the collocation tool only allows processing one master and slave product at once. Due 

to this, to collocate all the NDVI images in a single product, we need to do it step-by-step. For this 

exercise, you will find the output of this process in the following path. Close all the previous products 

opened in SNAP, navigate to the path and open the file Collocate_May.dim.    

Path: /shared/Training/LAND04_LandMonitoring_Cyprus/AuxData/May/ 

6.6 Band Subset 

Expand the collocated product and open the Bands folder. Before deriving the mean NDVI value per 

pixel, we will remove some of the bands of the collocated product that are not needed anymore. 

Click on the Collocate_May.dim and go to Raster -> Subset. Select the Band Subset tab on the top 

part of the window. Check the Select None option on the lower part of the window to unselect all the 

bands by default. Now, select the bands we want to keep by checking them:  

NDVI_1 | NDVI_2 | NDVI_3 | NDVI_4| NDVI_5| NDVI_6 | NDVI_7 

Once selected, click OK. Two pop-up messages will appear asking to include the collocation_flags 

bands created during the collocation process and to add a flag dataset. Click YES in both cases.  

   

Make sure to save to product. Right click on the subset product, select Save Product, navigate to the 

following path and set the name to Collocate_May_subset.dim. A window will appear asking you to 

convert the product to BEAM-DIMAP format. Click Yes. 

Path: /shared/Training/LAND04_LandMonitoring_Cyprus/AuxData/May/ 
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6.7 Mean NDVI 

Now, we will derive the mean NDVI value for each pixel in the image. Right click on the 

Collocate_May_subset product and select Band Math. Set the name to mean_NDVI, unclick the 

option Virtual (save expression only, don’t store data) and click on Edit Expression.  

Copy-Paste the following expression and click Ok. Do not forget to save the product afterwards.  

(NDVI_1+NDVI_2+NDVI_3+NDVI_4+NDVI_5+NDVI_6+NDVI_7)/7 

  

Expand the Bands folder of the product and double click on the file mean_NDVI. You can change the 

colour on the Colour Manipulation tab in the lower left corner. First, select Basic as Editor. Change 

the colour ramp to meris_veg_index. Now, click the Slider Editor, and stretch the histogram to the 

95% of the pixels by clicking on the icon. Finally, click Table and change the color of the first value (-

0.001) to light blue.  
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6.8 Time series 

SNAP offers a time series analysis tools suitable to represent temporal evolution and improve 

monitoring activities. In our exercise, the same processing chain can be run to obtain the mean NDVI 

for consecutive months in our study area by changing the input images at the beginning of the 

methodology. For convenience, this analysis has been done in advance for the months of June 2017 

and July 2017. Close all the files except Collocate_May_subset and open the mean NDVI files for each 

month located in the following path.  

File 1: Collocate_June_subset.dim | File 2: Collocate_July_subset.dim 

Path 1: /shared/Training/LAND04_LandMonitoring_Cyprus/AuxData/June/ 

Path 2: /shared/Training/LAND04_LandMonitoring_Cyprus/AuxData/July/ 

 

Expand each product and open the Bands folder. Double click on the mean_NDVI to visualize the 

mean NDVI image of each month. To make sure we are using the same colour distribution, select the 

first mean_NDVI visualization (index [1]) and press the Apply to other bands icon located in the upper 

right corner of the colour manipulation tab. A pop-up window will appear. Click Select all and press 

OK. Another pop-up window will appear, asking to whether to stretch the color palette between 

min/max values.  Select No. Then, go to Windows -> Tile Horizontally to synchronize the three views. 

 

You might have noticed that the three images have identical names. This is a requirement of the 

Time Series Analysis Tool in SNAP.  

Click on the Time Series Analysis button   on the main toolbar to open the toolview.  In the Time 

Series Analysis window, press the  button to configure your graph and press the  icon to add all 

the open products in SNAP to the time series analysis. Press the refresh icon ( ), rename the graph 

to NDVI_evolution and change the colour to red. Then, click Apply and Close. 
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Now close two of the mean_NDVI views, click on the Filter Bands ( ) icon of the Time Series 

Analysis tool ( ), select mean_NDVI and click OK. You can now move the cursor over the image and 

see the evolution of the mean NDVI value of each pixel in the graph.  

 

If you want to export the graph, you can do it as a text file (.csv) or as an image. Use the dedicated 

buttons in the lower right corner of the Time Series Analysis Tool (  and ). 

In case you want to continue the temporal profile, download the corresponding Sentinel-3 OLCI 

images for each month and repeat the steps defined in this guide. 
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7 Extra steps 

To download outputs from the Virtual Machine to your local computer press Ctrl+Alt+Shift. A pop-up 

window will appear on the left side of the screen. Click on bar below Devices. The folder structure of 

your VM will appear. Navigate to the path where the file you are interested in is located and double 

click on it to download it. In case you want to download a folder, you will have to zip it beforehand.  

 

THANK YOU FOR FOLLOWING THE EXERCISE! 

8 Further reading and resources 

Sentinel-3 information 
https://www.esa.int/Our_Activities/Observing_the_Earth/Copernicus/Sentinel-3 

Sentinel-3 mission 
https://sentinels.copernicus.eu/web/sentinel/missions/sentinel-3 

Sentinel-3 OLCI User Guide 
https://sentinels.copernicus.eu/web/sentinel/user-guides/sentinel-3-olci 

Sentinel-3 OLCI Technical Guide 
https://sentinels.copernicus.eu/web/sentinel/technical-guides/sentinel-3-olci 

FOLLOW US!!! 
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