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1 Introduction to RUS 

The Research and User Support for Sentinel core products (RUS) service provides a free and open 

scalable platform in a powerful computing environment, hosting a suite of open-source toolboxes pre-

installed on virtual machines, to handle and process data derived from the Copernicus Sentinel 

satellites constellation.   

Surface water is crucial resource sustaining human lives. 

It provides water for domestic and commercial use, it is 

used in agriculture (irrigation) and electricity 

production. Even small water bodies play a key role as 

the offer habitats to wildlife, often being a refuge for 

species but also provide livestock with fresh water. 

Therefore, in regions prone to drought such as Western 

Cape Province in South Africa, identification and 

monitoring of surface water, is necessary to assure the 

continuity of water supply for citizens, local economy 

but also to maintain natural habitats. More frequent and 

long-lasting droughts caused by global environmental changes are affecting many regions around the 

world. Warmer temperatures increase evaporation, lessening at the same time the water availability 

and causing soil and vegetation to dry out.  

A three-year’s drought threatened South Africa’s Western Cape Province. From 2016 until 2018 this 

region suffered a drought crisis, causing water dams to shrink significantly. The Cape Town claimed 

this period to be the worst drought in 100 years. In February 2018, the Theewaterskloof dam, which is 

the biggest dam in the province and provides about 50% of Cape Town’s water needs dropped to its 

11% of capacity. The city water consumption has fallen from 317 million gallons per day in 2015 to 

about 137 million gallons per day. Fast detection of any changes in surface water extent and its 

availability is crucial and enables decision-makers to take proper actions, in this case responsible water 

management.  

Satellite remote sensed data are widely used in detecting and monitoring waterbodies and with 

Sentinel-2 data, we will have a chance to detect waterbodies using different water indices and see 

changes in the water extent during the drought period. 

2 Training 

Approximate duration of this training session is one and a half hour.  

The Training Code for this tutorial is HYDR03. If you wish to practice the exercise described below 

within the RUS Virtual Environment, register on the RUS portal and open a User Service request from 

Your RUS service → Your dashboard. 

2.1 Data used 

• 16 low-cloud Sentinel-2A Level 1C images (Tile ID: T34HCH) acquired in wet and dry season 

from years 2016-2020 and one image from 2015 [downloadable at 

@https://scihub.copernicus.eu/ using the .meta4 file provided in the Original folder of this 

exercise]  

• Data and instructions how to perform the exercise stored locally 

Theewaterskloof Dam outside Cape Town drying out. 

Source:https://memeburn.com/2018/02/theewaterskl

oof-dam-cofferdam/ 

https://rus-copernicus.eu/
https://scihub.copernicus.eu/
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@/shared/Training/HYDR03_DroughtMonitoring_WesternCape/AuxData/ 

2.2 Software in RUS environment 

Internet browser, SNAP + GPT + Sentinel-2 Toolbox,  QGIS, (Extra steps: Sen2Cor) 

3 Register to RUS Copernicus 

To repeat the exercise using a RUS Copernicus Virtual Machine (VM), you will first have to register as 

a RUS user. For that, go to the RUS Copernicus website (www.rus-copernicus.eu) and click on 

Login/Register in the upper right corner.  

 

Select the option Create my Copernicus SSO account and then fill in ALL the fields on the Copernicus 

Users’ Single Sign On Registration. Click Register. 

  

Within a few minutes you will receive an e-mail with activation link. Follow the instructions in the e-

mail to activate your account.  

You can now return to https://rus-copernicus.eu/, click on Login/Register, choose Login and enter 

your chosen credentials. 

http://www.rus-copernicus.eu/
https://rus-copernicus.eu/
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Upon your first login you will need to enter some details. You must fill all the fields.   

 

4 Request a RUS Copernicus Virtual Machine 

Once you are registered as a RUS user, you can request a RUS Virtual Machine to repeat this exercise 

or work on your own projects using Copernicus data. For that, log in and click on Your RUS Service → 

Your Dashboard.  
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Click on Request a new User Service to request your RUS Virtual Machine. Complete the form so that 

the appropriate cloud environment can be assigned according to your needs. 

 

 
 

If you want to repeat this tutorial (or any previous one) select the one(s) of your interest in the 

appropriate field. 

 

 
 

Complete the remaining steps, check the terms and conditions of the RUS Service and submit your 

request once you are finished. 
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Further to the acceptance of your request by the RUS Helpdesk, you will receive a notification email 

with all the details about your Virtual Machine. To access it, go to Your RUS Service → Your Dashboard 

and click on Access my Virtual Machine.  
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Fill in the login credentials that have been provided to you by the RUS Helpdesk via email to access 

your RUS Copernicus Virtual Machine.  

 

This is the remote desktop of your Virtual Machine. 

 

5 Step by step  

5.1 Data download – ESA SciHUB 

In this step, we will download Sentinel-1 scenes from the Copernicus Open Access Hub using the online 

interface (Applications → Network → Firefox Web Browser or click the link below). 

Go to https://scihub.copernicus.eu/   

https://scihub.copernicus.eu/
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Go to “Open HUB”, if you do not have an account please register by going to “Sign-up” in the LOGIN 

menu in the upper right corner. 

 

 
After you have filled in the registration form, you will receive an activation link by e-mail.  
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Once your account is activated - or if you already have an account  - log-in. 

5.2 Download data 

In this exercise, we will analyze 16 Sentinel-2A images from years 2015-2020 from different seasons. 

(See  NOTE 1). Table below shows the date and reference of the images that will be used: 

 

DATE  SEASON  IMAGE ID 
2015-08-10 wet S2A_MSIL1C_20150810T084916_N0204_R121_T34HCH_20150810T084917 

2016-04-06 dry  S2A_MSIL1C_20160406T081652_N0201_R121_T34HCH_20160406T083818 

2016-08-24 wet S2A_MSIL1C_20160824T081602_N0204_R121_T34HCH_20160824T084517 

2016-12-02 dry  S2A_MSIL1C_20161202T082312_N0204_R121_T34HCH_20161202T084729 

2017-03-02 dry  S2A_MSIL1C_20170302T081841_N0204_R121_T34HCH_20170302T084108 

2017-08-09 wet S2A_MSIL1C_20170809T081601_N0205_R121_T34HCH_20170809T084800 

2017-12-27 dry  S2A_MSIL1C_20171227T082341_N0206_R121_T34HCH_20171227T120556 

2018-03-27 dry  S2A_MSIL1C_20180327T081601_N0206_R121_T34HCH_20180327T141730 

2018-08-24 wet S2A_MSIL1C_20180824T081601_N0206_R121_T34HCH_20180824T122203 

2018-12-22 dry  S2A_MSIL1C_20181222T082341_N0207_R121_T34HCH_20181222T100215 

 NOTE 1: Due to ESA policy on the availability of Sentinel data on Copernicus Open Access Hub and to 

ensure the continued access to all Sentinel data at all time, the Long-Term Archive (LTA) Access has been 

implemented to roll-out the oldest data from the online access. More information about the LTA can be 

found in the following links: 

https://scihub.copernicus.eu/userguide/#LTA_Long_Term_Archive_Access  

https://scihub.copernicus.eu/userguide/LongTermArchive. 

 

To download a product from the LTA, click on the Download Product icon - . A confirmation message 

will appear informing you that your request has been queued and the product added to your Cart. 

 
 

You will have to manually check your Cart from time to time to know when the product is available to be 

downloaded (no automatic notification will be sent). Once online, the product will remain available for 4 

days until been roll-out to the LTA again.  

Please note that every user account is only allowed to request 1 offline product every 30 minutes, if there 

is free space in the queue. The number of concurrent requests for offline products from all users is 

limited. You may receive an error when trying to download. If so, try again later. 

https://scihub.copernicus.eu/userguide/#LTA_Long_Term_Archive_Access
https://scihub.copernicus.eu/userguide/LongTermArchive
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2019-02-20 dry  S2A_MSIL1C_20190220T081951_N0207_R121_T34HCH_20190220T103552 

2019-08-09 wet S2A_MSIL1C_20190809T081611_N0208_R121_T34HCH_20190809T103427 

2019-12-17 dry  S2A_MSIL1C_20191217T082341_N0208_R121_T34HCH_20191217T102431 

2020-02-25 dry  S2A_MSIL1C_20200225T081921_N0209_R121_T34HCH_20200225T104030 

2020-08-23 wet S2A_MSIL1C_20200823T081611_N0209_R121_T34HCH_20200823T110549 

2020-11-11 dry  S2A_MSIL1C_20201111T082201_N0209_R121_T34HCH_20201111T102216 

 

To improve the data acquisition process, we will use a download manager (See  NOTE 2) that will 

take care of downloading all products that will be used in this exercise. The metadata of the Sentinel 

products are contained in a products.meta4 file created using the ‘Cart’ option of the Copernicus Open 

Access Hub. 

 

The products.meta4 file containing the links to the Sentinel-2 products to be downloaded have been 

already created following the methodology explained (See  NOTE 3). You can find the 

products.meta4 files saved in the following path: 

Path: /shared/Training/HYDR03_DroughtMonitoring_WesternCape/Original/ 

Before using the downloading manager and the .meta4 file, let us test if aria2 is properly installed in 

the Virtual Machine. To do this, open the Command Line (in the bottom of your desktop window) and 

type: 

aria2c 

 NOTE 2: A download manager is a computer program dedicated to the task of downloading possibly 

unrelated stand-alone files from (and sometimes to) the Internet for storage. For this exercise, we will 

use aria2. Aria2 is a lightweight multi-protocol & multi-source command-line download utility. More info 

at: https://aria2.github.io/ 

 

  

 

 

https://aria2.github.io/
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If aria2 is properly installed, the response should be as follows. If the response is ‘-bash aria2c: 

command not found’ it means aria2 is not installed (See  NOTE 4). 

 

 

Once aria2 is ready to use, we can start the download process. For that, we need to navigate to the 

folder where the products.meta4 is stored. Type the following command in the terminal and run it. 

cd shared/Training/HYDR03_DroughtMonitoring_WesternCape/Original/ 

Next, type the following command (in a single line) to run the download tool. Replace username and 

password (leave the quotation marks) with your login credentials for Copernicus Open Access Hub 

(COAH). Do not clear your cart in the COAH until the download process is finished. This expression is 

stored also in /AuxData/ folder of this training kit in text file named: Expressions.txt 

aria2c --http-user=’username’ --http-passwd=’password’ --check-certificate=

false --max-concurrent-downloads=2 -M products.meta4 

 NOTE 3: The Copernicus Open Access Hub allows you to add products to a ‘Cart’. For that, perform a 

query; select the desired products from the result list and click on the ‘Add Product to Cart’ icon -  

 
 

 
 

To view the products present in the cart just click anytime on the User Profile icon on top right corner of 

the screen and then on "Cart". To download the products contained in the cart just click on "Download”. 

Cart" on the bottom right of the page. A download window will pop up, asking the user confirmation to 

save a .meta4 file named ‘products.meta4’. This file contains all the metalinks of the products. 

 

 

 NOTE 4: If (and only if) the response is ‘-bash aria2c: command not found’, you need to install aria2. In 

the command line, type:  sudo apt-get install aria2 

When requested, type:  Y 

Once finished, test the installation as explanied before.   

 

c 
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The Sentinel products will be saved in the same path where the products.meta4 is stored. All 16 

products will be downloaded to the /Original folder. 

(Note that the constraint of maximum two parallel downloads at a time is imposed by the Copernicus 

Access Hub, if you increase the number the download will fail). This might take some time. 

Lastly, navigate to the folder where our data are saved: 

shared/Training/HYDR03_DroughtMonitoring_WesternCape/Original/ and unzip all 16 products by 

right-clicking each and going to “Extract Here”. 

Your folder should have the same structure as shown below. 

 

5.3 SNAP  – open and explore data 

Launch SNAP (icon on desktop ). When the SNAP window opens click Open product and 

navigate to: /shared/Training/ HYDR03_DroughtMonitoring_CapeTown/Original/  

Open the first S2 product (from 10 August 2015). We can first investigate the structure of the Sentinel 

2 Level 1C products. Click on the dot next to the product name to expand the structure. The L1C 

products contain (among others):  

• 13 TOA (top-of-atmosphere) reflectance bands  

• Quality flags Now, let’s visualize the product.  
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We will visualize it in true (natural) colors and as a false color composite which is better for 

distinguishing water surfaces. Right-click the product and click Open RGB image window, a new 

window will open. From the drop-down menu select:  

Profile: Sentinel 2 MSI Natural Colors 

Click OK. The RGB image will be opened at the View 

window. When the image opens, repeat the same but 

choose the false color profile. Select: 

Profile: Sentinel 2 MSI False-color Infrared. Click OK.  

Finally, go to Window → Tile Horizontally. 

 

 

 

 

 

 

For the purpose of this training atmospherically corrected (See  NOTE 5). Images are stored in the 

folder: /shared/Training/ HYDR03_DroughtMonitoring_WesternCape/Original/Level-2A/ 

 

 NOTE 5: The Sentinel-2 data are distributed as 100x100 km tiles resampled to a common grid in WGS84 

UTM projection at two levels of processing: 

• Level-1C – Top-Of-Atmosphere reflectances, systematically generated since the start of the mission.  

• Level-2A – Bottom-Of-Atmosphere reflectances (atmospherically and radiometrically corrected), 

systematically produces for products acquired over the Europe since the spring of 2017, the 

coverage has increased through 2018 to reach global coverage in the beginning of 2019. Can be 

produced on user side by applying the Sen2Cor algorithm. (See: Extra steps 6.1) 

 

 

PAN Mode 
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Note: Atmospheric correction of one image take some time. Processing of one image in Virtual 

Machine environment takes about 25 minutes. For your convenience we will proceed with images 

already atmospherically corrected.  

Now, let’s investigate the cloud cover and water mask bands that are the result of atmospheric 

correction applied to the level 2 products. Close for now the views created. Now navigate in SNAP 

navigate to File -> Session -> Open session.. and go to the path where the SNAP session is stored:  to 

/shared/Training/ HYDR03_DroughtMonitoring_WesternCape/AuxData/. Open file called 

preprocessing.snap. In Product Explorer window 16 atmospherically corrected products (Level-2) 

should appear. Select the first product from August 2015 [1] and go to Masks → scl. Open masks 

scl_cloud_high_proba (Cloud high probability), scl_water (Water) and scl_thin_cirrus (Thin cirrus). 

Pixels with detected clouds/cirus/water will appear white in the respective masks.  

Now you should have four bands open in your View window. Go to Window → Tile Evenly and then 

go to the Navigation tab, click Zoom All  

We can see that as expected our image is almost cloudless. The default water mask distributed with 

the Level-2 product, however, does not look very accurate.  

5.4 STEP 1 – Pre-processing  

Processing the data one by one while having 16 images would not be very time effective. However, we 

can use either the Batch Processing tool available in SNAP or the GPT tool (command line) to process 

all images automatically. 

To use either method, we first need to define the process we want to apply and all its steps. We can 

do this using the GraphBuilder tool. Another advantage of the GraphBuilder is that only the final 

product will be physically saved, and we save valuable disk space.  

So, let’s build our graph. First, in the Product Explorer select the first loaded product (so it is 

highlighted), then go to Tools → GraphBuilder. 
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At the moment, the graph only has two operators: Read (to read the input) and Write (to write the 

output). First of all, we can remove Write operator to not create confusion. To delete the operator, 

right click on it and select Delete.  

 

 

5.4.1 Resample  

The 13 bands in Sentinel-2 products do not all have the same resolution (therefore size) as mentioned 

in  NOTE 6. Many operators do not support products with bands of different sizes, so we need to 

resample the bands to equal resolution first.  

To add the operator right-click the white space between the existing operators and go to Add → Raster 

→ Geometric → Resample. 



17 
 

 

A new operator rectangle appears in our graph and a new tab appears below. Now connect the new 

Resample operator with the Read operator by clicking to the right side of the Read operator and 

dragging the red arrow towards the Resample operator. 

 

Below the white box with the graphical representation of the tools used in a processing chain, you will 

find a panel which allows to change the parameters of all tools placed into processing chain. We will 

update the parameters one by one here.  

Do not change anything in the Read tab.  

In the Resampling Parameters tab under “Define size of resampled product”, choose: By reference 

band from source product: B2 

 

 NOTE 6: The input product contains 13 spectral bands in three different spatial resolutions (The surface 

area measured on the ground and represented by an individual pixel). When we open the RGB view all 

our input bands have 20 m resolution, however, the view is displayed in the full 10 m resolution.  
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5.4.2 Subset  

Next step will be to subset the images to the area of interest, we do this by right-clicking the white 

space somewhere right of the resample operator and going to Add → Raster → Geometric → Subset. 

Connect the Subset operator with the Resample operator. 

 

In the Subset tab we are going to keep only the bands which will be necessary in next steps of the 

analysis. In the parameter Source band select following bands to keep in the final product:  B2, B3, B4, 

B8, B11, B12. Then we are going to clip our image only to the area of interest, which in our case is 

Theewaterskloof dam. Below the option Copy metadata select the option of subset Geographic 

coordinates. Below the world view window in the white text box copy and paste the subset polygon 

coordinates in Well-Known-Text format (WKT) from Expressions.txt file stored in: 

/shared/Training/HYDR03_DroughtMonitoring_WesternCape/AuxData/ 

POLYGON ((19.061834340155283 -33.955691701708375, 19.379564169402002 -33.96

028594353146, 19.376352000158878 -34.12895277789442, 19.057993224051753 -34

.124329459334305, 19.061834340155283 -33.955691701708375)) 

 

5.4.3 Write 

Now, finally we can add Write operator and connect it to the Subset.  

Change the directory of the output products to the path:  

/shared/Training/HYDR03_DroughtMonitoring_CapeTown/Processing/preprocessing/. 
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Now, save the graph as Graph_preprocessing.xml to:  

/shared/Training/HYDR03_DroughtMonitoring_WesternCape/AuxData/ by clicking Save at the 

bottom of the window. 

5.4.4 Batch processing 

Batch Processing is used when we want to apply identical pre-processing steps at once to multiple 

images. Once we have our graph with pre-processing steps created we are ready to apply the same 

steps to all 16 images.  

There are several approaches to do batch processing in SNAP, but in this step we will make use of built-

in tool in SNAP – Batch Processing tool.  To do this first close the Graph Builder window. 

Then open Batch Processing tool (Tools → Batch Processing). In the I/O Parameters tab we will add 

all opened products from the Product Explorer window [1]-[16] by Add Opened on the upper right 

(second icon from the top) and then click Refresh (second icon from the bottom). Like this we have 

loaded all 16 images from 2015-2020 of the same area.  

In the I/O Parameters tab, under the Target Folder: 

a) keep the format (Save as) is set to BEAM-DIMAP,  

b) change the directory to:  

/shared/Training/HYDR03_DroughtMonitoring_WesternCape/ Processing/preprocessing/ 

c) and the option “Keep source product name” unchecked. Do it before uploading the graph into 

Batch Processing Tool  (See  NOTE 7). 

 
Then click on Load Graph at the bottom of the window, and you should now navigate to saved 

Graph_preprocessing.xml file and open it. We see that new tabs have appeared at the top window 

corresponding to our operators from pre-processing graph.  

 NOTE 7: The product file names will be identical to the input file names. If you set your output directory 

to the folder that contains your input data, the input data will be overwritten! 
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In the Resample tab make sure that under Define size of resampled product, option “By reference 

band from source product” is selected and then that the B2 is highlighted as a reference band. This 

way we will ensure that all the bands will be resampled to 10 m resolution.  

  

At the Subset, check if all parameters are exactly the same as set in Graph Builder previously.  

In the Write tab, under the Name keep the default name (Subset_ and _resampled will be added). At 

the directory make sure that the path 

to:/shared/Training/HYDR03_DroughtMonitoring_WesternCape/Processing/preprocessing. 

Click Run.  

Add opened 

Refresh 
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The processing time will depend on your VM setup. (Approx. 3 mins with 30GB ram).  

You can check the  /shared/Training/HYDR03_DroughtMonitoring_WesternCape/Processing/ 

preprocessing/ for the output products. Once the processing is done close the Batch Processing 

window. All pre-processed products will appear automatically at 

the Product Explorer window.   

Once all products are loaded [17]-[32], right-click the first and go 

to Open RGB image window. Select the profile: Sentinel 2 MSI 

Land/Water and click OK. You can repeat this step for all products 

and the go to Window → Tile Evenly. On the left in the Navigation 

panel select: Zoom all  
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5.5 STEP 2 | Water radiometric indices calculation 

To detect water bodies, we will use several water radiometric indices from S2 data. A variety of 

different water indices exist and can be applied for different purposes. We will first introduce here 4 

indices selected for the purpose of this training. Later we are going to calculate them for all 16 images. 

We will use different water radiometric indices to create later a water mask based on the results of 

the water response to specific band combinations. Generally, water only reflects in the visible light 

range. As water has almost no reflection in the near infrared range it is very distinct from other 

surfaces. Because of this absorption property water bodies as well as features containing water can 

easily be detected, located and delineated with remote sensing. 

5.5.1 NDWI 

To detect the water bodies, we will use several water radiometric indices proposed in the literature. 

First index that we will use is the Normalized Difference Water Index. It was proposed by McFeeters2 

to detect surface waters in wetland environments and to allow for the measurement of surface water 

extent.  It allows also to:  

i) maximize the reflectance of the water body in the green band;  

ii) minimize the reflectance of water body in the NIR band. McFeeters’s NDWI is calculated as: 

 

 

 

5.5.2 MNDWI 

The main limitation of previously described NDWI index is that it is not efficient in sites where built-up 

areas signal noise can affect the water surface signal. It was noticed that the water bodies have 

stronger absorbability in the SWIR band than in the NIR band, while the built-up areas have greater 

radiation in the SWIR band than in the NIR band (Xu, 2006). Based on this finding the Modified 

Normalized Water Index was proposed which allows to suppress and even removing built-up land 

noise as well as vegetation and soil noise and therefore enhance water bodies extraction. 

The MNDWI is calculated using following equation:  

 

 
MNDWI = 

𝐺𝑟𝑒𝑒𝑛 −𝑆𝑊𝐼𝑅1

𝐺𝑟𝑒𝑒𝑛+𝑆𝑊𝐼𝑅1
 = 

𝐵3 −𝐵11

𝐵3+𝐵11
 

NDWI = 
𝐺𝑟𝑒𝑒𝑛 −𝑁𝐼𝑅

𝐺𝑟𝑒𝑒𝑛+𝑁𝐼𝑅
 = 

𝐵3 −𝐵8

𝐵3+𝐵8
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5.5.3 MNDWI + 5  

In 2015 the modification of existing Modified Normalized Vegetation Index was introduced (MNDVI 

+ V). This index use NIR and Red band (Zhou et al., 2017)  and it combines the Enhanced Vegetation 

Index and Normalized Difference Vegetation Index. This combination makes it more sensitive to 

surface water features, enhancing the ability to map their distribution. This index shows great 

performance also in flood detection and mapping as well as monitoring surface water resources 

(Bhaga et al. 2020). Using this index surface water will have negative values (<0) so opposite to all 

other water indices tested in this exercise.  

 

MNDWI + 5  = 
𝑁𝐼𝑅 −𝑅𝑒𝑑

𝑁𝐼𝑅+𝑅𝑒𝑑
 = 

𝐵8 −𝐵4

𝐵8+𝐵4
 

 

5.5.4 AWEI 

This is the last index which has been tested in this training. The Automated Water Extraction Index  

has been introduced by Feyisa et.at (2014). And it was designed to improve water extraction accuracy 

with a stable threshold value. This index introduced two equations which are AWEIsh (used in this 

exercise) and AWEInsh. In this training we concentrated only on one AWEI index and it is AWEIsh which 

enhance water bodies detection by removing shadow pixels. Both indices however use combination 

of blue, green, NIR, SWIR1 and SWIR2 bands.  

The equation used for calculating this index is following:  

 

 

 

5.5.5 Water radiometric indices calculation 

To calculate the water radiometric indices described we will create another short graph. We will 

produce four water radiometric indices for all 16 images.  First we will create short graph that 

calculates indices for all images at once. Then newly created bands will be stacked to one product 

which corresponds to each sensing date of images used. Band merge will be crucial to perform later 

Time Series analysis in SNAP as it is one the requirements of this tool.  

Go to Tools → Graph Builder. First of all, we can remove Write operator to not create confusion. To 

delete the operator, right click on it and select Delete.  

Then to calculate water indices add four Band Maths(1-4) operators (one for each water index): Add 

→ Raster → BandMaths.  

We will calculate the indices based on the mathematical equations applied on different bands of the 

product. The expressions used to calculate these water indices are stored in file: Expression.txt (lines: 

10 – 13) which is stored in: /shared/Training/HYDR03_DroughtMonitoring_WesternCape/AuxData/ 

After you placed all four BandMaths operators to your graph you can edit the parameters (expressions 

used for calculation of each index).  

AWEI = 𝐵𝑙𝑢𝑒 + 2.5 ∗ 𝐺𝑟𝑒𝑒𝑛 − 1.5 ∗ (𝑁𝐼𝑅 + 𝑆𝑊𝐼𝑅1) − (0.25 ∗ 𝑆𝑊𝐼𝑅2) =  

= B2 + 2.5 * B3 – 1.5 * (B8-B11) – (0.25 * B12) 
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After all four BandMaths operators are added you can click again on the white space in the graph 

builder go to Add → Raster → BandMerge and connect all four BandMaths operators to Band Merge. 

As a last step go to Add → Input-Output → Write. Connect Band Merge to Write operator. Your final 

graph should look like this below:  

 

 

Now move to the tabs below the graphical representation of operators and edit parameters.  

Do not change anything in the Read operator tab.  

In the BandMaths tab which indicates the first water radiometric index to calculate:  

• change Target band name: NDWI 

• go to Edit Expression button and copy and paste following equation to calculate the new band. 

Go to Band Math tab and copy and paste following condition statement (expression):  

(B3-B8)/(B8+B3) 

 

 Expressions are also stored in the Expression.txt file in the Training folder: 

/shared/Training/HYDR03_DroughtMonitoring_WesternCape/AuxData/) 
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In Band Math(2) tab: 

• change Target band name: MNDWI 

• go to Edit Expression button and copy and paste following equation to calculate the new band: 

(B3-B11)/(B8+B11) 

  

In Band Math(3) tab: 

• change Target band name: MNDWI5 

• go to Edit Expression button and copy and paste following equation to calculate the new band: 

(B8-B4)/(B8+B4) 

  

In Band Math(4) tab: 

• change Target band name: AWEI 

• go to Edit Expression button and copy and paste following equation to calculate the new band: 

B2 + 2.5 * B3 – 1.5 *(B8-B11) – 0.25 * B12 

   

In the next tab BandMerge we will merge all water radiometric indices. To do that select all bands 

(with CTRL key pressed) in the Source Bands parameter.  
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Do not change anything in Write tab.  

Now, save the graph as Graph_WIs.xml to:  

/shared/Training/HYDR03_DroughtMonitoring_WesternCape/AuxData/ by clicking Save at the 

bottom of the window. 

5.5.6 Graph Processing Tool | GPT 

In this exercise, we will use the SNAP GPT command line interface (which can be found in the bin folder 

of the Sentinel Toolbox installation) to process our Sentinel- products. This tool is used to execute 

SNAP raster data operators in batch-mode. The operators can be used stand-alone or combined as a 

directed acyclic graph (DAG). Processing graphs are represented using XML files. Using the GPT 

provides a convenient way to use operators in a headless environment or in batch mode (See  NOTE 

8). 

 

To access GPT, open a Terminal window by clicking on its icon - - write the following text and press 

enter (See  NOTE 9). 

gpt 

 

 NOTE 8: To run an operator using GPT, it is necessary to indicate the path to the source product(s), to 

the target product and to other operator-specific parameters which might be mandatory or specific. As 

for complex operators the call from the command line can easily become confusing, it is also possible to 

pass the required settings in form of a xml-encoded graph file. It will then suffice to just pass the graph 

as parameter to the GPT.  
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To process our images in batch mode using GPT we need to change the input and output reference to 

specific input/output files by variables (See  NOTE 10).Navigate to the following path, right click on 

the graph file (Graph_WIs.xml) and select Open With -> Open with Mousepad.  

Once the xml file is opened, click on View -> Line Numbers.  

Path: /shared/Training/HYDR03_DroughtMonitoring_WesternCape/AuxData/ 

 

In line 7, delete only the path to the input image highlighted in orange (do not remove <file> and 

</file>) and write $input (as highlighted in green). Line 7 should look like this: 

<file>$input</file> 

 

 

In line 105, delete only the path to the output image highlighted in orange (do not remove <file> and 

</file>) and write $output2 (as highlighted in green). Line 105 should look like this: 

<file>$output</file> 

 

 

NOTE 9: Note that in the RUS Copernicus Virtual Machines, the gpt command is an environment variable 

and can be called directly from the terminal. If this is not your case, you will have to set it or specify the 

path to gpt to call the program. 

NOTE 10: The graph created in the Graph Builder tool in SNAP is an xml document that contains the 

different operators that have been added. The xml document is structured in a way that all the 

information of a specific operator is specified between the and tags. 
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5.5.7 Batch processing 

Once the graph is modified with the $input and $output variables, we are ready to process them in 

batch mode with GPT. For that, when an image is processed, the $input and $output variables have to 

change with the appropriate name. There are several approaches to do so but, in this exercise, we will 

use a bash script (See  NOTE 11).  

 

Now, go to the path: /shared/Training/HYDR03_DroughtMonitoring_WestrenCape/AuxData/and 

open the file named: Script_WIs.sh.  

 

On line 1, we specify that the script should be run with Bash scripting language (See  NOTE 11).  

 

On line 3, 4 we specify folder where input data are stored and output folder (respectively) where our 

results will be saved.  

 

On lines 7 and 8 we specify the pattern of the beginning of the input product (line 7) and ending of the 

output (line 8). 

 

NOTE 11: A shell script is a computer program designed to be run by the Unix shell, a command-line 

interpreter. The various dialects of shell scripts are considered to be scripting languages. The one used 

in this exercise is called Bash script (https://en.wikipeia.org/wiki/Bash (Unix shell)). Typical operations 

performed by shell scripts include file manipulation, program execution, and printing text.  

If you want to run this exercise on Windows, you can replicate the steps in any programming language 

you are familiar with, such as Python or R.  

https://en.wikipeia.org/wiki/Bash
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Line 11 signifies the start of the loop. The script will loop over all files in the specified folder ending 

with “.dim”. In each iteration, the path to one input file is denoted by “i”.  

“do” on line 12 and “done” on line 19 enclose the steps that should be performed on each input 

product.  

 

On line 13,  we extract the name of the input product; on line 14, we extract the date of the acquisition 

from the Sentinel-2 product. 

 

On line 15 and 17 we specify that once the script will run, information about current date will be 

provided (printed) in the Terminal.   

On line 16 we call GPT and specify the path to our saved and edited graph file. Then with -P{variable 

name} we specify the parameters to be replaced in the graph file (marked with $ in the graph file) – 

input and output variables. We also create the output product name combining the sensing date of 

the product and the suffix for each output product. On line 19, the loop is closed.  

 

Once the script is saved, we can run it. Navigate to …/AuxData/ folder where shell script file is sotred. 

Right-click on the white space and go to Open Terminal Here. In the terminal type:  

sh Script_WIs.sh 

where Script_Wis.sh is the name of the Bash script file. Click Enter to run the script.  

 

The processing time will depend on your VM setup (approx. 2-3 min with 30 GB RAM). You can check 

the: /shared/Training/HYDR03_DroughtMonitoring_WesternCape/Processing/WIs/ for the output 

products. Close the terminal window. Once the images are processed you should see the list of 

products like this: 
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5.6 STEP 3 | Time Series 

Now, let’s have a look at different water radiometric indices, output from Bash processing. Go back to 

SNAP and go to File -> Session -> Open session..  

Navigate to /shared/Training/HYDR03_DroughtMonitoring_WesternCape/AuxData/ and open 

water_indices.snap  

You can now investigate different indices over the period from 2015 until 2020. Expand Bands of each 

product in Product Explorer. You will notice that all products have bands with the same name. This is 

the requirement of Time Series Tool in SNAP. In order to plot temporal changes in a graph compared 

bands need to have the same name.  

We can compare different water indices now in different period (for example in this case MNDWI5 

index). We can observe how the water level changed between the 2016 (April) and in the image from 

2018 (March) when the drought had its peak and finally we will compare with the image from 2020 

(February). 

 

SNAP offers a time series analysis tools suitable to represent temporal evolution and improve 

monitoring activities. In order to be able to compare the images they were produced in batch 

processing in a way that they all have common naming convention (sensing date_WIs). 

Expand each product and open the Bands folder. Double click for 

example on the NDWI band of all 16 products [1]-[16] to visualize 

the NDWI values in each date (wet and dry seasons). Then go to 

Window -> Tile Evenly to synchronize all views.  
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Click on the Time Series Analysis button  on the main toolbar to open the toolview. In the panel 

below the Product Explorer next to World View new tab will appear (as indicated above). In the  Time 

Series Analysis window, press the button to configure your graph and press the   icon to add 

all the open products in SNAP to the time series analysis. Press the refresh icon ( ), rename the graph 

to NDWI. Then, click Apply and Close. 

 

Now click on the Filter Bands ( ) of the Time Series Analysis tool. In the 

pop-up window select NDWI and click Ok. Make sure you select also  

icon to see the select band values in the position of your cursor. You can 

see the evolution of the NDWI values of each pixel in the graph, labeled 

with the year and month. Move to the area in the southern part of the dam 

and inspect that we can clearly see the differences in water radiometric 

indices values.  
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You can clearly see the seasonality of the NDWI values over different period (wet and dry season). You 

can also conclude that in the period between late 2016 and until the beginning of 2018 there has been 

very low NDWI value over the selected area. It suits to the period of the worst drought in this area. 

Moreover this image gives you also an idea of the pixel values over the water areas (generally the 

water area is indicated by the NDWI values > 0. We can see that in the period of drought this value In 

this exact position of cursor dropped to value below 0 which indicates that this pixel was not 

recognized anymore as water but as non-water area in indicated period. If you want to export the 

graph, you can do it as a text file (.csv) or as an image. Use the dedicated buttons in the lower right 

corner of the Time Series Analysis Tool ( and  ). You can investigate in the same way all other 

indices. You can find below Time Series graph of MNDWI +5 band which assigns values >0 to non-water 

areas, water is represented in this case in values 0<. What is important is that again we can see very 

clearly here the drought period which corresponds to known period of drought in this region.  
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5.7 STEP 4 | Water area and water mask 

 The second objective of this training is to explore the differences in the extent of water during the 

drought period.  

The surface water pixels generally appear much brighter than other surfaces (apart from the pixel 

values derived from MNDWI+5 water index). We will merge now information coming from all 4 

Sentinel-2 derived water radiometric indices (NDWI, MNDWI, MNDWI+5 and AWEI) to create a new 

band for each acquisition date that will contain only water surfaces.  

For this purpose we will use a threshold value for pixel to be classified as water. For the NDWI, MNDWI 

and AWEI bands the threshold will be equal to >=0 but in case of pixel values derived from the 

MNDWI+5 index pixels with values below 0 so (<=0) represent water surface. First of all simple method 

to extract the information on water area in different period of time will be presented here. For this 

purpose we will compare the water area changes in wet season. First open the MNDWI+5 band from 

3 products: [1]20150810_WIs, [3]20160824_Wis and [6]20170809_WIs by double click on that band. 

Then go to Window -> Tile Horizontaly. In Navigation click on the icon to see the whole area of all 

products. Then in the panel with tools on the right go to Mask Manager Tool.  

 

Here we will create a virtual mask, which will separate water surface in all three images. We will create 

the mask based on the logical band math expression. To create the first mask click on the icon        

 

Mask manager 



34 
 

New window will open. Then you should see a list of four water indices bands stored in collocated 

product. In the Expression window type: MNDWI5<0. Like this we can select only water pixels. Save 

the equation by clicking OK.  

 

You will see that new mask has been created in Mask Manager. It is also overlaid over the image 

from 2015-08-10. Repeat the same steps for other 2 displayed products.  

SNAP offers also a possibility to calculate the area of the mask. Because in this case the mask indicates 

the dam area only, we can use this option to see changes in the extent of this water body during the 

drought period. We will compare the area of the dam from before the drought (2015) in wet season 

with water extent from 2016 and 2017 also during the wet season (August).  

Select the first view of the image from 2015. To display the mask area navigate to main toolbar on 

the top of SNAP window. Go to Raster -> Mask -> Mask area 
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In the new window you will see the area of the mask (water) displayed in km2. The area of the mask is 

calculated based on the number of pixels which fall within created mask. Repeat the same steps for 

other 2 products. Then you can compare the how the water area dropped significantly over two years. 

What is important is that these changes are visible during the wet season. Later we will assess the 

changes during all time period including images from dry season as well.  

   

To close this window press Ok.  

One important drawback of this mask area method in SNAP is that you cannot store the water mask 

area and you cannot calculate it for several images at once to compare such mask area. That is why 

in Extra steps part of this tutorial you will see how to perform such area analysis in QGIS.  

Because we want to see the dynamics in water extent during the drought period and compare it with 

the water extent after the drought we will use Batch Processing again. For this we need to first create 

a new simple graph in Graph Builder to be able to process all 16 images simultaneously. We will extract 

water pixels based on pixel values coming from all four water indices. With this method we will create 

again a new band that will only contain the water surface.   

Now close the current views. Go to Tools -> Graph Builder. Add a Band Math operator, right click on 

it and select Connect graph.  

 

In Read operator leave everything as default.  

Go to Band Math tab and copy and paste following condition statement (expression):  
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if (MNDWI>=0 or NDWI>=0 or MNDWI5<=0 or AWEI>=0) then 1 else 0 

 

 

Under Write operator do not change anything in the name of the output product. Make sure that you 

select GeoTIFF as output file type. For your output set following Directory: 

Path: /shared/Training/HYDR03_DroughtMonitoring_WesternCape/Processing/water_mask/  

 

Once your graph is ready click Save and store the graph under the name: Graph_water_mask.xml. 

Store graph under following path:  

/shared/Training/HYDR03_DroughtMonitoring_WesternCape/AuxData/ 

 

Now we can start process of extracting only water pixels from the collocated product using just created 

graph. Close Graph Builder tool. Go to Tools -> Batch Processing. In I/O parameters tab we will add 

all opened products from the Product Explorer window [1]-[16] by Add Opened on the upper right 
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(second icon from the top) and then click Refresh (second icon from the bottom). Like this we have 

loaded all 16 images from 2015-2020 of the same area. Then: 

a) Deselect option Keep source product name 

b) Click on Load Graph at the bottom of the window, and you should now navigate to saved 

Graph_water_mask.xml file and open it. We see that new tabs have appeared at the top 

window corresponding to our operators from pre-processing graph.  

 

In Band Math tab do not change anything. In Write tab do not change the output product name. The 

suffix “_BandMath” will be added to all products. Make sure to save product as GeoTIFF file. Keep the 

previously set directory:  /shared/Training/HYDR03_DroughtMonitoring_WesternCape/Procesing/ 

water_mask. Once Batch Processing parameters are ready click Run.  

  

Processing will last about 1 minute.   

After that we can visually compare the water mask generated with the combined threshold from 

different water radiometric indices with all water indices bands. Below you can see generated water 

mask (lower right corner) compared to bands of different water indices from 2015-08-10. You can see 

that this method gave satisfactory results.  

Add opened 

Refresh 
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5.8 Visualization (QGIS) and comparison 

Let’s compare now the extent of the Theewaterskloof dam over the years 2015-2020 to see the 

evolution of its area. Launch QGIS Desktop application. Double click on the icon  in your Desktop. 

In the main window click on Open Project. Navigate to the path 

/shared/Training/HYDR03_DroughtMonitoring_WesternCape/AuxData/ where QGIS project is 

stored. Click on the file named: Drought_Monitoring.qgs and open it.  

 

To create a visualization of the dynamics in the Theewaterskloof dam extent the water mask GeoTIFF 

files created in SNAP (chapter 5.6) were converted to polygons. Then the selection of water areas only 

was made based on the pixel values (=1) assigned to water surface in the mask. Then the area of all 

water surface polygons were calculated. All steps of this processing in QGIS is described in details in 

Extra Steps chapter (6.2).  

Open Project 
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The final layers which are included in Drought_Monitoring.qgs QGIS project are stored in: 

/shared/Training/HYDR03_DroughtMonitoring_WesternCape/Processing/vectors/water_area_cha

nges/ folder.  

To visualize the layers of the water extent right-click on the first polygon layer and select Zoom to 

layer.  

You should be able to see following visualization. Visualization below shows the dynamics in dam 

extent in dry period from 2016 till 2020.  

 

You can also explore how the dam changed its shape during the wet season when you compare the 

images from August for all dates. We can see that the dam came back to the original shape in 2020.  

 

Moreover the area of the dam in each 3-4 months period from 2015-2020 was calculated in QGIS. 

Chart below represents changes in the water surface area, indicating seasonal variations but also the 

drought period from 2016-2018. Water area from about 42 km2 in 2015 shrunk into about 11 km2 in 

2018. We can see also that in 2020 the water area came back to its previous shape. Monitoring 

seasonal changes in the water level and consecutively also in water area is important in case of the 

crisis such as the one in 2018 when the Cape Town area almost run out of water for their citizens.  
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6 Extra steps 

6.1 Atmospheric correction  

The “Level 1C” data we have downloaded are radiometrically and geometrically corrected (including 

orthorectification and spatial registration). However, atmospheric correction is applied only to the 

Level 2A data which are not available for our study site at this time. 

 

Solar radiation reflected by the Earth’s surface to satellite sensors is affected by its interaction with 

the atmosphere. The objective of applying an atmospheric correction is to determine true surface 

(Bottom-Of-Atmosphere, BOA) reflectance values from the Top-Of-Atmosphere (TOA) reflectance 

values, by removing atmospheric effects. (See  NOTE 12) Atmospheric correction is especially 

important in cases where multi-temporal images are compared and analysed as it is in our case.1  

In this tutorial, we will use the Sen2Cor processor. Sen2Cor is a processor for Sentinel-2 Level 2A 

product generation and formatting; it performs the atmospheric, terrain and cirrus correction of 

TopOf-Atmosphere Level 1C input data. Sen2Cor creates Bottom-Of-Atmosphere, optionally terrain 

and cirrus corrected reflectance images; additional, Aerosol Optical Thickness, Water Vapour, Scene 

Classification Maps and Quality Indicators for cloud and snow probabilities. 

 TIP 1: Level 2A have been systematically produced for newly acquired products over Europe since the 

spring of 2017, the coverage has been increasing through 2018 to reach global coverage in the beginning 

of 2019. 
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Go to Optical → Thematic Land Processing → Sen2Cor and select Sen2Cor280. 

In the I/O Parameters tab, click on “…” next to the product name and navigate to the Original folder. 

Open the “.SAFE” folder of the 2015 product first. Then open the MTD_MSIL1C.xml file. In the 

Processing Parameters tab change the resolution to “ALL” and select “Display execution output”. Click 

Run. 

 

 

 

 

 

 

 

 

 

 

This is rather a time demanding process and requires approximately 30 minutes per image (with 30GB 

RAM). Unfortunately, you need to repeat the same steps for other products as well. So the same 

procedure should be applied to products [2]-[16]. Close Sen2Cor window when all processing is 

completed.  

 NOTE 12: : The radiance reaching the sensor is a result of following components: 
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You will see three new products created at the Product Explorer window, named “Output Product”. 

Select them all, right click on them and select “Close All Products”. Click “No” to the following windows 

that will appear. 

This process creates three new Level 2-A products in the .SAFE format in the Original folder. Move 

them to: /shared/Training/HYDR03_DroughtMonitoring_WesternCape/Original/Level-2A. 

 

6.2 Calculate the drought area in QGIS 

Due to the fact that SNAP software does not offer possibility to extract water area based on the water 

mask pixels in an automatic way for all 16 bands. This process was added to Extra steps in this tutorial 

and will be performed in QGIS.  

In order to process the data Open QGIS Desktop application. Double click on the icon  in your 

Desktop. In the main window select icon New Project. In the panel Browser navigate to .tiff water 

masks exported from SNAP in a final step of this exercise. Navigate to the path: 

/shared/Training/HYDR03_DroughtMonitoring_WesternCape/Processing/water_masks/ select all 

16 rasters and drag and drop to the Layers panel below.  

 

Now in order to extract the area of the dam we will need to convert raster files to vector format. To 

do that we will use batch processing tool in QGIS. First open Processing Toolbox. It should be a panel 

on the right. If you do not see it, in main menu bar go to View -> Panels -> Processing Toolbox. Now 

the panel on the right side of QGIS application should appear. In Search window write “Polygonize” 

and select tool Polygonize (raster to vector). Double click on this tool and new window will open.  
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You can perform this step in Batch Processing too in QGIS (note that for this you need to make sure 

that your QGIS application is up to date, sometimes when new updates are not installed this processing 

in batch mode will not function). 
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If you want to run vectorization only on one image in the tool window select just the image you want 

to vectorize, go to Vectorized box and select directory where your product should be saved. Click Run 

to launch the process. Your vectorized layer should looks like below:  

 

As a result you will receive a polygon layer which will be automatically opened in Layers panel. Open 

attribute table of the polygon (Vectorized). Right-click on it in and select Open Attribute table. You will 

see that the attribute table contains only one column “DN” and has two classes. In geotiff raster values 

= 1 corresponded to water pixels.  

So next step will be to select water area from the whole vector file. Go to Processing Toolbox again 

and open tool “Select by attribute”. In Input Layer select your polygon you want to process. Then in 

the Selection attribute leave “DN” column. In Operator select “=” and in the window Value type 1. In 

this way you will select only water polygons. Click Run.  
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Once the water are selected you will see them highlighted in yellow in QGIS when you go to your 

polygon layer. Then we should extract selected features to have only the water area.  

Go again to Processing Toolbox and select tool Extract selected features.  

In a new window which appear you can also process the images in Batch mode. Click on the button 

Run as Batch Process. In Input layer click on the button next “…” and choose option “Select Open 

Layers” there click on the option “Select all” and click Ok. Next to the column Selected features change 

assign the output path. Navigate to the folder you want to store your data and select shapefile as a file 

type. In the small window Autofill settings select option “Fill with parameter values” . In the Parameter 

to use option leave Input layer. Click Run.  

 

If you would like to calculate the area of the dam more precisely without having other polygons outside 

of the dam which have been classified as water (due to noise or other parameters) then you can use 

the layer named: ThewaterskloofDam.shp stored in /AuxData/ folder to clip your all selected polygons. 

This can also be run in a Batch Process in QGIS. To do this go to Vector -- > Geoprocessing Tools -- > 

Clip. As Input layer select the polygon layer you want to clip. In the option Overlay layer select the layer 

with the extent to which you want to clip your polygon file (ThewaterskloofDam.shp). You can also 

create a buffer of the original dam layer (of for example 30m and then use it to clip your polygons). 
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As a next step we will calculate the area of each water layer in 16 polygon shapefiles. For this go to 

Processing Toolbox and select tool Add geometry attributes. You can also run it as batch process which 

will speed up calculations. As input layers select clipped layers of the water areas from all dates.  

 

Because we would like to see the changes in the water area in all polygon layers we need to merge all 

the layers now into one shapefile. Go to Processing Toolbox and select tool Merge vector layers. In 

the box Input layers select all the layers with the geometry (area and perimeter of the polygon 

information). Save the file to your directory and click Run.  

 

 

 

 

 

 

 

 

Now finally we can assess complete information on the evolution of the extent of the dam.  
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Go to the last tool you will use in QGIS for this training. Navigate to Processing Toolbox and choose 

tool Statistics by categories. In Input vector layer place Merged polygon. In the field Field to calculate 

statistics select “area” field. In the field Field(s) with categories select “layer” (as shown below) click 

Ok. Save the file in .csv format.  Click Run.  At the end you will receive a table with the area of the dam 

summarized by the name of the layer which indicates the exact sensing date.  

   

The output of this calculation should looks as below:  

 

Here you can assess other statistical parameters. You can delete the columns which are not of your 

interest. Enable editing in the table and select option Delete fields. The area was calculated in m2. You 

can convert it to km2 using Field calculator in this attribute table. To do that add a new field and divide 

the “sum” column by 1000000.  
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At the end your table will look like this:  

 

You can also visualize now your results as the data are stored in .csv file. You can plot a graph to see 

the differences in the water extent.  

 

Thank you for following the exercise! 
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