
_p 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

FRESHWATER QUALITT MONITORING FROM SPACE  

LAGO TRASIMENO, ITALY 

TRAINING KIT – HYDR01 



1 
 

 

 

Research and User Support for Sentinel Core Products 

 

The RUS Service is funded by the European Commission, managed by the European Space Agency 

and operated by CSSI and its partners. 

Authors would be glad to receive your feedback or suggestions and to know how this material was 

used. Please, contact us on training@rus-copernicus.eu 

Cover images produced by RUS Copernicus  

 

 

The following training material has been prepared by Serco Italia S.p.A. within the RUS Copernicus 

project. 

Date of publication: February 2020 

Version: 1.1 

 

 

Suggested citation: 

Serco Italia SPA (2020). Freshwater Quality Monitoring from Space - Lago Trasimeno, Italy (version 

1.1). Retrieved from RUS Lectures at https://rus-copernicus.eu/portal/the-rus-library/learn-by-

yourself/ 

 

 

 
This work is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 

International License. 
 
 

 
 
DISCLAIMER 
 
While every effort has been made to ensure the accuracy of the information contained in this publication, RUS 
Copernicus does not warrant its accuracy or will, regardless of its or their negligence, assume liability for any 
foreseeable or unforeseeable use made of this publication. Consequently, such use is at the recipient’s own risk on 
the basis that any use by the recipient constitutes agreement to the terms of this disclaimer. The information 
contained in this publication does not purport to constitute professional advice. 

mailto:training@rus-copernicus.eu
https://rus-copernicus.eu/portal/the-rus-library/learn-by-yourself/
https://rus-copernicus.eu/portal/the-rus-library/learn-by-yourself/
http://creativecommons.org/licenses/by-nc-sa/4.0/
http://creativecommons.org/licenses/by-nc-sa/4.0/
http://creativecommons.org/licenses/by-nc-sa/4.0/


2 
 

Table of Contents 

1 Introduction ..................................................................................................................................... 3 

2 Training ............................................................................................................................................ 3 

2.1 Data used ................................................................................................................................. 3 

2.2 Software in RUS environment ................................................................................................. 3 

3 Register to RUS Copernicus ............................................................................................................. 4 

4 Request a RUS Copernicus Virtual Machine .................................................................................... 5 

5 Step by step ..................................................................................................................................... 8 

5.1 Data download – ESA SciHUB .................................................................................................. 8 

5.2 Data exploration .................................................................................................................... 12 

5.3 STEP 1 – Pre-processing......................................................................................................... 13 

5.4 STEP 2 – Atmospheric correction & bio-optical model ......................................................... 18 

5.5 STEP 3 – Empirical algorithms ............................................................................................... 22 

6 Extra steps ..................................................................................................................................... 30 

6.1 Downloading the outputs from VM ...................................................................................... 30 

7 Sources & References .................................................................................................................... 30 

 

 

 

 

 

 

  



3 
 

1 Introduction 

The Research and User Support for Sentinel core products (RUS) service provides a free and open 

scalable platform in a powerful computing environment, hosting a suite of open source toolboxes 

pre-installed on virtual machines, to handle and process data derived from the Copernicus Sentinel 

satellites constellation. 

Freshwater is a fundamental resource for 

human civilisation, the availability or 

unavailability of it is directly linked to water 

security, food security, economic 

productivity and conflicts. Moreover, 

freshwater ecosystems play a major role in 

driving global biodiversity and ecological 

stability, however they are also 

exceptionally vulnerable to human 

mismanagement and climate change. With 

the progress of climatic change and growing 

world population, the pressure on our 

freshwater resources is growing and with it 

the need for careful monitoring and management, to preserve them for current and future 

generations. Remote sensing enables us to monitor a number of water-quality indicators that reflect 

the state of the entire freshwater ecosystems. These indicators observable from space help us to 

estimate among others the concentrations of Chlorophyll-a, Total suspended matter (TSM), Coloured 

dissolved organic matter (CDOM), as well as the density of cyanobacteria and water turbidity. 

For theoretical introduction please watch: https://youtu.be/Fx01Jtif884 on RUS Copernicus 

Training channel.  

2 Training 

Approximate duration of this training session is two hours.  

2.1 Data used 

• 12 low-cloud Sentinel-2A Level 1A tile (Tile ID: T32TQN) acquired from 16 April to 15 November 

2018 [downloadable @ https://scihub.copernicus.eu/] 

S2A_MSIL1C_20180416T100031_N0206_R122_T32TQN_20180416T120852.zip 

S2B_MSIL1C_20180511T100029_N0206_R122_T32TQN_20180511T134849.zip 

S2B_MSIL1C_20180531T100029_N0206_R122_T32TQN_20180531T120906.zip 

S2B_MSIL1C_20180630T100029_N0206_R122_T32TQN_20180630T134105.zip 

S2B_MSIL1C_20180710T100029_N0206_R122_T32TQN_20180710T135302.zip 

S2A_MSIL1C_20180718T101031_N0206_R022_T32TQN_20180718T171829.zip 

S2B_MSIL1C_20180809T100019_N0206_R122_T32TQN_20180809T140850.zip 

S2B_MSIL1C_20180822T101019_N0206_R022_T32TQN_20180822T142412.zip 

S2B_MSIL1C_20180829T100019_N0206_R122_T32TQN_20180829T190727.zip 

S2A_MSIL1C_20180906T101021_N0206_R022_T32TQN_20180906T122259.zip 

S2B_MSIL1C_20180928T100019_N0206_R122_T32TQN_20180928T170858.zip 

S2A_MSIL1C_20181115T101251_N0207_R022_T32TQN_20181115T103245.zip 

2.2 Software in RUS environment 

Internet browser, SNAP + Sentinel-2 Toolbox, QGIS, (Extra steps: Sen2Cor, Google Earth) 

Lago Trasimeno Credits: Photo by  

https://youtu.be/Fx01Jtif884
https://scihub.copernicus.eu/
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3 Register to RUS Copernicus 

To repeat the exercise using a RUS Copernicus Virtual Machine (VM), you will first have to register as 

a RUS user. For that, go to the RUS Copernicus website (www.rus-copernicus.eu) and click on 

Login/Register in the upper right corner.  

 

Select the option Create my Copernicus SSO account and then fill in ALL the fields on the Copernicus 

Users’ Single Sign-On Registration. Click Register. 

 

Within a few minutes you will receive an e-mail with activation link. Follow the instructions in the e-

mail to activate your account.  

You can now return to https://rus-copernicus.eu/, click on Login/Register, choose Login and enter 

your chosen credentials. 

http://www.rus-copernicus.eu/
https://rus-copernicus.eu/
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Upon your first login you will need to enter some details. You must fill all the fields.   

 

4 Request a RUS Copernicus Virtual Machine 
Once you are registered as a RUS user, you can request a RUS Virtual Machine to repeat this exercise 

or work on your own projects using Copernicus data. For that, log in and click on Your RUS Service → 

Your Dashboard.  
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Click on Request a new User Service to request your RUS Virtual Machine. Complete the form so that 

the appropriate cloud environment can be assigned according to your needs. 
  

 
 

If you want to repeat this tutorial (or any previous one) select the one(s) of your interest in the 

appropriate field. 

 

 
 

Complete the remaining steps, check the terms and conditions of the RUS Service and submit your 

request once you are finished. 
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Further to the acceptance of your request by the RUS Helpdesk, you will receive a notification email 

with all the details about your Virtual Machine. To access it, go to Your RUS Service → Your 

Dashboard and click on Access my Virtual Machine.  
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Fill in the login credentials that have been provided to you by the RUS Helpdesk via email to access 

your RUS Copernicus Virtual Machine.  

 

This is the remote desktop of your Virtual Machine. 

 

5 Step by step  

5.1 Data download – ESA SciHUB 

In this step we will download a Sentinel-2 scene from the Copernicus Open Access Hub using the 

online interface (Applications → Network → Web Browser or click the link below). 

Go to https://scihub.copernicus.eu/   

https://scihub.copernicus.eu/
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Go to “Open HUB”, if you do not have an account please register by going to “Sign-up” in the LOGIN 

menu in the upper right corner. 

 

After you have filled in the registration form, you will receive an activation link by e-mail. Once your 

account is activated or if you already have an account, “LOGIN”.  

 

Switch the rectangle-drawing mode to pan mode by clicking on the “Pan” icon in the lower left 

corner of the map (Green arrow) and navigate over Portugal (approximate area – blue rectangle). 
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Switch to drawing mode and draw a search rectangle over the lake approximately as indicated below 

(yellow). Open the search menu (red arrow) and specify the following parameters: 

Sensing period:  From 2018/04/16 to 2018/11/15 

Check Mission:   Sentinel-2  

Product Type:   S2MSIL1C 

Press “Search” (red arrow below). 

 

In our case, the search returns four results depending on the exact search area defined. Using the 

icon, import only the following products to Cart:  

S2A_MSIL1C_20180416T100031_N0206_R122_T32TQN_20180416T120852.zip 

S2B_MSIL1C_20180511T100029_N0206_R122_T32TQN_20180511T134849.zip 

S2B_MSIL1C_20180531T100029_N0206_R122_T32TQN_20180531T120906.zip 

S2B_MSIL1C_20180630T100029_N0206_R122_T32TQN_20180630T134105.zip 

S2B_MSIL1C_20180710T100029_N0206_R122_T32TQN_20180710T135302.zip 

S2A_MSIL1C_20180718T101031_N0206_R022_T32TQN_20180718T171829.zip 

S2B_MSIL1C_20180809T100019_N0206_R122_T32TQN_20180809T140850.zip 

S2B_MSIL1C_20180822T101019_N0206_R022_T32TQN_20180822T142412.zip 

S2B_MSIL1C_20180829T100019_N0206_R122_T32TQN_20180829T190727.zip 

S2A_MSIL1C_20180906T101021_N0206_R022_T32TQN_20180906T122259.zip 

S2B_MSIL1C_20180928T100019_N0206_R122_T32TQN_20180928T170858.zip 

S2A_MSIL1C_20181115T101251_N0207_R022_T32TQN_20181115T103245.zip 
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Then click on the Profile icon in the upper left corner (marked with green circle above) and go to 

Cart. You should now have six products in your cart. Click on the arrow to Download the Cart.  

 

The grey products are currently placed in an Offline archive: to learn how to request them please 

follow the steps outlined here: https://scihub.copernicus.eu/userguide/LongTermArchive  

 

A products.meta4 file will be downloaded to your /home/rus folder. To download our data, we will 

use aria2 tool. To use the tool, we first need to place the products.meta4 file to the folder where we 

wish our data to be downloaded to: 

/shared/Training/HYDR02_FreshWaterQuality_Trasimeno/Original 

First let’s test our aria2 installation. To do this we open the Command Line  (in the bottom of your 

desktop window) and type: 

 

The correct response should be as follows: 

 

 

If the response is “-bash aria2c: command not found” see  NOTE 1. If you have received the 

correct response, then we can run the tool by typing following commands in the command line 

(replace <username> and <password> with your login credentials for Copernicus Open Access Hub):  

TIP: Alternatively, you can try to retrieve the products from other repositories such as: PEPS 

(https://peps.cnes.fr/rocket/#/home) or ONDA DIAS Catalogue (https://catalogue.onda-

dias.eu/catalogue/) or others. Registering for a free account is usually necessary, but archived data 

retrieval will be faster than with Open Access Hub. 

 

aria2c 

 NOTE 1: If (and only if) the response is “-bash aria2c: command not found”. Then we have to install the 

tool, to do this in command line type: sudo apt-get install aria2 

When requested type: Y 

Then you can test your installation again.  

https://scihub.copernicus.eu/userguide/LongTermArchive
https://peps.cnes.fr/rocket/#/home
https://catalogue.onda-dias.eu/catalogue/
https://catalogue.onda-dias.eu/catalogue/


12 
 

 

The first line changes our directory to the target directory. The second line runs the download tool 

(Type the red text all in single line). All twelve products will be downloaded to the Original folder two 

products in parallel automatically.  

(Note that the constraint of maximum 2 parallel downloads at a time is imposed by the Copernicus 

Access Hub, if you increase the number, your download will fail). This might take some time. 

5.2 Data exploration 

Launch SNAP (icon on desktop ). When the SNAP window opens click Open product  and 

navigate to:   /shared/Training/HYDR02_FreshWaterQuality_Trasimeno/Original/  

Open the first S2 product (from 16 April 2018). We can first investigate the structure of the Sentinel-

2 Level 1C products. Click on the dot next to the product name to expand the structure. The L1C 

products contain (among others): 

• 13 TOA (top-of-atmosphere) reflectance bands 

• Quality flags 

Now, let’s visualize the product. We will visualize it in true (natural) colours and as a false color 

composite which is better for distinguishing water surfaces. Right-click the product and click Open 

RGB image window, a new window will open. From the drop-down menu select:  

Profile : Sentinel 2 MSI Natural Colors 

Click OK. 

When the image opens, repeat the same but choose the false 

colour Profile. 

Profile : Sentinel 2 MSI False-color Infrared 

Finally, go to Window → Tile Horizontally.  

 

cd /shared/Training/HYDR02_FreshWaterQuality_Trasimeno/Original  

 

aria2c --http-user='<username>' --http-passwd='<password>' --check-

certificate=false --max-concurrent-downloads=2 -M products.meta4 
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5.3 STEP 1 – Pre-processing 

Processing the data one by one would not be very time effective. However, we can use either the 

Batch Processing tool available in SNAP or the GPT tool (command line) to process all images 

automatically.  

To use either method, we first need to define the process we want to apply and all its steps. We can 

do this using the GraphBuilder tool. Another advantage of the GraphBuilder is that only the final 

product will be physically saved, and we save valuable disk space.   

So, let’s build our graph. First, in the Product Explorer select the first loaded product (so it is 

highlighted), then go to Tools → GraphBuilder.  

 

At the moment, the graph only has two operators: Read (to read the input) and Write (to write the 

output).  

The 13 bands in Sentinel-2 products do not all have the same resolution (therefore size) as 

mentioned in  NOTE 3. Many operators do not support products with bands of different sizes so 

first we need to resample the bands to equal resolution.   

To add the appropriate operator, right-click the white space between existing operators and go to 

Add → Raster → Geometric → Resample. 

 NOTE 2: The Sentinel-2 data are distributed as 100x100 km tiles resampled to a common grid in WGS84 

UTM projection at two levels of processing: 

• Level-1C – Top-Of-Atmosphere reflectances, systematically generated since the start of the mission. 

• Level-2A – Bottom-Of-Atmosphere reflectances (atmospherically and radiometrically corrected), 

systematically produced for products acquired over Europe since the spring of 2017, the coverage 

has increased through 2018 to reach global coverage in the beginning of 2019. Can be produced on 

user side by applying the Sen2Cor algorithm. 
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A new operator rectangle appears in our graph and new tab appears below. Now connect the new 

Resample operator with the Read operator by clicking to the right side of the Read operator and 

dragging the red arrow towards the Resample operator.  

 

Next step will be to subset the images to the area of interest, we do this by right-clicking the white 

space somewhere right of the resample operator and going to Add → Raster → Geometric → 

Subset. Connect the Subset operator with the Resample operator. 

 

Finally, connect the Subset operator to the Write operator.  

Now, let’s set the parameters. In Resample tab, we set:   

Under Define size of resampled product: Select the “By reference band from source product” and 

choose the B2 band (we will resample all the bands to 10m resolution).  

 

Credits: ESA 2015 

NOTE 3: The input product 

contains 13 spectral bands 

in three different spatial 

resolutions (The surface 

area measured on the 

ground and represented by 

an individual pixel).  When 

we open the RGB view all 

our input bands have 20 m 

resolution, however, the 

view is displayed in the full 

10 m resolution.  
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In the Subset tab, select Geographic Coordinates, in the text-window paste the subset polygon 

coordinates in Well-Known-Text format (WKT) from Expressions_WQ.txt file in:  

/shared/Training/HYDR02_FreshWaterQuality_Trasimeno/  

 

 

We can leave the Read and Write tabs unchanged. Now, save the graph as STEP1_Graph_Prep.xml 

to: /shared/Training/HYDR02_FreshWaterQuality_Trasimeno/Processing/ by clicking Save at the 

bottom of the window and then close the GraphBuilder window.  

In this tutorial, we will use the GPT and shell script to automatize the processing of our 12 products. 

To do this, we must first edit the saved graph file.  

To edit the file, we leave SNAP and in the file explorer, navigate to the …/Processing folder and right-

click on the saved graph file. Select Open with -> Open with “Mousepad”. When the file is open, go 

to View -> Line Numbers for easier navigation.  

Now, we need to replace the input and output file path with a pattern that will allow the shell script 

(See  NOTE 4) to recognize and replace it with appropriate value for each file automatically.  

 

In line 7 (in the node with id=’Read’) replace the path to input file with (between <file> and </file>): 

$Input (“$” signifies that what follows is a parameter).  

POLYGON ((12.009554862976 43.20463943481, 12.198662757873 43.20463943481, 

12.198662757873 43.0686149597, 12.009554862976 43.0686149597, 12.009554862976 

43.20463943481, 12.009554862976 43.20463943481)) 

 NOTE 4: A shell script is a computer program designed to be run by the Unix shell, a command-line 

interpreter. The various dialects of shell scripts are considered to be scripting languages. The one used 

in this exercise is called Bash script (https://en.wikipedia.org/wiki/Bash_(Unix_shell)). Typical operations 

performed by shell scripts include file manipulation, program execution, and printing text.  

If you wish to run this exercise on Windows, you can replicate the steps in any programming language 

you are familiar with, such as Python or R.  

https://en.wikipedia.org/wiki/Bash_(Unix_shell)
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In line 51 (in the node with id=’Write’) replace the path to output file with (between <file> and 

</file>):  $Output 

 

Now, go to the to the …/Processing/Code/ folder and open the STEP1_script_gpt.sh  

 

On line 1, we specify that the script should be run with Bash scripting language. (See  NOTE 4) 

 

On line 3, 4 and 5, we specify our desired output folder path, and the pattern beginning and ending 

of the output name respectively.  

 

Line 7 signifies the start of the loop. The script will loop over all files in the specified folder ending 

with “.zip”. In each iteration, the path to one input file is denoted by “i”.  

“do” on line 8 and “done” on line 13 enclose the steps that should be performed on each input 

product.  
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On line 9, we extract the name of the input product; on line 10, we extract the date of the acquisition 

from the name.  

 

On line 11, we create the final path and name of our output, combining our specified output folder 

path, the beginning of the output name, the acquisition date and specified name end including the 

format suffix.  

 

On line 12, we call GPT and specify the path to our saved and edited graph file. Then with -P{variable 

name} we specify the parameters to be replaced in the graph file (marked with $ in the graph file). 

We have set the variables when we edited the .xml graph file – Input, Output. On line 13, the loop is 

closed.  

 

If your input and output folders are different you need to edit the file accordingly and save it. 

To run the script, we navigate to the folder where it is saved 

(/shared/Training/HYDR02_FreshWaterQuality_Trasimeno/Processing/Code/) and right-click on 

the white space and go to Open Terminal Here. In the terminal type: 

 

where STEP1_script_gpt.sh is the name of the Bash script file. Click ENTER to run the script.  

 
… 

 

sh STEP1_script_gpt.sh 

First product processed  

All products completed  
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The processing time will depend on your VM setup. (approx. 3 mins with 30GB ram). You can check 

the /shared/Training/HYDR02_FreshWaterQuality_Trasimeno/Processing/Pre-processed for the 

output products. Close the terminal window. 

Now, let’s have a look at them. Go back to SNAP and go to File → Session → Open session.. Navigate 

to /shared/Training/HYDR02_FreshWaterQuality_Trasimeno/ and open Pre-processed.snap 

Once all products are loaded, right-click the first and go to Open RGB image window. Select the 

Sentinel 2 MSI Natural Colors profile and click OK. You can repeat this step for all products and the 

go to Window → Tile Evenly.  

 

Even by visual assessment we can determine that increase in biological production occurs 

throughout the summer and fall and decreases again towards colder months. However, to be able to 

quantify the concentration of phytoplankton and other substances we need to process the data 

further.  

5.4 STEP 2 – Atmospheric correction & bio-optical model 

As mentioned previously, atmospheric correction is crucial, in order to be able to separate different 

optically active constituents in water (chl-a, TSM, CDOM, phosphorus etc.). Number of different 

atmospheric correction algorithms exist for Case 2 waters. Here we will use the Case 2 Regional 

Coast Colour Processor. 

While available in SNAP graphical interface and in the command line interface (GPT), it is not 

available in the Graph builder tool. We cannot therefore create a graph in the GUI as we have done 

in the previous step, however we can use the GUI to create a parameter file which we can then use in 

combination with GPT and bash script (or python or another scripting language) to run it in batch. 

The C2RCC processor allows many different parameters to be set, to accommodate more accurate 

atmospheric correction and extraction of the optically active constituents.  

Let’s go to SNAP and set our parameters. Go to Optical → Thematic Water Processing → C2RCC 

Processors → S2-MSI. In the I/O Parameter tab, we do not need to change anything.  

In the Processing Parameters tab, we can set following: 



19 
 

Salinity: 0.0001 PDU 
Elevation: 257 m 

The atmospheric parameters – 

Temperature (Water), Ozone 

and Air Pressure at Sea Level – 

will be set in our bash script, 

because here we can not specify 

different value for each image.  

We will leave all other 

parameters as default, including 

the thresholds and factors used 

for TSM and Chl-a extraction.  

Finally, we can select which data 

we wish to include in the output. 

Here we select: 

• Output normalized water 

leaving reflectances  

• Output irradiance attenuation 

coefficients 

• Output uncertainties 

 

 

 

 

 

 

 

 

Then click File → Save Parameters and save them as c2rcc_param.xml (XML format as the SNAP 

graphs) to:  /shared/Training/HYDR02_FreshWaterQuality_Trasimeno/Processing 

Go to the file location (in file explorer) and open it. It will automatically open in the internet browser 

window.  

Now, we will use another Bash processing script to run the C2RCC algorithm on all our images and 

assign the respective water temperature, ozone and pressure values.  

These parameters will naturally change over time. The values we will use, were manually acquired 

from ECMWF ERA-Interim global atmospheric reanalysis dataset 

(https://www.ecmwf.int/en/forecasts/datasets/reanalysis-datasets/era-interim) for each image 

acquisition date. A CSV (Met_Aux.csv) file containing the values is saved in the AuxData folder. Below 

you can see the screenshot of the data, you do not need to open them.  

https://www.ecmwf.int/en/forecasts/datasets/reanalysis-datasets/era-interim
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Now we can go to the Bash script we will use to run the processor on all the images automatically. It 

is similar to the one used previously for pre-processing. It is named STEP2_script_C2RCC.sh and you 

can find it in: /shared/Training/HYDR02_FreshWaterQuality_Trasimeno/Processing/Codes/ 

 

On lines 3 to 7 we specify input parameters, such as the path to out output directory, path to the 

meteorological ancillary data (table above), the path to the C2RCC parameter file saved from SNAP 

GUI and the input file end and output file end, respectively. 

 

Line 9 signifies the start of the loop. The script will iterate over all files in the specified folder ending 

with “.dim”. In each iteration the path to one input file is denoted by “i”. “do” on line 10 and “done” 

on line 17 enclose the steps that should be performed on each input product.  

 

On line 11, we extract the input file name, on line 12 we extract the image acquisition date. On 13 to 

15 we extract from the Met_aux.csv file the ozone, air pressure at sea level and water temperature 

for the appropriate date.   
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Finally, on line 16 we call GPT (SNAP command line utility) and the c2rcc.msi tool. Then, we load the 

parameter file we have created in the SNAP GUI. However, in this file the ozone pressure and 

temperature parameters were not set in the parameter file, instead we overwrite the values in the 

parameter file with the values extracted from the Met_aux.csv file. “done” at line 17 closes the loop. 

 

To run the script, we navigate to the folder where it is saved 

(/shared/Training/HYDR02_FreshWaterQuality_Trasimeno/Processing/Code/) and right-click on 

the white space and go to Open Terminal Here. In the terminal type: 

 

where STEP2_script_C2RCC.sh is the name of the Bash script file. Click ENTER to run the script.  

 

Finally, we can go back to SNAP and go to File → Session → Open Session, then click Yes in the 

dialog that opens. Then open:  

/shared/Training/HYDR02_FreshWaterQuality_Trasimeno/C2RCC_processed.snap 

Now, let’s investigate the results. In Product Explorer open the structure of one product and go to 

Bands. Here we choose the product #8 from 22 August 2018 and opened the conc → chl_conc & 

tsm_conc and the iop → iop_agelp (gelbstoff == CDOM attenuation coefficient). 

For each opened view you can go to the Colour Manipulation tab and click on Import colour palette 

from text file . In /shared/Training/HYDR02_FreshWaterQuality_Trasimeno/AuxData you can 

find the appropriate colour map for Chlorophyll, TSM and aCDOM. To keep the pre-set values, click 

No in the Import Colour Palette dialog. To visualize the images next to one another you can go to 

Window → Tile Horizontally.  

sh STEP2_script_C2RCC.sh 
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Apart from the chlorophyll-a, TSM and aCDOM extracted using bio-optical model, in the rhown folder 

we can also find the atmospherically corrected normalized water leaving radiances, which we can use 

for our empirical models.  

5.5 STEP 3 – Empirical algorithms  

Empirical approaches require in-situ measurements of the variable of interest which serve as a basis 

for establishing an empirical relationship - linear or non-linear regression - with the water leaving 

radiance measured in one or multiple sensor bands.  

While there are many different band ratios and equations reported in literature (see Ansper and 

Alikas (2019) and Dörnhöfer and Oppelt (2016) for exhaustive summary), we will use the following 

two: 

• Two-Band NIR–Red Ratio Model - It uses red band located in the range of maximum chl-a 

absorption between 660 and 690 nm and Near-infrared band between 700 and 720 nm.  

𝐶ℎ𝑙 𝑎 ~ 
𝑅(𝜆705)

𝑅(𝜆665)
 → 

𝐵5

𝐵4
 

• Maximum Chlorophyll Index (MCI) – It is so-called line-height algorithm, developed for 

detecting surface blooms and near-surface vegetation in inland, coastal and ocean waters, it 

has been used with chl-a over 10 mg/m3. 
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𝑀𝐶𝐼 =  𝑅705 −  𝑅665− 0.53 ∗ (𝑅740 −  𝑅665) → 𝐵5 − 𝐵4 − 0.53 ∗ (𝐵6 − 𝐵4) 

Where index 0.53 represents the ratio of wavelengths of the used bands. Instead of band 6, 

band 7 is sometimes used.  

To calculate the band-ratios we will create another short graph. Go to Tools → Graph Builder and 

add two Band Maths operators (Add → Raster → BandMaths). Then add another Write operator 

(Add → Input/Output → Write). Then connect the operators as shown below.  

 

Now, in the BandMaths operator tab below, set the appropriate band math expressions as follows.  

 

 
In BandMath (2) operator tab, set: 

Target Band: MCI 

No-Data value: NaN 

Expression:   

Then go to the Write tabs, in both write tabs change the format – Save as: GeoTIFF.  

if Valid_PE then (rhown_B5 – rhown_B4 - 0.53*(rhown_B6 – rhown_B4)) else NaN 



24 
 

  

Then save the graph as STEP3_Graph_BMath.xml, to the …/Processing folder. Now we will edit the 

graph as we have done for the pre-processing step. The only difference this time is that we have two 

outputs, instead of one.  

In File Explorer, navigate to the …/Processing folder, right-click on STEP3_Graph_BMath.xml and 

click ok Open in Mousepad.  

In line 7 (in the node with id=’Read’) replace the path to input file with (between <file> and </file>): 

$Input (“$” signifies that what follows is a parameter).  

 

Now we need to find the Write node (in the node with id=”Write”) – It will likely not be on the same 

line as shown below as the position might be random. Here, replace the path to output file with 

(between <file> and </file>):  $Output1  
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Then find the Write(2) node (in the node with id=”Write(2)”) – It will likely not be on the same line as 

shown below as the position might be random. Here, replace the path to output file with (between 

<file> and </file>):  $Output2 then save the changes and close the Mousepad.  

Now, go to the to the …/Processing/Code/ folder and open the STEP3_script_gpt.sh  

 

To run the script, we navigate to the folder where it is saved 

(/shared/Training/HYDR02_FreshWaterQuality_Trasimeno/Processing/Code/) and right-click on 

the white space and go to Open Terminal Here. In the terminal type: 

 
where STEP3_script_BMath.sh is the name of the Bash script file. Click ENTER to run the script.  

 

When the script finishes, we have now two additional folders in our …/Processing folder. Go back to 
SNAP then go to File → Session → Open session. Click Yes and open: 
 /shared/Training/HYDR02_FreshWaterQuality_Trasimeno/Processed.snap 

Open the conc_chl band in the C2RCC product as well as the MCI and R705_665 bands. We can apply 

the same colour pallet (in the case of C2RCC select No, for other two bands select Yes to stretch the 

colour pallet between mon and max). Keep in mind that the MCI and R705_R665 are not yet 

concentration measurements but only indicators.  

sh STEP3_script_BMath.sh 
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Now in a final step we can use the in-situ data to define the empirical relationship between the 

indicators and the true values. The in-situ data below have been acquired from Agenzia Regionale 

per la Protezione Ambientale dell’Umbria (Arpa Umbria – Regional Environment Protection Agency of 

Umbria region in Italy).  

In the .../AuxData folder you can find polygons (approx. 50x50 m) surrounding the sampling point. 

These can be used for example in QGIS to extract the mean value from the images closest to the in-

situ data sampling date as shown below (e.g. Zonal statistics tool).   

Data 
Chl-a 

(mg/m3) 
Station 

code 
Image difference in 

days 
MCI R705/R665 

16-May-18 2.9 TRS30 -5 0.00196 0.67388 

16-May-18 9.4 TRS35 -5 0.00247 0.68835 

09-Jul-18 6.5 TRS30 1 0.00199 0.67142 

09-Jul-18 3.6 TRS35 1 0.00342 0.70807 

04-Sep-18 39.4 TRS30 2 0.00425 0.80622 

04-Sep-18 24.3 TRS35 2 0.00349 0.77898 

21-Nov-18 22.7 TRS30 -6 0.00551 0.81416 

Then by simple regression, we calculate the empirical relationship between the indicator value and 

the in-situ measurement.  

NOTE: the R2 value is the coefficient of determination – how well can our indicator predict actual 

concentration – here we have very low R2 for both indicators, which means that our Empirical models 

will not perform very well. This is due to the fact that we have used very few in-situ data samples and 

moreover they were not taken on the same day as our images. Chlorophyll value changes 

dynamically in time and longer period between in-situ measurement and image date will result in 

decorrelation.  

However, in order to demonstrate the method, we can now use our empirical models to retrieve the 

chlorophyll concentrations and compare them with the one derived by C2RCC algorithm. 
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You can do this easily by editing the graph used to calculate the MCI and R705_R665. We can change 

the expressions and the band names in the appropriate nodes: 

 

 

Then in the Bash script we can rename the output folders and output file names.  
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We can save the edited graph and the edited Bash script file under a different name (keep in mind 

that you need to change the path to the graph in the bash script file as well). And run the processing 

as previously.  

When the script finishes, you should now have two additional folders in our …/Processing folder with 

suffix “_Chl”. In these folders we can find our Chlorophyll-a concentration calculated using empirical 

model based on Maximum Chlorophyll Index (…/MCI_Chl) and NIR-RED Ratio (…/R705_R655_Chl).  

We can now compare our results with the chlorophyll concentration derived using the bio-optical 

model employed in C2RCC.  

 

First let’s have a look at Chlorophyll-a concentration derived from MCI using empirical model 

calibrated with our in-situ data.  
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We have used the same colour pallet as for the C2RCC derived concentrations (page 22) and 

visualized all images side by side (Window → Tile Evenly). We can see that compared to the C2RCC; 

our empirical MCI model does not capture the low values at all. While in higher values the 

distribution seems quite similar, it tends to be biased towards higher values. Now, let’s have look at 

the Two-Band NIR-Red Ratio model. It seems to capture lower values better than the MCI based 

model but compared to C2RCC it seems also biased towards higher values.  

 

The main limitation of our models is that we do not have sufficient number of in-situ measurements 

to properly calibrate the models. Moreover, our in-situ data have been acquired as much as 6 days 

apart from our images. Since chlorophyll concentration changes dynamically over time, this 

difference introduces significant uncertainty to our model, making in even more unreliable.  

In this exercise we have aimed at demonstrating the method of deriving chlorophyll concentration 

from remotely sensed data using bio-optical algorithm implemented in C2RCC and two empirical 

models. However, for reliable results, larger number of in-situ data for training and validation are 

necessary! 

THANK YOU FOR FOLLOWING THE EXERCISE! 
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6 Extra steps 

6.1 Downloading the outputs from VM 

On your keyboard, press Ctrl+Alt+Shift. A pop-up window will appear on the left side of the screen. 

Click on the bar below Devices, the folder structure of your VM will appear. Navigate to your 

Processing folder and double click any file you want to download.  
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