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1 Introduction 

The Research and User Support for Sentinel core products (RUS) service provides a free and open 

scalable platform in a powerful computing environment, hosting a suite of open source toolboxes 

pre-installed on virtual machines, to handle and process data derived from the Copernicus Sentinel 

satellites constellation. 

Water surfaces, whether they are lakes, rivers, 

dams or ponds are crucial part of our 

landscapes. Timely monitoring of surface water 

and delivering data on the dynamics of surface 

waters are essential for policy and decision-

making processes.  

Number of different methods has been 

developed for the extraction/delineation of 

waterbodies in remotely sensed data. 

Generally, we can split the basic methods to 

three categories: single band thresholding, 

band ratio indexes, more sophisticated 

methods (machine learning, etc.).  

In this webinar, we will have look at the two first approaches. First, we will use Sentinel-2 optical 

data to calculate the Normalized Difference Water Index (NDWI). Then we will use the thresholding 

method with averaged stack of Sentinel-1 SAR data and see the advantages and disadvantages of 

each method.   

2 Training 

Approximate duration of this training session is two hours.  

2.1 Data used 

• One cloud-free Sentinel-2A Level 2A tile (Tile ID: T34UEE) acquired on August 16, 2017 

[downloadable @ https://scihub.copernicus.eu/] 

S2A_MSIL2A_20170816T095031_N0205_R079_T34UEE_20170816T095031.zip 

• Five Sentinel-1A IW GRDH products acquired in July and August 2017 [downloadable @ 

https://scihub.copernicus.eu/] 

S1A_IW_GRDH_1SDV_20170711T161931_20170711T161956_017426_01D1DE_4164.zip 

S1A_IW_GRDH_1SDV_20170723T161931_20170723T161956_017601_01D729_290F.zip 

S1A_IW_GRDH_1SDV_20170804T161932_20170804T161957_017776_01DC8A_4628.zip 

S1A_IW_GRDH_1SDV_20170816T161933_20170816T161958_017951_01E1D7_0173.zip 

S1A_IW_GRDH_1SDV_20170828T161933_20170828T161958_018126_01E722_FB07.zip 

 

2.2 Software in RUS environment 

Internet browser, SNAP + Sentinel-2 Toolbox, QGIS, (Extra steps: Sen2Cor, Google Earth) 

Flims, Switzerland Credits: Photo by Stephen Leonardi on Unsplash. 

https://scihub.copernicus.eu/
https://scihub.copernicus.eu/
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3 Register to RUS Copernicus 

To repeat the exercise using a RUS Copernicus Virtual Machine (VM), you will first have to register as 

a RUS user. For that, go to the RUS Copernicus website (www.rus-copernicus.eu) and click on 

Login/Register in the upper right corner.  

 

Select the option Create my Copernicus SSO account and then fill in ALL the fields on the Copernicus 

Users’ Single Sign On Registration. Click Register. 

 

Within a few minutes you will receive an e-mail with activation link. Follow the instructions in the e-

mail to activate your account.  

You can now return to https://rus-copernicus.eu/, click on Login/Register, choose Login and enter 

your chosen credentials. 

http://www.rus-copernicus.eu/
https://rus-copernicus.eu/
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Upon your first login you will need to enter some details. You must fill all the fields.   

 

4 Request a RUS Copernicus Virtual Machine 
Once you are registered as a RUS user, you can request a RUS Virtual Machine to repeat this exercise 

or work on your own projects using Copernicus data. For that, log in and click on Your RUS Service → 

Your Dashboard.  
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Click on Request a new User Service to request your RUS Virtual Machine. Complete the form so that 

the appropriate cloud environment can be assigned according to your needs. 
  

 
 

If you want to repeat this tutorial (or any previous one) select the one(s) of your interest in the 

appropriate field. 

 

 
 

Complete the remaining steps, check the terms and conditions of the RUS Service and submit your 

request once you are finished. 
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Further to the acceptance of your request by the RUS Helpdesk, you will receive a notification email 

with all the details about your Virtual Machine. To access it, go to Your RUS Service → Your 

Dashboard and click on Access my Virtual Machine.  
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Fill in the login credentials that have been provided to you by the RUS Helpdesk via email to access 

your RUS Copernicus Virtual Machine.  

 

This is the remote desktop of your Virtual Machine. 

 

5 Step by step  

5.1 Data download – ESA SciHUB 

In this step we will download a Sentinel-2 scene from the Copernicus Open Access Hub using the 

online interface (Applications → Network → Web Browser or click the link below). 

Go to https://scihub.copernicus.eu/   

https://scihub.copernicus.eu/
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Go to “Open HUB”, if you do not have an account please register by going to “Sign-up” in the LOGIN 

menu in the upper right corner. 

 

After you have filled in the registration form, you will receive an activation link by e-mail. Once your 

account is activated or if you already have an account, “LOGIN”.  
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Switch the rectangle-drawing mode to pan mode by clicking on the “Pan” icon in the lower left 

corner of the map (Green arrow) and navigate over Portugal (approximate area – blue rectangle). 

 

Switch to drawing mode and draw a search rectangle approximately as indicated below. Open the 

search menu (red arrow) and specify the following parameters: 

Sensing period:  From 2017/07/01 to 2017/08/31 

Check Mission:   Sentinel-1  

Satellite Platform: S1A* 

Product Type:   GRD 

Sensor Mode:   IW  

Relative Orbit:   29 

 

Press “Search” (red arrow below). 
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In our case, the search returns five results depending on the exact search area defined. Using the 

icon, import all six products to Cart.  

Then open the search menu again and reset the parameters as defined below, do not forget to 

deselect Mission: Sentinel-1 as this time we will search for Sentinel-2 data (See  TIP 1): 

Sensing period:  From 2017/08/16 to 2017/08/16 

Check Mission:   Sentinel-2  

Product Type:   S2MSI2Ap 

 

 

 TIP 1: For the Level 2A products we are downloading, the atmospheric correction has already been 

applied (pre-processing of Level-1C product to a Level-2A is described in section 4.1). Since April 2017, 

the Level-2A products available to download for acquisitions over Europe (such as this case). Global 

coverage of Level 2A products is available as of December 2018. 
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In our case, the search returns four results depending on the exact search area defined. Using the 

icon, import only the following product to Cart:  

S2A_MSIL2A_20170921T101021_N0205_R022_T32TQQ_20170921T101436 

Then click on the Profile icon in the upper left corner (marked with green circle above) and go to 

Cart. You should now have six products in your cart. Click Download Cart.  

 

A products.meta4 file will be downloaded to your /home/rus folder. To download our data, we will 

use aria2 tool. To use the tool, we first need to place the products.meta4 file to the folder where we 

wish our data to be downloaded to: /shared/Training/HYDR01_WaterBodies_TrainingKit/Original 

First let’s test our aria2 installation. To do this we open the Command Line  (in the bottom of your 

desktop window) and type: 

 

The correct response should be as follows: 

 
 If the response is “-bash aria2c: command not found” (see  NOTE 1). 

 
If you have received the correct response, then we can run the tool by typing following commands in 

the command line (replace <username> and <password> with your login credentials for Copernicus 

Open Access Hub):  

aria2c 

 NOTE 1: If (and only if) the response is “-bash aria2c: command not found”. Then we have to install the 

tool, to do this in command line type: sudo apt-get install aria2 

When requested type: Y 

Then you can test your installation again.  



 

13 
 

 

The first line changes our directory to the target directory. The second line runs the download tool 

(Type the red text all in single line). All six products will be downloaded to the Original folder two 

products in parallel automatically  

(Note that the constraint of maximum 2 parallel downloads at a time is imposed by the Copernicus 

Access Hub, if you increase the number, your download will fail). This might take some time. 

5.2 Optical data – Sentinel-2 

5.2.1 SNAP – open and explore data 

Launch SNAP (icon on desktop ). When the SNAP window opens click Open product  and 

navigate to:   /shared/Training/HYDR01_WaterBodies_TrainingKit/Original  

Open the S2 product. Now, we will look at the product. We could visualize it in true (natural) colours 

but for distinguishing water surfaces, it is better to use the false colour. Right-click the product and 

click Open RGB image window, a new window will open. From the drop-down menu select:  

Profile: Sentinel 2 MSI False-colour-Infrared 

Click OK. 

 

Now, let’s investigate the cloud cover and water mask bands that are the result of atmospheric 

correction applied to the level 2 products.  

Expand the product in the Product Explorer window and go to Masks → scl. Open masks 

scl_cloud_high_proba (Cloud high probability), scl_water (Water) and scl_thin_cirrus (Thin cirrus). 

Pixels with detected clouds/cirus/water will appear white in the respective masks.  

Now you should have four bands open in your View window. Go to Window → Tile Evenly and then 

go to the Navigation tab, click Zoom All .  

cd /shared/Training/HYDR01_WaterBodies_TrainingKit/Original  

 

aria2c --http-user='<username>' --http-passwd='<password>' --check-

certificate=false --max-concurrent-downloads=2 -M products.meta4 
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We can see that as expected our image is cloudless. The default water mask distributed with the 

Level-2 product, however, does not look very accurate.  

5.2.2 Resample 

The 13 bands in Sentinel-2 products do not all have same resolution (therefore size, see  NOTE 2). 

Many operators in SNAP toolbox do not support products with bands of different sizes so first we 

need to resample the bands to equal resolution.  

Go to Raster → Geometric Operations → Resampling (See  NOTE 3).  

Do not change anything in the I/O Parameters tab. 

In the Resampling Parameters tab under “Define size of resampled product”, choose: By reference 

band from source product: B2  

 
Click Run. 

After the process is completed, if a window appears, click Yes. 
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A new product [2] appeared in the Product Explorer tab. Now we will have a look at the product. 

Close all the views we have open and expand the product structure by clicking the + sign on the left 

of the product name, then expand the Band folder and double click B8 (842nm) - (NIR).  

5.2.3 Subset  

In the next step, we will subset the image to our area of interest. Click on the resampled product in 

the Product Explorer tab, to highlight it. Then go to Raster → Subset and in the Spatial Subset tab, 

set Pixel coordinates to:    

Scene start X:  200        

Scene start Y:  0   

Scene end X:  7300       

Scene end Y:  6850 

 

 

 

 

 

 

Keep the other Subset tabs as by default. Click OK. 

A new product will appear in the Product Explorer tab [3]. Right-click the new product and click Save 

Product. In the pop-up window click Yes, in the next window navigate to 

/shared/Training/HYDR01_WaterBodies_TrainingKit/S2_Processing and save the subset data. 

Right-click the product [3] and click Open RGB image window and from the dropdown menu select: 

Profile: Sentinel 2 MSI Land/Water 

Click OK. 

Credits: ESA 2015 

NOTE 2: The input product 

contains 13 spectral bands 

in three different spatial 

resolutions (The surface 

area measured on the 

ground and represented by 

an individual pixel).  When 

we open the RGB view all 

our input bands have 20 m 

resolution, however, the 

view is displayed in the full 

10 m resolution.  

 NOTE 3: The resampling product appears in the Product Explorer window but it is not physically saved. 

Therefore, it will be lost if you close it or if you close the source product. 
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5.2.4 NDWI 

To detect the water bodies, we will use the Normalized Difference Water Index – NDWI. It was 

proposed by McFeeters2 and it is designed to:  

i) maximize the reflectance of the water body in the green band;  

ii) minimize the reflectance of water body in the NIR band. McFeeters’s NDWI is calculated 

as:   

𝑁𝐷𝑊𝐼 =  
𝐺𝑟𝑒𝑒𝑛 − 𝑁𝐼𝑅

𝐺𝑟𝑒𝑒𝑛 + 𝑁𝐼𝑅
=  

𝐵3 − 𝐵8

𝐵3 + 𝐵8
 

 

 

Right-click on the newly created subset product [3], select BandMaths and set: 

Name: NDWI 

Deselect “Virtual (save expression only, don’t store data)” - we want the band to be stored!  

Click on “Edit Expression” and set as Expression: 

Click OK in both windows. 

(B3 – B8)/(B3 + B8) 
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The open water pixels appear much brighter than other surfaces. Now, let’s create another new band 

that will only contain water surfaces.  

We will set the threshold for pixel to be classified as water to >= 0.  

Right click the product [3] and go to BandMaths again. Set: 

Name: NDWI_mask 

Deselect “Virtual (save expression only, don’t store data)” - we want the band to be stored! 

Click on “Edit Expression” and set as Expression:   if NDWI >= 0 then 1 else 0 

Click OK in both windows. 

You can also go to Window → Tile Horizontally to see the difference between the NDWI and the 

NDWI_mask bands. 
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Finally, right click on product [3] and go to Save Product. If a window appears click Yes and navigate 

to: /shared/Training/HYDR01_WaterBodies_TrainingKit/S2_Processing to save it. If another 

window appears, click Yes as well. 

Then go to File → Export → GeoTIFF.  

Click on Subset and go to Band Subset tab; select only NDWI_mask band and click OK. Save as File 

name: S2_watermasks.tiff.  

Finally click Export Product. 

 TIP 2: The NDWI can sometimes erroneously enhance also very bright build-up areas, and numerous 

modifications have been proposed. We will test a modified version designed to minimize the build-up 

noise. It uses the short wave infrared (SWIR) band instead the near infrared (NIR) as the absorption of 

water surfaces is greater in SWIR than in NIR. MNDWI is calculated as:   

𝑁𝐷𝑊𝐼 =  
𝐺𝑟𝑒𝑒𝑛 − 𝑆𝑊𝐼𝑅

𝐺𝑟𝑒𝑒𝑛 + 𝑆𝑊𝐼𝑅
=  

𝐵3 − 𝐵11

𝐵3 + 𝐵11
 

 

Right click on the newly created subset product [3], select BandMaths and set: 

Name: NDWI 

Deselect Virtual “(save expression only, don’t store data)” – we want the band to be stored! 

Click on “Edit Expression” and set as Expression: (B3 – B11)/ (B3 + B11) 

Create mask the same way as for NDWI. Compare both masks. What are the differences? Are there 

differences in detail? Can you explain why? 
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Our first water mask is ready. Take some time to compare it to the RGB image. Now, let’s derive the 

water mask from SAR data so we can compare.  

Close the SNAP window. Any dialog windows that might appear asking you to save the data, click Yes. 

5.3 SAR data – Sentinel-1 

5.3.1 SNAP – open and explore data 

Launch SNAP (icon on desktop ). When the SNAP window opens click Open Product , navigate 

to /shared/Training/HYDR01_WaterBodies_TrainingKit/Original and open the five S1 products. 

Right-click each product and expand the Bands folder. Then double click the Intensity_VH band.  

 

5.3.2 Build step-by step processing chain 

We will now need to pre-process all five images but doing this one by one would be quite time 

consuming so let’s use the Batch Processing tool available in SNAP to process all images at the same 

time.  
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To use the tool, we first need to define the process we want to apply and all its steps. We can do this 

using the GraphBuilder tool. The nice thing about the GraphBuilder is also that no intermediate 

product will be physically saved, only the end-product, which saves valuable disk space.   

Go to Tools → GraphBuilder.  

At the moment, the graph only has two operators: Read (to read the input) and Write (to write the 

output).  

 
Since our Area of Interest (AOI) is quite small and there is no need to process the whole image, we 

start by adding a Subset operator. To add the operator right-click the white space in the graph 

builder and go to Add → Raster → Geometric → Subset. 

A new operator rectangle appears in our graph and a new tab appears below. Now connect the new 

Subset operator to the Read operator by clicking to the right side of the Read operator and dragging 

the red arrow towards the Subset. 

 
In the next step, we will update the orbit metadata (See  NOTE 4). To add the operator, right-click 

the white space between existing operators and go to Add → Radar → Apply-Orbit-File. Connect the 

new Apply-Orbit-File operator with the Subset operator. 

 

 

The next step will remove the thermal noise (See  NOTE 5). We add this operator by right-clicking 

the white space somewhere left of the resample operator and going to Add → Radar → Radiometric 

→ ThermalNoiseRemoval. Connect the ThermalNoiseRemoval operator with the Apply-Orbit-File 

operator.  

 NOTE 4: The orbit state vectors provided in the metadata of a SAR product are generally not accurate 

and can be refined with the precise orbit files, which are available days-to-weeks after the generation 

of the product. The orbit file provides accurate satellite position and velocity information. Based on this 

information, the orbit state vectors in the abstract metadata of the product are updated. (SNAP Help) 



 

21 
 

 

Now, we can add the Calibration operator. The objective of SAR calibration is to provide imagery in 

which the pixel values can be directly related to the radar backscatter. Though uncalibrated SAR 

imagery is sufficient for qualitative use, calibrated SAR images are essential to quantitative use of 

SAR data (See  NOTE 6).  

To add the operator go to Add → Radar → Radiometric → Calibration. Connect the 

ThermalNoiseRemoval operator to the Calibration operator. 

 

 

Our data are still in radar geometry, moreover due to topographical variations of a scene and the tilt 

of the satellite sensor, the distances can be distorted in the SAR images. Therefore, as the last step of 

our preprocessing, we will apply terrain correction to compensate for the distortions and reproject 

the scene to geographic projection (See  NOTE 7).  

To add the operator, go to Radar → Geometric → Terrain Correction → Terrain-Correction then 

connect the Calibration operator to it. 

 

 

At the moment, do not change anything in the parameter tabs and save the graph by clicking Save at 

the bottom of the window.  

 

Navigate to:  

/shared/Training/HYDR01_WaterBodies_TrainingKit/S1_Processing and save the graph with the 

File Name: Graph_preprocess.xml.   

Close the GraphBuilder window. 

 NOTE 5: Thermal noise in SAR imagery is the background energy that is generated by the receiver itself.   

(SNAP Help) It skews the radar reflectivity to towards higher values and hampers the precision of radar 

reflectivity estimates. Level-1 products provide a noise LUT for each measurement dataset, provided in 

linear power, which can be used to remove the noise from the product. 

 NOTE 6: Typical SAR data processing, which produces level-1 images, does not include radiometric 

corrections and significant radiometric bias remains. The radiometric correction is necessary for the 

pixel values to truly represent the radar backscatter of the reflecting surface and therefore for 

comparison of SAR images acquired with different sensors or acquired from the same sensor but at 

different times, in different modes, or processed by different processors. (SNAP Help) 

NOTE 7: The geometry of topographical distortions in SAR 

imagery is shown on the right.  Here we can see that point B 

with elevation h above the ellipsoid is imaged at position B’ 

in SAR image, though its real position is B".  The offset Δr 

between B' and B" exhibits the effect of topographic 

distortions. (SNAP Help) 
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5.3.3 Batch processing 

In the Product Explorer window, we select (highlight) the product [1] (11 July 2017). Now we can 

open the Batch Processing tool (Tools → Batch Processing). 

We will add the opened products by clicking Add Opened on the upper right (second icon from the 

top) and click Refresh. Then, we click Load Graph at the bottom of the window, navigate to our 

saved graph, and open it. We see that new tabs have appeared at the top of window corresponding 

to our operators with the exception of Write; this is correct, as these parameters will be set in the 

I/O Parameters tab.  

In the I/O Parameters tab set the directory to: /shared/Training/HYDR01_WaterBodies_TrainingKit 

/S1_Processing and then deselect the “Keep source product name”.   

 

In the Subset tab press Ctrl and select bands Amplitude_VH and Intensity_VH and then click to select 

the Geographic Coordinates option. Paste the area of interest definition in WKT (well know text) 

format to the text window below the map.  

 

Click Update and then click the Zoom-in icon  to see your subset on the map.  

POLYGON ((21.03027778 54.14805556, 22.11722222 54.14833333, 22.10111111 

53.52722222, 21.03000000 53.53250000, 21.03027778 54.14805556))  
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In the Apply-Orbit-File tab we can accept the default settings.  

 

In the ThermalNoiseRemoval tab select VH polarization and make sure that “Remove Thermal 

Noise” option is selected. 

 

In the Calibration tab we will also accept all default settings.   

 

In the Terrain-Correction tab: Map Projection -> Predefined CRS. Click on “Select” and choose: 

AUTO: 42001 – WGS 84 / Auto UTM. Leave all the other default settings.  
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Click OK in both windows and finally click Run to pre-process our images.  

 
Approximate processing time: 10 minutes depending on machine 

Close the Batch Processing window. Now you should have five new products in the Product Explorer 

tab. Select the original products [1-5], right-click on them and click Close 5 Products. 

5.3.4 Coregister and average 

Now, we need to add all our pre-processed products to a single coregistered stack, so we can 

calculate the 2-month mean. Unfortunately, coregistration is rather heavy and time consuming, so be 

patient. Averaging the observations will greatly decrease the speckle and make the delineation of 

water bodies much more accurate.  

Go to Radar → Coregistration → Coregistration.  

In the ProductSet-Reader tab, we will add the opened products by clicking Add Opened on the upper 

right (second icon from the top) and then click Refresh.  
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In the CreateStack tab, set Resampling Type: “Nearest Neighbour” and click Find Optimal Master.    

 
In the Cross-Correlation tab, leave the defaults.  

 

In the Warp tab, leave the defaults.  

 

In the Write tab, change the name to S1A_IW_summerStack make sure that the output directory is: 

/shared/Training/HYDR01_WaterBodies_TrainingKit/S1_Processing  
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Click Run.  Approximate processing time: 20 minutes depending on machine 

Close the Coregistration window. A new product [11] has appeared in the Product Explorer window. 

Expand it and have a look at the contents of the Bands folder. It contains five bands, each 

corresponding to one acquisition date.  Double click the first band to open it in View window.  

 

We can see the extent of the image is larger than that of our S2 subset (marked in red above) 

although we have used the exact coordinates. This is because we have performed the subset before 

we have projected (assigned coordinate system) the product. We can correct this by using a simple 

subset again. Go to Raster → Subset.  

In the Spatial Subset tab click on the Geo Coordinates and set: 

North latitude bound: 54.148 

West longitude bound:  21.030 

South latitude bound:  53.527 

East longitude bound:  22.101 

Click OK.  

 

 

 

 

 

 

New product [12] has appeared in 

the Product Explorer tab.  

Right-click the product and go to Open RGB Image Window.  
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Set:  Red:      $12.Sigma0_VH_mst_11Jul2017 

         Green:  $12.Sigma0_VH_slv2_04Aug2017 

         Blue:     $12.Sigma0_VH_slv4_28Aug2017 

Click OK. 

 

 

 

 

This we do just out of interest, by creating the multi-temporal RGB combination we can see the 

changes that have occurred between the acquisitions. These will mostly be related to harvested 

fields. We will not see many changes in the water bodies unless for example, the water level changed 

significantly, or an area was flooded. Now, let’s calculate the average backscatter.  

Go to Radar → Coregistration → Stack Tools → Stack Averaging.  In the I/O Parameters tab make 

sure that the directory is: /shared/Training/HYDR01_WaterBodies_TrainingKit/S1_Processing.  

In the Processing Parameters tab, set Statistics: Mean Average.  

Click Run.   
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A new product [13] was created; the Bands folder contains a single band with averaged values.  

 

If we open all the bands of the stacked product and the averaged band and use the Window → Tile 

Evenly tool, then we can see that the averaged image appears much smoother.  

5.3.5 Binarization 

To separate water from non-water on an image we need to have enough separability between the 

two classes. Let’s close all views except for the averaged band.  

Then go to the Product Explorer window and right-click on the averaged band “Sigma0_VH”.  

Go to Linear from/to dB and click yes to add the dB band as new virtual band. This operation 

transforms the histogram to logarithmic scale and helps us to better distinguish between water and 

other surfaces.   
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Let’s inspect the histogram to find a good threshold value. In addition, we can also draw some 

polygons over water surfaces and extract statistics… 

 

Then we can go to Analysis → Statistics.  

Tick the “Use ROI mask” option, select geometry and then click Refresh.  

 

In our case, just by visual analysis we will select value -25 as our threshold.  Go to Product Explorer 

tab and right-click the Sigma0_VH_dB band.  

Select Band Maths… and set as Name: “water_mask”. Deselect the Virtual option. Then click on Edit 

Expression … and type:  

 
if $13.Sigma0_VH_db < -25.0 then 1 else 0 
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Click OK in both windows.  

 

Finally, right click on product [13] and go to Save Product.  

Then go to File → Export → GeoTIFF. Click on Subset and go to Band Subset tab; select only 

“water_mask” band and save as S1_watermask.tiff at:  

/shared/Training/HYDR01_WaterBodies_TrainingKit/S1_Processing and click on Export Product. 
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5.4 Visualization (QGIS) and comparison 

Let’s compare the 2 masks we have produced. To be able to do so, we will open the saved masks 

(GeoTIFF) in QGIS.  

Go to Application → Processing → QGIS Desktop. Click on the Add Raster Layer button located in 

the left panel ( ), navigate to: /shared/Training/HYDR01_WaterBodies_TrainingKit/S2_Processing 

select the saved S2_watermask.tiff and click Open.  

Load also the S1_watermask.tiff from the S1_Processing folder.  

Right click the S1_watermask in the Layers Panel and go to Properties. In the Transparency tab set:  

Global transparency: 50 % 

Additional no data value: 0 

 

Then, go to Style tab and set Render type to Singleband pseudocolor, scroll down and click  to add 

a value to the colour table. Click the value 0 and change it to 1. Then double-click the Colour field and 

change the colour to blue. Click OK.  

Now do the same for the S2_watermask but change the colour to red and leave the transparency at 

0%.  
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Finally, we can add a base-map to link our water masks to GIS data. Click on Web → OpenLayers 

plugin → Google Maps → Google Satellite (See  NOTE 8). Then in the Layer Panel click on the 

Google Satellite layer and drag it below our raster layers.  

In case Google Satellite is not available for any reason, use a different layer, e.g. Bing → Bing Aerial. 

 

 

 

THANK YOU FOR FOLLOWING THE EXERCISE! 

 

  

 NOTE 8: In case the OpenLayers plugin is not installed, click on Plugins → Manage and Install Plugins. 

Select the “All” tab on the left side panel and write “OpenLayers plugin” on the search box. Select the 

plugin on the list and click “Install Plugin”. Restart QGIS to finalize the installation.  
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6 Extra steps 

6.1 Atmospheric correction for S2 

Solar radiation reflected by the Earth’s surface to satellite sensors is affected by its interaction with 

the atmosphere. The objective of applying an atmospheric correction is to determine true surface 

(Bottom-Of-Atmosphere, BOA) reflectance values from the Top-Of-Atmosphere (TOA) reflectance 

values, by removing atmospheric effects. (See  NOTE E1) Atmospheric correction is especially 

important in cases where multi-temporal images are compared and analysed as it is in our case (pre-

fire and post-fire images).1  

 

In this tutorial, we will use the Sen2Cor processor. Sen2Cor is a processor for Sentinel-2 Level 2A 

product generation and formatting; it performs the atmospheric, terrain and cirrus correction of Top-

Of-Atmosphere Level 1C input data. Sen2Cor creates Bottom-Of-Atmosphere, optionally terrain and 

cirrus corrected reflectance images; additional, Aerosol Optical Thickness, Water Vapour, Scene 

Classification Maps and Quality Indicators for cloud and snow probabilities.  

To run the atmospheric correction, we first need to go out of SNAP and in File Manager navigate to 

the folder where our data are saved: /shared/Training/HYDR01_WaterBodies_TrainingKit/Original 

and unzip the product by right-clicking each and going to “Extract Here”. This will create a folder with 

suffix “.SAFE”.  

 

Then go back to SNAP and go to Optical → Thematic Land Processing → Sen2Cor.  

 NOTE E1: The radiance reaching the sensor is a result of following components: 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1.  Radiation from the sun and, scattered into the field 

of view of the sensor by the atmosphere without 

reaching the surface. 

2. Direct radiation that goes through the atmosphere 

without being absorbed or scattered, reaches the 

sensor after being reflected by the target pixel. 

3. Radiation scattered by the atmosphere into the 

target pixel and reflected back towards the sensor. 

 4. & 5. Direct or diffuse radiation reflected or scattered by 

the surrounding areas into the field of view of the sensor. 

This effect is so called “adjacency effect” or “blurring 

effect”. 

6. Diffuse radiation coming from the adjacent features into 

the field of view of the sensor.  

7. So-called trapping effect and it is a part of the radiation 

reflected from the surface into the air column above the 

surface being scattered and ultimately reaches the sensor.  

Credits: Mousivand et al., 20151  
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In the I/O Parameters we need to click on … next to the product name and navigate inside of the first 

product folder (“.SAFE” suffix). Then, open the MTD_MSIL1C.xml file. In the Processing Parameters 

tab change the resolution to “ALL” and select “Display execution output”. Click Run.  

 

This is rather a time demanding process and requires approximately 30 minutes per image (with 8GB 

RAM). 

The process creates a new Level 2-A product in the .SAFE format in the original folder. Now let’s load 

the result to SNAP.  

Click Open product , navigate to: /shared/Training/HYDR01_WaterBodies_TrainingKit/Original 

then open the Level-2A product folder for 2016: S2*_MSIL2A_*.SAFE  

And open the MTD_MSIL2A.xml 

6.2 Downloading the outputs from VM 

On your keyboard, press Ctrl+Alt+Shift. A pop-up window will appear on the left side of the screen. 

Click on the bar below Devices, the folder structure of your VM will appear. Navigate to your 

Processing folder and double click any file you want to download.  
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FOLLOW US!!! 
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