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1 Introduction 

The Research and User Support for Sentinel core products (RUS) service provides a free and open 

scalable platform in a powerful computing environment, hosting a suite of open source toolboxes pre-

installed on virtual machines, to handle and process data acquired by the Copernicus Sentinel satellites 

constellation.  

Mount Etna is one of the three active volcanoes 

in Italy and one of the most active in the world, 

with an almost constant state of activity. It is a 

stratovolcano, located on the east coast of Sicily, 

Italy and more specifically at the province of 

Catania.  

Parts of the volcano are shared among different 

local municipalities. It is the largest volcano in 

Italy, covering an area of around 1,190 km2, and 

it also is one of the tallest active volcanoes in 

Europe. Currently, it is of a height of 3,326 m.   

Etna’s eruptions are of multiple patterns. They 

can be either flank or occur at the summit, which 

has five distinct craters.  

There are also plenty of vents that provide 

relevant material systematically. The volcano is 

known for many eruptions, with the volcanic activity to have firstly started taking place at about 

500,000 years ago. There has been an increase at the eruptive events recorded the last few years, and 

the most recent summit eruptions have started in February 2021. The city of Catania has been affected 

by this recent event, mainly by the volcanic ash that covered most of the area.  

Mount Etna lies above the convergent plate margin between the African Plate and the Eurasian Plate. 

The African continental plate is constantly moving towards Europe and subducts underneath the 

Eurasian plate. In the image here on the left, we see the thrust tectonics prevailing the Italian Peninsula 

and its surroundings.  

Some eruptions apart from being highly explosive, they may also threaten the inhabited areas around 

the volcano. Several injuries, deaths, damages and loss of properties have been recorded because of 

volcanic eruptions and the following to them natural phenomena all over the world.  

Due to the history of recent activity and nearby population, Mount Etna has been designated a Decade 

Volcano by the United Nations. In June 2013, it was added to the list of UNESCO World Heritage Sites. 

2 Training 

Approximate duration of this training session is two hours.  

The Training Code for this tutorial is HAZA11. If you wish to practice the exercise described below 

within the RUS Virtual Environment, register on the RUS portal to request a Virtual Machine. Go to 

Your RUS Service → Your training activities and Request a Webinar Training. 

Neri M., et al., 2017 - Topographic Map of Mount Etna’s 

Summit Craters. DOI: 10.1080/17445647.2017.1352041 

 

https://rus-copernicus.eu/
https://doi.org/10.1080/17445647.2017.1352041
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2.1 Data used 

• 46 Sentinel-2 MSIL2A images are available over Etna volcano for the period 1 February 2021 until 

24 May 2021, every 2-3 days available [downloadable at https://scihub.copernicus.eu/]. 20 out 

of the 46 were covered by clouds, therefore they are not appropriate for our processing. It is 

advised to download only those from the list below, that do not have the “clouds” as description. 

S2B_MSIL2A_20210201T095129_N0214_R079_T33SVB_20210201T121019 - clouds 

S2A_MSIL2A_20210203T094211_N0214_R036_T33SVB_20210203T122614 

S2A_MSIL2A_20210206T095201_N0214_R079_T33SVB_20210206T120655 

S2B_MSIL2A_20210208T094049_N0214_R036_T33SVB_20210208T120726 - clouds 

S2B_MSIL2A_20210211T095029_N0214_R079_T33SVB_20210211T121618 

S2A_MSIL2A_20210213T094111_N0214_R036_T33SVB_20210213T122449 - clouds 

S2A_MSIL2A_20210216T095101_N0214_R079_T33SVB_20210216T120430 

S2B_MSIL2A_20210218T094029_N0214_R036_T33SVB_20210218T141009 

S2B_MSIL2A_20210221T095029_N0214_R079_T33SVB_20210221T115149 

S2A_MSIL2A_20210223T094031_N0214_R036_T33SVB_20210223T122213 

S2A_MSIL2A_20210226T095031_N0214_R079_T33SVB_20210226T122801 

S2B_MSIL2A_20210228T094029_N0214_R036_T33SVB_20210228T123605 

S2B_MSIL2A_20210303T095029_N0214_R079_T33SVB_20210303T113435 

S2A_MSIL2A_20210305T094031_N0214_R036_T33SVB_20210305T121638 - clouds 

S2A_MSIL2A_20210308T095031_N0214_R079_T33SVB_20210308T121258 

S2B_MSIL2A_20210310T094029_N0214_R036_T33SVB_20210310T122941 - clouds 

S2B_MSIL2A_20210313T095029_N0214_R079_T33SVB_20210313T115645 - clouds 

S2A_MSIL2A_20210315T094031_N0214_R036_T33SVB_20210315T120006 - clouds 

S2A_MSIL2A_20210318T095031_N0214_R079_T33SVB_20210318T113807 - clouds 

S2B_MSIL2A_20210320T094029_N0214_R036_T33SVB_20210320T113342 - clouds 

S2B_MSIL2A_20210323T095029_N0214_R079_T33SVB_20210323T113649 - clouds 

S2A_MSIL2A_20210325T094031_N0214_R036_T33SVB_20210325T114733 

S2A_MSIL2A_20210328T095031_N0214_R079_T33SVB_20210328T113651 - clouds 

S2B_MSIL2A_20210330T094029_N0300_R036_T33SVB_20210330T124902 

S2B_MSIL2A_20210402T095029_N0300_R079_T33SVB_20210402T133211 

S2A_MSIL2A_20210404T094031_N0300_R036_T33SVB_20210404T122544 - clouds 

S2A_MSIL2A_20210407T095031_N0300_R079_T33SVB_20210407T143611 - clouds 

S2B_MSIL2A_20210409T094029_N0300_R036_T33SVB_20210409T120755 

S2B_MSIL2A_20210412T095029_N0300_R079_T33SVB_20210412T121559 

S2A_MSIL2A_20210414T094031_N0300_R036_T33SVB_20210414T123112 

S2A_MSIL2A_20210417T095021_N0300_R079_T33SVB_20210417T121415 

S2B_MSIL2A_20210419T094029_N0300_R036_T33SVB_20210419T121500 - clouds 

S2B_MSIL2A_20210422T095029_N0300_R079_T33SVB_20210422T130900 - clouds 

S2A_MSIL2A_20210424T094031_N0300_R036_T33SVB_20210424T123436 - clouds 

S2A_MSIL2A_20210427T095031_N0300_R079_T33SVB_20210427T121331 

S2B_MSIL2A_20210429T094029_N0300_R036_T33SVB_20210429T124306 

S2B_MSIL2A_20210502T095029_N0300_R079_T33SVB_20210502T121950 - clouds 

S2A_MSIL2A_20210504T094031_N0300_R036_T33SVB_20210504T122449 - clouds 

S2A_MSIL2A_20210507T095031_N0300_R079_T33SVB_20210507T151839 - clouds 

https://scihub.copernicus.eu/
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S2B_MSIL2A_20210509T094029_N0300_R036_T33SVB_20210509T120133 

S2B_MSIL2A_20210512T095029_N0300_R079_T33SVB_20210512T132953 

S2A_MSIL2A_20210514T094031_N0300_R036_T33SVB_20210514T123226 - clouds 

S2A_MSIL2A_20210517T095031_N0300_R079_T33SVB_20210517T120344 

S2B_MSIL2A_20210519T094029_N0300_R036_T33SVB_20210520T124025 

S2B_MSIL2A_20210522T095029_N0300_R079_T33SVB_20210522T113428 

S2A_MSIL2A_20210524T094031_N0300_R036_T33SVB_20210524T122558 

2.2 Software in RUS environment 

Internet browser, SNAP + Sentinel-2 Toolbox, QGIS, Google Earth. 

3 Register to RUS Copernicus 

To repeat the exercise using a RUS Copernicus Virtual Machine (VM), you will first have to register as 

a RUS user. For that, go to the RUS Copernicus website (www.rus-copernicus.eu) and click on 

Login/Register in the upper right corner.  

 
Select the option Create my Copernicus SSO account and then fill in ALL the fields on the Copernicus 

Users’ Single Sign On Registration. Click Register.  

  

http://www.rus-copernicus.eu/
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Within a few minutes you will receive an e-mail with activation link. Follow the instructions in the e-
mail to activate your account.  
You can now return to https://rus-copernicus.eu/, click on Login/Register, choose Login and enter 
your chosen credentials. 

  
Upon your first login you will need to enter some details. You must fill all the fields.   

 

4 Request a RUS Copernicus Virtual Machine to repeat a Webinar  
Once you are registered as a RUS user, you can request a RUS Virtual Machine to repeat this exercise 

or work on your own projects using Copernicus data. For that, log in and click on Your RUS Service → 

Your training activities.  

 

https://rus-copernicus.eu/
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Select HAZA11 – Volcano Monitoring with Sentinel-2, check the field “I have read and agree to the 

Terms and conditions of RUS Service” and then click on Request Webinar Training to request your RUS 

Virtual Machine.  

 

Further to the acceptance of your request by the RUS Helpdesk, you will receive a notification email 

with all the details about your Virtual Machine.  

To access it, go to Your RUS Service → Your Dashboard and click on Access my Virtual Machine.  

NOTE: If the “Access my Virtual Machine” is greyed out, please access your VM from the direct link 

you have received at the email informing you about the creation of your VM.  

 

Fill in the login credentials that have been provided to you by the RUS Helpdesk via email to access 

your RUS Copernicus Virtual Machine.  

HAZA11 – Volcano Monitoring with Sentinel-2 
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This is the remote desktop of your Virtual Machine. 

 

5 Step by step  

5.1 Data download – ESA SciHUB 

In this step, we will download the Sentinel-2 scenes we will use for the exercise, from the Copernicus 

Open Access Hub using the online interface.  

Go to Applications → Network → Firefox Web Browser or click the link below. 

Go to https://scihub.copernicus.eu/   

https://scihub.copernicus.eu/
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Go to “Open HUB”, if you do not have an account please register by going to “Sign-up” in the LOGIN 

menu in the upper right corner. 
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After you have filled in the registration form, you will receive an activation link by e-mail. Once your 

account is activated or if you already have an account, “LOGIN”. 

Navigate over Mount Etna, in Sicily (approximate area – green rectangle).  

 

We need to download 26 Sentinel-2 cloud free images over the area of interest.  

Zoom in a bit more, switch to “drawing mode” and draw a search rectangle approximately as indicated 

below. Open the search menu by clicking to the left part of the search bar. We will specify at once the 

parameters for all products: 

For Sentinel-2: 

Sensing period: From 2021/02/01 to 2021/05/24 

Select: Mission: Sentinel-2 

Product Type: S2MSIL2A 

 

Then click on the “Search”  icon. The search will return too many results for the time period we set. 

We need to download only some specific, so select one, click on the “View Product Details” icon as 

shown below and check under the “Product”, which is the “Relative Orbit” it belongs to. In our case 

we need products that belong to the Relative Orbit Number: 36 and 79. Then, by going back to the 

main menu, you can run the search once for Relative Orbit Number 36 and once for 79. 
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As you can see, some of the products we need appear to be “Offline”. For those products, once we 

click on the download icon  of the first one, the following message will appear. Click OK. 

The product is automatically added in the “Cart”. In case an error 

message appears, try again a bit later – you can request for one 

product per account per hour. (See  NOTE 1 and  NOTE 2): 

The product will be online within few minutes.  

By the time the product turns online, it remains like that for 4 

days and then it goes back to offline again. You need to 

frequently check your cart for the product availability.  

 

 

You need to repeat the same process for all downloadable images mentioned in Chapter 2.1, the 

products will be downloaded at /home/rus as zip files. Move them to:  

/shared/Training/HAZA11_VolcanoMonitoring_Etna/Original folder. You will find subfolders with 

the Original folder, based on the month the data were retrieved (02, 03, 04 and 05). Paste them 

accordingly. 

Instead of waiting until you will retrieve all this data, you can alternatively follow the instructions on 

the next chapter, and download immediately all the images you wish. 

5.2 Data download – CREODIAS 

As you are using Firefox Web Browser, go to the CREODIAS Finder: https://finder.creodias.eu/# 

If you do not have an account, click on “Register” and sign up. After you have completed the process, 

just “Log In”, and you are ready to proceed. 

Then go to the “Product Identifier or path” field, and copy and paste the images from the list below, 

one by one. 

 NOTE 1: Please keep in mind that you cannot download more than 2 products at the same time, per 

account from SciHub. 

 NOTE 2: You can find more information about the retrieval of offline/long term archive products here: 

https://scihub.copernicus.eu/twiki/do/view/SciHubUserGuide/LongTermArchive#Retrieval_of_offline

_products_vi & https://scihub.copernicus.eu/userguide/LongTermArchive  

https://finder.creodias.eu/
https://scihub.copernicus.eu/twiki/do/view/SciHubUserGuide/LongTermArchive#Retrieval_of_offline_products_vi
https://scihub.copernicus.eu/twiki/do/view/SciHubUserGuide/LongTermArchive#Retrieval_of_offline_products_vi
https://scihub.copernicus.eu/userguide/LongTermArchive
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S2A_MSIL2A_20210203T094211_N0214_R036_T33SVB_20210203T122614 

S2A_MSIL2A_20210206T095201_N0214_R079_T33SVB_20210206T120655 

S2B_MSIL2A_20210211T095029_N0214_R079_T33SVB_20210211T121618 

S2A_MSIL2A_20210216T095101_N0214_R079_T33SVB_20210216T120430 

S2B_MSIL2A_20210218T094029_N0214_R036_T33SVB_20210218T141009 

S2B_MSIL2A_20210221T095029_N0214_R079_T33SVB_20210221T115149 

S2A_MSIL2A_20210223T094031_N0214_R036_T33SVB_20210223T122213 

S2A_MSIL2A_20210226T095031_N0214_R079_T33SVB_20210226T122801 

S2B_MSIL2A_20210228T094029_N0214_R036_T33SVB_20210228T123605 

S2B_MSIL2A_20210303T095029_N0214_R079_T33SVB_20210303T113435 

S2A_MSIL2A_20210308T095031_N0214_R079_T33SVB_20210308T121258 

S2A_MSIL2A_20210325T094031_N0214_R036_T33SVB_20210325T114733 

S2B_MSIL2A_20210330T094029_N0300_R036_T33SVB_20210330T124902 

S2B_MSIL2A_20210402T095029_N0300_R079_T33SVB_20210402T133211 

S2B_MSIL2A_20210409T094029_N0300_R036_T33SVB_20210409T120755 

S2B_MSIL2A_20210412T095029_N0300_R079_T33SVB_20210412T121559 

S2A_MSIL2A_20210414T094031_N0300_R036_T33SVB_20210414T123112 

S2A_MSIL2A_20210417T095021_N0300_R079_T33SVB_20210417T121415 

S2A_MSIL2A_20210427T095031_N0300_R079_T33SVB_20210427T121331 

S2B_MSIL2A_20210429T094029_N0300_R036_T33SVB_20210429T124306 

S2B_MSIL2A_20210509T094029_N0300_R036_T33SVB_20210509T120133 

S2B_MSIL2A_20210512T095029_N0300_R079_T33SVB_20210512T132953 

S2A_MSIL2A_20210517T095031_N0300_R079_T33SVB_20210517T120344 

S2B_MSIL2A_20210519T094029_N0300_R036_T33SVB_20210520T124025 

S2B_MSIL2A_20210522T095029_N0300_R079_T33SVB_20210522T113428 

S2A_MSIL2A_20210524T094031_N0300_R036_T33SVB_20210524T122558 

 

Click on Search and the image will appear on the right (see below). Then click on the Product Name, 

and once it opens, click on the download icon . 
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Repeat the same process for all Sentinel-2 images mentioned above. The products will be downloaded 

at /home/rus as zip files. Move them to:  

/shared/Training/HAZA11_VolcanoMonitoring_Etna/Original folder. You will find subfolders with 

the Original folder, based on the month the data were retrieved (02, 03, 04 and 05). Paste them 

accordingly. 

5.3 SNAP – open and explore data 

Open SNAP software from the icon located on the desktop  or go to Applications → Processing → 

SNAP Desktop. Click the Open Product icon , navigate to: /shared/Training/HAZA11_VolcanoMo 

nitoring_Etna/Original/02 folder and open all Sentinel-2 products (from oldest to the most recent), 

that were acquired on February 2021.  

Navigate to the path mentioned above and drag the products from the folder one by one and drop 

them to the Product Explorer Window. The opened products will appear in Product Explorer window.  

Click + or to expand the contents of product from 18 February 2021 and see the information it 

includes.  
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5.3.1 Create RGB image – Natural Colors B4, B3, B2 

Right click on the product from 18 February 2021 and Open RGB Image Window. At the Profile, select: 

Sentinel 2 MSI Natural Colours. The B4, B3 and B2 bands will be selected. Click OK. Then right click at 

the product from 21 February 2021 as well and open another RGB image.  

   

Go to Window → Tile Horizontally to see the two RGB images created side by side. 

You can go to the World Map tab and zoom in to see the location of the opened product on the globe. 

 

In the Navigation tab, click on the two icons shown within the red rectangular below, to synchronize 

the views and the cursor position between the views.  

5.4 Sentinel-2 Processing  

5.4.1 Graph Builder 

We need to create a Graph, where we will insert all the necessary operators, in order to prepare our 

data for the processing, so that they are in a form where we can create an RGB image that will be able 

to distinguish which of the white-grey areas are snow/volcanic ash and which are clouds. We will also 

manage to “see” the hot lava that is flowing from the crater.  

World Map 

View Window Product Explorer 

IW1 IW2 IW3 
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We will use the GraphBuilder tool, to create a chain with the processing steps we want to apply and 

at the end, only the final product will be physically saved (this way we will also save disk space since 

the products of the intermediate steps will not be stored). 

For now, we will not define any parameters in the tabs (they will be defined in the Batch Processing 

step where we will apply this processing for the rest images we have downloaded, at once), we will 

only create and save the graph.  

Go to Tools → GraphBuilder. Right-click on the Write operator and Delete it.  

 

As mentioned, we will set the parameters at the Batch Processing step later on. We have only the 

Read operator in the graph for now. 

 

We first need to resample all the Bands so that they have a common resolution, otherwise we cannot 

proceed with the next steps. To add the Resample operator, right-click and go to Add → Raster → 

Geometric → Resample. Connect the Read operator to it. 

 

We then need to create a Subset of the image, since we want to focus only over a certain area and we 

do not need the whole extent of it. To add the Subset operator, go to Add → Raster → Geometric → 

Subset. 

 

To create the output of this processing, we will add the Write operator. Right-click and go to Add → 

Input-Output → Write. Connect the Subset operator to it. 

 

Click on the  icon to save the graph. Go to the: /shared/Training/HAZA11_VolcanoMonito 

ring_Etna/Processing folder and save it with the name: Resample_Subset_Graph. 

Right-click on the 

operator and delete it 
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5.4.2 Batch Processing 

Batch Processing is used when we want to apply identical pre-processing steps at once, to multiple 

images. Open the Batch Processing tool by going to Tools → Batch Processing. 

Deselect the “Keep source product name” option. In the I/O Parameters tab we will add all opened 

products from the Product Explorer window by clicking Add Opened at the right (second icon from 

the top of the column at the right) and then click Refresh (second icon from the bottom). In this case 

we have loaded all images from February 2021. We should repeat the same for the rest of the images 

afterwards.  

Then we will click on Load Graph at the bottom of the window, navigate to the path of our saved graph 

and open it. We see that new tabs have appeared at the top of window corresponding to our 

operators.  

 

5.4.2.1 Resample 

In the Resample tab, select under the “Define size of resampled product” select the option: By 

reference band from source product and then select B2. This way we will resample all the bands in 

10m resolution.  
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5.4.2.2 Subset 

At the Subset tab, under the Source Bands, select only the B2, B3, B4, B8, B11 and B12 bands, by 

having the Ctrl selected on your keyboard. If you want to keep more or all bands, you do not need to 

select anything. Then select the Geographic Coordinates option and copy the WKT (well known text) 

from the Subset Geometry file in the /shared/Training/HAZA11_VolcanoMonitoring_Etna/AuxData 

folder and paste it to the text window below the map. WKT: 

POLYGON ((14.887468127522402 37.84592660279196, 15.086066763207151 37.84594891816823,  

   15.085893344366365 37.69618188436187, 14.887694871568335 37.6961596883839,  

   14.887468127522402 37.84592660279196)) 

Click Update and then click the Zoom-in icon  to see your subset on the map. 

 

In order to find which is the WKT you need for your Subset, select the Rectangle drawing tool and 

draw an area you wish to subset. Then click on the Selection tool and click on the rectangle you have 

created. Right click on it and select “WKT from Geometry”. Copy and paste the text in a file. 

 

Zoom in 
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5.4.2.3 Write – create the outputs 

In the Write tab, under Name keep the default name (Subset and resampled will be added). At the 

Directory set the path to /shared/Training/HAZA11_VolcanoMonitoring_Etna/Processing/02 for 

February. Change the paths for the next images of the rest months, accordingly. 

 

Click Run. Once the processing is completed for all products, they will appear at the Product Explorer 

Window. 

5.4.3 Create RGB image – False-Color B12, B11, B4  

Right click again on the product from 18 February 2021 and Open RGB Image Window. At the Profile, 

select: Sentinel 2 MSI Natural Colors. The B4, B3 and B2 bands will be selected. Click OK. Then right 

click at the same product again and this time at the Profile, select: Sentinel 2 MSI False-color Urban 

and the B12, B11 and B4 bands will be selected. Click OK.    

Go to Window → Tile Horizontally to see the two RGB images created side by side. 

As we compare the two images, we see that while in the one on the right with the natural colours we 

cannot see any of the lava, when we use Band 12 in the red channel and Band 11 in the green channel 

in the left one, we start to better understand the area.  

These two bands are in frequencies of the Shortwave Infrared part of the electromagnetic spectrum, 

moreover, B11 is ideal for distinguishing different soil types. 

With this combination (also by using Band 4 in the blue channel) we can “read” the heat of the lava 

that has not cooled down yet and it is being depicted it in red. Also, we can separate which of the 

white parts correspond to clouds and which correspond to snow or volcanic ash. 

Feel free to try more bands combinations of the available in SNAP when creating a RGB image, to see 

what are the different results you can get. 
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5.5 Export products  

In order to further process the outputs and combine them with any other kind of data in a GIS 

environment or in Google Earth, we first need to export them to the compatible format. 

For GIS processing:  

Select each product that is at the Product Explorer Window, one by one, and go to File → Export → 

GeoTIFF.  

Click on the “Subset” on the right side and at the window that opens, go to the Band Subset tab. Select 

only those bands you want to use for the final visualization e.g. for a natural-colour image, select B4, 

B3 and B2, while for the false-colour that we want to use in this case, select only the B12, B11 and B4. 

In the Metadata Subset tab, choose the option “Select none”. Click OK. 

  

Then set the product to be exported with the name you wish, and then set the path you want to save 

the tif file at the Save in field e.g. shared/Training/HAZA11_VolcanoMonitoring_Etna/Export/Geo 

TIFF_for_QGIS/02. Click Export Product. 
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For Google Earth processing:  

If you want to export the products for use is Google Earth, first you need to have them projected in 

“Geographic Lat/Lon”. Let’s create another graph in the Graph Builder to reproject the products, and 

let’s use again the Batch Processing, in order to apply it at once to all images. 

Go to Tools → GraphBuilder. Right-click on the Write operator and Delete it. Again, do not set yet any 

parameters, just create the graph.  

We need to reproject the products. Right-click and go to Add → Raster → Geometric → Reproject. 

Connect the Read operator to it. To create the output, we will add the Write operator. Right-click and 

go to Add → Input-Output → Write. Connect the Reproject operator to it.  

 

Click on the  icon to save the graph. Go to the: /shared/Training/HAZA11_VolcanoMonito 

ring_Etna/Processing folder and save it with the name: Reprojection_Graph. 

Open the Batch Processing tool by going to Tools → Batch Processing. 

Deselect the “Keep source product name” 

option. In the I/O Parameters tab we will add 

all opened products from the Product 

Explorer window by clicking Add Opened at 

the right (second icon from the top of the 

column at the right) and then click Refresh 

(second icon from the bottom).  

If you have not have the products you want to 

reproject opened in the Product Explorer 

Window, click on the first icon from the top, 

the Add, and go to the path where the images 

are stored so that you load them in the batch 

processing window manually.  
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In this case we have loaded all the Subset images from February 2021. We should repeat the same for 

the rest of the images afterwards.  

Then we will click on Load Graph at the bottom of the window, navigate to the path of our saved graph 

and open it. We see the two tabs have appeared at the top of window corresponding to our operators.  

In the Reproject tab, at the Custom CRS, at the Projection, select the “Geographic Lat/Lon (WGS 84)” 

option. Also, deselect the “Reproject tie-point grids” option. 

 

Finally, in the Write tab, keep the default name (projected will be added), set as Directory: shared/ 
Training/HAZA11_VolcanoMonitoring_Etna/Processing/02 for the images of February, and click Run. 
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Once the products have been created and opened in the Product Explorer Window, select each one 
and go to File → Export → Other → View as Google Earth KMZ.  

Alternatively, if you have the relative RGB image opened in the View 

Window, right-click on the image and select “Export View as Google 

Earth KMZ”.  

Then set the path to which you want to save it, e.g. 

shared/Training/HAZA11_VolcanoMonitoring_Etna/Export/Kmz 

_for_GoogleEarth/02 for the month of February. 

Finally, use as File Name something you consider representative, e.g. 
20210218-12-11-4.kmz and click Save. 

6 Data Visualization 

Below you can see a comparison of all available images over Etna, even those with clouds, for the 
month of February (Natural-colour vs False-colour RGB images). In the next one, you can see all the 
cloud free RGB False-colour images from February to May 2021 and monitor the lava flow along time.  
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7 QGIS Visualization and Processing 

Open QGIS Desktop and load all the cloudless images over Etna volcano at the Layers panel. You will 

find them under the path shared/Training/HAZA11_VolcanoMonitoring_Etna/Export/GeoTIFF_for_ 

QGIS/ and the suitable subfolder: 02, 03, 04 and 05.  

Also, add from the shared/Training/HAZA11_VolcanoMonitoring_Etna/AuxData/Contour lines 

folder the contours_20m.shp and contours_100m.shp files and continue with the Lavaflow.shp file 

from the shared/Training/HAZA11_VolcanoMonitoring_Etna/AuxData/ folder. 

Finally, go to Web → OpenLayers plugin → Bing Maps → Bing Aerial with labels in order to add a 

basemap layer (See  NOTE 3). 

 

You can select and deselect the layers loaded, and see how the lava has been flowing during this period 

from February to May 2021 around Etna. Below there is an example of how the area looks like on 18 

February 2021. 

 

On this image, we see the pattern of the total lava 

that has been flowing during the whole period we 

study.  

Right-click on the Lavaflow layer and go to 

“Properties”.  

In the “Symbology” tab, select Categorized. 

On “Column”, select id.  

On “Colour ramp” select Random Colors.  

Click on Classify and then click OK. Below you see the lava flowing every single day in a different colour. 

 NOTE 3: In case the OpenLayers plugin is not installed, click on Plugins → Manage and Install Plugins. 

Select the “All” tab on the left side panel and write “OpenLayers plugin” on the search box. If you cannot 

find it, go to “Settings” and select the “Show also experimental plugins” option. Go back to the “All” 

tab, select the plugin on the list and click “Install Plugin”. Restart QGIS to finalize the installation. 



25 
 

 

Right-click on the Lavaflow layer again and go to “Open Attribute Table”.  

Click on the “Open field calculator” 

 icon and set the following 

parameters, in order to calculate 

the extent of the area covered on 

each image, by lava:  

Select the “Create virtual field” 

option.  

Set at the “Output field name”: 

area.  

In the column at the center, expand 

Geometry. 

Double click on $area.  

Click OK. 

As you can see below, an extra column will be created at the Attribute Table, where you will have the 

extent of the lava that was flowing in every image of the ones processed, in m2. 

 

You can include as many additional data as you have for your area of interest, so that they will assist 

you for the processing you need to perform. 
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8 Google Earth Visualization and Processing 

Launch Google Earth and load all the cloudless .kmz files of the Etna volcano. You will find them under 

the path shared/Training/HAZA11_VolcanoMonitoring_Etna/Export/Kmz_for_Google Earth/ and 

the suitable subfolder: 02, 03, 04 and 05.  

NOTE: If there is no Google Earth icon on the desktop of your VM, open a terminal, type Google-Earth-

pro, click Enter and it will be launched. 

Also, add from the shared/Training/HAZA11_VolcanoMonitoring_Etna/AuxData/Contour lines 

folder the cont20m.kmz and cont100m.kmz files. 

You can view the results in any combination you prefer. Below you can see in 3D how the lava that 

was flowing on 18 February 2021 from the New SE crater looks like.  

 

You can download images after May 2021 to continue monitoring how the volcanic activity of Mount 

Etna has been evolving. 

Also, you can adopt this methodology for another area of study, and benefit from the different band 

combinations. 
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9 Extra Steps 

9.1 Download files from VM  

In your VM, press Ctrl+Alt+Shift.  

A pop-up window will appear on the left side of the screen. Click on the bar below Devices, navigate 

to the folders you have saved the files you want to download and double click on them. The 

downloading process to your local computer will start automatically.  

 

 

THANK YOU FOR FOLLOWING THE EXERCISE! 

 

10 Further reading and resources 

• Barreca, G., Branca, S., & Monaco, C. (2018). Three-dimensional modeling of Mount Etna 

volcano: Volume assessment, trend of eruption rates, and geodynamic significance. Tectonics, 

37, 842–857. https://doi.org/10.1002/2017TC004851 

• Marco Neri, Marina De Maio, Stefano Crepaldi, Enrico Suozzi, Muriel Lavy, Federico 

Marchionatti, Sonia Calvari & Maria Fabrizia Buongiorno (2017) Topographic Maps of Mount 

Etna’s Summit Craters, updated to December 2015, Journal of Maps, 13:2, 674-683, DOI: 

10.1080/17445647.2017.1352041 http://dx.doi.org/10.1080/17445647.2017.1352041 

• Tanguy, JC., Condomines, M., Le Goff, M. et al. Mount Etna eruptions of the last 2,750 years: 

revised chronology and location through archeomagnetic and 226Ra-230Th dating. Bull 

Volcanol 70, 55–83 (2007). https://doi.org/10.1007/s00445-007-0121-x 

• https://sentinel.esa.int/web/sentinel/missions/sentinel-2 - Sentinel 2 mission 

• https://srtm.csi.cgiar.org/srtmdata/ - Download the contours  
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