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1 Introduction 

The Research and User Support for Sentinel core products (RUS) service provides a free and open 

scalable platform in a powerful computing environment, hosting a suite of open source toolboxes pre-

installed on virtual machines, to handle and process data acquired by the Copernicus Sentinel satellites 

constellation.  

The Stromboli volcano is located in the Southern 

Tyrrhenian Sea, north of Sicily. It is one of the 

three active volcanoes in Italy and is the 

northernmost island of the main eight islands of 

the Aeolian Archipelago.  

It is a stratovolcano of persistent eruptive 

activity with approximately 3 km elevation and 

at least the 2 km to be below the sea level. The 

summit is at 924 m.a.s.l. and the surface area of 

the island is only 12.6 km2.  

There are two settlements on the island, one in 

the NE and one in the SW. Due to the products 

of the volcanic activity, the island is enriched 

with very fertile soil.  

The archipelago is a volcanic arc, which in 

present years extends for more than 140 km. 

The African continental plate is constantly moving towards Europe and subducts underneath the 

Eurasian plate. The magma generation rises to the surface and forms the volcanoes.  

The relatively high pressure of the gases ejects basaltic lava and its products to hundreds of meters in 

the air. Volcanoes with similar mechanisms with the one we studied today, are call of “Strombolian-

type” activity. Due to this behaviour, the island carries the nickname “Lighthouse of the 

Mediterranean”.  

Many significant explosions and lava flows have been recorded during the last 50 years, with the most 

recent events on July 3, 2019 and on November 10 and 16, 2020. The event on July 3rd which we will 

focus on, was a paroxysmal eruption, meaning among others, that there were almost no warning signs 

for this to happen.  

2 Training 

Approximate duration of this training session is two hours.  

The Training Code for this tutorial is HAZA10. If you wish to practice the exercise described below 

within the RUS Virtual Environment, register on the RUS portal to request a Virtual Machine. Go to 

Your RUS Service → Your training activities and Request a Webinar Training. 

 

Cross-section of the Stromboli plumbing system  

Source: Krzysztof et al., 2016 - (after Aiuppa et al., 2010; 

simplified) 

https://rus-copernicus.eu/
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2.1 Data used 

• Eight Sentinel-1 IW SLC images acquired from 27 May 2019 until 8 July 2019, every 6 days 

[downloadable at https://scihub.copernicus.eu/] 

S1A_IW_SLC__1SDV_20190527T165633_20190527T165659_027416_0317B7_C2DD.zip 

S1B_IW_SLC__1SDV_20190602T165549_20190602T165616_016520_01F187_9A86.zip 

S1A_IW_SLC__1SDV_20190608T165633_20190608T165700_027591_031D18_4A85.zip 

S1B_IW_SLC__1SDV_20190614T165550_20190614T165617_016695_01F6B7_5EB5.zip 

S1A_IW_SLC__1SDV_20190620T165634_20190620T165701_027766_032252_FE0C.zip 

S1B_IW_SLC__1SDV_20190626T165551_20190626T165618_016870_01FBE2_B18F.zip 

S1A_IW_SLC__1SDV_20190702T165635_20190702T165702_027941_03279A_BE4C.zip 

S1B_IW_SLC__1SDV_20190708T165552_20190708T165619_017045_020114_3F42.zip 

 

2.2 Software in RUS environment 

Internet browser, SNAP + Sentinel-1 Toolbox. 

3 Register to RUS Copernicus 

To repeat the exercise using a RUS Copernicus Virtual Machine (VM), you will first have to register as 

a RUS user. For that, go to the RUS Copernicus website (www.rus-copernicus.eu) and click on 

Login/Register in the upper right corner.  

 

Select the option Create my Copernicus SSO account and then fill in ALL the fields on the Copernicus 

Users’ Single Sign On Registration. Click Register.  

https://scihub.copernicus.eu/
http://www.rus-copernicus.eu/
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Within a few minutes you will receive an e-mail with activation link. Follow the instructions in the e-

mail to activate your account.  

You can now return to https://rus-copernicus.eu/, click on Login/Register, choose Login and enter 

your chosen credentials. 

  

Upon your first login you will need to enter some details. You must fill all the fields.   

 

https://rus-copernicus.eu/
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4 Request a RUS Copernicus Virtual Machine to repeat a Webinar  
Once you are registered as a RUS user, you can request a RUS Virtual Machine to repeat this exercise 

or work on your own projects using Copernicus data. For that, log in and click on Your RUS Service → 

Your training activities.  

 

Select HAZA10 – Volcano Monitoring with Sentinel-1, check the field “I have read and agree to the 

Terms and conditions of RUS Service” and then click on Request Webinar Training to request your RUS 

Virtual Machine.  

 

Further to the acceptance of your request by the RUS Helpdesk, you will receive a notification email 

with all the details about your Virtual Machine.  

To access it, go to Your RUS Service → Your Dashboard and click on Access my Virtual Machine.  

HAZA10 – Volcano Monitoring with Sentinel-1 
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Fill in the login credentials that have been provided to you by the RUS Helpdesk via email to access 

your RUS Copernicus Virtual Machine.  

 
This is the remote desktop of your Virtual Machine. 
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5 Step by step  

5.1 Data download – ESA SciHUB 

In this step, we will download the Sentinel-1 scenes we will use for the exercise, from the Copernicus 

Open Access Hub using the online interface.  

Go to Applications → Network → Firefox Web Browser or click the link below. 

Go to https://scihub.copernicus.eu/   

 

Go to “Open HUB”, if you do not have an account please register by going to “Sign-up” in the LOGIN 

menu in the upper right corner. 

 

https://scihub.copernicus.eu/
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After you have filled in the registration form, you will receive an activation link by e-mail. Once your 

account is activated or if you already have an account, “LOGIN”. 

Navigate over Stromboli island, at the Southern Tyrrhenian Sea, north of Sicily (approximate area – 

green rectangle).  

 

We need to download 8 Sentinel-1 images over the area of interest.  

Zoom in a bit more, switch to “drawing mode” and draw a search rectangle approximately as indicated 

below. Open the search menu by clicking to the left part of the search bar. We will specify at once the 

parameters for all products: 

For Sentinel-1: 

Sensing period: From 2019/05/25 to 2019/07/10 

Select: Mission: Sentinel-1 

Product Type: SLC 

Sensor Mode: IW  

Relative Orbit Number: 44 
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Then click on the “Search”  icon. The search returns 8 results for the time period we set. We need 

to download them all, so we click on the “Download Product”  icon of each one (See  NOTE 1 

and  NOTE 2): 

S1A_IW_SLC__1SDV_20190527T165633_20190527T165659_027416_0317B7_C2DD 

S1B_IW_SLC__1SDV_20190602T165549_20190602T165616_016520_01F187_9A86 

S1A_IW_SLC__1SDV_20190608T165633_20190608T165700_027591_031D18_4A85 

S1B_IW_SLC__1SDV_20190614T165550_20190614T165617_016695_01F6B7_5EB5 

S1A_IW_SLC__1SDV_20190620T165634_20190620T165701_027766_032252_FE0C 

S1B_IW_SLC__1SDV_20190626T165551_20190626T165618_016870_01FBE2_B18F 

S1A_IW_SLC__1SDV_20190702T165635_20190702T165702_027941_03279A_BE4C 

S1B_IW_SLC__1SDV_20190708T165552_20190708T165619_017045_020114_3F42 

 

  

If the products appear to be “Offline”, once we click on the download icon, the following message will 

appear. Click OK. 

 NOTE 1: Please keep in mind that you cannot download more than 2 products at the same time, per 

account from SciHub. 
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The product is automatically added in the “Cart”. In case an error 

message appears, try again a bit later – you can request for one 

product per account per hour.  

The product will be online within few minutes.  

By the time the product turns online, it remains like that for 4 

days and then it goes back to offline again. You need to 

frequently check your cart for the product availability. 

 

The products will be downloaded at /home/rus as zip files. Move them to:  

/shared/Training/HAZA10_VolcanoMonitoring_Stromboli/Original folder. 

5.2 SNAP – open and explore data 

Open SNAP software from the icon located on the desktop  or go to Applications → Processing → 

SNAP Desktop. Click the Open Product icon , navigate to: /shared/Training/HAZA10_VolcanoMo 

nitoring_Stromboli/Original folder and open all Sentinel-1 products (from oldest to the most recent).  

In this case, we will process only the pair of images acquired right before the eruption so open a folder 

in your VM, navigate to the path mentioned above and drag the products from the folder one by one 

and drop them to the Product Explorer Window (first the 20190626 and then the 20190702). The 

opened products will appear in Product Explorer window.  

Click + or to expand the contents of product [1] from 26 June 2019, then expand Bands folder and 

double click on Intensity_IW1_VV band to visualize it in the View window. You can go to the World 

View tab and zoom in to see the location of the opened product on the globe. 

 

Open the Intensity_IW2_VV and Intensity_IW3_VV bands as well and go to Window → Tile 

Horizontally. In the Navigation tab and click on the two icons shown within the red rectangular below, 

to synchronize the views and the cursor position between the views. (See  NOTE 3 and NOTE 4). 

 NOTE 2: You can find more information about the retrieval of offline/long term archive products here: 

https://scihub.copernicus.eu/twiki/do/view/SciHubUserGuide/LongTermArchive#Retrieval_of_offline

_products_vi & https://scihub.copernicus.eu/userguide/LongTermArchive  

World View 

View Window 

Product 
Explorer 

https://scihub.copernicus.eu/twiki/do/view/SciHubUserGuide/LongTermArchive#Retrieval_of_offline_products_vi
https://scihub.copernicus.eu/twiki/do/view/SciHubUserGuide/LongTermArchive#Retrieval_of_offline_products_vi
https://scihub.copernicus.eu/userguide/LongTermArchive
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5.3 Sentinel-1 Processing  

We will use the GraphBuilder tool, to create a chain with the steps of the processes we want to apply 

and at the end, only the final product will be physically saved (this way we will also save disk space 

since the products of the intermediate steps will not be stored). 

We will create in total 4 graphs for our processing steps, we will define the parameters for each 

operator and then you can repeat the whole methodology and apply it for the rest pairs of images we 

have downloaded. For now, we will not define any parameters in the tabs (they will be defined in the 

Batch Processing step), we will only create the graph. 

5.3.1 Graph Builder – Graph 1 

Go to Tools → GraphBuilder to build our graph.  

We can see that the graph has only two operators: Read (to read the input) and Write (to write the 

output). Below there also are the corresponding to the operators’ tabs.  

Right-click on the Write operator and Delete it. The corresponding tab will be removed as well. This is 

to avoid confusion to the sequence of the graph. The Write operator will be added again at the end.  

 NOTE 3: The Interferometric Wide (IW) swath mode captures three sub-swaths using Terrain 

Observation with Progressive Scans SAR (TOPSAR). IW SLC products contain one image per sub-swath 

and one per polarisation channel, for a total of three (single polarisation) or six (dual polarisation) 

images in an IW product. Each sub-swath image consists of a series of bursts, where each burst has been 

processed as a separate SLC image. The images for all bursts in all sub-swaths are resampled to a 

common pixel spacing grid in range and azimuth while preserving the phase information.  

(Source: https://sentinel.esa.int/web/sentinel/user-guides/sentinel-1-sar/acquisition-

modes/interferometric-wide-swath)  

 

 
 NOTE 4: The RADAR instrument onboard Sentinel-1 carries an antenna that is looking always to the right 

during its pass. These two scenes were acquired during ascending pass (the satellite was moving in 

direction from south to north). That is why we see that the view of the image appears as if “mirrored” 

across the horizontal dimension, because the view shows the pixels in the order of the data acquisition. 

Navigation 

A
zi

m
u

th
 

Range 

IW1 IW2 IW3 

https://sentinel.esa.int/web/sentinel/technical-guides/sentinel-1-sar/products-algorithms/level-1-algorithms/topsar-processing
https://sentinel.esa.int/web/sentinel/user-guides/sentinel-1-sar/acquisition-modes/interferometric-wide-swath
https://sentinel.esa.int/web/sentinel/user-guides/sentinel-1-sar/acquisition-modes/interferometric-wide-swath
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5.3.1.1 TOPS Split 

There is now only the Read operator. Our area of interest is located in the IW2 swath and is covered 

sufficiently by processing 2 bursts. We will use the TOPSAR-Split operator (See  NOTE 5). 

To add the TOPSAR-Split operator, right-click at the empty white space right of the Read operator and 

go to Add → Radar → Sentinel-1 TOPS → TOPSAR-Split. Connect the Read operator to it by dragging 

the red arrow from the right side of Read operator towards the TOPSAR-Split operator. 

 

 

5.3.1.2 Apply Orbit File 

Next, we will apply the updated orbits to the products (See  NOTE 6). Right-click and go to Add → 

Radar → Apply-Orbit-File. Connect the TOPSAR-Split operator to it. 

 

 

5.3.1.3 Write – create the output 

Last, we add the Write operator right-click and go to Add → Input-Output → Write. Connect the 

Apply-Orbit-File operator to it. Click on the icon and save the graph with the name 

Graph_1 within the /shared/Training/HAZA10_VolcanoMonitoring_Stromboli/AuxData folder. 

  

 NOTE 5: In this case that we are using a pair of ascending products, the IW1 is the one to the west. If 

we work with descending products, the IW1 is the one to the east. Depending on our area of interest, 

we can process some or all bursts of a sub-swath, or even merge more sub-swaths but this will be quite 

time consuming and computationally heavy in the following steps. 

 NOTE 6: The orbit state vectors provided in the metadata of a SAR product are generally not accurate 

and can be refined with the precise orbit files which are available days-to-weeks after the generation of 

the product. The orbit file provides accurate satellite position and velocity information. Based on this 

information, the orbit state vectors in the abstract metadata of the product are updated. 

Right-click on the 

operator and delete it 
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5.3.2 Batch Processing 

Batch Processing is used when we want to apply identical pre-processing steps at once, to multiple 

images (in this case only in two). Open the Batch Processing tool by going to Tools → Batch Processing. 

In the I/O Parameters tab we will add both opened products from the Product Explorer window by 

clicking Add Opened at the right (second icon from the top of the column at the right) and then click 

Refresh (second icon from the bottom).  

Then we will click on Load Graph at the bottom of the window, navigate to the path of our saved graph 

and open it. We see that new tabs have appeared at the top of window corresponding to our 

operators. 

 

In the TOPSAR-Split tab Zoom in to the product and select: 

Subswath: IW2 

Polarisations: VV 

Bursts: 6 to 7 (drag the two sliders accordingly)  

 

Zoom in 
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In the Apply-Orbit-File tab we will keep the default settings and make sure that you will select the “Do 

not fail if new orbit file is not found” option.  

 

In the Write tab keep the “Name” that is created with the “Orb” suffix and under the “Directory” set 

the path to /shared/Training/HAZA10_VolcanoMonitoring_Stromboli/Processing folder. Click Run.  

 

Both products will be created and added in the Product Explorer window. Expand the Bands folder 

and only the 2 bursts out of the original 9 will be included now in the product. 
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5.3.3 Graph Builder – Graph 2 

Go again to Tools → GraphBuilder, right-click on the Write operator and Delete it. This time, we will 

also define in parallel the parameters in the tabs. 

5.3.3.1 Back Geocoding 

Now we will coregister the two products. Image coregistration is the alignment of master and slave 

images, the pixels of the slave images correspond to those of the master and represent an identical 

area.  

Add one more Read operator. Right click and go to Add → Input-Output → Read. The inputs will be 

the products we want to coregister. 

 

In the Read tab select the product [3] that contains only the 2 bursts of IW2 swath with updated orbits: 

S1B_IW_SLC__1SDV_20190626T165551_20190626T165618_016870_01FBE2_B18F_Orb 

 

In the Read(2) tab select the product [4] that contains only the 2 bursts of IW2 swath with updated 

orbits: S1A_IW_SLC__1SDV_20190702T165635_20190702T165702_027941_03279A_BE4C_Orb 

 

To add the Back-Geocoding operator right-click and go to Radar → Coregistration → S-1 TOPS 

Coregistration → Back-Geocoding. Connect both Read and Read(2) operators to it. 

 

In the Back-Geocoding tab set: Digital Elevation Model: SRTM 1Sec HGT (Auto Download), select the 

“Output Deramp and Demod Phase” option as well and leave the rest parameters as by default. 
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5.3.3.2 Enhanced Spectral Diversity 

This operator follows the Back-Geocoding operator, it first estimates a constant range offset for each 

burst using a small block of data in the center of the burst and then it estimates a constant azimuth 

offset. Finally, the estimates from all bursts are averaged to get the final constant range and azimuth 

offset for the whole image.  

To add the Enhanced-Spectral-Diversity operator right-click and go to Radar → Coregistration → S-1 
TOPS Coregistration → Enhanced-Spectral-Diversity. Connect the Back-Geocoding operator to it. 

 

In the Enhanced-Spectral-Diversity tab keep all the default parameters. 

 

5.3.3.3 Interferogram formation 

We will create an interferogram from the two images. To add the Interferogram operator right-click 

and go to Add → Radar → Interferometric → Products → Interferogram. Connect the Enhanced-

Spectral-Diversity operator to it. A phase and a coherence band will be created.  

 

In the Interferogram tab, keep the default parameters and set as Coherence Range Window Size: 20. 
The Coherence Azimuth Window Size will automatically change to 5. 
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5.3.3.4 TOPS Deburst 

Now we will remove the “black space” between the two bursts (See  NOTE 7). To add the TOPSAR-

Deburst operator right-click and go to Add → Radar → Sentinel-1 TOPS → TOPSAR-Deburst. Connect 

the Interferogram operator to it. 

 

In the TOPSAR-Deburst tab keep the default settings (Polarizations: VV). 

 

 

5.3.3.5 Write – create the output 

To add the Write operator right-click and go to Add → Input-Output → Write. Connect the TOPSAR-

Deburst operator to it. 

 

In the Write tab set as “Name”: 20190626_20190702_IW2_Orb_Stack_Ifg_Deb and as “Directory”: 
/shared/Training/HAZA10_VolcanoMonitoring_Stromboli/Processing (Click on the  icon to set 
the appropriate path).  

 

Click on the  icon to save the graph for future use under the: /shared/Training/ 

HAZA10_VolcanoMonitoring_Stromboli/AuxData folder and save it with the name: Graph_2.  

Then click Run. 

 NOTE 7: There is overlapping information in every burst with its neighbouring ones, both in range and 

azimuth direction in order to provide contiguous coverage of the ground. Until now each burst has been 

processed as a separate SLC image We will merge the bursts (in azimuth direction) and preserve the 

phase information as well. For the overlapping region in range, merging is done between subswaths. 
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Once the processing is completed, the product will appear at the Product Explorer Window.You can 

open the Phase and the Coherence bands and see how the volcano looks like. (Go to Window → Tile 

Vertically). 

 

5.3.4 Graph Builder – Graph 3 

Go once more to Tools → GraphBuilder, right-click on the Write operator and Delete it.  

In the Read tab select the product [5] that contains the product with the Interferogram: 

20190626_20190702_IW2_Orb_Stack_Ifg_Deb  

 

5.3.4.1 Topographic Phase Removal  

This is to estimate and subtract the topographic phase from the deburst interferogram. To add the 

TopoPhaseRemoval operator right-click and go to Add → Radar → Interferometric → Products → 

TopoPhaseRemoval. Connect the Read operator to it. 

 

 

In the TopoPhaseRemoval tab set as Digital Elevation Model: SRTM 1Sec HGT (Auto Download). 
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5.3.4.2 Multilooking 

By applying this operator, we will reduce the inherent speckle noise that originally appears to the SAR 

images and we will obtain square pixels. To add the Multilook operator right-click and go to Add → 

Radar → SAR Utilities → Multilook. Connect the TopoPhaseRemoval operator to it. 

 

In the Multilook tab keep the “GR Square Pixel” option selected and set Number of Range Looks: 8. 

The Number of Azimuth Looks will automatically change to 2 and the Mean GR Square Pixel to 

28.643908. 

 

5.3.4.3 Phase Filtering 

Phase filtering reduces the phase noise (See  NOTE 8). To add the GoldsteinPhaseFiltering operator 

right-click and go to Add → Radar → Interferometric → Filtering → GoldsteinPhaseFiltering. Connect 

the Multilook operator to it. 

 

In the GoldsteinPhaseFiltering tab set the FFT Size to 32 and keep the rest parameters as by default. 

 

 

5.3.4.4 Write – create the output 

Finally we will save the product and we will also export it for SNAPHU. To add the Write operator right-

click and go to Add → Input-Output → Write. Connect the GoldsteinPhaseFiltering operator to it. 

 

 NOTE 8: It is necessary step since it will enhance the phase unwrapping accuracy for the upcoming step. 
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In the Write tab set the following: 

Name: 20190626_20190702_IW2_Orb_Stack_Ifg_Deb_DInSAR_ML_Flt 

Directory: /shared/Training/HAZA10_VolcanoMonitoring_Stromboli/Processing 

 

To add the SnaphuExport operator right-click and go to Add → Radar → Interferometric → 

Unwrapping → SnaphuExport. Connect the GoldsteinPhaseFiltering operator to it as well. 

 

In the SnaphuExport tab click on  icon to set the Target folder. Navigate to the following path: 

/shared/Training/HAZA10_VolcanoMonitoring_Stromboli/Processing and write at the File Name: 

SNAPHU. Click Select.  

Then define the following parameters in the SnaphuExport tab: 

Initial method: MCF 

Number of Tile Rows: 1 

Number of Tile Columns: 1 

Row Overlap: 0 

Column Overlap: 0 

 

Click on  icon and save the graph under /shared/Training/HAZA10_VolcanoMonitori 

ng_Stromboli/AuxData folder with the name Graph_3. Then click Run. This is the result. 
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5.3.4.5 Phase Unwrapping 

Phase unwrapping is prerequisite to convert phase units to length units (See  NOTE 9). Open the: 

  /shared/Training/HAZA10_VolcanoMonitoring_Stromboli/Processing/ 

SNAPHU/20190626_20190702_IW2_Orb_Stack_Ifg_Deb_DInSAR_ML_Flt 

folder and right-click in the empty space.  

 

Select “Open Terminal Here”. 

 

The following terminal will appear. 

 

 

In the same folder, open the snaphu.conf file. 

In line 28 (go to View → Line Numbers), add the # symbol and leave a space before LOGFILE. Go to 

File → Save and save the changes. Then go to line 7 and copy the command shown in the picture 

below in blue, to call snaphu:  

snaphu -f snaphu.conf Phase_ifg_VV_26Jun2019_02Jul2019.snaphu.img 3365 

Paste it in the Terminal and press Enter to run it. 

 
 

 NOTE 9: Two-dimensional phase unwrapping is the process of recovering unambiguous phase data from 

a 2-D array of phase values known only modulo 2pi rad. 
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5.3.5 Graph Builder – Graph 4 

Now we will create the last graph of the processing, and for this we go to Tools → GraphBuilder and 
we right-click on the Write operator to Delete it.  

First, add one more Read operator. Right click and go to Add → Input-Output → Read. 

 
In the Read tab select the product that was created from the last Write operator:  
[6] 20190626_20190702_IW2_Orb_Stack_Ifg_Deb_DInSAR_ML_Flt  

 

In the Read(2) tab click on  icon to select the product that contains the unwrapped phase: 

UnwPhase_ifg_VV_26Jun2019_02Jul2019.snaphu.hdr from the following path:  

/shared/Training/HAZA10_VolcanoMonitoring_Stromboli/Processing/SNAPHU/20190626_201907
02_IW2_Orb_Stack_Ifg_Deb_DInSAR_ML_Flt 
Under the Name it will be written as: UnwPhase_ifg_VV_26Jun2019_02Jul2019.snaphu 
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5.3.5.1 SNAPHU Import 

We will import the results from SNAPHU processing. Add → Radar → Interferometric → Unwrapping 

→ SnaphuImport. Connect both Read and Read(2) operators to it. 

 

In the SnaphuImport tab, select the “Do NOT save Wrapped Interferogram in the target product”. 

 

5.3.5.2 Displacement 

In order to convert the phase information into displacement, go to Add → Radar → Interferometric 
→ Products → PhaseToDisplacement. Connect the SnaphuImport operator to it. 

 

In the PhaseToDisplacement tab there are no parameters to be changed. 

 

5.3.5.3 Write – create the output 

As last step, we will save the product that will contain the displacement band. Go to Add → Input-

Output → Write. Connect the PhaseToDisplacement operator to it. 

 

In the Write tab set the following: 

Name: 20190626_20190702_IW2_Orb_Stack_Ifg_Deb_DInSAR_ML_Flt_Disp 

Directory: /shared/Training/HAZA10_VolcanoMonitoring_Stromboli/Processing 
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Click on icon and save the graph under /shared/Training/HAZA10_VolcanoMonitoring 

_Stromboli/AuxData folder with the name Graph_4. Then click Run.  

 

We see that we cannot understand clearly the output and for this reason we will proceed to the last 

step, the Geocoding, in order to convert the RADAR coordinates into geographic and remove the 

displacement that refers to the sea surface. We will only keep the information about the volcano. 

5.3.6 Geocoding – Terrain Correction 

Go to the menu Radar → Geometric → Terrain Correction → Range Doppler Terrain Correction. 

in the I/O Parameters tab, set the following: 

Source: 20190626_20190702_IW2_Orb_Stack_Ifg_Deb_DInSAR_ML_Flt_Disp 

Name: 20190626_20190702_IW2_Orb_Stack_Ifg_Deb_DInSAR_ML_Flt_Disp_TC 

Directory: /shared/Training/HAZA10_VolcanoMonitoring_Stromboli/Processing 

 

In the Processing Parameters tab keep the default parameters (we need SRTM3Sec as DEM.  

Make sure that the “Mask out areas without elevation” is selected and click Run. 
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This is the final product. 

 

In order to better visualize the deformation, we have created a colour palette where with within the 

scale, with red we show the areas that have been moved away relatively to the satellite, with blue the 

areas that have been moved closer to the satellite and with white those who remained stable. Go to 

the  icon - “Import colour palette from text file”.  
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For the dates of images we have processed, navigate to /shared/Training/HAZA10_VolcanoMonitori 

ng_Stromboli/AuxData folder and insert the 20190626_20190702.cpd colour palette. 

 

 

5.3.7 Export products  

If you want to further process your outputs and combine them with any other kind of data in a GIS 

environment or in Google Earth, you first need to export them to the compatible format. 

For GIS processing:  

Select the 20190626_20190702_IW2_Orb_Stack_Ifg_Deb_DInSAR_ML_Flt_Disp_TC product and go 

to File → Export → GeoTIFF.  

Set it with the name you wish, and then set the path you want to save the tif file at the Save in field 

e.g. shared/Training/HAZA10_VolcanoMonitoring_Stromboli/Processing.  Click Export Product. 

If you want to export it for use is Google Earth, first you need to have it Terrain Corrected in geographic 

Lat and Lon, right click on the opened band at the View Window and select “Export View as Google 

Earth KMZ”. Then set the path to which you want to save it. 
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6 Data Interpretation 

We have downloaded 8 images in total, but we processed only 2 of them as a pair. In order to monitor 

the volcano, it is suggested to process some images before the eruption and some after. In this case, 

the rest suggested pairs to be proceed are those of the following dates: 

Pair 1: 20190527 - 20190602 

Pair 2: 20190602 - 20190608 

Pair 3: 20190608 - 20190614 

Pair 4: 20190614 - 20190620 

Pair 5: 20190620 - 20190626 

Pair 6: 20190626 - 20190702 →THIS HAS BEEN PROCESSED IN THIS TUTORIAL 

Pair 7: 20190702 - 20190708 

If we load them all in SNAP with the corresponding to each colour palette that is available in the 

AuxData folder, we can see the following displacement over time. 

 
In the results showing the conditions every 6 days 

consequently, we can see that the whole island is 

periodically deflating and inflating.  

Stromboli is one of the most monitored volcanoes in 

the world with a great surveillance system and many 

scientists have worked all these years on its activity. 

As confirmed by F. Di Traglia et al., 2014, inflation and 

deflation were recorded immediately before and 

after each new effusive event, like in our case. Any 

vent opening can cause sliding and high displacement 

rate is recorded.  

Also, the displacement rate increases during the 

upwelling because the magma is less dense, while the 

displacement rate decreases when the degassed 

magma column is pushed out from the pipe. 
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7 Extra Steps 

7.1 Download files from VM  

In your VM, press Ctrl+Alt+Shift.  

A pop-up window will appear on the left side of the screen. Click on the bar below Devices, navigate 

to the folders you have saved the files you want to download and double click on them. The 

downloading process to your local computer will start automatically.  

 

 

THANK YOU FOR FOLLOWING THE EXERCISE! 
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