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1 Introduction 

The Research and User Support for Sentinel core products (RUS) service provides a free and open 

scalable platform in a powerful computing environment, hosting a suite of open source toolboxes pre-

installed on virtual machines, to handle and process data acquired by the Copernicus Sentinel satellites 

constellation.  

On 4 August 2020 in Lebanon, at around 

17:55 local time (14:55 UTC), a fire broke 

out in Warehouse 12 at the Port of Beirut, 

where a cargo of 2,750 tonnes of 

ammonium nitrate was stored, followed 

by 2 explosions a few minutes later.  

The first explosion produced a large cloud 

of smoke, damaging heavily the 

warehouse, while the second that was 

caused by nitrogen dioxide, a byproduct 

of ammonium nitrate decomposition, 

produced a red-orange cloud surrounded 

by a white condensation cloud.  

The consequences were severe in many 

fields and levels. It is estimated that more 

than 200 people lost their lives, 6,500 

were injured and 300,000 people went 

homeless since homes as far as 10 km 

away were damaged. The blast affected 

over half of Beirut, with the cost to be 

above $15 billion in property damages.  

Within the port area, the explosion destroyed a section of shoreline leaving a crater around 124m in 

diameter and 43m in depth. Experts estimated that the explosion was one of the biggest non-nuclear 

explosions in history, it was detected as a seismic event of magnitude 3.3.  

It was felt in many countries such as Turkey, Syria, Israel, Palestine and parts of Europe, and was heard 

in Cyprus, more than 240 km away. The Lebanese government declared a two-week state of 

emergency in response to the disaster.  

2 Training 

Approximate duration of this training session is two hours.  

The Training Code for this tutorial is HAZA08. If you wish to practice the exercise described below 

within the RUS Virtual Environment, register on the RUS portal to request a Virtual Machine. Go to 

Your RUS Service → Your training activities and Request a Webinar Training. 

 

View of the Beirut port and surroundings in Lebanon, before (image 

above) and after (image below) the explosion, on August 4th, 2020.  

(Source: Google Earth) 

 

https://rus-copernicus.eu/
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2.1 Data used 

• Three Sentinel-1 IW SLC images acquired on 25 July 2020, 31 July 2020 and 6 August 2020 

[downloadable at https://scihub.copernicus.eu/] 

S1B_IW_SLC__1SDV_20200725T033445_20200725T033512_022622_02AEEE_A0BA 

S1A_IW_SLC__1SDV_20200731T033531_20200731T033558_033693_03E7B2_D1A9 

S1B_IW_SLC__1SDV_20200806T033445_20200806T033512_022797_02B43D_3A0B 

• Two Sentinel-2 Level 2A images (Tile ID: T36SYC) acquired on 24 July 2020 and 18 August 2020 

[downloadable at https://scihub.copernicus.eu/] 

S2A_MSIL2A_20200724T081611_N0214_R121_T36SYC_20200724T110803 

S2B_MSIL2A_20200818T081609_N0214_R121_T36SYC_20200818T110855 

2.2 Software in RUS environment 

Internet browser, SNAP + Sentinel-1 and Sentinel-2 Toolboxes, QGIS. 

3 Register to RUS Copernicus 

To repeat the exercise using a RUS Copernicus Virtual Machine (VM), you will first have to register as 

a RUS user. For that, go to the RUS Copernicus website (www.rus-copernicus.eu) and click on 

Login/Register in the upper right corner.  

 

Select the option Create my Copernicus SSO account and then fill in ALL the fields on the Copernicus 

Users’ Single Sign On Registration. Click Register.  

https://scihub.copernicus.eu/
https://scihub.copernicus.eu/
http://www.rus-copernicus.eu/
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Within a few minutes you will receive an e-mail with activation link. Follow the instructions in the e-

mail to activate your account.  

You can now return to https://rus-copernicus.eu/, click on Login/Register, choose Login and enter 

your chosen credentials. 

  

Upon your first login you will need to enter some details. You must fill all the fields.   

 

https://rus-copernicus.eu/
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4 Request a RUS Copernicus Virtual Machine to repeat a Webinar  
Once you are registered as a RUS user, you can request a RUS Virtual Machine to repeat this exercise 

or work on your own projects using Copernicus data. For that, log in and click on Your RUS Service → 

Your training activities.  

 

Select HAZA08 - Lebanon Damage Assessment with Sentinel-1 & Sentinel-2, check the field “I have 

read and agree to the Terms and conditions of RUS Service” and then click on Request Webinar 

Training to request your RUS Virtual Machine.  

 

Further to the acceptance of your request by the RUS Helpdesk, you will receive a notification email 

with all the details about your Virtual Machine.  

To access it, go to Your RUS Service → Your Dashboard and click on Access my Virtual Machine.  
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Fill in the login credentials that have been provided to you by the RUS Helpdesk via email to access 

your RUS Copernicus Virtual Machine.  

 
This is the remote desktop of your Virtual Machine. 
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5 Step by step  

5.1 Data download – ESA SciHUB 

In this step, we will download the Sentinel-1 and Sentinel-2 scenes we will use for the exercise, from 

the Copernicus Open Access Hub using the online interface. Go to Applications → Network → Firefox 

Web Browser or click the link below. 

Go to https://scihub.copernicus.eu/   

 

Go to “Open HUB”, if you do not have an account please register by going to “Sign-up” in the LOGIN 

menu in the upper right corner. 

 

https://scihub.copernicus.eu/
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After you have filled in the registration form, you will receive an activation link by e-mail. Once your 

account is activated or if you already have an account, “LOGIN”. 

Navigate over Lebanon, eastern Mediterranean Sea (approximate area – green rectangle).  

 

We need to download 3 Sentinel-1 images over the area of interest, two before the event and one 

after it.  

Zoom in a bit more, switch to “drawing mode” and draw a search rectangle approximately as indicated 

below. Open the search menu by clicking to the left part of the search bar. We will specify at once the 

parameters for both products before the date of the explosion and for the one afterwards as well: 

For Sentinel-1: 

Sensing period: From 2020/07/25 to 2020/08/06 

Select: Mission: Sentinel-1 

Product Type: SLC 

Sensor Mode: IW  

Relative Orbit Number: 21 
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Then click on the “Search”  icon. The search returns 3 results for the time period we set. We need 

to download them all, so we click on the “Download Product”  icon of each one: 

S1B_IW_SLC__1SDV_20200725T033445_20200725T033512_022622_02AEEE_A0BA 

S1A_IW_SLC__1SDV_20200731T033531_20200731T033558_033693_03E7B2_D1A9 

S1B_IW_SLC__1SDV_20200806T033445_20200806T033512_022797_02B43D_3A0B 

 

 

Return to the search menu and set the parameters for the two Sentinel-2 products we will need, one 

before and one after the explosion. Deselect Sentinel-1 mission and apply the following steps. 

For Sentinel-2: 

Sensing period: From 2020/07/24 to 2020/08/18 

Select: Mission: Sentinel-2 

Product Type: S2MSI2A 

 NOTE 1: Please keep in mind that you cannot download more than 2 products at the same time, per 

account from SciHub. 
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Then click on the “Search”  icon. The search returns 6 results for the time period and the area we 
set. If you draw a larger rectangle, you will have more results when searching. Download only the two 

following images by clicking on the “Download Product”  icon: 

S2A_MSIL2A_20200724T081611_N0214_R121_T36SYC_20200724T110803 
S2B_MSIL2A_20200818T081609_N0214_R121_T36SYC_20200818T110855 

 
The products will be downloaded at /home/rus as zip files. Move them to:  

/shared/Training/HAZA08_LebanonDamageAssessment/Original folder. 

5.2 SNAP – open and explore data 

Open SNAP software from the icon located on the desktop  or go to Applications → Processing → 

SNAP Desktop. Click the Open Product icon , navigate to: /shared/Training/HAZA08_LebanonDa 

mageAssessment/Original folder and open all Sentinel-1 products (from oldest to the most recent). 

Alternatively, open a folder in your VM, navigate to the path mentioned above, drag the products from 

the folder one by one and drop them to the Product Explorer Window (first the 20200725, then the 

20200731 and last the 20200806). The opened products will appear in Product Explorer window.  

Click + or to expand the contents of product [1] from 25 July 2020, then expand Bands folder and 

double click on Intensity_IW1_VV band to visualize it in the View window. You can go to the World 

View tab and zoom in to see the location of the opened product on the globe (See  NOTE 2). 
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Open the Intensity_IW2_VV and Intensity_IW3_VV bands as well, and go to Window → Tile 

Horizontally. Go to the Navigation tab and click on the two icons shown within the red rectangular 

below, to synchronize the views and the cursor position between the views. (See  NOTE 3). 

 

 

 

 NOTE 2: The Interferometric Wide (IW) swath mode captures three sub-swaths using Terrain 

Observation with Progressive Scans SAR (TOPSAR). IW SLC products contain one image per sub-swath 

and one per polarisation channel, for a total of three (single polarisation) or six (dual polarisation) 

images in an IW product. Each sub-swath image consists of a series of bursts, where each burst has been 

processed as a separate SLC image. The images for all bursts in all sub-swaths are resampled to a 

common pixel spacing grid in range and azimuth while preserving the phase information. (Source: 

https://sentinel.esa.int/web/sentinel/user-guides/sentinel-1-sar/acquisition-modes/interferometric-

wide-swath) The Beirut port is located on the IW3 sub-swath of the selected images. 

 

 
 NOTE 3: The RADAR instrument onboard Sentinel-1 carries an antenna that is looking always to the right 

during its pass. These two scenes were acquired during descending pass (the satellite was moving in 

direction from north to south). That is why we see that the view of the image appears as if “mirrored”, 

because the view shows the pixels in order of the data acquisition. 

World View 

View Window 

Product 
Explorer 

Navigation 

A
zi

m
u

th
 

Range 

IW1 IW2 IW3 

https://sentinel.esa.int/web/sentinel/technical-guides/sentinel-1-sar/products-algorithms/level-1-algorithms/topsar-processing
https://sentinel.esa.int/web/sentinel/user-guides/sentinel-1-sar/acquisition-modes/interferometric-wide-swath
https://sentinel.esa.int/web/sentinel/user-guides/sentinel-1-sar/acquisition-modes/interferometric-wide-swath
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5.3 Sentinel-1 Processing – Part 1 

We will use the GraphBuilder tool, to create a chain with the steps of the processes we want to apply 

and at the end, only the final product will be physically saved (this way we will also save disk space 

since the products of the intermediate steps will not be stored). 

In this part, we will reach up to the step where we will use two pairs of Sentinel-1 images, in order to 

create two coregistered products. The first pair will consist of the two images before the event, and 

the second pair will consist of the one image right before the event and the other one after it. 

5.3.1 Graph Builder 

Go to Tools → GraphBuilder to build our graph.  

We can see that the graph has only two operators: Read (to read the input) and Write (to write the 

output). Below there also are the corresponding to the operators’ tabs.  

Right-click on the Write operator and Delete it. The corresponding tab will be removed as well. This is 

to avoid confusion to the sequence of the graph. The Write operator will be added again at the end.  

For now, we will not define any parameters in the tabs, we will first create the graph and then we will 

go tab by tab to insert the desired parameters. Follow the instructions written in black to build the 

graph and once it is ready, go back and insert the parameters written in purple. There will be a 

reminder and further instructions when you reach that step. 

 

5.3.2 Read the input products 

There is only one Read operator in the graph (for the first product of the pair) and we will add one 

more, for the second product of the pair. Right-click at the empty white space below the Read operator 

and go to Add → Input-Output → Read. The Read(2) operator will be created. Place it below Read. 

 

 

Right-click on the 

operator and delete it 
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In the Read tab, as Source Product, select the product with Name:  

S1B_IW_SLC__1SDV_20200725T033445_20200725T033512_022622_02AEEE_A0BA 

 

In the Read(2) tab, as Source Product, select the product with Name:  

S1A_IW_SLC__1SDV_20200731T033531_20200731T033558_033693_03E7B2_D1A9 

 

5.3.3 TOPS Split 

Every Interferometric Wide swath (IW) consists of 3 sub-swaths and each one of maximum 9 bursts. 

In SNAP we can process only one swath at a time until the Deburst step. Our area of interest is located 

in the IW3 swath and is covered sufficiently by processing 2 bursts. We will use the TOPSAR-Split 

operator; this way we will reduce the total processing time.  

To add the TOPSAR-Split operator for the first product, right-click right of the Read operator and go 

to Add → Radar → Sentinel-1 TOPS → TOPSAR-Split. Connect the Read operator to it by dragging the 

red arrow from the right side of Read operator towards the TOPSAR-Split operator. 

 

Repeat the same to add the TOPSAR-Split(2) operator and connect it with the Read(2) operator.  

 

In the TOPSAR-Split tab, Zoom in to the product and select: Subswath: IW3, Polarisations: VV, Bursts: 
5 and 6 (drag the two sliders accordingly). 

 

Zoom in 
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In the TOPSAR-Split(2) tab Zoom in to the product and select: Subswath: IW3, Polarisations: VV, 
Bursts: 3 to 4 (drag the two sliders accordingly). 

 

5.3.4 Apply Orbit File 

Next, we will apply the updated orbits to the products (See  NOTE 4). Right-click and go to Add → 

Radar → Apply-Orbit-File. Connect the TOPSAR-Split operator to it. 

 

Repeat the same to add the Apply-Orbit-File(2) operator and connect it with the TOPSAR-Split(2) 

operator.  

 

 

In both the Apply-Orbit-File tab and the Apply-Orbit-File(2) tab, we will keep the default settings, and 

make sure that you will select the “Do not fail if new orbit file is not found” option. 

 

 

5.3.5 Back Geocoding 

Now we will coregister the two products. Image coregistration is the alignment of master and slave 

images, the pixels of the slave images correspond to those of the master and represent an identical 

area. To add the Back-Geocoding operator right-click and go to Radar → Coregistration → S-1 TOPS 

Coregistration → Back-Geocoding. Connect both Apply-Orbit-File and Apply-Orbit-File(2) operators 

to it. 

 NOTE 4: The orbit state vectors provided in the metadata of a SAR product are generally not accurate 

and can be refined with the precise orbit files which are available days-to-weeks after the generation of 

the product. The orbit file provides accurate satellite position and velocity information. Based on this 

information, the orbit state vectors in the abstract metadata of the product are updated. (SNAP Help) 

Zoom in 
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In the Back-Geocoding tab set: Digital Elevation Model: SRTM 1Sec HGT (Auto Download), select the 

“Output Deramp and Demod Phase” option as well and leave the rest parameters as by default. 

 

5.3.6 Enhanced Spectral Diversity 

This operator follows the Back-Geocoding operator, it first estimates a constant range offset for each 

burst using a small block of data in the center of the burst and then it estimates a constant azimuth 

offset. Finally, the estimates from all bursts are averaged to get the final constant range and azimuth 

offset for the whole image.  

To add the Enhanced-Spectral-Diversity operator right-click and go to Radar → Coregistration → S-1 

TOPS Coregistration → Enhanced-Spectral-Diversity. Connect the Back-Geocoding operator to it. 

 

In the Enhanced-Spectral-Diversity tab keep all the default parameters. 

 

5.3.7 Write – create the output 

To add the Write operator right-click and go to Add → Input-Output → Write. Connect the Enhanced-

Spectral-Diversity operator to it. 
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In the Write tab set the following:  
Name: S1_IW_SLC_20200725_20200731_Orb_Stack  
Directory: /shared/Training/HAZA08_LebanonDamageAssessment/Processing (Click on the  icon 
to set the appropriate path). 

 

Click on the  icon to save the graph for future use.  

Go to the: /shared/Training/HAZA08_LebanonDamage 

Assessment/AuxData folder and save it with the name: 

Graph_S1_part1. 

Now go all the way up to the purple parts of the chapters 

5.3.2 to 5.3.7, fill the tabs with the appropriate parameters 

and finally click Run. 

Once the processing is completed, the coregistered product will appear at the Product Explorer 

Window. 

5.3.8 Repeat chapters 5.3.2 to 5.3.7  

We will now keep the same graph we have built, opened, and we will go again tab by tab, to set the 

new parameters in each one, so that we create the coregistered product of the second pair of images. 

In the Read tab, as Source Product, select the product with Name:  

S1A_IW_SLC__1SDV_20200731T033531_20200731T033558_033693_03E7B2_D1A9 

 

In the Read(2) tab, as Source Product, select the product with Name:  

S1B_IW_SLC__1SDV_20200806T033445_20200806T033512_022797_02B43D_3A0B 

 

In the TOPSAR-Split tab Zoom in to the product and select: Subswath: IW3, Polarisations: VV, Bursts: 

3 to 4 (drag the two sliders accordingly). 
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In the TOPSAR-Split(2) tab Zoom in to the product and select: Subswath: IW3, Polarisations: VV, 

Bursts: 4 to 5 (drag the two sliders accordingly). 

 

In both the Apply-Orbit-File tab and the Apply-Orbit-File(2) tab, we will keep the default settings, and 

make sure that you will select the “Do not fail if new orbit file is not found” option. 

 

 

In the Back-Geocoding tab set again: Digital Elevation Model: SRTM 1Sec HGT (Auto Download), select 

the “Output Deramp and Demod Phase” option as well and leave the rest parameters as by default. 

 

In the Enhanced-Spectral-Diversity tab keep all the default parameters. 

 

Zoom in 

Zoom in 



21 
 

 

In the Write tab set the following:  

Name: S1_IW_SLC_20200731_20200806_Orb_Stack  

Directory: /shared/Training/HAZA08_LebanonDamageAssessment/Processing 

 

Click Run. Once the processing is completed, the coregistered product will appear at the Product 

Explorer Window as well. 

If we now expand the Bands folder of both the coregistered products, we will see that they contain 

the information of both the images used. 
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5.4 Sentinel-1 Processing – Part 2 

In this part of the Sentinel-1 processing, we will create another graph where we will apply the 

necessary steps on the two coregistered products, in order to have them ready to extract the 

information showing the damage caused at the area due to the explosion. First, we will perform it for 

the coregistered product with the images before the event, and then for the coregistered product with 

the one image before and the one after the event. 

5.4.1 Graph Builder 

Let’s go again to Tools → GraphBuilder, right-click on the Write operator and Delete it. This time we 

can set the parameters in each tab, along with the creation of the corresponding operator. 

 

In the Read tab, as Source Product, select the product with Name:  

S1_IW_SLC_20200725_20200731_Orb_Stack  

 

5.4.2 Coherence Estimation 

Since we are having in the coregistered product the Intensity bands of both products, we will use the 

Coherence operator, to estimate how well “correlated” the pixels between the master and slave 

images used, are. Right-click and go to Add → Radar → Interferometric → Products → Coherence. 

Connect the Read operator to it. 

 

In the Coherence tab, set as Coherence Range Window Size: 20 and the Coherence Azimuth Window 

Size will automatically turn to 5. 
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5.4.3 TOPS Deburst 

Now we will remove the “black space” between the two bursts (See  NOTE 5). To add the TOPSAR-

Deburst operator right-click and go to Add → Radar → Sentinel-1 TOPS → TOPSAR-Deburst. Connect 

the Coherence operator to it. 

 

In the TOPSAR-Deburst tab keep the default settings (Polarizations: VV). 

 

 

5.4.4 Mulitlooking 

By applying this operator, we will reduce the inherent speckle noise that originally appears to the SAR 

images and we will obtain square pixels. To add the Multilook operator right-click and go to Add → 

Radar → SAR Utilities → Multilook. Connect the TOPSAR-Deburst operator to it. 

 

In the Multilook tab keep the “GR Square Pixel” option selected and set Number of Range Looks: 8. 

The Number of Azimuth Looks will change to 2 and the Mean GR Square Pixel to 27.348389. 

 

5.4.5 Geocoding – Terrain Correction 

We will apply the Terrain Correction operator, to convert the RADAR coordinates into geographic. To 

add the Terrain-Correction operator, right-click and go to Radar → Geometric → Terrain Correction 

→ Terrain-Correction. 

 

In the Processing Parameters tab keep the default parameters. 

 NOTE 5: There is overlapping information in every burst with its neighbouring ones, both in range and 

azimuth direction in order to provide contiguous coverage of the ground. Until now each burst has been 

processed as a separate SLC image We will merge the bursts (in azimuth direction) and preserve the 

phase information as well. For the overlapping region in range, merging is done between subswaths. 
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5.4.6 Subset 

We will now create a Subset of the product, since we do not need the whole extent of it. You can set 

a different area according to your needs, or even skip the Subset step and keep the whole extent. To 

add the Subset operator, go to Add → Raster → Geometric → Subset. 

 

At the Subset tab, select the Geographic Coordinates option. Copy the WKT (well know text) shown 

below from the /shared/Training/HAZA08_LebanonDamageAssessment/AuxData/Expressions folder 

and paste it to the text window below the map.  

 

 

Click Update and then click the Zoom-in icon  to see your subset on the map. 

POLYGON ((35.46431271053535 33.92680438517669, 35.57418094686884 

33.92680438517669, 35.57418094686884 33.85970773162247, 35.46431271053535 

33.85970773162247, 35.46431271053535 33.92680438517669)) 
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5.4.7 Write – create the output 

To create the output of this processing, we will add the Write operator. Right-click and go to Add → 

Input-Output → Write. Connect the Subset operator to it. 

 

In the Write tab set the following:  

Name: S1_IW_SLC_20200725_20200731_Orb_Stack_Coh_Deb_ML_TC_Subset 

Directory: /shared/Training/HAZA08_LebanonDamageAssessment/Processing 

 

Click on the  icon to save the graph for future use. Go to the: /shared/Training/HAZA08_Leba 

nonDamageAssessment/AuxData folder and save it with the name: Graph_S1_part2. 

Click Run. Once the processing is completed, the product will appear at the Product Explorer Window. 

5.4.8 Repeat chapters 5.4.2 to 5.4.7  

We will now keep the same graph we have built, opened, and we will go again tab by tab, to set the 

new parameters in each one, so that we will extract the information showing the damage caused at 

the area due to the explosion, of the second coregistered product (with the one image before and the 

one after the event). Let’s go all the way up to the chapters 5.4.1 to 5.4.7. 

In the Read tab, as Source Product, select the product with Name:  

S1_IW_SLC_20200731_20200806_Orb_Stack  

Zoom in 
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In the Coherence, TOPSAR-Deburst, Multilook and Terrain-Correction tabs, keep the same 

parameters as before. Check each one to make sure they have not been modified. 
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In the Subset tab, keep the same parameters as before. Copy again the WKT (well know text) from the 

/shared/Training/HAZA08_LebanonDamageAssessment/AuxData/Expressions folder and paste it to 

the text window below the map. 

Click Update and then click the Zoom-in icon  to see your subset on the map. 

 
In the Write tab set the following:  

Name: S1_IW_SLC_20200731_20200806_Orb_Stack_Coh_Deb_ML_TC_Subset 

Directory: /shared/Training/HAZA08_LebanonDamageAssessment/Processing 

 
Click Run. Once the processing is completed, the product will appear at the Product Explorer Window. 

 

Zoom in 
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5.5 Sentinel-1 Processing – Part 3  

Now that we have created both final products that include the bands with the estimated coherence, 

we need to put them into one, in order to be allowed to apply the Change Detection operator. To do 

so, we will use the Create Stack operator. 

5.5.1 Create Stack 

Go to Radar → Coregistration → Stack Tools → Create Stack. 

In the 1-ProductSet-Reader tab, click on Add Opened, and all the products that are opened in the 

Product Explorer Window will be loaded. We need to keep only the last two. Select all the previous 

ones, and click on the  icon to remove them.  

Once there are only the 2 products that we want to stack, click on the Refresh  icon. The relative 

information will appear at the rest fields as shown below. 

 

In the 2-CreateStack tab, set as Initial Offset Method: Product Geolocation, and keep the rest 

parameters as by default. 

 

In the Write tab set the following:  

Name: S1_IW_SLC_20200725_20200731_Orb_Stack_Coh_Deb_ML_TC_Subset_Stack 

Directory: /shared/Training/HAZA08_LebanonDamageAssessment/Processing 

Click Run. The Stack product that will contain the coherence bands of both final products, will appear 

at the Product Explorer Window.  
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5.5.2 Change Detection 

This is the final step, where we will detect the changes between the two coherence images, and the 

result of it will show us the damage caused due to the explosion. 

Go to Radar → SAR Applications → Change Detection. 

In the I/O Parameters tab set the following: 

Source: S1_IW_SLC_20200725_20200731_Orb_Stack_Coh_Deb_ML_TC_Subset_Stack 

Name: S1_IW_SLC_20200725_20200731_Orb_Stack_Coh_Deb_ML_TC_Subset_Stack_change 

Directory: /shared/Training/HAZA08_LebanonDamageAssessment/Processing 

 



30 
 

 

In the Processing Parameters tab keep the default parameters and click Run. 

 

The product with the change detection result will appear at the Product Explorer Window. Expand the 

Bands folder and double click on the ratio band to open it at the View Window. You can also expand 

the Masks folder and open the ratio_change band. 

We will work with the ratio band, but you can apply the following steps to the ratio_change band if 

you wish as well. 
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Go to the Colour Manipulation tab on the left and click on the Import Colour Palette  icon. Then, 

navigate to the /shared/Training/HAZA08_LebanonDamageAssessment/AuxData folder, select the 

Damage_S1_change.cpd and click Open. At the window message that appears below, click No. 

 

 

Repeat the last step. Open the palettes Damage_S1_change_1.cpd and Damage_S1_change_2.cpd. 
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5.5.3 Export Sentinel-1 product  

Select the S1_IW_SLC_2020 

0725_20200731_Orb_Stack 

_Coh_Deb_ML_TC_Subset_ 

Stack_change product and 

go to File → Export → 

GeoTIFF.  

The File Name will be set to  

S1_IW_SLC_20200725_2020 

0731_Orb_Stack_Coh_Deb_ 

ML_TC_Subset_Stack_chang 

e.tif.  

At the Save in field, set the 

/shared/Training/HAZA08_LebanonDamageAssessment/Processing path. Click Export Product. 
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5.6 Sentinel-2 Processing – Part 1 

Close SNAP and reopen it, to load the Sentinel-2 products this time. First load the product before the 

event, S2A_MSIL2A_20200724T081611_N0214_R121_T36SYC_20200724T110803 and then the one 

after the event, S2B_MSIL2A_20200818T081609_N0214_R121_T36SYC_20200818T110855. 

5.6.1 Create RGB image 

Right click on the first product and select Open RGB Image Window. At the Profile, select: Sentinel 2 

MSI Natural Colours. The B4, B3 and B2 bands will be selected. Click OK. Right click at the second 

product as well and open another RGB image.  

  

Go to Window → Tile Horizontally to see the two RGB images created side by side. If we zoom in over 

the area of the port, we can clearly see the damages on the right one. 

 

We can close the second image, and right click again on the first one to create another RGB image. 

This time, at the Profile select: Sentinel-2 MSI False-Colour Infrared. The B8, B4 and B3 bands will be 

selected. Click OK.  

We see the different result B8 (NIR) is giving us and this is the band we will use to detect the changes 

over the area once we complete all the pre-processing steps. 
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5.6.2 Graph Builder 

We will create again a Graph, where we will insert all the necessary operators, in order to prepare our 

data for the damage assessment. First, we will apply it for the product before the event and then we 

will repeat it for the product after the event. Go to Tools → GraphBuilder. Right-click on the Write 

operator and Delete it.  

5.6.3 Read inputs 

We will set the parameters in each tab along with the operators. 

 
In the Read tab, as Source Product, select the product with Name:  

S2A_MSIL2A_20200724T081611_N0214_R121_T36SYC_20200724T110803 

 

5.6.4 Resample 

We then need to resample all the Bands so that they have a common resolution, otherwise we cannot 

proceed with the next steps. To add the Resample operator, right-click and go to Add → Raster → 

Geometric → Resample. Connect the Read operator to it. 

 
In the Resample tab, select under the “Define size of resampled product” select the option: By 

reference band from source product and then select B2. This way we will resample all the bands in 

20m. If you want to resample them in e.g. 10m, you can select the B1 band. 
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5.6.5 Subset 

We will now create a Subset of the first product, as we did for the Sentinel-1 product before. To add 

the Subset operator, go to Add → Raster → Geometric → Subset. 

 

At the Subset tab, select the Geographic Coordinates option and copy the WKT (well know text) from 

the /shared/Training/HAZA08_LebanonDamageAssessment/AuxData/Expressions folder as 

mentioned before and paste it to the text window below the map.  

Click Update and then click the Zoom-in icon  to see your subset on the map. 

 

5.6.6 Write – create the outputs 

To create the output of this processing, we will add the Write operator. Right-click and go to Add → 

Input-Output → Write. Connect the Subset operator to it. 

 

In the Write tab set the following:  

Name: S2_MSIL2A_20200724_resampled_subset 

Directory: /shared/Training/HAZA08_LebanonDamageAssessment/Processing 

 

Click on the  icon to save the graph for future use. Go to the: /shared/Training/HAZA08_Leba 

nonDamageAssessment/AuxData folder and save it with the name: Graph_S2. 

Click Run. Once the processing is completed, the product will appear at the Product Explorer Window. 

Zoom in 
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5.6.7 Repeat chapters 5.6.3 to 5.6.6 

Now let’s repeat the same steps for the second product. 

In the Read tab, as Source Product, select the product with Name:  

S2B_MSIL2A_20200818T081609_N0214_R121_T36SYC_20200818T110855 

 

In the Resample and Subset tabs, keep the same parameters as before. Check each one to make sure 

they have not been modified. 

 

 

In the Write tab set the following:  

Name: S2_MSIL2A_20200818_resampled_subset 

Directory: /shared/Training/HAZA08_LebanonDamageAssessment/Processing 

 

Click Run. Once the processing is completed, the product will appear at the Product Explorer Window. 

You can open both Subset products at the View Window, to see their extent. 

Zoom in 
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5.7 Sentinel-2 Processing – Part 2 

Once we have both products subset, we need to put them in one, as we did before with the Sentinel-

1 products. For sentinel-2 products, we will use the Collocation operator.  

5.7.1 Collocation 

Go to Raster → Geometric Operations → Collocation. 

As “Master” product, select the S2_MSIL2A_20200724_resampled_subset 

As “Slave” Product, click on the Add product(s) and select the S2_MSIL2A_20200724_resampled_ 

subset and click OK. 

 

As “Name”, set S2_20200724_20200818_collocate 

Under the “Renaming of Source Product Components”, at “Rename master components” set: 

${ORIGINAL_NAME}_20200724 and at “Rename slave components” set: 

${ORIGINAL_NAME}_20200818. 

Click Run and once the processing is completed, the collocated product will appear in the Product 

Explorer Window. 
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5.7.2 Sea Mask 

We want to remove the pixels that correspond to the Sea. Go to Raster → Masks → Land/Sea Mask. 

In the I/O Parameters tab set as “Source Product”: S2_20200724_20200818_collocate, as “Name”: 

S2_20200724_20200818_collocate_msk and as directory /shared/Training/HAZA08_LebanonDama 

geAssessment/Processing 
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In the Processing Parameters tab, at the “Source Bands” keep the Ctrl pressed and select only the 

B8_20200724 and B8_20200818 bands. Check the Mask out the Sea option and click Run. 

 

If we open the B8 bands of the masked, collocated product, we will see that the sea has been removed. 

 

5.7.3 Band Maths 

Next, we want to create the final band that will show us the areas that have been damaged. For this, 

we right-click on the S2_20200724_20200818_collocate_msk product and click on the “Band Maths”. 

Set as “Name”: S2_change and deselect the “Virtual (save expression only, don’t store data) option”. 

Then click on ”Edit Expression” and insert the following: B8_20200724 - B8_20200818. Click OK in both 

windows. The new band will be created in the product. Double click and open it. 

Select: 

B8_20200724 

B8_20200818 
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If you want to save this band, right click on the product and click on “Save 

Product”. 

Click on the Import Colour Palette  icon. Then, navigate to the 

/shared/Training/HAZA08_LebanonDamageAssessment/AuxData folder, 

select the Damage_S2.cpd and click Open.  

At the window message that appears below, click No. In red we can see 

the areas that have been damaged from the explosion. 
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5.7.4 Reprojection 

The last step is to reproject the product so that we can insert it in QGIS. Go to Raster → Geometric 

Operations → Reprojection. 

In the I/O Parameters tab set the following: 

Source: S2_20200724_20200818_collocate_msk 

Name: S2_20200724_20200818_collocate_msk_reprojected 

Directory: /shared/Training/HAZA08_LebanonDamageAssessment/Processing 

 

In the Reprojection Parameters tab, keep all the parameters as by default. 

Click Run. 
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5.7.5 Export Sentinel-2 product 

Select the S2_20200724_20200818_collocate_msk_reprojected product and go to File → Export → 

GeoTIFF. Click on Subset and select only the S2_change band. Click OK. The File Name will be set to 

S2_20200724_20200818_collocate_msk_reprojected.tif. At the Save in field, set the 

/shared/Training/HAZA08_LebanonDamageAssessment/Processing path. Click Export Product. 

  

5.8 QGIS Visualization 

Open QGIS and load the S1_IW_SLC_20200725_20200731_Orb_Stack_Coh_Deb_ML_TC_Subset_ 

Stack_change.tif and the S2_20200724_20200818_collocate_msk_reprojected.tif at the Layers 

panel. Right-click on the S1 product and go to “Properties”.  

In the “Symbology” tab, set at “Render Type” Singleband Pseudocolour 

On “Style”, click and select “Load Style”. Navigate to the /shared/Training/HAZA08_LebanonDamage 

Assessment/AuxData folder, select Damage_S1.qml and click Open to load the palette.  

We see that there is a black background in both images, so we will remove it by going in the 

“Transparency” tab and set as “Additional no data value”: 0 
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Click OK. 
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Repeat the same steps for the Sentinel-2 product in the Symbology and the Transparency tabs, and 

when going at Load Style, select the Damage_S2.qml palette. 

 
Go to Web → OpenLayers plugin → Bing Maps → Bing Aerial with labels (See  NOTE 6). 

 

 NOTE 6: In case the OpenLayers plugin is not installed, click on Plugins → Manage and Install Plugins. 

Select the “All” tab on the left side panel and write “OpenLayers plugin” on the search box. If you cannot 

find it, go to “Settings” and select the “Show also experimental plugins” option. Go back to the “All” 

tab, select the plugin on the list and click “Install Plugin”. Restart QGIS to finalize the installation. 
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Now that we have added a basemap at the 

background, we can select which tif. files we 

want to visualize on the top of them.  

For example, we see the Sentinel-1 product with 

the Damage_S1_2 palette (right), the Sentinel-2 

product with the Damage_S2 palette, (bottom 

left) and both S-1 and S-2 products (bottom right) 

  

6 Extra Steps 

6.1 Download files from VM  

In your VM, press Ctrl+Alt+Shift.  

A pop-up window will appear on the left side of the screen. Click on the bar below Devices, navigate 

to the folders you have saved the files you want to download and double click on them. The 

downloading process to your local computer will start automatically.  

 

 

 

THANK YOU FOR FOLLOWING THE EXERCISE! 
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7 Further reading and resources 

• https://sentinel.esa.int/web/sentinel/missions/sentinel-1 - Sentinel-1 Mission 

• https://sentinel.esa.int/web/sentinel/missions/sentinel-2 - Sentinel-2 Mission 
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