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1 Introduction 

The Research and User Support for Sentinel core products (RUS) service provides a free and open 

scalable platform in a powerful computing environment, hosting a suite of open source toolboxes pre-

installed on virtual machines, to handle and process data derived from the Copernicus Sentinel 

satellites constellation. 

2 Typhoon Hagibis  

Hagibis was the biggest typhoon to hit Japan in 

decades and was considered to be the most 

devastating typhoon to hit the Kantō region of 

Japan since Ida in 1958. The system reached 

tropical storm status late on 5 October as it 

travelled westward. On 12 October, Hagibis 

made landfall at Izu Peninsula as a Category 2.  

With extreme events like this likely to increase 

in number and in severity as a consequence of 

climate change, satellites are playing an 

increasingly important role in understanding and tracking huge storms. Sentinel-1 is especially valuable 

as it can “see” through clouds and help map the scale of flooded areas immediately during the event 

and well as the damage afterwards even in absence of cloud free optical imagery.  

In this exercise we will use two different Sentinel-1 Level-1 data products to look at different aspects 

of the typhoon. The Ground Range Detected product will be used to map flooded areas during the 

event, while the loss od coherence resulting from damage after the flooding subsided will be derived 

from the Single Look Complex data.  

3 Training 

Approximate duration of this training session is two hours.  

The Training Code for this tutorial is HAZA06. If you wish to practice the exercise described below 

within the RUS Virtual Environment, register on the RUS portal (rus-copernicus.eu) and open a User 

Service request from Your RUS service > Your dashboard. 

3.1 Data used 

• Five Sentinel-1 images acquired between September 24 and October 18, 2019, two are GRD data 

products and three are the SLC data products. [downloadable @ https://scihub.copernicus.eu/]  

S1B_IW_GRDH_1SDV_20191012T204154_20191012T204223_018447_022C0C_B106 

S1A_IW_GRDH_1SDV_20191006T204235_20191006T204300_029343_0355EA_C9CC 

S1A_IW_SLC__1SDV_20191018T204233_20191018T204300_029518_035BEF_380F 

S1A_IW_SLC__1SDV_20191006T204233_20191006T204300_029343_0355EA_AFB2 
S1A_IW_SLC__1SDV_20190924T204233_20190924T204300_029168_034FDF_708B 

• Auxiliary data stored locally  

@/shared/Training/HAZA06_WatchingATyphoon_Hagibis_TrainingKit/AuxData 

Damage caused by typhoon Hagibis Credits: japan-forward.com 

https://rus-copernicus.eu/portal/
https://scihub.copernicus.eu/
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3.2 Software in RUS environment 

Internet browser, SNAP + Sentinel-1Toolbox 

4 Register to RUS Copernicus 

To repeat the exercise using a RUS Copernicus Virtual Machine (VM), you will first have to register as 

a RUS user. For that, go to the RUS Copernicus website (www.rus-copernicus.eu) and click on 

Login/Register in the upper right corner.  

 

Select the option Create my Copernicus SSO account and then fill in ALL the fields on the Copernicus 

Users’ Single Sign On Registration. Click Register. 

 

Within a few minutes you will receive an e-mail with activation link. Follow the instructions in the e-

mail to activate your account.  

You can now return to https://rus-copernicus.eu/, click on Login/Register, choose Login and enter 

your chosen credentials. 

http://www.rus-copernicus.eu/
https://rus-copernicus.eu/
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Upon your first login you will need to enter some details. You must fill all the fields.   

 

5 Request a RUS Copernicus Virtual Machine 
Once you are registered as a RUS user, you can request a RUS Virtual Machine to repeat this exercise 

or work on your own projects using Copernicus data. For that, log in and click on Your RUS Service → 

Your Dashboard.  
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Click on Request a new User Service to request your RUS Virtual Machine. Complete the form so that 

the appropriate cloud environment can be assigned according to your needs. 
  

 
 

If you want to repeat this tutorial (or any previous one) select the one(s) of your interest in the 

appropriate field. 

 

 
 

Complete the remaining steps, check the terms and conditions of the RUS Service and submit your 

request once you are finished. 
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Further to the acceptance of your request by the RUS Helpdesk, you will receive a notification email 

with all the details about your Virtual Machine. To access it, go to Your RUS Service → Your Dashboard 

and click on Access my Virtual Machine.  
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Fill in the login credentials that have been provided to you by the RUS Helpdesk via email to access 

your RUS Copernicus Virtual Machine.  

 

This is the remote desktop of your Virtual Machine. 

 

6 Step by step  

6.1 Data download – ESA SciHUB 

In this step, we will download a Sentinel-2 scene from the Copernicus Open Access Hub using the online 

interface (Applications → Network → Firefox Web Browser or click the link below). 

Go to https://scihub.copernicus.eu/   

https://scihub.copernicus.eu/
https://scihub.copernicus.eu/
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Go to “Open HUB”, if you do not have an account please register by going to “Sign-up” in the LOGIN 

menu in the upper right corner. 
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After you have filled in the registration form, you will receive an activation link by e-mail. Once your 

account is activated or if you already have an account, “LOGIN”.  

Navigate on the map to the island of Honsu in Japan. Then change to the drawing mode (indicated by 

green arrow below) and draw a rectangle arround the city of Sendai.  

Open search menu by clicking to the left part of the search bar and specify following parameters: 

Sensing period: From 2019/10/06 to 2019/10/12 

Check Mission: Sentinel-1 

Product Type: GRD 

Sensor Mode: IW 

Relative Orbit Number: 46 

 

Click on the magnifying glass symbol to start the search. In our case the search returns 2 results, but it 

will depend on the exact search rectangle you have defined. 

 

 

TIP: It may sometimes happen that the data used to create this exercise are temporarily unavailable. 

In such case, you can use other date period for the same location. 
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Go through the list and select these 2 full scenes by checking the box next to the product name:  

• S1B_IW_GRDH_1SDV_20191012T204154_20191012T204223_018447_022C0C_B106 

• S1A_IW_GRDH_1SDV_20191006T204235_20191006T204300_029343_0355EA_C9CC 

Once they are all selected click on  to add the products to the cart. A little green cart symbol should 

appear next to the product name.  

Then return to the search parameters  and change them as follows: 

Sensing period: From 2019/09/24 to 2019/10/18 

Check Mission: Sentinel-1 

Product Type: SLC 

Sensor Mode: IW 

Relative Orbit Number: 46 

Then press search again. The search returns 4 results, but it will depend on the exact search rectangle 

you have defined.  

Go through the list and select these 3 full scenes by checking the box next to the product name:  

• S1A_IW_SLC__1SDV_20191018T204233_20191018T204300_029518_035BEF_380F 

• S1A_IW_SLC__1SDV_20191006T204233_20191006T204300_029343_0355EA_AFB2 
• S1A_IW_SLC__1SDV_20190924T204233_20190924T204300_029168_034FDF_708B 

Once they are all selected click on  to add the products to the cart.  

 

Then go to the cart by clicking on the green cart symbol left of the full text search. There should be 5 

products in your cart.  

Finally, let’s download the cart in the form of .meta file. The file contains links to each of the files, we 

will need the file and download client to download the actual data.  
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The products.meta4 file will be downloaded to your /home/rus folder. To download our data, we will 

use aria2 tool. To use the tool, we first need to move the products.meta4 file to the folder where we 

wish our data to be downloaded to - /shared/Training/HAZA06_WatchingATyphoon_Hagibis/Original/ 

Then, let’s test our aria2 installation. To do this we open the Command Line  (in the bottom of your 

desktop window), type the following and press Enter: 

 

The correct response should be as follows: 

 

If the response is “-bash aria2c: command not found” (see  NOTE 1). 

 

If you have received the correct response, then we can run the tool by typing following commands in 

the command line (replace <username> and <password> with your login credentials for Copernicus 

Open Access Hub):  

 

The first line changes our directory to the target directory. The second line runs the download tool 

(Type the red text all in single line). All five products will be downloaded to the Original folder two 

aria2c 

 NOTE 1: If (and only if) the response is “-bash aria2c: command not found”. Then we have to install the 

tool, to do this in command line type: sudo apt-get install aria2 

When requested type: Y 

Then you can test your installation again.  

cd /shared/Training/HAZA06_WatchingATyphoon_Hagibis/Original/ 

 

aria2c --http-user='<username>' --http-passwd='<password>' --check-

certificate=false --max-concurrent-downloads=2 -M products.meta4 
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products in parallel automatically (Note that the constraint of maximum two parallel downloads at a 

time is imposed by the Copernicus Access Hub, if you increase the number the download will fail). This 

might take some time.  

When the products are downloaded move them to the appropriate directories inside the /Original 

folder based on the product type.  

6.2 Storm Surge and flooding – Sentinel-1 GRDH  

In the first part of this exercise we will identify the area flooded when typhoon Hagibis made a landfall 

on 12 October 2019. We will use the Ground Range Detected (GRD) data, which consist of focused SAR 

data that has been detected, multi-looked and projected to ground range using an Earth ellipsoid 

model. Phase information is lost.  

Launch SNAP . When SNAP window opens click Open product , navigate to 

/shared/Training/HAZA06_WatchingATyphoon_Hagibis_TutorialKit/Original/GRDH and open the 

*.zip files.  

The opened products will appear in Product Explorer. Click + or the  to expand the contents of the 

file from 6 October 2019, then expand Bands and double click Amplitude_VV to visualize the band. 

Then do the same for the image from 12 October 2019. To compare both images, go to Window → 

Tile Horizontally and zoom-in to the coastal area on the mid left side of the image. 

 

 

6.2.1 Pre-processing 

We need to apply identical pre-processing steps to all our scenes. However, processing the data step 

by step and product by product would be time consuming and inconvenient. Luckily, we can use the 

TIP: We can see that the view appears “mirrored to the side”: this is because the scene was acquired 

during descending pass (the satellite was moving in north to south direction looking to the west) and 

the view shows the pixels in order of data acquisition as the image is not yet projected into 

cartographic coordinates. 
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Batch Processing tool available in SNAP to apply all steps to both images in one go (this also saves disk 

space as only the final products are physically saved). 

6.2.1 Build the Graph 

To use the tool, we first need to define the process we want to apply and all its steps. We can do this 

using the GraphBuilder. To build our graph, go to Tools → GraphBuilder.  

 

At the moment, the graph only has two operators: Read (to read the input) and Write (to write the 

output).  

First, we will update the orbit metadata (See  NOTE 2). To add the operator, right-click the white 

space between existing operators and go to Add → Radar → Apply-Orbit-File. A new operator 

rectangle appears in our graph and a new tab appears below. Now connect the new Apply-Orbit-File 

operator to the Read operator by clicking to the right side of the Read operator and dragging the red 

arrow towards the Apply-Orbit-File. 

 

 

The next step will remove the thermal noise (See  NOTE 3). We do this by right-clicking the white 

space and going to Add → Radar → Radiometric → ThermalNoiseRemoval. Connect the 

ThermalNoiseRemoval operator with the Apply-Orbit-File operator.  

 

 NOTE 2: The orbit state vectors provided in the metadata of a SAR product are generally not accurate 

and can be refined with the precise orbit files which are available days-to-weeks after the generation of 

the product. The orbit file provides accurate satellite position and velocity information. Based on this 

information, the orbit state vectors in the abstract metadata of the product are updated. (SNAP Help) 

 NOTE 3: Thermal noise in SAR imagery is the background energy that is generated by the receiver itself.   

(SNAP Help) It skews the radar reflectivity to towards higher values and hampers the precision of radar 

reflectivity estimates. Level-1 products provide a noise LUT for each measurement dataset, provided in 

linear power, which can be used to remove the noise from the product. 
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Now, we can add the Calibration operator. The objective of SAR calibration is to provide imagery in 

which the pixel values can be directly related to the radar backscatter. Though uncalibrated SAR 

imagery is sufficient for qualitative use, calibrated SAR images are essential to quantitative use of SAR 

data (See  NOTE 4). To add the operator go to Add → Radar → Radiometric → Calibration. Connect 

the ThermalNoiseRemoval operator to the Calibration operator. 

 

 

SAR images have inherent salt and pepper like texturing called speckles which degrade the quality of 

the image and make interpretation of features more difficult (See  NOTE 5). To reduce the speckle 

effect and smooth the image we apply speckle filter. To add the operator, go to Radar → Speckle 

Filtering → Speckle-Filter then connect the Calibration operator to it. 

 

 

Our data are still in radar geometry, moreover due to topographical variations of a scene and the tilt 

of the satellite sensor, the distances can be distorted in the SAR images. Therefore, as the last step of 

our pre-processing, we will apply terrain correction to compensate for the distortions and reproject 

the scene to geographic projection (See  NOTE 6). To add the operator, go to Radar → Geometric 

→ Terrain Correction → Terrain-Correction and then connect the Speckle-Filter operator to it.  

 

 

Next, since our Area of Interest (AOI) is quite small and there is no need to process the whole image, 

so we will add a Subset operator. To add the operator right-click the white space in the graph builder 

and go to Add → Raster → Geometric → Subset. Connect the new Terrain-Correction operator to the 

Subset operator.  

 NOTE 4: Typical SAR data processing, which produces level-1 images, does not include radiometric 

corrections and significant radiometric bias remains. The radiometric correction is necessary for the pixel 

values to truly represent the radar backscatter of the reflecting surface and therefore for comparison of 

SAR images acquired with different sensors or acquired from the same sensor but at different times, in 

different modes, or processed by different processors. (SNAP Help) 

 NOTE 5: Speckle is caused by random constructive and destructive interference of the de-phased but 

coherent return waves scattered by the elementary scatters within each resolution cell. Speckle noise 

reduction can be applied either by spatial filtering or multilook processing. (SNAP Help) 

NOTE 6: The geometry of topographical distortions in SAR 

imagery is shown on the right.  Here we can see that point B 

with elevation h above the ellipsoid is imaged at position B’ in 

SAR image, though its real position is B".  The offset Δr between 

B' and B" exhibits the effect of topographic distortions. (SNAP 

Help) 
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Finally, we will convert the values to decibel to enhance the contrast. To do this go to Raster → Data 

Conversion → LinearToFromDb. Then connect the Subset operator to it and connect the 

LinearToFromDb operator to the Write operator.  

 

For the moment, do not change anything in the parameter tabs and save the graph as 

Graph_preprocess.xml to:  

/shared/Training/Training/HAZA06_WatchingATyphoon_Hagibis/Processing/Flood_mapping/ by 

clicking Save at the bottom of the window. After you save the graph, close the GraphBuilder window. 

6.2.2 Batch processing 

In the Product Explorer, we select (highlight) the product [1]. Now we can open the Batch Processing 

tool at Tools → Batch Processing. 

We will add the opened products by clicking Add Opened on the upper right (second icon from the 

top) and click Refresh. Then click Load Graph at the bottom of the window and navigate to our saved 

graph and open it. We see that new tabs have appeared at the top of window corresponding to our 

operators except for Write; this is correct as these parameters will be set in the I/O Parameters tab.  

In the I/O Parameters tab, set directory to: 

/shared/Training/Training/HAZA06_WatchingATyphoon_Hagibis/Processing/Flood_mapping/ and 

deselect the “Keep source product name” option. (See  NOTE 7). 

 

 

Now let’s set the parameters.  

In the Apply-Orbit-File tab we well keep the default settings.  

 NOTE 7: The product file names will be identical to the input file names. If you set your output directory 

to the folder that contains your input data, the input data will be overwritten! 
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In the ThermalNoiseRemoval tab, select VV polarization and make sure that the “Remove Thermal 

Noise” option is selected. 

 

In the Calibration tab, we will also keep all default settings.   

 

Now we go to the Speckle-Filter tab. For this exercise we choose the simple Lee filter with Window 

Size of 3x3 pixels (See  NOTE 8).  

 

 

Last, we go in the Terrain-Correction tab, set Digital Elevation Model to SRTM 1Sec HGT (Auto 

Download), then click on the Map Projection and set as Projection: UTM / WGS84 (Automatic).  

 NOTE 8: Lee Filter, introduced by Jong-Sen Lee in 1980, is a widely used local statistics filter for speckle 

noise reduction. It is a pointwise linear filter minimizing the mean square error using measurements of 

the sample mean and sample variance of the noisy image and knowledge of the type of detection and 

number of looks. 
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Click OK. At the “Map Projection” you will see: UTM Zone 36, South / World Geodetic System 1984. 

  

 

 

Leave all the other default settings.  

In the Subset tab, click to select the Geographic Coordinates option and paste the area of interest 

definition in WKT (well know text) format to the text window below the map. Click Update and then 

click the Zoom-in icon  to see your subset on the map.  

 

POLYGON ((140.638 38.923, 141.699 38.922,141.690 37.969, 140.643 37.970, 140.638 

38.923)) 
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In the LinearToFromdB, leave the default settings. Finally, in the Write tab, set the output folder to:  

/shared/Training/Training/HAZA06_WatchingATyphoon_Hagibis/Processing/Flood_mapping/     

Click Run to pre-process our images. Approximate processing time: 5 minutes 

Now you should have two new products in the Product Explorer. Select the original products [1-2], 

right-click on them and click Close 2 Products (Click No if asked to save).  

6.2.3 Stack 

In this step we will stack our images into a single product to be able to compare the changes in values 

due to the flooded area.  

To create a stack, we will go to Radar → Coregistration → Stack Tools → Create Stack.  

Similarly, as in Batch Processing, in the 1-ProductSet-Reader tab, we will add the opened products by 

clicking Add Opened on the upper right (second icon from the top) and click Refresh.  

 

Then in the 2-CreateStack tab, click on Find Optimal Master and set: 

Resampling Type: NEAREST_NEIGHBOUR 

Initial Offset Method: Product Geolocation 

 



20 
 

In the 3-Write tab, rename the product to Subset_S1A_IW_GRDH_20191006_20191012_Prep_Stack 

and change the Directory to:   

 /shared/Training/HAZA06_WatchingATyphoon_Hagibis_TrainingKit/Processing/Flood_Mapping 

 

Then click Run.  Approximate processing time: 45 seconds 

In the next step we will reassign the NoData value to NaN (“Not a Number”) to facilitate better 

visualization later. Go to Raster → Data Conversion → Set No-Data Value.  

In the I/O Parameters tab, make sure that product [5] is selected and directory is set to 

.../Flood_Mapping and add “_nD” to the output name. In the Processing Parameters tab, set: 

No Data Value: NaN 

 

Click Run.  

In the last step we will mask out the open ocean to make to the comparison clearer. To do this we will 

use a shapefile of Japan land mass. In the Product Explorer go to the stack product with No Data [6] 

and click on it to highlight it, then from Bands open Sigma0_VH_db_slv1_12Oct2019 (double click). 

Then go to Vector → Import ESRI Shapefile.  
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Navigate to /shared/Training/HAZA06_WatchingATyphoon_Hagibis_TrainingKit/AuxData/Shapefile and 

select JPN_adm0.shp, click Open. The shapefile will be overlaid on top of the view. It will also appear 

in the Vector Data folder in the product. 

 

Then to apply the mask we will go to Raster → Masks → Land/Sea Mask.  

In the I/O Parameters tab, make sure that product [6] is selected and directory is set to 

.../Flood_Mapping. In the Processing Parameters tab, set “Use Vector Mask” the loaded vector 

JPN_adm0 should be selected automatically.  

 

Then click Run.  

When the new product appears in the Product Explorer, go to the masked product [7] and in the Vector 

Data folder right-click on JPN_adm0 and delete it. 

Now, we can visualize multitemporal RGB composites to better identify the flooded area. First close 

all views if any are opened.   
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Now, in the Product Explorer right-click on the stack product [7] and go to Open RGB Image Window. 

(See  NOTE 9). 

Set: Red:  $7.Sigma0_VH_db_mst_06Oct2019        

Green:  $7.Sigma0_VH_db_slv1_12Oct2019        

Blue:  $7.Sigma0_VV_db_mst_06Oct2019 

 

 

To separate new open water areas, we can use multiple methods. We can use classification, single 

band thresholding or difference-band thresholding among others. As is visible on the image above, 

flooded areas with open water will have significantly lower backscatter in VH than they had before the 

event (not flooded). Therefore, by subtracting the VH band of 12 October (during the event) from the 

VH band of 6 October (before the event) we should be able to isolate them.  

In the Product Explorer, right-click on the masked product [7] and go to Band Maths … In the menu 

that appears set:  

Name: Diff_06Oct_12Oct_VH 

Deselect Virtual (save expression only don’t save data) 

Click on Edit Expression… and set as Expression:  

NOTE 9: In this band combination the areas that 

appear purple represent pixels that were darker during 

the flood event than before → new open water 

surfaces. Brighter green areas represent pixels that are 

brighter during the event compared to pre event 

image → Wet soil and semi submerged vegetation. 

Blue and white areas represent build up. 

Sigma0_VH_db_mst_06Oct2019 - Sigma0_VH_db_slv1_12Oct2019 



23 
 

 

Click OK. The new band will be immediately opened in view. Repeat the step for VV.  

Name: Diff_06Oct_12Oct_VV 

Deselect Virtual (save expression only don’t save data) 

Click on Edit Expression… and set as Expression:  

 

Once the band is opened go to Window → Tile Horizontally.   

 

Click into the VH View and go to Colour Manipulation tab, right click on the middle slider and remove 

it (click on Delete). Then move the white slider to 6.0. at the bottom of the tab go to More Options 

and select Discrete colours.  

For VV do not delete the middle slider but set it to -5.0 set the white threshold to 5.0. We can also 

change the colour of the sliders by clicking on them (In this example we have changed the black slider 

to red and the grey to black).  

Sigma0_VV_db_mst_06Oct2019 - Sigma0_VV_db_slv2_12Oct2019 

RGB VH VV 
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The red areas in VV then correspond to areas where is potentially submerged vegetation as VV 

generally penetrates deeper in canopy than VH and newly submerged vegetation can appear brighter. 

However, the brighter values can also be caused by wet bare soil (higher backscatter due to higher 

dielectric constant). 

We can apply the same thresholds using Band Math … to create binary bands with conditional 

expressions.  

VH:  

VV:  

 

  

if Diff_06Oct_12Oct_VH > 6.0 then 1 else 0 

if Diff_06Oct_12Oct_VV > 5.0 then 1 else (if Diff_06Oct_12Oct_VV > - 

5.0 then 0 else -1) 
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6.3 Damage detection – Sentinel-1 SLC 

In the second part of this exercise we will calculate difference in coherence for a pair prior to the event 

and a pair during the event.  Then we can identify the areas with significant coherence loss presumed 

expected to correspond to damaged areas due to surface damage. 

Re-start SNAP ( ). When SNAP window opens click Open product , navigate to 

/shared/Training/HAZA06_WatchingATyphoon_Hagibis_TrainingKit/Original/SLC and open the three 

*.zip files. 

The opened products will appear in the Product Explorer on the left. Expand the first image to the left 

and select Bands. Right click on the “Intensity_IW1_VH” and select Open Image Window to create and 

visualize the image for the selected band. (See  NOTE 10). 

 

The image appears in the upper left corner of the View window. Do the same for the next products. 

To synchronize the views, go to Navigation pane in the lower left (red arrow) and make sure the cursor 

   and the views   are linked. 

 
Credits: ESA User Guides for Sentinel-1 SAR 

NOTE 10: The Interferometric 

Wide (IW) swath mode 

captures three sub-swaths 

using Terrain Observation with 

Progressive Scans SAR 

(TOPSAR). Each sub-swath 

image consists of a series of 

bursts. The input product 

contains 3 IW bands, and 9 

bursts.  

https://sentinel.esa.int/web/sentinel/technical-guides/sentinel-1-sar/products-algorithms/level-1-algorithms/topsar-processing
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6.3.1 Coherence Estimation 

Although in this step we cannot use batch processing we can use the graph builder to simplify the 

process instead of running each step manually. Therefore, the processing chain we will follow will be 

represented by a graph and saved as an XML file. 

In order to open Graph Builder tool, go to Tools → GraphBuilder.  

Initially, the graph has two operators: Read (to read the input) and Write (to write the output). First, 

DELETE the Write operator (right-click on it and select Delete).  

With right-click on the top panel, you can add an operator, while a corresponding tab with all involving 

parameters is created and added on the bottom panel.   

 

Our aim is to produce two coherence images that correspond accordingly to the period prior and 

during the event. For each we have to create a graph and process the image pair. Let’s start with the 

first coherence image, for the pre-event period, by using the images of 24 September and 6 October 

2019. 

In the Read operator, select the input image: 

S1A_IW_SLC__1SDV_20190924T204233_20190924T204300_029168_034FDF_708B 

To add a new Read operator for the second image, go to Add → Input-Output → Read. It will be 

denoted as Read(2). Then, select as input image: 

S1A_IW_SLC__1SDV_20191006T204233_20191006T204300_029343_0355EA_AFB2 

Since the area of interest is included only in six bursts of the Sentinel-1 image, there is no need to 

process the entire sub-swath with all 9 bursts (See  NOTE 11). The TOPSAR Split operator provides 

a convenient way to split each sub-swath with selected bursts into a separate product. To add the S-1 

TOPSAR Split operator click Radar → Sentinel-1 TOPS → S-1 TOPS Split. 

 

NOTE 11: The extraction of bursts in a sub-swath covering the area of interest may differ in Sentinel-1 

images acquired on different dates.  
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A new operator rectangle appears in our graph and a new tab appears below. Now connect the new 

TOPSAR Split operator with the first Read operator by clicking to the right side of the Read operator 

and dragging the red arrow towards the TOPSAR Split operator.  

Repeat the same for the Read(2) operator to have graph as shown below. 

 

In the TOPSAR Split tab, select the following parameters.  

Subswath: IW1 

Polarisations: VV 

Bursts: 3 to 8 

In bursts selection click on the arrows and drag up to the specified number of bursts. 

 

Repeat the same step for the TOPSAR Split(2).  

 

We now continue by applying the orbit files in Sentinel-1 products in order to provide accurate satellite 

position and velocity information. To add the operator, right-click to the right of the TOPSAR-Split 

operator and go to Add → Radar → Apply-Orbit-File, then connect the new operator to the TOPSAR-

Split. Now do the same to add the Apply-Orbit-File(2). 

 

In the Apply-Orbit File tab, select the parameters: 
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Orbit State Vectors: Sentinel Precise (Auto Download) 

Check “Do not fail if new orbit file is not found” 

 

Now set the same parameters for the Apply-Orbit-File(2) operator. 

Next step will be to co-register the two Sentinel-1 images. For this reason, the second image (slave) 

will be co-registered with respect to the first image (master). Sentinel-1 Back Geocoding operator co-

registers two S-1 split products (master and slave) of the same sub-swath using the orbits of the two 

products and a Digital Elevation Model (DEM). Right-click somewhere between the Apply-Orbit-File 

operators and go to Add → Radar → Coregistration → S-1 TOPS Coregistration → Back-Geocoding. 

Connect the Back-Geocoding operator with BOTH the Apply-Orbit-File operators.  

 

In the Back-Geocoding tab, set SRTM 1Sec HGT as Digital Elevation Model to use and check Output 

Deramp and Demod Phase. 

 

In this step, the coherence image is estimated from the stack of the coregistered complex images. To 

add the Coherence operator go to Add → Radar → Interferometric → Products → Coherence and 

then connect the Coherence operator to Back-Geocoding operator. 

 

In the Coherence tab set the following parameters: 

Check Substract flat-earth phase 

Coherence Range Window Size: 20 

Coherence Azimuth Window Size: 6 (changes automatically) 
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We continue the processing steps with Sentinel-1 TOPSAR Deburst. We have seen that each sub-swath 

image consists of a series of bursts, where each burst has been processed as a separate SLC image. The 

individually focused complex burst images are included, in azimuth-time order, into a single sub-swath 

image with black-fill demarcation in between. There is sufficient overlap between adjacent bursts and 

between sub-swaths to ensure the continuous coverage of the ground. The images for all bursts in all 

sub-swaths are resampled to a common pixel spacing grid in range and azimuth while preserving the 

phase information. To add TOPSAR-Deburst operator, go to Add → Radar → Sentinel-1 TOPS → 

TOPSAR-Deburst. 

 

In the TOPSAR-Deburst tab, select Polarizations: VV. Then, connect the TOPSAR-Deburst operator  

with the Coherence operator. 

 

Finally, add the Write operator again by going to Add → Input-Output → Write. Then connect the 

TOPSAR-Deburst operator with the Write operator and in the Write tab define the output directory 

as:   /shared/Training/HAZA06_WatchingATyphoon_Hagibis_TrainingKit/Processing/Damage_Detection 

 

Set the name of the output product as:  S1A_IW_SLC_20190924_20191006_Orb_Stack_Coh_Deb 

At this moment, save the graph as Graph_Coherence_20190924_20191006.xml in 

.../Processing/Damage_Detection folder by clicking Save at the bottom of the window.  

Then click Run. The new product will appear in the Product Explorer when the process finishes. 

Approximate processing time: 45 seconds 
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Once the process is finished, a new product will appear in your Product Explorer tab. Now we will 

generate the the coherence image also for the co-seismic period (period including the seismic event). 

Go back to our graph and in the Read and Read(2) tabs select the following Sentinel-1 scenes as input 

images: 

Read   S1A_IW_SLC__1SDV_20191006T204233_20191006T204300_029343_0355EA_AFB2 

Read(2)   S1A_IW_SLC__1SDV_20191018T204233_20191018T204300_029518_035BEF_380F 

Then, in the Write tab set the name of the output product as: 

S1A_IW_SLC_20191006_20191012_Orb_Stack_Coh_Deb  

Save in the same folder (…/Processing/Damage_Detection/). Once the second coherence product is 

generated, close the Graph Builder window. Then close all opened Views. 

6.3.2 Multilooking 

Go to Product Explorer and expand the first pre-processed product 

S1A_IW_SLC_20190924_20191006_Orb_Stack_Coh_Deb. Then go to Bands and open the coherence 

band by double clicking it. As the original SAR image contains inherent speckle noise, multilook 

processing is applied at this moment to reduce the speckle appearance and to improve the image 

interpretability (See  NOTE 12). Go to Radar → Multilook to open the multilook operator.  

 

In the I/O Parameters tab, set the following parameters: 

Input: S1A_IW_SLC_20190924_20191006_Orb_Stack_Coh_Deb 

Output: S1A_IW_SLC_20190924_20191006_Orb_Stack_Coh_Deb_ML 

Directory: /shared/Training/HAZA06_WatchingATyphoon_Hagibis_TrainingKit/Processing/Damage_Detection 

In the Processing Parameters tab, set the following parameters: 

Number of Range Looks: 3 

Number of Azimuth Looks: 1 

 

 NOTE 12: The multilooking factors are selected in a way to both obtain square pixels and to maintain as 
much as possible the spatial resolution.  
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Then click Run. A new product appeared in the Product Explorer, go to Bands and open the 

multilooked coherence band, then go to Window → Tile Vertically.  

 

Repeat the same step for the second pre-processed product:  

S1A_IW_SLC_20191006_20191012_Orb_Stack_Coh_Deb  

6.3.3 Geocoding 

Due to topographical variations of a scene and the oblique viewing angle of the satellite sensor, 

features appear distorted in SAR images. Terrain corrections are intended to compensate for these 

distortions, so that the geometric representation of the image will be as close as possible to the real 

world, based on selected map geometry. For geocoding the Sentinel-1 products we will use the Range 

Doppler Terrain Correction operator that implements the Range Doppler orthorectification method 

[1].  

We will apply Range Doppler Terrain Correction operator to the multilooked products.  

Go to Radar → Geometric → Terrain Correction → Range-Doppler Terrain Correction to open the 

operator.  

In the I/O Parameters tab, set the following parameters: 

Input: S1A_IW_SLC_20190924_20191006_Orb_Stack_Coh_Deb_ML (first multilooked product) 

Output: S1A_IW_SLC_20190924_20191006_Orb_Stack_Coh_Deb_ML_TC 

Directory: /shared/Training/HAZA06_WatchingATyphoon_Hagibis_TrainingKit/Processing/Damage_Damage 

In the Processing Parameters tab, set the following parameters: 

Pixel Spacing (m): 15 

Map Projection: WGS84(DD) 
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Now, click Run.  Repeat the process for the second multilooked product:   

S1A_IW_SLC_20191006_20191012_Orb_Stack_Coh_Deb_ML 

6.3.4 Create Stack 

The Create Stack operator allows collocating two spatially overlying SAR products, where the pixel 

values of one product are resampled into the geographical raster of the other.  

First, in the Product Explorer select product [1] to [7], right click and select Close 7 products. Now you 

should have only the two multilooked products open.  

To apply Create Stack operator go to Radar → Coregistration → Stack Tools → Create Stack. 

In the ProductSet-Reader tab, click Add Opened on the upper right to add the following opened 

products and then click refresh: 

S1A_IW_SLC_20190924_20191006_Orb_Stack_Coh_Deb_ML_TC 

S1A_IW_SLC_20190924_20191006_Orb_Stack_Coh_Deb_ML_TC 
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We proceed with CreateStack tab by defining the following parameters: 

Resampling Type: NEAREST_NEIGHBOUR 

Initial Offset Method: Product Geolocation 

Click on Find Optimal Master.  

 

Finally, in the Write tab set the output parameters: 

Name: Coherence_20190924_20191006_20191012_Stack 

Directory: 

/shared/Training/HAZA06_WatchingATyphoon_Hagibis_TrainingKit/Processing/Damage_Detection/ 
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In the Product Explorer pane expand the new stack product and open both coherence bands in the 

View window. Then go to Window → Tile Horizontally to compare them visually. As you may see in 

the histogram in the Colour Manipulation tab, areas with low coherence are shown in black color, 

while areas of high coherence are shown in white.  

Click on the view [10]coh_IW1_VV_24Sep2019_06Oct2019, 

then go to Colour Manipulation tab and click on  and 

select:  

coh_IW1_VV_24Sep2019_06Oct2019_slv1_06Oct2019 

Then click OK. In the next dialog click No. 

 

At a first sight, the coherence levels of the two images are quite different, denoting changes that might 

be attributed to the damage caused by the storm and flooding. To estimate the difference in the 
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coherence levels between the two coherence images, we will use the SAR interferometric coherence 

difference (ICD) (See  NOTE 13). 

 

Close all opened views. Right-click the Coherence_20190924_20191006_20191012_Stack product in 

the Product Explorer and go to Band Maths... Set the parameters: 

Name: ICD 

Untick option “Virtual (save expression only, don’t store data)” 

Then click on Edit Expression… and set: 

Expression:   

 

The new band will automatically open in view window. Go to Window → Tile Single.  

With the Colour Manipulation tool, you can modify the colour visualization of the image to show in 

red the coherence differences possibly attributed to the earthquake induced damages. You can drag 

the sliders to new position and click to change their colour. For convenience, a colour palette has been 

created for you.  

Click on the  Import Colour Palette icon, navigate to following path and select the file 

S1_ICD_colour_palette.cpd. Click No – we do not want to distribute points of colour palette between 

min/max – we want to keep the predefined points.  

/shared/Training/HAZA06_WatchingATyphoon_Hagibis_TrainingKit/AuxData/  

 NOTE 13: When a pair of SAR images is available, further parameters (InSAR complex coherence and 
intensity correlation) can be computed. Both parameters can be derived combining the pre-seismic, the 
post-seismic and the co-seismic (i.e. one pre-seismic and one post-seismic image) pairs. 
The complex coherence of two images is defined as follows: 

ρ =
Ε(s1s2

∗)

√Ε(s1s1
∗)Ε(s2s2

∗)
 

where s1 and s2 are the corresponding complex pixel values, and E( ) indicates the expected value. 
The SAR interferometric coherence difference (ICD) is given by: 

ICD = 𝜌(𝑝𝑟𝑒) − 𝜌(𝑝𝑜𝑠𝑡) 
 

 

coh_IW1_VV_24Sep2019_06Oct2019 - coh_IW1_VV_24Sep2019_06Oct2019_slv1_06Oct2019 
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6.3.5 Export as GeoTIFF 

In Product Explorer select the product [10] and go to File → Export → GeoTIFF (NOT! GeoTIFF/Big 

TIFF). In the dialog that opens click Subset → Band Subset and select the band IDC. Then click OK and 

save the file as SLC_Damage_Detection.tif to: 

/shared/Training/HAZA06_WatchingATyphoon_Hagibis_TrainingKit/Processing/Damage_Detection 

 

Finally, click Export Product to proceed.  

 

Now we can import the image to another GIS/Remote sensing software for further processing or map 

creation.  

TIP: In some cases the export to GeoTIFF does not work. This is a bug of the current version of SNAP 

and can be bypassed (if exporting single band) by right-clicking the image in view and selecting Export 

View as Image, then select Full scene, Full resolution and GeoTIFF – TIFF with geolocation. 
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7 Extra steps  

7.1 Downloading the outputs from VM 

Press Ctrl+Alt+Shift. A pop-up window will appear on the left side of the screen. Click on bar below 

Devices, the folder structure of your VM will appear. Navigate to your Processing folder and double 

click any file you want to download.  

 

8 Further reading and resources  

SENTINEL-1 SAR User Guide Introduction – link 

ESA Sentinel Online - link  

Science Toolbox Exploitation Platform (STEP) – link 
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