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1 Introduction 

The Research and User Support for Sentinel core products (RUS) service provides a free and open 

scalable platform in a powerful computing environment, hosting a suite of open source toolboxes pre-

installed on virtual machines, to handle and process data acquired by the Copernicus Sentinel satellites 

constellation.  

Earthquakes occur very often worldwide, especially in volcanic regions like Hawaii. They can be caused 

by tectonic faults, by the movement of magma in volcanoes (volcano tectonic earthquakes) and be 

related to dike intrusion.  

The earthquake occurred in the south-

east of the Hawaii archipelago on May 

4, 2018 at the Hawaii Island, was of 

magnitude of Mw 6.9 and produced 

around 5 meters of fault slip. It is the 

largest earthquake affecting this 

region after the one in 1975, where 2 

people were killed and another 28 

were injured.  

This event was related to the new lava 

outbreaks at the Kilauea Volcano and 

the aftershock events continued until 

August 2018. The earthquake 

produced a minor tsunami that 

reached a maximum height of 40 cm in 

Kapoho, 20 cm in Hilo and 15 cm in 

Honuapo. 

Hawaii region is known as one of around 60 hotspots that exist in the world and its islands are formed 

due to the continuous flow of magma towards the surface. The tectonic plate is moving to a north-

west direction while the hotspot remains at the same location, creating new volcanoes. This is the 

reason why the youngest island is located to the south-east and why only the volcanoes in the 

southern half are active. Seismic activity will always take place in such regions and sometimes it can 

also be related to volcanic eruptions. 

2 Training 

Approximate duration of this training session is two hours.  

The Training Code for this tutorial is HAZA05. If you wish to practice the exercise described below 

within the RUS Virtual Environment, register on the RUS portal and open a User Service request from 

Your RUS service → Your dashboard.  

2.1 Data used 

• Two Sentinel-1A IW SLC images with VH & VV polarization acquired on 23 April 2018 and 5 May 

2018 [downloadable at https://scihub.copernicus.eu/] 

S1B_IW_SLC__1SDV_20180423T161524_20180423T161551_010613_0135DD_33F0 

S1B_IW_SLC__1SDV_20180505T161525_20180505T161552_010788_013B7D_25D2 

All earthquakes recorded at the area of study from 15 March 2018 to 

15 August 2018 with magnitude 3.5 – 7.0. In blue, the event of 4 May 

2018. (Source: https://earthquake.usgs.gov/earthquakes/map/) 

https://rus-copernicus.eu/
https://scihub.copernicus.eu/
https://earthquake.usgs.gov/earthquakes/map/
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2.2 Software in RUS environment 

Internet browser, SNAP + Sentinel-1 Toolbox, QGIS, (Extra steps: Google Earth) 

3 Register to RUS Copernicus 

To repeat the exercise using a RUS Copernicus Virtual Machine (VM), you will first have to register as 

a RUS user. For that, go to the RUS Copernicus website (www.rus-copernicus.eu) and click on 

Login/Register in the upper right corner.  

 

Select the option Create my Copernicus SSO account and then fill in ALL the fields on the Copernicus 

Users’ Single Sign On Registration. Click Register. 

  

Within a few minutes you will receive an e-mail with activation link. Follow the instructions in the e-

mail to activate your account.  

You can now return to https://rus-copernicus.eu/, click on Login/Register, choose Login and enter 

your chosen credentials. 

http://www.rus-copernicus.eu/
https://rus-copernicus.eu/
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Upon your first login you will need to enter some details. You must fill all the fields.   

 

4 Request a RUS Copernicus Virtual Machine 
Once you are registered as a RUS user, you can request a RUS Virtual Machine to repeat this exercise 

or work on your own projects using Copernicus data. For that, log in and click on Your RUS Service → 

Your Dashboard.  
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Click on Request a new User Service to request your RUS Virtual Machine. Complete the form so that 

the appropriate cloud environment can be assigned according to your needs. 
  

 
 

If you want to repeat this tutorial (or any previous one) select the one(s) of your interest in the 

appropriate field. 

 

 
 

Complete the remaining steps, check the terms and conditions of the RUS Service and submit your 

request once you are finished. 
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Further to the acceptance of your request by the RUS Helpdesk, you will receive a notification email 

with all the details about your Virtual Machine. To access it, go to Your RUS Service → Your Dashboard 

and click on Access my Virtual Machine.  
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Fill in the login credentials that have been provided to you by the RUS Helpdesk via email to access 

your RUS Copernicus Virtual Machine.  

 

This is the remote desktop of your Virtual Machine. 

 

5 Step by step  

5.1 Data download – ESA SciHUB 

In this step, we will download the Sentinel-1 scenes from the Copernicus Open Access Hub using the 

online interface. Go to Applications → Network → Firefox Web Browser or click the link below. 

Go to https://scihub.copernicus.eu/   

https://scihub.copernicus.eu/
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Go to “Open HUB”, if you do not have an account please register by going to “Sign-up” in the LOGIN 

menu in the upper right corner. 
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After you have filled in the registration form, you will receive an activation link by e-mail. Once your 

account is activated or if you already have an account, “LOGIN”. 

Navigate to Hawaii (approximate area – green rectangle).  

 

Zoom in to the south-east part of the Hawaii Island, switch to “drawing mode” and draw a search 

rectangle approximately as indicated below. Open the search menu by clicking to the left part of the 

search bar and specify the following parameters: 

Sensing period: From 2018/04/23 to 2018/05/05 

Select: Mission: Sentinel-1 

Product Type: SLC 

Sensor Mode: IW  

Relative Orbit Number: 87 (It is important for InSAR processing since we need the products to have 

the same geometry). 

 

Then click on the “Search” icon. In our case, the search returns 2 results for the time period we set. 

Download both scenes by clicking on the “Download Product” icon: 

S1B_IW_SLC__1SDV_20180423T161524_20180423T161551_010613_0135DD_33F0 

S1B_IW_SLC__1SDV_20180505T161525_20180505T161552_010788_013B7D_25D2 
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The products will be downloaded at /home/rus as zip files. Move them to:   

/shared/Training/HAZA05_EarthquakeDeformation_Hawaii_TutorialKit/Original folder. 

5.2 SNAP – open and explore data 

Open SNAP software from the icon located on the desktop  or go to Applications → Processing → 

SNAP Desktop. Click the Open Product icon , navigate to: 

/shared/Training/HAZA05_EarthquakeDeformation_Hawaii_TutorialKit/Original folder and open 

the two S-1 downloaded products (first the 20180423 and then the 20180505): 

S1B_IW_SLC__1SDV_20180423T161524_20180423T161551_010613_0135DD_33F0.zip 

S1B_IW_SLC__1SDV_20180505T161525_20180505T161552_010788_013B7D_25D2.zip 

The opened products will appear in Product Explorer window. Click + or to expand the contents of 

product [1] from 23 April 2018, then expand Bands folder and double click on Intensity_IW1_VV band 

to visualize it in the View window. You can go to the World Map tab and zoom in to see the location 

of the opened product on the globe (See  NOTE 1). 

 

Zoom 

World Map 

View 

Product Explorer 



13 
 

Open the Intensity_IW1_VV band of the product [2] from 5 May 2018 as well and compare them by 

going to Window → Tile Horizontally. Go to the Navigation tab and click on the two icons shown 

within the red rectangular below to synchronize the views and the cursor position between the views. 

 

 

5.3 Pre-processing 

We need to apply identical pre-processing steps to both products and we will use the GraphBuilder 

and the Batch Processing tools.  

By using the GraphBuilder tool, we can define the steps of the process we want to apply and at the 

end only the final product will be physically saved (this way we will also save disk space since the 

products of the intermediate steps will not be stored).  

By using the Batch Processing tool, we will apply all steps to both images in one go.  

5.3.1 Graph Builder 

Go to Tools → GraphBuilder to build our graph.  

We can see that the graph has only two operators: Read (to read the input) and Write (to write the 

output). Below there also are the corresponding to the operators’ tabs.  

First, right-click on the Write operator and Delete it. The corresponding tab will be removed as well. 

This is to avoid confusion to the sequence of the graph. The Write operator will be added again at the 

end.  

For now, we will not define any parameters in the tabs (they will be defined in the Batch Processing 

step), we will only create the graph. 

 NOTE 1: The RADAR instrument onboard Sentinel-1 carries an antenna that is looking always to the right 

during its pass. These two scenes were acquired during descending pass (the satellite was moving in 

direction from north to south) and in this case while looking to the right it was actually looking towards 

the west. That is why we see that the view of the image appears as if “mirrored”, because the view 

shows the pixels in order of the data acquisition. 

Navigation 
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Every Interferometric Wide swath (IW) consists of 3 sub-swaths and each one of maximum 9 bursts. 

In SNAP we can process only one swath at a time until the Deburst step (See chapter 5.4.3). Our area 

of interest is located in the IW1 and is covered sufficiently by processing 2 bursts. We will use the 

TOPSAR-Split operator; this way we will reduce the total processing time (See  NOTE 2). 

To add the TOPSAR-Split operator, right-click at the empty white space right of the Read operator and 

go to Add → Radar → Sentinel-1 TOPS → TOPSAR-Split. Connect the Read operator to it by dragging 

the red arrow from the right side of Read operator towards the TOPSAR-Split operator. 

 

 

Now we will add the Apply-Orbit-File operator by right-clicking and going to Add → Radar → Apply-

Orbit-File (See  NOTE 3). Connect the TOPSAR-Split operator to it. 

 

 

Finally, we will add the Write operator to write our output product. To add the operator right-click 

and go to Add → Input-Output → Write. Connect the Apply-Orbit-File operator to it. 

 

 NOTE 2: In this case that we are using a pair of descending products, the IW1 is the one to the east. If 

we work with ascending products, the IW1 is the one to the west. Depending on our area of interest, 

we can process some or all bursts of a sub-swath, or even merge more sub-swaths but this will be quite 

time consuming and computationally heavy in the following steps. 

 NOTE 3: The orbit state vectors provided in the metadata of a SAR product are generally not accurate 

and can be refined with the precise orbit files which are available days-to-weeks after the generation of 

the product. The orbit file provides accurate satellite position and velocity information. Based on this 

information, the orbit state vectors in the abstract metadata of the product are updated. 
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Then click on  icon at the bottom of the Graph Builder window and save the graph under 

/shared/Training/HAZA05_EarthquakeDeformation_Hawaii_TutorialKit/Processing folder with the 

name Preprocess_Graph.xml. 

 

Close the Graph Builder window.  

5.3.2 Batch Processing  

Batch Processing is used when we want to apply identical pre-processing steps at once, to multiple 

images (in this case only in two). Open the Batch Processing tool by going to Tools → Batch Processing. 

In the I/O Parameters tab we will add both opened products from the Product Explorer window by 

clicking Add Opened at the right (second icon from the top) and then click Refresh (second icon from 

the bottom). Deselect the “Keep source product name” option.  

Then we will click on Load Graph at the bottom of the window, navigate to our saved graph and open 

it. We see that new tabs have appeared at the top of window corresponding to our operators. 

 

Add Opened 

Refresh 
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In the TOPSAR-Split tab Zoom in to the product and choose: 

Subswath: IW1 

Polarisations: VV 

Bursts: 4 to 5 (drag the two sliders accordingly) 

 

In the Apply-Orbit-File tab we will keep the default settings and make sure that you will select the “Do 

not fail if new orbit file is not found” option. 

 

In the Write tab keep the “Name” that is created with the “Orb” suffix and under the “Directory” set 

the path to /shared/Training/HAZA05_EarthquakeDeformation_Hawaii_TutorialKit/Processing 

folder. Then click Run.  

 

 

Zoom in 
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Now close the Batch Processing window, collapse the products [1] and [2] and close the opened View 

windows as well. The two new products have appeared to the Product Explorer window. Expand the 

products [3] and [4], expand the Bands folder and double click on the Intensity_IW1_VV band.  

 

5.4 Coregistration and Interferometric Processing 

5.4.1 Data Coregistration 

Image coregistration is the alignment of master and slave images; the pixels of the slave images 

correspond to those of the master and represent an identical area. 

Let’s open again a GraphBuilder window. Go to Tools → GraphBuilder. We can see that the graph has 

only two operators: Read and Write and below there also are the corresponding to the operators’ 

tabs.  

  

First, right-click on the Write operator and Delete it. This time, we will also define in parallel the 

parameters in the tabs. 
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Now, add one more Read operator. Right click and go to Add → Input-Output → Read. The inputs will 

be the products we want to coregister. 

 

In the Read tab choose the product [3] that contains only the 2 bursts of IW1 swath with updated 

orbits: S1B_IW_SLC__1SDV_20180423T161524_20180423T161551_010613_0135DD_33F0_Orb 

 

In the Read(2) tab choose the second product [4] as well that contains only the 2 bursts of IW1 swath 

with updated orbits: 

S1B_IW_SLC__1SDV_20180505T161525_20180505T161552_010788_013B7D_25D2_Orb 

 

5.4.1.1 Back-Geocoding 

Now we will coregister the two products by using their orbits and a DEM. To add the Back-Geocoding 

operator right-click and go to Radar → Coregistration → S-1 TOPS Coregistration → Back-Geocoding. 

Connect both Read and Read(2) operators to it.  

 

In the Back-Geocoding tab set: 

Digital Elevation Model: SRTM 1Sec HGT (Auto Download) (See  NOTE 4). 

DEM Resampling Method: BILINEAR_INTERPOLATION 

Resampling Type: BILINEAR_INTERPOLATION 

Select the “Output Deramp and Demod Phase” option as well (See  NOTE 5). 

Right-click and delete 

the operator 



19 
 

 

 

 

5.4.1.2 Enhanced Spectral Diversity 

This Enhanced Spectral Diversity operator follows the Back-Geocoding operator, it first estimates a 

constant range offset for each burst using a small block of data in the center of the burst and then it 

estimates a constant azimuth offset. Finally, the estimates from all bursts are averaged to get the final 

constant range and azimuth offset for the whole image. 

To add the Enhanced-Spectral-Diversity operator right-click and go to Radar → Coregistration → S-1 

TOPS Coregistration → Enhanced-Spectral-Diversity. Connect the Back-Geocoding operator to it (See 

 TIP 1). 

 

In the Enhanced-Spectral-Diversity tab keep all the default parameters. 

 

 

 NOTE 4: We will use the SRTM 1Sec HGT (Auto Download) which has ~30m resolution instead of the 

default SRTM 3sec (Auto Download) which has ~90m resolution, but this will increase the processing 

time. In case you want to process more than 2 images simultaneously and you do not have enough 

RAM, you can use the SRTM 3sec (Auto Download) DEM. 

 NOTE 5: The “Output Deramp and Demod Phase” option is necessary when Enhanced Spectral Diversity 

is following. 

 TIP 1: If you want to coregister only two Sentinel-1 images and save the stack product created, you can 

replace all steps of chapters 5.3 until 5.4.1.2 by going to: Radar → Coregistration → S1 TOPS 

Coregistration → S-1 TOPS Coregistration with ESD. 
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5.4.2 Interferogram Formation  

Let’s create the interferogram of the two images used for the stack product. To add the Interferogram 

operator right-click and go to Add → Radar → Interferometric → Products → Interferogram. Connect 

the Enhanced-Spectral-Diversity operator to it. A phase and a coherence band will be created. 

 

In the Interferogram tab keep the default parameters and set as Coherence Range Window Size: 18. 

The Coherence Azimuth Window Size will automatically change to 5. 

 

5.4.3 TOPS Deburst 

Now we will remove the “black space” between the two bursts (See  NOTE 6). To add the TOPSAR-

Deburst operator right-click and go to Add → Radar → Sentinel-1 TOPS → TOPSAR-Deburst. Connect 

the Interferogram operator to it. 

 

In the TOPSAR-Deburst tab keep the default settings (Polarizations: VV). 

 

 

 NOTE 6: There is overlapping information in every burst with its neighbouring ones, both in range and 

azimuth direction in order to provide contiguous coverage of the ground. Until now each burst has been 

processed as a separate SLC image We will merge the bursts (in azimuth direction) and preserve the 

phase information as well. For the overlapping region in range, merging is done between subswaths. 
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5.4.4 Write/create the product 

To add the Write operator right-click and go to Add → Input-Output → Write. Connect the TOPSAR-

Deburst operator to it. 

 

In the Write tab set the following: 

Name: S1B_IW1_20180423_Orb_stack_ifg_Deb 

Directory: /shared/Training/HAZA05_EarthquakeDeformation_Hawaii_TutorialKit/Processing 

 

Then click on  icon at the bottom of the Graph Builder window and save the graph under 

/shared/Training/HAZA05_EarthquakeDeformation_Hawaii_TutorialKit/Processing folder with the 

name Process_Graph_1.xml. 

 

Finally, click on the icon at the bottom of the Graph Builder window. The process will be 
completed in 40 minutes in a 32GB RAM VM. 

Now close the Graph Builder window, collapse the products [3] and [4] and close the opened View 
windows as well. The new product has appeared to the Product Explorer window. Expand the product 
[5], expand the Bands folder and double click on the Phase_ifg_IW1_VV_23Apr2018_05May2018 and 
the coh_IW1_VV_23Apr2018_05May2018 bands.  
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Let’s open another GraphBuilder window. Go to Tools → GraphBuilder. 

Keep only the Read operator and delete again the Write operator. 

 

In the Read tab choose the coregistered product [5] S1B_IW1_20180423_Orb_stack_ifg_Deb. 

 

5.4.5 Topographic Phase Removal  

This is to estimate and subtract the topographic phase from the deburst interferogram. To add the 

TopoPhaseRemoval operator right-click and go to Add → Radar → Interferometric → Products → 

TopoPhaseRemoval. Connect the Read operator to it. 

 

In the TopoPhaseRemoval tab set as Digital Elevation Model: SRTM 1Sec HGT (Auto Download) and 

select the “Output topographic phase band” option as well. 
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5.4.6 Multilooking 

By applying this operator, we will reduce the inherent speckle noise that originally appears to the SAR 

images and we will obtain square pixels. To add the Multilook operator right-click and go to Add → 

Radar → Multilook. Connect the TopoPhaseRemoval operator to it. 

 

In the Multilook tab keep the “GR Square Pixel” option selected and set Number of Range Looks: 6. 

The Number of Azimuth Looks will automatically change to 2 and the Mean GR Square Pixel to 

26.533897. 

 

5.4.7 Phase Filtering 

Phase filtering reduces the phase noise (See  NOTE 7). To add the GoldsteinPhaseFiltering operator 

right-click and go to Add → Radar → Interferometric → Filtering → GoldsteinPhaseFiltering. Connect 

the Multilook operator to it. 

 

In the GoldsteinPhaseFiltering tab set the FFT Size to 128 and keep the rest parameters as by default. 

 

 

Finally we will save the product and we will also export it for SNAPHU. To add the Write operator right-

click and go to Add → Input-Output → Write. Connect the GoldsteinPhaseFiltering operator to it. 

 NOTE 7: It is necessary step since it will enhance the phase unwrapping accuracy for the upcoming step 

(See chapter 5.4.8).  
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In the Write tab set the following: 

Name: S1B_IW1_20180423_Orb_stack_ifg_Deb_DInSAR_ML_Flt 

Directory: /shared/Training/HAZA05_EarthquakeDeformation_Hawaii_TutorialKit/Processing 

 

To add the SnaphuExport operator right-click and go to Add → Radar → Interferometric → 

Unwrapping → SnaphuExport. Connect the GoldsteinPhaseFiltering operator to it as well. 

 

In the SnaphuExport tab click on  icon to set the Target folder. Navigate to the following path: 

/shared/Training/HAZA05_EarthquakeDeformation_Hawaii_TutorialKit/Processing and write at 

the File Name: SNAPHU. Click Select.  
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Then define the following parameters in the SnaphuExport tab: 

Initial method: MCF 

Number of Tile Rows: 1 

Number of Tile Columns: 1 

Row Overlap: 0 

Column Overlap: 0 

 

Click on  icon at the bottom of the Graph Builder window and save the graph under 

/shared/Training/HAZA05_EarthquakeDeformation_Hawaii_TutorialKit/Processing folder with the 

name Process_Graph_2.xml. 

 

Finally, click on the icon at the bottom of the Graph Builder window.  

Now close the Graph Builder window, collapse the product [5] and close the opened View windows 

as well. The new product has appeared to the Product Explorer window. Expand the product [6], 

expand the Bands folder and double click on the Phase_ifg_IW1_VV_23Apr2018_05May2018, 

topo_phase_VV_23Apr2018_05May2018 and the coh_IW1_VV_23Apr2018_05May2018 bands.  

Choose the Phase_ifg_IW1_VV_23Apr2018_05May2018 band in the View window, go to Colour 

Manipulation tab and click on the “Auto-adjust to 100% of all pixels” icon . We can see values that 

correspond to the fringes of the differential interferogram (-pi, pi). Repeat the same for the 
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 coh_IW1_VV_23Apr2018_05May2018 band. Coherence values vary from 0 to 1 (1 = most coherent). 

 

5.4.8 Phase Unwrapping 

Phase unwrapping is prerequisite to convert phase units to length units (See  NOTE 8). Open the: 

/shared/Training/HAZA05_EarthquakeDeformation_Hawaii_TutorialKit/ 

Processing/SNAPHU/S1B_IW1_20180423_Orb_Stack_Ifg_Deb_DInSAR_ 

ML_Flt/ folder and right-click in the empty space.  

 

Select “Open Terminal Here”. 

 

The following terminal will appear. 

 

 
In the same folder, open the snaphu.conf file. 

In line 28 (go to View → Line Numbers), add the # symbol and leave a space before LOGFILE. Go to 

File → Save and save the changes. Then go to line 7 and copy the command shown in the picture 

below in blue, to call snaphu:  

snaphu -f snaphu.conf Phase_ifg_VV_23Apr2018_05May2018.snaphu.img 3435 

Paste it in the Terminal and press Enter to run it. 
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When the processing is completed, the terminal will contain all the information, as shown below. 

 
The time needed for the process to be completed depends on the characteristics of your machine. It 

might take up to 30 minutes. With a 32GB RAM VM it lasted 20 minutes. 

 

 NOTE 8: Two-dimensional phase unwrapping is the process of recovering unambiguous phase data from 

a 2-D array of phase values known only modulo 2pi rad. 
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5.4.8.1 SNAPHU import to SNAP 

Now we will import the results from SNAPHU processing. Go to Radar → Interferometric → 

Unwrapping → Snaphu Import. 

In the 1-Read-Phase tab, select the product that was created from the Write operator:  

[6] S1B_IW1_20180423_Orb_Stack_Ifg_Deb_DInSAR_ML_Flt 

 

In the 2-Read-Unwrapped-Phase tab, click on  to select the product that contains the unwrapped 

phase: UnwPhase_ifg_VV_23Apr2018_05May2018.snaphu.hdr from the following path:  

/shared/Training/HAZA05_EarthquakeDeformation_Hawaii_TutorialKit/Processing/SNAPHU/S1B_
IW1_20180423_Orb_Stack_Ifg_Deb_DInSAR_ML_Flt 

You will see that under the Name it is written: UnwPhase_ifg_VV_23Apr2018_05May2018.snaphu 

 

In the 3-SnaphuImport tab, select the “Do NOT save Wrapped Interferogram in the target product” 

option. 

 

In the Write tab, set the following: 

Name: S1B_IW1_20180423_Orb_stack_ifg_Deb_DInSAR_ML_Flt_Unw 

Directory: /shared/Training/HAZA05_EarthquakeDeformation_Hawaii_TutorialKit/Processing 

 Click Run.  
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Now close the Snaphu Import window, collapse the product [6] and close the opened View windows 

as well. The new product has appeared to the Product Explorer window. Expand the product [7], 

expand the Bands folder and double click on the Unw_Phase_23Apr2018_05May2018 band. In Colour 

Manipulation tab you can see the absolute values of the phase. 

 

5.4.9 Displacement  

It is time to convert the interferometric phase to displacement. Go to Radar → Interferometric → 

Products → Phase to Displacement. 

In the I/O Parameters tab set the following: 

As source (Input): [7] S1B_IW1_20180423_Orb_stack_ifg_Deb_DInSAR_ML_Flt_Unw  

As Name (Output): S1B_IW1_20180423_Orb_stack_ifg_Deb_DInSAR_ML_Flt_Unw_dsp  

As Directory: /shared/Training/HAZA05_EarthquakeDeformation_Hawaii_TutorialKit/Processing 

 

Click Run since there are no parameters in the Processing Parameters tab to be changed. 
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Now close the Phase to Displacement window, collapse the product [7] and close the opened View 

window as well. The new product has appeared to the Product Explorer window. Expand the product 

[8], expand the Bands folder and double click on the displacement band. 

Click on the “Import colour palette from text file” icon , and open the Displacement.cpd colour 

palette from: /shared/Training/HAZA05_EarthquakeDeformation_Hawaii_TutorialKit/AuxData 

folder. 

 

5.5 Geocoding 

We will apply the Terrain Correction in the product containing the unwrapped interferogram and then 

to the one containing the displacement as well, to convert the RADAR coordinates into geographic.  

Go to Radar → Geometric → Terrain Correction → Range-Doppler Terrain Correction. 

In the I/O Parameters tab set the following: 

As source (Input): [6] S1B_IW1_20180423_Orb_stack_ifg_Deb_DInSAR_ML_Flt 

As Name (Output): S1B_IW1_20180423_Orb_stack_ifg_Deb_DInSAR_ML_Flt_TC 

As Directory: /shared/Training/HAZA05_EarthquakeDeformation_Hawaii_TutorialKit/Processing 

 

In the Processing Parameters tab set the following:  
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In Source Bands select only:  Intensity_ifg_VV_23Apr2018_05May2018 

Phase_ifg_VV_23Apr2018_05May2018 

topo_phase_VV_23Apr2018_05May2018  

coh_IW1_VV_23Apr2018_05May2018 

In Digital Elevation Model: SRTM 1Sec HGT (Auto Download)  

  

Keep the rest parameters as by default. Click Run. 

Repeat the same for the displacement product as well. 

In the I/O Parameters tab set the following: 

As source (Input): [8] S1B_IW1_20180423_Orb_stack_ifg_Deb_DInSAR_ML_Flt_Unw_dsp 

As Name (Output): S1B_IW1_20180423_Orb_stack_ifg_Deb_DInSAR_ML_Flt_Unw_dsp_TC 

As Directory: /shared/Training/HAZA05_EarthquakeDeformation_Hawaii_TutorialKit/Processing 
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In the Processing Parameters tab set the following:  

In Source Bands select: displacement 

In Digital Elevation Model: SRTM 1Sec HGT (Auto Download)  

  
Keep the rest parameters as by default. Click Run. 

Now close the Range Doppler Terrain Correction window, collapse all products and close the opened 

View windows as well. The two new products have appeared to the Product Explorer window. Expand 

the products [9] and [10], expand the Bands folder and double click on the bands you want to visualise 

(e.g. coh_IW1_VV_23Apr2018_05May2018 band of product [9]). 
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As you can see, although at the Range Doppler Terrain Correction step the option “Mask out areas 

without elevation” was selected, we still have pixels that correspond to sea. This is because we used 

SRTM 1sec DEM with 30m resolution. 

5.6 Masking 

To mask out the sea from both geocoded products, go to Raster → Masks → Land/Sea Mask. 

In the I/O Parameters tab set the following: 

As source (Input): [9] S1B_IW1_20180423_Orb_stack_ifg_Deb_DInSAR_ML_Flt_TC 

As Name (Output): S1B_IW1_20180423_Orb_stack_ifg_Deb_DInSAR_ML_Flt_TC_msk 

As Directory: /shared/Training/HAZA05_EarthquakeDeformation_Hawaii_TutorialKit/Processing 

 

In the Processing Parameters tab select the “Mask out the Sea” option.  

Click Run. 

 

Repeat the same for the displacement product as well. 

In the I/O Parameters tab set the following: 

As source (Input): [10] S1B_IW1_20180423_Orb_stack_ifg_Deb_DInSAR_ML_Flt_Unw_dsp_TC 
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As Name (Output): S1B_IW1_20180423_Orb_stack_ifg_Deb_DInSAR_ML_Flt_Unw_dsp_TC_msk 

As Directory: /shared/Training/HAZA05_EarthquakeDeformation_Hawaii_TutorialKit/Processing 

In the Processing Parameters tab select the “Mask out the Sea” option. Click Run. 

Now close the Range Doppler Terrain Correction window, collapse all products and close the opened 

View windows as well. The two new products have appeared to the Product Explorer window. Expand 

the products [11] and [12], expand the Bands folder and double click on the bands you want to 

visualise (e.g. coh_IW1_VV_23Apr2018_05May2018 band of product [11]). 

 

5.7 Export products 

Now we will export the bands we want to visualise in QGIS, in GeoTIFF format. Select the appropriate 

band from the Product Explorer window. Go to File → Export → GeoTIFF. 

Set in Save In: /shared/Training/HAZA05_EarthquakeDeformation_Hawaii_TutorialKit/Processing 

path and click on “Subset”. 
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Go to Band Subset tab and select only the band you want to export, e.g. from S1B_IW1_20180423_ 

Orb_stack_ifg_Deb_DInSAR_ML_Flt_TC product, select the coh_IW1_VV_23Apr2018_05May2018 

band and click OK. Set as File Name: Coherence_Hawaii.tif 

 

 

Repeat for any band you want to export. 

6 Visualization in QGIS 

Open QGIS Desktop application. In the Browser Panel, navigate to /shared/Training/HAZA05_Earth 

quakeDeformation_Hawaii_TutorialKit/Processing folder and add the Coherence_Hawaii.tif. Right-

click on it, go to Transparency tab, set the “Additional no data value” to 0 to remove the black area 

of the layer. In order to visualize better the results, set the Global Transparency to e.g. 40% and click 

OK. 

  

Also, go to the Auxdata folder and add the Geology_Hawaii.shp and Faults_Hawaii.shp. You can 

select which layers you want to be activated and arrange then in the desired order.  

Activate the Geology_Hawaii.shp, right-click on it and go to Properties. In the Style tab select: 

Categorized, in Column: AGE_RANGE, then click Classify and finally OK. You can also select other 

category in the Column field to classify the data or set a specific Color ramp. 
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Deactivate all layers and add the Displacement_Hawaii.tif from the Processing folder. Right-click on 

it and go to Properties.  

In the Transparency tab, set the “Additional no data value” to 0 to remove the black area of the layer.  

In the Style tab go to Style → Load Style, navigate to the Auxdata folder and open the predefined 

color palette: Displacement_qgis.qml.  

Click OK. 
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Activate the Faults_Hawaii.shp, right-click on it, go to Properties and in the Style tab set the Color to 

green and the Width to 0.46. Select OK. 
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7 Extra Steps 

Google Earth is not pre-installed in RUS VMs and if you want to visualise the results, you need to 

download them to your local computer. Let’s export the results to KML format. Go to SNAP and export 

the bands you want from the final products (e.g. Phase, Coherence) as mentioned in the 5.7 chapter. 

Go to File → Export → Other → View as Google Earth KMZ. Also, download from the Auxdata folder 

the Fault_Google_Earth.kml file and then load them in Google Earth. 

 

 

7.1 Download files from VM  

In your VM, press Ctrl+Alt+Shift.  

A pop-up window will appear on the left side of the screen. Click on the bar below Devices, navigate 

to the folders you have saved the files you want to download and double click on them. The 

downloading process to your local computer will start automatically.  
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Once the KML files have been downloaded, you can load and visualize them in Google Earth. 

 

 

THANK YOU FOR FOLLOWING THE EXERCISE! 

8 Further reading and resources 

• Richards J.A., 2009. Remote Sensing with Imaging Radar. Springer-Verlag Berlin Heidelberg. 376pp. 

• Walter T.R., Amelung F., 2006. Volcano-earthquake interaction at Mauna Loa volcano, Hawaii. 

Journal of Geophysical Research, vol. 111, B05204, 2006.  

• Ghiglia D.C., Pritt M.D., 1998. Two-dimensional phase unwrapping: theory, algorithms, and 

software. New York: Wiley. 493pp. 

• http://www.esa.int/About_Us/ESA_Publications/InSAR_Principles_Guidelines_for_SAR_Interfero

metry_Processing_and_Interpretation_br_ESA_TM-19 - InSAR Principles 

• https://sentinel.esa.int/web/sentinel/missions/sentinel-1 - Sentinel-1 Mission 

• https://earthquake.usgs.gov/hazards/ - Download Hawaii shapefiles 
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