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1 Introduction 

The Research and User Support for Sentinel core products (RUS) service provides a free and open 

scalable platform in a powerful computing environment, hosting a suite of open source toolboxes 

pre-installed on virtual machines, to handle and process data derived from the Copernicus Sentinel 

satellites constellation. 

A series of four initial deadly wildfires erupted 

across central Portugal in the afternoon of 17 

June 2017 within minutes of each other. An 

intense heat wave preceded the fires, with 

many areas of Portugal seeing temperatures in 

excess of 40 °C (104 °F).  

During the night of 17–18 June, 156 fires 

erupted across the country, particularly in 

mountainous areas 200 km (120 mi) north-

northeast of Lisbon.  

Portugal’s fires have burnt 520,000 hectares of 

forest this year, 52 times the size of Lisbon and 

representing nearly 60 % of the total area burnt in the entire European Union in 2017. The amount of 

land burnt is the highest ever in Portugal's history. 

2 Training 

Approximate duration of this training session is two hours.  

The Training Code for this tutorial is HAZA04. If you wish to practice the exercise described below 

within the RUS Virtual Environment, register on the RUS portal and open a User Service request 

from Your RUS service → Your dashboard. 

2.1 Data used 

• Two cloud-free Sentinel-3A Level 1B RBT products acquired on June 18, 2017 (after the main 

event). [downloadable @ https://scihub.copernicus.eu/]  
S3A_SL_1_RBT____20170618T104548_20170618T104848_20170618T125104_0179_019_051_2340_SVL_O_NR_002.zip 

S3A_SL_1_RBT____20170618T220242_20170618T220542_20170619T003422_0179_019_058_0539_SVL_O_NR_002.zip 

2.2 Software in RUS environment 

Internet browser, SNAP + Sentinel-3 Toolbox, QGIS, (Extra steps: Google Earth) 

 

 

Portugal wildfires June 2017 Credits: www.theguardian.com [June 

18, 2017]  

https://rus-copernicus.eu/
https://scihub.copernicus.eu/
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3 Register to RUS Copernicus 

To repeat the exercise using a RUS Copernicus Virtual Machine (VM), you will first have to register as 

a RUS user. For that, go to the RUS Copernicus website (www.rus-copernicus.eu) and click on 

Login/Register in the upper right corner.  

 

Select the option Create my Copernicus SSO account and then fill in ALL the fields on the Copernicus 

Users’ Single Sign On Registration. Click Register. 

  

Within a few minutes you will receive an e-mail with activation link. Follow the instructions in the e-

mail to activate your account.  

You can now return to https://rus-copernicus.eu/, click on Login/Register, choose Login and enter 

your chosen credentials. 

http://www.rus-copernicus.eu/
https://rus-copernicus.eu/
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Upon your first login you will need to enter some details. You must fill all the fields.   

 

4 Request a RUS Copernicus Virtual Machine 

Once you are registered as a RUS user, you can request a RUS Virtual Machine to repeat this exercise 

or work on your own projects using Copernicus data. For that, log in and click on Your RUS Service → 

Your Dashboard.  
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Click on Request a new User Service to request your RUS Virtual Machine. Complete the form so that 

the appropriate cloud environment can be assigned according to your needs. 
  

 
 

If you want to repeat this tutorial (or any previous one) select the one(s) of your interest in the 

appropriate field. 

 

 
 

Complete the remaining steps, check the terms and conditions of the RUS Service and submit your 

request once you are finished. 
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Further to the acceptance of your request by the RUS Helpdesk, you will receive a notification email 

with all the details about your Virtual Machine. To access it, go to Your RUS Service → Your 

Dashboard and click on Access my Virtual Machine.  
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Fill in the login credentials that have been provided to you by the RUS Helpdesk via email to access 

your RUS Copernicus Virtual Machine.  

 

This is the remote desktop of your Virtual Machine. 

 

5 Data download – ESA SciHUB 

In this example, we will download a Sentinel-3 scene from the Copernicus S-3 PreOpsHub using the 

online interface (Applications → Network → Web Browser or click the link below). 

Go to https://scihub.copernicus.eu/   

https://scihub.copernicus.eu/
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Go to “S-3 Pre-Ops”, click “Login” in upper right corner and login using the credentials provided at 

the top of the login window. 

 

Switch the rectangle-drawing mode to pan mode by clicking on the “Pan” icon in the lower left 

corner of the map (Green arrow) and navigate over Portugal (approximate area – blue rectangle). 
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Switch to drawing mode and draw a search rectangle approximately as indicated below. Open the 

search menu (red arrow) and specify the following parameters: 

Sensing period: From 2017/06/18 to 2017/06/18  

Check Mission: Sentinel-3 

Product Type:  SL_1_RBT___  

 

In our case, the search returns 4 results. However, the second pair is the same data processed at 

different facility. Therefore, let’s download the first pair (pay attention to date and time of 

acquisition, below in red):  

S3A_SL_1_RBT____20170618T220242_20170618T220542_20170620T020303_0179_019_058_6599_LN2_O_NT_002 

S3A_SL_1_RBT____20170618T104548_20170618T104848_20170619T154448_0179_019_051_2340_LN2_O_NT_002 

Data will be downloaded to /home/rus/Downloads as ZIP archives. Move the archives to 

/shared/Training/HAZA04_ActiveFire_Portugal_TutorialKit/Original  

Right-click each archive and use “Extract Here” to unzip the folders. To open them in SNAP, go to 

open file and in the product, folder select xfdumanifest.xml.  
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6 Sentinel-3 SLSTR  

SLSTR stands for Sea and Land Surface Temperature Radiometer. It is a dual scan temperature 

radiometer in the low Earth orbit (800 - 830 km altitude) on board of the Sentinel-3 satellite. It 

employs along track scanning dual view (nadir and backward oblique) technique for 9 channels in the 

visible (VIS), thermal (TIR) and short wave (SWIR) infra-red spectrum.  

It also provides two dedicated channels for fire and high temperature event monitoring at 1 km 

resolution (by extending the dynamic range of the 3.74μm channel and including dedicated detectors 

at 10.85μm that are capable of detecting fires at ~650 K without saturation). (Sentinel-3 SLSTR User 

Guide, ESA). 

 

It is distributed as Level-1b product (1 product - BRT) or Level-2 (4 products – WCT, WST, LST, FPR) 

products, based on the type and level of pre-processing applied to the raw data (not all products are 

available to public). In this training we will use the Level-1b RBT product, which consists of the full-

resolution geolocated radiometric measurements for each view (n - nadir, o - oblique) and for each 

channel.  

• on a 1 km grid for brightness temperatures (notation “_in” or “_io” - bands S6 to S9 and F1 

and F2 “fire bands”) 

• on a 0.5 km grid for radiances (S1 to S5). In this case, three stripes are distinguished: A 

(“_an”, “_ao”), B (“_bn”, “_bo”), and TDI (“_cn”, “_co”), with TDI a derived product from A 

and B stripes.  

IMPORTANT! In this tutorial, we will only use the nadir (“_in”) brightness temperature bands and 

nadir stripe A (“_an”) radiance bands. 

The nine bands in VNIR/SWIR/TIR (Credits: Sentinel-3 SLSTR User Guide, ESA) 
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7  Step by step  

7.1 SNAP – open project and explore data 

Launch SNAP (icon on desktop ). When the SNAP window opens click Open Product , navigate 

to: /shared/Training/HAZA04_ActiveFire_Portugal_TutorialKit/Original and open the S3 products 

by opening each folder and selecting the xfdumanifest.xml file.  

At the pop-up window, choose “Sentinel-3 products” and click OK. 

  

Now, we will look at the products. Right-click the first loaded product acquired at 10:45 and click 

Open RGB image window, a new window will open. Set:  

Profile: SLSTR L1 Nadir 

 

 

 

 

 

Now open the RGB view for the night product (acquired at 22:02) as well. When you have both Views 

opened go to Navigation tab in the lower left and make sure the cursor   and the views  are 

linked. Then, go to Window → Tile Evenly. Go back to Navigation tab and click  Zoom All to 

center the Views.  

Sentinel-3 sensors (Credits: Sentinel-3 

SLSTR User Guide, ESA) 
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NOTE: If “World View” tab is not available, go to View → Tool Windows and open the “World Map”. 

Since we are creating the RGB View with radiance bands (reflected solar radiation), we cannot see 

anything in the night RGB composite, as expected. Go to the World View tab. We can see that the 

products do not cover exactly the same area - they correspond to different passes of the satellite.  

Take a little time to explore the structure of the S3 products (expand them). During this exercise, we 

process two images - one acquired during the day (10:45) and one acquired during the night (22:02). 

You will notice that the RBT product contains many bands and even more masks, we do not need to 

worry about all of them though.  

As mentioned before, we will only use the nadir bands with suffix “_in” (corresponding to 1 km 

brightness temperature bands S6 – S9 and fire bands F1 and F2) or “_an” (corresponding to radiance 

bands S1 – S5 in stripe A) in their name. Read about Sentinel-3 SLSTR RBT product and its 

organization and contents in section 6 Sentinel-3 SLSTR.   

The processing of day and night acquisitions differ slightly, and we will go through the steps 

separately.  

7.2 Pre-processing DAY 

Cloud masking is essential to the detection of active fire pixels because optically thick clouds make it 

impossible to identify active fires through passive remote sensing. Moreover, solar reflected MIR 

radiation from certain clouds can appear similar to fire signals and some cloud-contaminated pixels 

will likely be falsely classified as fires if they are not masked out prior to fire detection. (Wooster et 

al., 2012). 

The Level-1B product contains cloud mask, however some cloud mask algorithms also identify 

optically thick smoke as cloud, even though fire detections can typically be made through smoke. 

Smoke is generally relatively transparent at MIR wavelengths unlike meteorological cloud. This 

makes the cloud masks available in the product unsuitable for active fire detection and we need to 

derive our own mask.  
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We will use simple cloud test developed for daytime fire detection by Giglio et al. (2003). 

{(𝜌0.65 + 𝜌0.86  > 0.9) 𝑂𝑅 (𝑇12 < 265 𝐾)} 𝑂𝑅 {(𝜌0.65 +  𝜌0.86  > 0.7) 𝐴𝑁𝐷 (𝑇12 < 285 𝐾)}   

Where, ρλ and Tλ correspond to reflectance and thermal bands at certain wavelength (λ [μm]).  

7.2.1 Radiance to reflectance 

As the Level-1B product contains TOA radiance, our first step will be to convert the solar radiance 

bands to reflectance (See  NOTE 1).  

 

Go to Optical → Preprocessing → Radiance-to-Reflectance Processor. 

In the I/O Parameters tab, make sure that the DAYTIME product is selected as input. Set the Name 

of the target product to S3A_SL_1_RBT_20170618T104548_radrefl and the target folder under 

Directory to: /shared/Training/HAZA04_ActiveFire_Portugal_TutorialKit/Processing 

In the Processing Parameters tab set: 

Sensor: SLSTR_500m 

Conversion mode: RAD_TO_REFL 

Check all fields to “Copy tie point grids, flag bands and masks and non-spectral bands”. 

 

 NOTE 1: The conversion from TOA radiance (LTOA) to TOA reflectance (RTOA) is defined by the following 

equation: 

𝑅𝑇𝑂𝐴(𝜆) =  
𝜋𝐿𝑇𝑂𝐴(𝜆)

𝐸0(𝜆)cos (𝜃)
  

Where, E0 and θ are the solar spectral irradiance and the sun zenith angle at the time of acquisition, 

respectively. The solar spectral irradiance values are taken from the L1 product metadata of the SLSTR 

product.  

Radiance is the variable directly measured by remote sensing instruments. It is the amount of light seen 

by instrument from a surface of an object. In the SLSTR products is given as radiance of a surface per 

unit wavelength [mW*m-2*sr-1*nm-1 = watt per square meter per nanometre]. 

Reflectance is the ratio (percentage) of the amount of light leaving a target to the amount of light 

arriving to the target. It has no units. It is the property of the observed object/material.  
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Click Run. A new product [3] has been created. Click OK to the pop-up window and close the 

Radiance-to-Reflectance Processor window. If we expand the Bands folder in the product, we can 

see that the brightness temperature folders (*BT) have not changed but the radiance folders were 

replaced by reflectance folders. Close all view windows.  

7.2.2 Resample 

As mentioned previously, the brightness temperature (BT) bands of S3 RBT product have resolution 

of 1000 m while the radiance (now reflectance) bands have resolution of 500 m. For further 

processing, it is necessary to have all bands in the same resolution. As for the active fire detection we 

will use the BT bands and we will resample all the reflectance bands to 1000 m.  

Go to Raster → Geometric Operations → Resampling.  

In the I/O Parameters tab, make sure that the daytime reflectance product [3] is selected as input. 

Select Save as: .  

Set the Name of the target product to: S3A_SL_1_RBT_20170618T104548_radrefl_resampled and 

the target folder under Directory to: /shared/Training/HAZA04_ActiveFire_Portugal/Processing 

In the Processing Parameters tab set: By reference band from source product: F1_BT_in 

 

Click Run. A new product [4] has been created. Click OK to the pop-up window and close the 

Resampling window.  

7.2.3 Reproject 

The Sentinel-3 Level-1B products are geocoded but not projected, therefore in this step we will 

reproject the data.  

Go to Raster → Geometric Operations → Reprojection.  

In the I/O Parameters tab, make sure that the daytime resampled product [4] is selected as input. 
Set the name of the target product to: 
S3A_SL_1_RBT_20170618T104548_radrefl_resampled_reprojected and the target folder under 
Directory to: /shared/Training/HAZA04_ActiveFire_Portugal_TutorialKit/Processing 
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In the Reprojection Parameters tab set: 

Under Coordinate Reference System (CRS) choose: Custom CRS and at Projection: UTM Zone  

Click on Projection Parameters and set as Zone: 29 and as Hemisphere: North 

 

Click OK and then click Run. A new product [5] has been created. Click OK at the pop-up dialog and 

close the Reprojection window.  

7.2.4 Subset 

In the last pre-processing step, we will create a subset of our area of interest. Click on the new 

product [5] in the Product Explorer window to highlight it.  

Go to Raster → Subset.  

In the Spatial Subset tab, at the Geo Coordinates tab, set the following coordinates: 

North latitude bound:     41.00  

West longitude bound:   -10.00  

South latitude bound:     38.00 

East longitude bound:    -7.0 

The subset area is indicated by the blue 

rectangle on the left of the dialog 

window. Click OK. 

The subset product [6] will appear in 

the Product Explorer window but is not 

physically saved. We will save it after 

the creation of the cloud mask.  

Right-click the product again and select 

Open RGB Image Window and set:  
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Red:  $6.S3_reflectance_an   

Green:  $6.S2_reflectance_an      

Blue:  $6.S1_reflectance_an 

 

 

 

Click OK. 

 

 

7.2.5 Create a cloud mask band 

As discussed before, we will create our own cloud mask. Right-click on the subset product [6] and 

click Band Maths. A new window will open.  

 

Set as Name:  “cloud_mask” 

Deselect “Virtual (safe expression only, don’t store data)” 

Then click on “Edit Expression…” and enter the following statement:  

Click OK in both windows. 

TIP: All expressions you will be using during this tutorial are available to copy-paste them from the 

Expressions_AF.txt file in /shared/Training/HAZA04_ActiveFire_Portugal_TutorialKit/Auxdata/ 

folder. 

(S2_reflectance_an + S3_reflectance_an) > 0.9 or S9_BT_in < 265 or 

((S2_reflectance_an + S3_reflectance_an) > 0.7 and S9_BT_in < 285) 
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The new band will automatically open in a new “View” window.  

 

 
Right-click the subset product [6] and go to Save Product. In the next dialog click Yes and save the 

product as Subset_S3A_SL_1_RBT_20170618T104548_radrefl_resampled_reprojected to 

/shared/Training/HAZA04_ActiveFire_Portugal_TutorialKit/Processing 

7.3 Pre-processing NIGHT 

The preprocessing steps are the same for the night product with the exeption of the radiance to 

reflectance conversion. To derive the night cloud mask we do not need the reflectances, only the 

brightness temperature bands therefore only the Resampling, Peprojection and Subset steps will be 

applied.  

Similarly as for the day-time product, Night-time pixels are flagged as cloud if the single condition is 

satisfied. (Giglio et al. (2003)). 

TIP: You can also build the expression yourself using the Expression Editor. 
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𝑇12 < 265 𝐾 

Where, T12 correspond to thermal band S9, at central wavelength of 12 μm.  

7.3.1 Resample 

Follow the steps described in section 7.2.2 Resample.  

Go to Raster → Geometric Operations → Resampling.  

In the I/O Parameters tab, make sure that the NIGHT-time product [2] is selected as input.  

Select Save as: .  

Set the Name of the target product to S3A_SL_1_RBT_20170618T220242_resampled and the target 

folder under Directory to: /shared/Training/HAZA04_ActiveFire_Portugal_TutorialKit/Processing.  

In the Processing Parameters tab set: By reference band from source product: F1_BT_in 

Click Run. A new product [7] has been created. Click OK to the pop-up window and close the 

Resampling window.  

7.3.2 Reproject 

Follow the steps described in section 7.2.3 Reproject.  

Go to Raster → Geometric Operations → Reprojection.  

In the I/O Parameters tab, make sure that the night-time resampled product [7] is selected as input. 

Set the name of the target product to: S3A_SL_1_RBT_20170618T220242_resampled_reprojected 

and the target folder under Directory to: 

/shared/Training/HAZA04_ActiveFire_Portugal_TutorialKit/Processing 

In the Reprojection Parameters tab set: 

Under Coordinate Reference System (CRS) choose: Custom CRS and at Projection: UTM Zone  

Click on Projection Parameters and set as Zone: 29 and as Hemisphere: North 

Click OK and then click Run. A new product [8] has been created. Click OK at the pop-up dialog and 

close the Reprojection window.  

7.3.3 Subset 

Follow the steps described in section 7.2.4. Subset. Click on the new product [8] in the Product 

Explorer window to highlight it.  

Go to Raster → Subset.  

In the Spatial Subset tab, at the Geo Coordinates tab, set the following coordinates: 

North latitude bound:    41.00  West longitude bound:   -10.00   

South latitude bound:    38.00  East longitude bound:     -7.0 

 

Click OK. The subset product [9] will appear in the Product Explorer window but is not physically 

saved. We will save it after the creation of the cloud mask.  
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7.3.4 Create a cloud mask band. 

As discussed before, we will create our own cloud mask. Right-click on the subset product [9] and 

click Band Maths. A new window will open.  

Set as Name: “cloud_mask” 

Deselect “Virtual (safe expression only, don’t store data)” 

Then click on “Edit Expression…” and enter the following statement:  

 

The new band will automatically open in a new “View” window.  

 

Right-click the subset product [9] and go to Save Product. In the next dialog click Yes and save the 

product as Subset_S3A_SL_1_RBT_20170618T220242_resampled_reprojected to  

/shared/Training/HAZA04_ActiveFire_Portugal_TutorialKit/Processing 

Now both of our products are ready for Active Fire Pixel Detection. Let’s close SNAP window 

completely and open a new one.  

S9_BT_in < 265  
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7.4 Active fire detection 

In this step, we will apply a simple algorithm to identify pixels containing one or more active fires at 

the time of the satellite overpass. This approach exploits the different responses of middle-infrared 

(MIR) and thermal-infrared (TIR) bands to hot subpixel targets. In particular, the algorithm looks for a 

significant increase in radiance (brightness temperature) at 3.74μm in comparison to observed 

radiance (BT) at 10.85μm as well as in absolute value (See  NOTE 2).  

 

As described in section 7.1 SNAP – Open Project and Explore 

Data there are two bands (F1 and F2, “fire channels”) 

dedicated to fire detection (greatly increased saturation 

temperature threshold).  

In the new SNAP window, click Open Product , navigate 

to: /shared/Training/HAZA04_ActiveFire 

_Portugal_TutorialKit/Processing and open both subset 

products we have created during the pre-processing phase.  

Right-click the daytime product and select Add Land Cover 

Band, in the dialog that appears, scroll down and select 

“CCILandCover-2015”, and then click OK.  

This will add a new band containing the land cover layer. 

Repeat the same for the night-time product.  

 NOTE 2: This characteristic active fire signature is the result of the large difference in blackbody 

radiation at 4μm and 11μm, emitted at vegetation combustion temperatures, as described by the Planck 

function. The image below shows the spectral radiance emitted from blackbodies at Earth ambient 

temperature (300 K) and a range of possible vegetation fire temperatures (650 - 1400 K). The 

approximate central wavelengths of the Sentinel-3 SLSTR MIR (3.74μm) and TIR (10.85μm) channel are 

also indicated.  

 
Credits: Sentinel-3 Active Fire: Fire Detection and Fire Radiative Power Assessment (ESA) 
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7.4.1 Daytime fire detection 

Now, let’s visualize all the bands we will use to define the fire detection algorithm for the daytime 

product. Expand the daytime product folder go to Bands → “F*BT_in” folder, double-click both 

bands [“F1_BT_in (3742 nm)”, “F2_BT_in (10854 nm)”] to open them both in the View Window. 

Next, scroll down to the bottom of the Bands folder and double-click “cloud_mask” and 

“land_cover_CCILandCover-2015” band.  

Go to Window → Tile Horizontally and in Navigation tab select Zoom all. In the Product Explorer 

window, collapse all the expanded folders. 

 

Click on the “land_cover_CCILandCover-2015” view, go to Colour Manipulation tab and inspect the 

classes in the land cover layer. Which classes will be correlated with forest fires?  

  

Now zoom to the bright spot in the center of “F1_BT_in band (3742nm)”. All other views will zoom 

to the same area. Inspect other opened bands by going to the Pixel Info window; there you can see 

the values of the pixel over which you move your cursor in all opened bands. 



23 
 

 

Now go back to Product Explorer window and let’s design our test to detect active fire pixels. Pixel is 

classified as fire-pixel if the following conditions are true: 

Initial test F1_BT_in > 325 K 

Eliminate warm background  (F1_BT_in - F2_BT_in) > 18 K 

Eliminate clouds cloud_mask == 0 

Eliminate non-forest pixels 
'land_cover_CCILandCover-2015' >= 50 and  
'land_cover_CCILandCover-2015' <= 130 

Right-click the daytime product and go to Band Maths…. A new window will open.  

Set as Name: fire_detection_LC 

Deselect the “Virtual (safe expression only, don’t store data)” option. 

Then click “Edit Expression…” and enter the following conditions under Expression:  

 

 

F1_BT_in > 325 and (F1_BT_in - F2_BT_in) > 18 and cloud_mask == 0 and 

'land_cover_CCILandCover-2015' >= 50 and 'land_cover_CCILandCover-2015' 

<= 130 
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Click OK in both windows. The new band “fire_detection_LC” will be created and added in the Bands 

folder at the daytime product. 

 

Go to Window → Tile Single. In Navigation tab select Zoom all. Now, we can see the active fire 

pixels for 18 June 2017 at 10:45:48. To save our results, right-click the daytime product and select 

Save Product. Finally, close all our opened views. 

7.4.2 Night-time fire detection 

Now let’s adapt our thresholds for the night-time image. First, let’s open all our input bands to 

inspect them as we did for the daytime detection. Open and view the bands as at 7.4.1 Daytime fire 

detection chapter. 
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We can see that the distinction between the BT of land and ocean is not clearly visible during the 

night as it was during the day. We can also see some clouds covering over the area where we have 

detected the active fire pixels during the day. Use the Pixel Info tool again to explore the pixel values 

in our input bands. Think how you would change the thresholds we had used for the daytime 

detection. 

The conditions for cloud mask and land cover will remain the same but due to the cooler background 

response during night, we need to slightly lower our thresholds. Let’s set the initial test to 315 K and 

the warm background check to 15 K. Right-click the daytime product and go to Band Maths…. A new 

window will open.  

Set as Name: “fire_detection_LC” 

Deselect the “Virtual (safe expression only, don’t store data)” option. 

Then click Edit Expression… and enter the following conditions under “Expression”:  

 

 

Go to Window → Tile Single. In Navigation tab select Zoom all. Now, we can see the active fire 

pixels for 18 June 2017 at 22:02:42. To save our results, right-click the night-time product and select 

Save Product. However, in this case we need to be aware that some active cloud pixels could have 

been obscured by clouds. Close all view windows. 

7.5 Export as GeoTIFFs 

Open only the “fire_detection_LC” band of the day-time product. In Product Explorer tab, select 

(highlight) the daytime product.  

Then go to File → Export → GeoTiff (NOT! Geotiff/Big Tiff). In the dialog, that opens click Subset → 

Band Subset (second tab) and select only band “fire_detection_LC” (last in the list, use the Select 

none button to deselect all), then go to the Metadata Subset tab and click Select none. Click OK. In 

F1_BT_in > 315 and (F1_BT_in - F2_BT_in) > 15 and cloud_mask == 0 and 

'land_cover_CCILandCover-2015' >= 50 and 'land_cover_CCILandCover-2015' 

<= 130 
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the dialog that appears, click No and save the file with the File Name: fire_detection_DAY.tif to the 

Processing folder by clicking on Export Product. Repeat the same for the night-time product (save as 

fire_detection_NIGHT.tif).  

 

Now, we can import the image to another GIS/Remote sensing software for further processing or 

map creation (section 8.2 Convert to vector). In the extra steps of this tutorial, we will use QGIS. To 

download the results to your local computer, see section 8.1 Downloading the outputs from VM. 

7.6 Compare results with operational monitoring 

Now, you can compare your results with operationally derived products using different sensors such 

as VIRS, MODIS etc. Go to Global Wildfire Information System – GWIS 

(http://gwis.jrc.ec.europa.eu/static/gwis_current_situation/public/index.html) and see how your 

result compares. Be aware that the site provides daily summary as compared to our product showing 

a snapshot in time. (Set: date-range from 18 June 2018 to 18 June 2017, select MODIS and VIRES and 

zoom in to the area of our interest). 

http://gwis.jrc.ec.europa.eu/static/gwis_current_situation/public/index.html


27 
 

 

 

THANK YOU FOR FOLLOWING THE EXERCISE! 

8 Extra steps  

8.1 Downloading the outputs from VM 

Press Ctrl+Alt+Shift. A pop-up window will appear on the left side of the screen. Click on bar below 

Devices, the folder structure of your VM will appear. Navigate to your Processing folder and double 

click any file you want to download.  
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8.2 Convert to Vector 

Go to Application → Processing → QGIS Desktop 

(or use the desktop icon).  

Click on the Add Raster Layer , navigate to: 

/shared/Training/HAZA04_ActiveFire_Portugal_T

utorialKit/Processing select the 

fire_detection_DAY.tif and click Open.  

 

It will appear completely black (Image a), except 

for some No Data values which will appear in 

white. This happens because the No Data values 

are transparent, and our background is white. This 

means that if you set the background colour to a 

different one than white, e.g. red, the No Data 

values will appear red as well. 

Right-click on the opened raster-layer in the Layers 

Panel (lower left) and go to Properties.  

 

In the Style tab set:   

Render type: Singleband gray 

Band: Band 1 (Gray) 

Max: 1 

 

Click OK to see the fire pixel values at the band 

(they will appear in white, Image b). 

 

Right-click again on the opened raster-layer in the Layers Panel (lower left) and go to Properties.  

Image a Image b 

No Data 

Values 

No Data 

Values 

Fire Pixel 

Values 
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In the Style tab set:  Render type: Singleband pseudocolor  

Band: Band 1 (Gray) 

Max: 1 

Then click  Load colour map from file to import predefined colour map. Navigate to the Auxdata 

folder and open Active_fire_no_background.txt. Or design your own (fire pixels have value 1, 

background pixels have value 0). Click OK.  

  
We can also add a base map layer. Go to Web → OpenLayers plugin → Google Maps → Google 

Satellite. Drag the Google Satellite layer below the fire_detection layer in the Layers Panel (See  

NOTE E2). 

 

 

 NOTE E2: In case the OpenLayers plugin is not installed, click on Plugins →Manage and Install Plugins. 

Select the “All” tab on the left side panel and write “OpenLayers plugin” on the search box. Select the 

plugin on the list and click “Install Plugin”. Restart QGIS to finalize the installation.  

Fire Pixel 

Values 
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Then go to Processing → Toolbox, expand GDAL/OGR, then expand [GDAL] Conversion and double 

click the  Polygonize (raster to vector) tool.  

In the Parameters tab, check your input layer to be “fire_detection_DAY [EPSG:32629]”, keep the 

“Output field name” as default and at “Vectorized” select “Save to file…” and save it at the 

Processing folder with “File name”: “fire_detection_DAY”) 

 

Click Run.  
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You can see that the 0 values and No Data have been polygonised as well. We can remove them by 

right-clicking the Vectorized layer in the Layers Panel and going to Open Attribute Table. Then click 

 “Select features using an Expression” and enter "DN" < 1 (including quotation marks). Click at the 

lower right “  Select” and then click Close.  

 
All polygons except the ones with value 1 (fire) have been selected. Click Edit and then click 

Remove. This will remove all selected polygons.  

 
Now, click on Edit again to finish editing. Then click Save to save your edits. Close the Attribute Table. 

 
Now we have a shapefile layer containing only our fire pixels.  

You can repeat the 8.2 Convert to Vector chapter for the night band as well. 

Edit Remove 
Select features using an Expression  
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9 Further reading and resources  

Global Wildfire Information System (GWIS)  

(http://gwis.jrc.ec.europa.eu/static/gwis_current_situation/public/index.html) 

Global Forest Watch - Fires (http://fires.globalforestwatch.org/map/) 

CCI Land Cover (http://maps.elie.ucl.ac.be/CCI/viewer/index.php) 
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