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1 Introduction to RUS 

The Research and User Support for Sentinel core products (RUS) service provides a free and open 

scalable platform in a powerful computing environment, hosting a suite of open source toolboxes pre-

installed on virtual machines, to handle and process data acquired by the Copernicus Sentinel satellites 

constellation.  

In this tutorial, we will map the snow cover evolution in the Sierra Nevada from February to May 2021 

based on Sentinel-3 OLCI products. We will carry out this study in the SNAP software on RUS virtual 

machines. 

2 Snow Cover Mapping - Background 

Snow cover is the land area 

blanketed in snow at a given time. 

Air temperature is one of the main 

factors that determines the amount 

of precipitation that falls on land as 

snow and its melting rate. In many 

regions of the world, warming 

trends are inducing fewer snow falls 

and earlier snowmelt.  

While snow cover in winter has 

remained fairly steady and has 

increased in the fall since 1972 in 

North America, the United States Environmental Protection Agency (EPA) has found that spring and 

summer snow cover have been plummeting. In fact, the U.S snow season has shortened by more than 

two weeks in roughly 50 years, the last day of snow now being 19 days earlier than it was in 1972. 

In particular, climate change has made California dryer and hotter which means that more rain than 

snow is now falling. Since much of the rainfall evaporates, spring and summer snowpack constitutes 

the main water source to fill up reservoirs that fuel human activities such as agriculture or hydropower 

generation. 

The decreasing snow cover and the shift in snow season are contributing factors to the megadrought 

California has been experiencing since the year 2000. These past 22 years have been the driest years 

in at least 1200 years based on tree ring records. This has now major impacts on human lives and food 

production in this American state. For the first time, the federal government is thinking about cutting 

water supplies by 25%. 
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Hence monitoring snow cover is of prime importance to determine the amount of available water in 

California. With their high spatial and temporal resolution and coverage, earth observation satellites 

constitute key tools to assess the snow cover on a regular basis. In particular, it is possible to compute 

the Normalized Difference Snow Index (NDSI) from the data collected by the Ocean and Land Colour 

Instrument (OLCI) on board Sentinel-3A and Sentinel-3B. The NDSI is a key indicator of the presence of 

snow. The methodology presented here has been adapted from Kokhanovsky et al. (2019) 

3 Training 

Approximate duration of this training session is one hour and a half.  

The Training Code for this tutorial is CRYO05. If you wish to practice the exercise described below 

within the RUS Virtual Environment, register on the RUS portal to request a Virtual Machine. Go to 

Your RUS Service → Your training activities and Request a Webinar Training. 

3.1 Data used 

• 4 low/no-cloud Sentinel-3A images acquired on February 6th, March 5th, April 1st, and May 6th 2021 

(one image per month): 

[downloadable @ https://scihub.copernicus.eu/] 
S3A_OL_1_EFR____20210206T181455_20210206T181755_20210207T232248_0179_068_141_2340_LN1_O_NT_002.zip 

S3A_OL_1_EFR____20210305T181452_20210305T181752_20210307T000051_0179_069_141_2340_LN1_O_NT_002.zip 

S3A_OL_1_EFR____20210401T181454_20210401T181754_20210402T222055_0179_070_141_2340_LN1_O_NT_002.zip 

S3A_OL_1_EFR____20210506T180730_20210506T181030_20210507T222424_0179_071_255_2340_LN1_O_NT_002.zip 

3.2 Software in RUS environment 

Internet browser, SNAP+Sentinel-3 Toolbox, QGIS 

4 Register to RUS Copernicus 

To repeat the exercise using a RUS Copernicus Virtual Machine (VM), you will first have to register as 

a RUS user. For that, go to the RUS Copernicus website (www.rus-copernicus.eu) and click on 

Login/Register in the upper right corner.  

https://rus-copernicus.eu/
https://scihub.copernicus.eu/
http://www.rus-copernicus.eu/
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Select the option Create my Copernicus SSO account and then fill in ALL the fields on the Copernicus 

Users’ Single Sign On Registration. Click Register. 

  

Within a few minutes, you will receive an e-mail with an activation link. Follow the instructions in the 

e-mail to activate your account.  

You can now return to https://rus-copernicus.eu/, click on Login/Register, choose Login and enter 

your chosen credentials. 

https://rus-copernicus.eu/
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Upon your first login you will need to enter some details. You must fill all the fields.   

 

5 Request a RUS Copernicus Virtual Machine to repeat a Webinar 

Once you are registered as a RUS user, you can request a RUS Virtual Machine to repeat this exercise 

or work on your own projects using Copernicus data. For that, log in and click on Your RUS Service  → 

Your training activities. 
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Select CRYO05 – Snow Cover Mapping in California with Sentinel-3, check the field “I have read and 

agree to the Terms and conditions of RUS Service” and then click on Request Webinar Training to 

request your RUS Virtual Machine. 

 

Further to the acceptance of your request by the RUS Helpdesk, you will receive a notification email 

with all the details about your Virtual Machine. 

To access it, go to Your RUS Service → Your Dashboard and click on Access my Virtual Machine. 

NOTE: If the “Access my Virtual Machine” is greyed out, please access your VM from the direct link 

you have received at the email informing you about the creation of your VM. 

CRYO05 – Snow Cover Mapping in California with Sentinel-3 
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Fill in the login credentials that have been provided to you by the RUS Helpdesk via email to access 

your RUS Copernicus Virtual Machine. 

This is the remote desktop of your Virtual Machine. 



9 
 

  
 

 

 

6 Step by step  

6.1 Data download – ESA SciHUB 

In this step, we will download the Sentinel-3 scenes used for the exercise, from the Copernicus Open 

Access Hub using the online interface. 

Go to Applications  Network  Firefox Web Browser or click the link below. 

Go to https://scihub.copernicus.eu/ 

Before starting the exercise, make sure you are registered in the Copernicus Open Access Hub so that 

you can access the free data provided by the Sentinel satellites. 

 

 

https://scihub.copernicus.eu/
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Go to “Open Hub”. If you do not have an account, sign up in the upper right corner, fill in the details 

and click register. 

You will receive a confirmation email at the e-mail address you have specified: open the email and click 

on the link to finalize the registration. 

Once your account is activated – or if you already have an account – LOGIN. 
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In this guide, we describe the procedure to download the 4 Sentinel-3A images. Drag the Map to 

California and define the study area using the  button (approximate area – orange rectangle located 

east of San Francisco and just South East of Carson City). Then, open the search menu by clicking on 

the left part of the search bar (  ) and specify the parameters below. Press the search button (  ) 

after that. 

Sensing period: From 2021/02/06 to 2021/02/06 

Check mission: Sentinel-3 

Satellite Platform: S3A_* 

Product type: OL_1_EFR  



12 
 

  
 

 

 

In this case, the search returns 1 result (blue tile).  

 

As you can see, the product appears Offline. Hitting the download icon  will trigger the offline 

product retrieval: 
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This will automatically add the product to the “Cart” . In case an error  message appears, try again a 

bit later – you can request one offline  product per account per hour. (See  NOTE 1 and  NOTE 2). 

The product will be online within a few hours. Once online, the product will remain available for 

download for at least 3 days before it is moved back offline. 

 

You need to repeat the same process for the following images and adapt the search criteria: 

 S3A product from March 5th 2021:  

 S3A_OL_1_EFR____20210305T181452_20210305T181752_20210307T000051_0179_069_141_2340_LN1_O_NT_002 

o Sensing period: From 2021/03/05 to 2021/03/05 

o Check mission: Sentinel-3 

o Satellite Platform: S3A_* 

o Product type: OL_1_EFR  

 S3A product from April 1st 2021: 

 S3A_OL_1_EFR____20210401T181454_20210401T181754_20210402T222055_0179_070_141_2340_LN1_O_NT_002 

o Sensing period: From 2021/04/01 to 2021/04/01 

o Check mission: Sentinel-3 

o Satellite Platform: S3A_* 

o Product type: OL_1_EFR  

 S3A product from May 6th 2021 

 S3A_OL_1_EFR____20210506T180730_20210506T181030_20210507T222424_0179_071_255_2340_LN1_O_NT_002 

o Sensing period: From 2021/05/06 to 2021/05/06 

o Check mission: Sentinel-3 

o Satellite Platform: S3A_* 

o Product type: OL_1_EFR  

     NOTE 2: You can find more information about the retrieval of offline/long term archive products here:  

 https://scihub.copernicus.eu/userguide/DataRestoration. Most Sentinel products remain online for a 

month after they are published. They are then moved offline and need to be requested back online as 

previously shown. In a more general way, the scihub user guide is a very useful resource to check. 

     NOTE 1: Please keep in mind that you cannot download more than 2 products at the same time, per 

account from SciHub. 

https://scihub.copernicus.eu/userguide/DataRestoration
https://scihub.copernicus.eu/userguide/
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Each search should give you a unique product. The products will be downloaded to /home/rus/ as zip 

archives. Move them to the below path and unzip the archives: Right-click on the product → Extract 

Here . These 4 products were chosen because of their very low cloud coverage over our 

area of interest. 

Path: /shared/Training/CRYO05_SnowCover_California/Original/ 

 

6.2 SNAP – Open and Explore data 

Once you have extracted the archives, open the SNAP software from the icon  located on the 

desktop. Hit the Open Product icon, browse to the Original/ folder and open the product from 

 NOTE 3:  Copy-paste the S-3 Image name in the Search Criteria box (upper left corner) of the 
Copernicus Open Access Hub to find the images faster (make sure to clear all other search criteria 
first).  
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February 6th by selecting its xfdunmanifest.xml file. You can also navigate to the product folder from 

a product browser and drag and drop the xfdunmanifest.xml file in the Product Explorer Tab. 

The product is now open in the Product Explorer Tab of the SNAP software. Feel free to expand the 

product tree by hitting the key  button left of the open product. Unfold the product content and 

appreciate how SNAP conveniently gathers the data into several folders.  

The main data of interest (top of atmosphere radiances in the 21 spectral bands of OLCI is stored in 

the Bands → Oa*_radiance folder. The other folders contain data that give additional information on 

the context of the measurements. For example, the Masks folder encloses very useful information on 

the quality of the retrieval. MetaData contains static information about the product such as the 

timestamp, the platform name, the observation mode, etc. 

 

If you want to check the properties of a band, right-click on the band and hit Properties. 
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6.2.1 Create RGB Image – Natural Colours Oa08, Oa06, Oa04 

To visualize our product content, right click on the S3A product name and select Open RGB Image 

Window. Select Oa08 for Red, Oa06 for Green and Oa04 for Blue. Hit OK and the RGB view will open 

in the View Window 

 

When on the view, select the Hand  button to drag the view to your area of interest. Simply use 

the centre wheel of your mouse to zoom in and out. You can go to the World View tab and zoom in to 

see the location of the opened product on the globe. 

 

On the generated view, you can notice that most of the Sierra Nevada mountain chain is covered in 

snow on February 6th 2021.  

 TIP 1: $1 Refers to the index number of the product in the Product Explorer Tab 
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6.2.2 Create RGB Image – Oa17, Oa6, Oa3 

In order to enhance the snow visualization, we are going to open a second view with different OLCI 

bands. Just like in section 6.2.1, right click again on the product name and select Open an RGB Image 

Window. Then in the profile section, choose OLCI L1 – 17.6.3. Then, to make both views simultaneously 

visible, go to Window → Tile Horizontally  

 

Then, in the Navigation tab, click on the two icons shown within the blue rectangle below, to 

synchronize the views and the cursor position across the views. 
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Now, feel free to navigate on the views, zoom in and out to explore the different features of the 

pictures! 

 

Close the RGB View opened with the natural colours (Tristimulus RGB view). Open the three 

remaining S3A products in SNAP in chronological order (products from March, April and May 2021) 

and open RGB views with the OLCI L1 – 17.6.3 profile for each of them. Finally, go to Window→ Tile 

Horizontally to simultaneously inspect the 4 months. It is possible to visually assess the snow cover 

decrease from February to May 2021. 
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6.3 The Normalized Difference Snow Index (NDSI) 

Visual inspection of the products clearly shows a strong snow cover decrease over the course of spring 

2021. To more quantitatively assess the snow cover extent, we will compute the so-called Normalized 

Difference Snow Index (NDSI, see  NOTE 3).  

 

6.4 SNAP – Sentinel-3 Pre-processing 

As you may have noticed, computing NDSI out of OLCI products involves using atmospherically 

corrected radiances. The native OLCI L1B products only contain Top of Atmosphere (TOA) radiances 

for the 21 spectral bands (see  NOTE 4). Our pre-processing step will therefore consist in using 

Optical→Preprocessing→Rayleigh Correction.  At the time of writing this exercise, this module does 

not work in batch mode and we need to apply it to each individual scene one by one. The Rayleigh 

correction module fully corrects the selected bands for molecular absorption and scattering to 

compute the so-called Bottom of Rayleigh reflectances (rBRR). This module does not account for 

aerosol absorption and scattering, so these effects will be neglected in our study.  

 NOTE 3: NDSI is related to the presence of snow in a pixel and allows to distinguish snow from most 

cloud types. Indeed, on satellite images, snow may appear as bright as clouds. In the SWIR part of the 

spectrum, snow strongly absorbs solar radiation as opposed to clouds. As OLCI has no SWIR band, 

Kokhanovski et al. (2019) have adapted the NDSI computation to the OLCI sensor: 

𝑁𝐷𝑆𝐼 =
𝑅(𝜆1) − 𝑅(𝜆2)

𝑅(𝜆1) + 𝑅(𝜆2)
 

Where 𝑅(𝜆𝑛) are the atmospherically corrected radiances for: 

 𝜆1 = 865 𝑛𝑚 (band 17) 

 𝜆2 = 1020 𝑛𝑚 (band 21) 
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Let’s first apply the Rayleigh correction to the S3A product from February 6th. First go to 

Optical→Preprocessing→Rayleigh Correction. In the I/O Tab, make sure the product from February 

6th is selected as Source Product. Then set the Directory to 

/home/rus/shared/Training/CRYO05_SnowCover_California_S3/Processing/Rayleigh/. In the 

Processing Parameters Tab, select the Oa02, Oa03, Oa06, Oa17 and Oa21_radiance source bands. You 

can select all 5 source bands at once by holding down the Ctrl key. Make sure that only the Compute 

bottom of Rayleigh reflectance bands option is selected.  

 

 NOTE 4: Radiance is the variable directly measured by remote sensing instruments. It is the amount of 

light seen by an instrument from a surface of an object. In the OLCI products, it is given as mW.m-2.sr-

1.μm-1. This amount of light is hence measured at the Top of Atmosphere. Some applications may 

require that the TOA radiances are first corrected for atmospheric effects (molecular and aerosol 

scattering and absorption) to work with Bottom of Atmosphere (BOA) radiances. BOA radiances is the 

amount of light leaving a target at the bottom of our atmosphere. 
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Finally, hit Run! The processing may take up to 10mn per OLCI product. The output product 

automatically opens in SNAP. You need to repeat this step for the three remaining products (March, 

April and May 2021). You can see that only the selected rBRR bands have been written to the output 

products. 

 

Once this is done, you can close the 4 original OLCI L1B products. For this, select the 4 products and 

right click on the selection and hit Close 4 products. 

 

 

 

6.5 SNAP – Sentinel-3 Processing 

Now that we have computed the bottom of Rayleigh reflectances for the 4 products, we are going to 

apply the following processing steps: 

 Spatial subset to crop the products to our region of interest 

 NDSI and snow flag computation 

 Reprojection to set a Coordinate Reference System (CRS) to our products 

 Collocation of the four products to stack the snow flags for the individual months altogether  
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Repeating the analysis for every image one by one would be very time consuming. For this reason, we 

can create a graph containing all steps of our methodology and use the batch processing option of 

SNAP to run bulk processing.  

6.5.1 Graph Builder 

We will use the GraphBuilder tool, to create a chain with the processing steps we want to apply and 

at the end, only the final product will be physically saved (this way we will also save disk space since 

the products of the intermediate steps will not be stored). To create an empty graph, go to Tools → 

GraphBuilder. At the creation, the graph only has two operators: Read (to read the input) and Write 

(to write the output). To avoid any confusion, right click on the Write operator and delete it. 

 

In the Graphbuilder, we will not define any parameters in the tabs (they will be defined in the Batch 

Processing step where we will apply this processing for the images we have downloaded, at once). We 

will only create and save the graph. 

First, we need to create a Subset of the image, since we want to focus only over a defined area and we 

do not need the whole extent of the products. To add the Subset operator, right click on the Graph 

Builder and go to Add→Raster→Geometric→ Subset. Then, connect the Read operator to the subset 

tab. To connect two blocks, start from the right of the block to create a red arrow and drag it to the 

following block. 
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The next processing step will consist in deriving the NDSI and snow flag over land pixels. For this task, 

we will use the Band Math operator. Right-click and go to Add→Raster→BandMaths. Connect the 

operators as shown below (see  NOTE 5). 

 

Then to set a defined CRS to our output, right click and go to Add→Raster→Geometric→Reproject.  

 

Finally, we just need to properly save the output. For that, right click and navigate to Add→Input-

Output→Write. Your final graph should be similar to the one shown below: 

 NOTE 5:  In batch processing mode, the output of the BandMaths operator is the computed band (NDSI) 

only. If in your product, you would like to save additional data such as the reflectances or the quality 

flags, use the Add→Raster→BandMerge operator as follows. 

 

This way, you will be able to select the bands to be written to the output product. 



24 
 

  
 

 

 

Finally, click on Save in the lower part of the panel and save the graph in the following path as 

’NDSI.xml’ without setting any parameter ( see TIP 2). Once the graph is saved, close the Graph Builder. 

Path: /shared/Training/CRYO05_SnowCover_California/AuxData/ 

6.5.2 Batch Processing 

If the same processing scheme is applied to multiple images, the Batch Processing tool is what you are 

looking for. To use the Batch Processing tool go to Tools→Batch Processing. First, you need to Load 

the Graph you want to run. Hit Load Graph, browse to /shared/Training/ 

CRYO05_SnowCover_California/AuxData/ and load the NDSI.xml you just created. New tabs 

corresponding to our operators appear at the top of the window. 

 

In the I/O Parameters tab, unselect the “Keep source product name” option. In the same tab, we will 

add all opened products from the Product Explorer window by clicking Add Opened button at the 

right and then hit Refresh . In our case, we have loaded the 4 pre-processed S3A images from 

February, March, April and May 2021. 

 TIP 2: As we have created an empty graph, the Graph builder may display an error message 

Expression is invalid. This is normal as we have no set any parameters yet. 

If you did not succeed to create the processing graph, you will find a backup version in  

/shared/Training/CRYO05_SnowCover_California/AuxData/Backup/ 
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6.5.2.1 Subset 

In the Subset tab, first select all Source Bands (use the ctrl+A keyboard shortcut). Then select 

Geographic Coordinates, copy-paste the following Well-Known Text (WKT) into the box below the 

graph and hit Update to define the area and hit  to Zoom-in. 

 

 

POLYGON ((-124 40, -116.5 40, -116.5 36, -124 36, -124 40)) 
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6.5.2.2 BandMath – snow_flag 

Click now on the BandMaths tab, set the target band name to snow_flag set the No-Data value to 

NaN, click on Edit Expression and copy-paste the following expression. Click Ok afterwards.  

This expression means that a land pixel is considered as covered in snow if the NDSI is greater than 

0.03 and the rBRR_02 greater than 0.4 (threshold from Kokhanovsky et al. (2019)).  

 

6.5.2.3 Reproject 

In the Reproject tab, define the Custom CRS as UTM / WGS 84 (Automatic) located towards the 

bottom of the list and unselect Reproject tie-point grids.  

if ((rBRR_17- rBRR_21)/(rBRR_17+ rBRR_21))>0.03 and rBRR_02>0.4 and quality_flags_land then 

true else false 



27 
 

  
 

 

 

6.5.2.4 Write 

In the Write tab, under Name keep the default name (projected_Subset and Bandmath will be added). 

For the Directory set the path to  

/shared/Training/CRYO05_SnowCover_California/Processing/ 

Finally Hit Run!  

 

The processing may take up to 3mn. The processed products will automatically open in the Product 

Explorer Window when the processing is completed. Close the Batch Processing window and the 4 
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Rayleigh products that were used as inputs. Keep only the 4 projected_Subset_S3A_OL_1_EFR* 

products. 

6.6 Analysis of the processed products 

The 4 processed products now contain only a single band called snow flag. Let’s open each snow-flag 

band by double-clicking on snow_flag and then go to Window→Tile Horizontally. 

 

You can notice that all products have effectively been cropped to our polygon of interest and have 

been reprojected. The areas blanketed in snow appear in white as opposed to snow-free areas in black. 

For comparison purposes, below is an image of the four RGB views we generated earlier. 

 

6.7 Checking the accuracy of the computed snow flag by visual inspection 

If you want to check the accuracy of your snow flag on one product, then follow the steps described in 

this section. Otherwise, you can jump to the following 6.8 section. Checking the accuracy is useful 
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when you are developing your algorithm to tune the different thresholds on the NDSI and the rBRR_02 

channel. 

Let’s open the Rayleigh product from February 6th again. Go to 

/shared/Training/CRYO05_SnowCover_California/Processing/Rayleigh and drag and drop the 

S3A_OL_1_EFR____20210206T181455_20210206T181755_20210207T232248_0179_068_141_2340

_LN1_O_NT_002.SEN3_rayleigh.dim file to the Product Explorer Tab of SNAP. Close the 4 snow flag 

views opened earlier. Do not close the products, only the views. 

Right click on the product and hit Band Maths. Call the new band snow_flag and after clicking on the 

Edit Expression… button, copy and paste the snow flag expression we used earlier and hit OK. Make 

sure that the Virtual option is selected. This will allow us to easily adapt the snow_flag expression 

later on.  

 

Now, open an RGB view of the Rayleigh corrected product using the rBRR_17 for Red, rBRR_06 for 

Green and rBRR_03 for Blue 

 

The generated image has a white veil on it. This is due to the settings in the colour manipulation tab. 

if ((rBRR_17- rBRR_21)/(rBRR_17+ rBRR_21))>0.03 and rBRR_02>0.4 and quality_flags_land then 

true else false 
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In this tab for each colour, hit the  button and define the slider values so they are between 0 and 

0.6 for the 3 colours (Red, green and Blue). To change a slider value, you can move it along the colour 

bar or double click on a slider value to define a new value.  

 

Our view now looks better. 

 

Now, go to View→Tool Window→ Mask Manager. This opens up all the available masks in the 

product. There you can activate and deactivate a mask, change the colour of a mask or set its 

transparency. 
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We are going to create a snow_mask out of our snow flag band. Hit the  button at the upper right 

corner of the mask manager tab. In the Expression tab write the following expression and hit OK:  

 

The created mask appears at the bottom of the mask list. Let’s name it snow_mask and switch its 

colour to cyan. 

snow_flag==1 
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Then by zooming in and activating/deactivating the mask, you can check its accuracy and identify 

whether your algorithm is too conservative or too permissive.  

 

To tune the different thresholds and ultimately check how they affect our snow mask, in the Product 

Explorer Tab, expand the bands of the Rayleigh corrected product. Right-click on the snow flag band 

and hit Properties. By hitting the  button of the Pixel-Value Expression line, you can play around 

with the threshold and see how they affect the mask. For example, by setting rBRR_02>0.9, we notice 

that the mask is way too conservative. So let’s bring back the threshold on rBBR_02 to its original value 

of 0.4. 
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You can of course repeat this procedure for the other products.  

Finally, go to Raster→Masks→Mask Area… Select the snow_mask and hit OK: approx. 30,000 km² of 

our region of interest was covered in snow on February 6th 2021. 

 

After this, close the view and close the Rayleigh product(s) (do not forget to save the changes if you 

wish to!) 
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6.8 Snow cover time series 

6.8.1 Collocation of the outputs 

After batch processing the products, we end up with 4 products cropped to the same area of interest 

in the same CRS containing a single band (snow_flag). The following step will aim at stacking all the 

snow flag outputs of the batch processing in a single product to allow further processing. For this task, 

we will use the Collocation tool, which enables the user to collocate spatially overlapping products. 

Collocating products implies that the pixel values of all slave products are resampled into the 

geographical raster of the master one. Here we will choose the product from February 6th as the master 

and the products from March, April and May as slaves. Click on Raster → Geometric Operations → 

Collocation. 

 

Make sure to select projected_Subset_S3A_OL_1_EFR___20210206* as Master. Then hit the  

button from the Slave Products section and hit Add product(s). Select the snow_flag products from 

March, April and May 2021 and hit OK. Name the Target Product collocate_feb_march_apr_may and 

set the output Directory to /shared/Training/CRYO05_SnowCover_California/Processing/. Select the 

Bilinear interpolation method resampling at the bottom of the window. And hit Run! 

 

After a few seconds, the collocate_feb_march_apr_may product opens in the product explorer tab. 

Close the Collocation window, and now let’s expand the Bands of the collocated product. The following 
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table shows you the correspondence between the band names and the product month (see  NOTE 

6).  

Band name Significance 

snow_flag_M Snow flag band of the master product (Feb. 6th 2021) 

snow_flag_S0 Snow flag band of the first slave product (March 5th 2021) 

snow_flag_S1 Snow flag band of the second slave product (April 1st 2021) 

snow_flag_S2 Snow flag band of the third slave product (May 6th 2021) 

Feel free to open the snow flag bands in SNAP to check them out.  

 

6.8.2 Snow cover decrease assessment 

The last step of our processing is to derive a single band out of the 4 snow flag bands to classify the 

pixels depending on when they were identified as snow-covered. The classes are summarized in the 

following table 

Class number Significance Colour 

1 Pixel is snow-covered from Feb. to May OR in May only  

2 Pixel is snow-covered from Feb. to April OR in April only  

3 Pixel is snow-covered from Feb. to March OR in March only  

4 Pixel is snow-covered in February only  

 NOTE 6: If you did not open the OLCI L1B products in chronological order in SNAP, then *_S0 will 

correspond to the first item of the slave product list, *_S1 to the second item of the slave product list 

and *_S2 to the last item of the slave product list. And you will have to adapt the classification 

expression of part 6.8.2 accordingly. 
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To create the band, right click on the collocated product and hit Band Maths. Name the band 

snow_cover, unselect the Virtual option and copy and paste the following expression in the Edit 

Expression tab. 

The new band automatically opens in SNAP as a black and white view. 

 

To add a colour ramp, go to Colour manipulation → Basic → Colour Ramp. There, you should find a 

set of pre-defined colour bars that are saved in /home/rus/.snap/auxdata/color_palettes/. 

if ((snow_flag_S2 and snow_flag_S1 and snow_flag_S0 and snow_flag_M) or (snow_flag_S2 and 

!snow_flag_S1 and !snow_flag_S0 and !snow_flag_M)) then 1  

else if ((!snow_flag_S2 and snow_flag_S1 and snow_flag_S0 and snow_flag_M) or (!snow_flag_S2 

and snow_flag_S1 and !snow_flag_S0 and !snow_flag_M)) then 2  

else if ((!snow_flag_S2 and !snow_flag_S1 and snow_flag_S0 and snow_flag_M) or 

(!snow_flag_S2 and !snow_flag_S1 and snow_flag_S0 and !snow_flag_M)) then 3 

else if ((!snow_flag_S2 and !snow_flag_S1 and !snow_flag_S0 and snow_flag_M)) then 4  

else NaN 
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To correctly visualize the snow cover decrease, we are going to use a colour ramp created ahead of 

this webinar. For this, hit the Import colour palette from text file button  and navigate to 

/shared/Training/CRYO05_SnowCover_California/AuxData/ and select snow_cover.cpd. When 

opening the file, a window appears, hit No. 

You can now assess the snow cover decrease between February and May 2021 in the Sierra Nevada. 

 TIP 3: The SNAP default colour ramps are in /home/rus/.snap/auxdata/color_palettes/. You can 

copy the snow_cover.cpd file to this folder and have it appear as a default colour ramp. Once in the 

home/rus/ folder, go to View→Show Hidden Files to make the .snap/ folder appear. If you wish to 

open these files within snap, you have to type the name of the .snap folder in the searchbar. 
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Again, you can use the Mask Manager to create new masks (f(x) button) and then select the 

RasterMaskMask Area… tool of SNAP to create new masks out of the snow cover band to assess 

the area covered in snow at a particular time. For example you can create a mask with the following 

expression: 

This will tell you the global snow coverage extent from February to May (~28,000km² in our case). 

Then it is possible to assess which fraction of this area was still covered in snow in May with the 

following expression: 

Approx. 2,500km² (less than 10% of the initial area) was snow-covered in May. 

7 Conclusions 

Satellite imagery is widely used to map and assess snow cover extent, especially in remote areas. 

Space-borne technologies offer a frequent and global coverage of our continents. As this exercise 

highlighted, simple index computations based on the spectral properties of snow in the near infrared 

part of the spectrum allow a relatively easy assessment of the snow cover extent. The Sentinel-3 

constellation constitutes a valuable asset to monitor the snow cover evolution at a large scale on a 

frequent basis. Furthermore, the OLCI products could be combined with other sensors to create multi-

sensor products and hence ensure a gap-free coverage of the Sierra Nevada. 

In this exercise, we have used low/no-cloud coverage images. Even though NDSI allows to distinguish 

snow from most cloud types, it remains challenging to accurately assess the snow cover extent under 

very cloudy conditions. Furthermore, OLCI only acquires data during daytime. The observations are 

hence limited at higher/lower latitudes during the winter season when daytime is limited.  

This demonstration also does not take into account the forest coverage of the area. Indeed, when fresh 

snow falls, it first falls on trees. As the snow gets older and heavier, it falls off the tree branches and 

snow_cover>0 

snow_cover==1 
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may be hidden from view. Some forest areas may be covered in snow even though they do not directly 

appear as snow covered from space. This could lead to an underestimation of the snow-covered area. 

If you want to learn more about this topic, you should watch our previous CRYO03 webinar. 

Finally, monitoring the snow cover area is one way of monitoring snow cover. One could also study the 

fractional snow cover, the snow water equivalent, the snow depth or the liquid water content 

8 Extra steps – Export to QGIS 

8.3 Export as a GeoTIFF 

SNAP allows the user to export the outputs as GeoTIFF for further analysing and processing in a GIS 

software such as QGIS. To do this, make sure to select the collocate_feb_march_april_may product 

in the Product Explorer Tab. Then from File→Export, choose the GeoTIFF option. In the dialog tab that 

opens, hit Subset.  

 

At the Band Subset (second tab) use the Select none button to deselect them all first and then select 

only the snow_cover band. Then go to the Metadata Subset tab and click Select none. Finally, hit OK 

and hit No in both dialog tabs that open. 

 

Define your export folder thanks to the Save in option and hit Export Product. 

https://www.youtube.com/watch?v=qvMaDkdJ2Ac
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8.4 Opening the File in QGIS 

Your GeoTIFF is now ready to be opened in QGIS (  icon from your VM desktop)! First open the 

software. From the left panel, expand the XYZ Tiles and drag the OpenStreetMap and drop it to the 

layer panel. 

 

Then, from a file browser, drag and drop your generated GeoTIFF in QGIS and zoom in to the Sierra 

Nevada using the central wheel of your mouse. A black & white view of the snow cover has opened. 
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Double-click on the GeoTIFF layer. This will open the properties of your layer. In the Symbology section, 

set the Render Type as Singleband pseudocolor. Then with the  button, navigate to 

/shared/Training/CRYO05_SnowCover_California/AuxData/ and open the snow_cover_QGIS.txt file 

which is a pre-defined colour ramp. Then simply hit OK. 

 

Enjoy the result! 
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THANK YOU FOR FOLLOWING THE EXERCISE! 

9 Further reading and resources 

Sentinel-3 OLCI User Guide  
https://sentinel.esa.int/web/sentinel/user-guides/sentinel-3-olci 

Sentinel-3 OLCI Technical Guide  
https://sentinel.esa.int/web/sentinel/technical-guides/sentinel-3-olci 

Sentinel-3 Marine User Handbook  
https://earth.esa.int/eogateway/documents/20142/1564943/Sentinel-3-OLCI-Marine-User-Handbook.pdf 

Climate Change Indicators: Snow Cover 
https://www.epa.gov/climate-indicators/climate-change-indicators-snow-cover 

What the megadrought means to the American West (CBS)  
https://www.youtube.com/watch?v=K9hUNufKIKw 

Retrieval of Snow Properties from the Sentinel-3 Ocean and Land Colour Instrument  

https://doi.org/10.3390/rs11192280 
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