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1 Introduction 

The Research and User Support for Sentinel core products (RUS) service provides a free and open 

scalable platform in a powerful computing environment, hosting a suite of open source toolboxes pre-

installed on virtual machines, to handle and process data derived from the Copernicus Sentinel 

satellites constellation. 

2 Snow mapping – background 

Snow cover is an important driver of many 

climatic, hydrological and ecological 

processes and is a required input to many 

models aiming to study and predict them. 

Snow cover area (SCA) is also one of the 

essential climate variables (ECVs) specified 

by the Global Climate Observing System 

(GCOS) to be observed by remote sensing in 

support of the United Nations Framework 

Convention on Climate Change (UNFCCC) 

and the Intergovernmental Panel on Climate 

Change (IPCC).  

There are multiple methodologies designed to observe snow cover using optical and SAR satellites. In 

this exercise you will learn how to process low-cloud optical Sentinel-2 data using the SNAP toolbox to 

create snow cover maps based on the Normalized Difference Snow Index (NDSI). The methodology has 

been adapted and simplified from Gascoin et al. (2019) - Theia Snow collection: high-resolution 

operational snow cover maps from Sentinel-2 and Landsat-8 data. Earth System Science Data 11 (2). 

3 Training 

Approximate duration of this training session is one hour.  

3.1 Data used 

• Four low/no-cloud Sentinel-2A Level 2A products (Tile ID: T33UUQ) acquired during February and 

March 2019 [downloadable @ https://scihub.copernicus.eu/]  

• S2B_MSIL2A_20190218T101059_N0211_R022_T33UUQ_20190218T161620.zip 

• S2A_MSIL2A_20190223T101021_N0211_R022_T33UUQ_20190223T123814.zip 

• S2B_MSIL2A_20190228T101029_N0211_R022_T33UUQ_20190228T143058.zip 

• S2B_MSIL2A_20190320T101029_N0211_R022_T33UUQ_20190320T195148.zip 

3.2 Software in RUS environment 

Internet browser, SNAP + Sentinel-2 Toolbox, Aria2 

  

https://scihub.copernicus.eu/
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4 Register to RUS Copernicus 

To repeat the exercise using a RUS Copernicus Virtual Machine (VM), you will first have to register as 

a RUS user. For that, go to the RUS Copernicus website (www.rus-copernicus.eu) and click on 

Login/Register in the upper right corner.  

 

Select the option Create my Copernicus SSO account and then fill in ALL the fields on the Copernicus 

Users’ Single Sign On Registration. Click Register. 

 

Within a few minutes you will receive an e-mail with activation link. Follow the instructions in the e-

mail to activate your account.  

You can now return to https://rus-copernicus.eu/, click on Login/Register, choose Login and enter 

your chosen credentials. 

http://www.rus-copernicus.eu/
https://rus-copernicus.eu/
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Upon your first login you will need to enter some details. You must fill all the fields.   

 

5 Request a RUS Copernicus Virtual Machine 
Once you are registered as a RUS user, you can request a RUS Virtual Machine to repeat this exercise 

or work on your own projects using Copernicus data. For that, log in and click on Your RUS Service → 

Your Dashboard.  
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Click on Request a new User Service to request your RUS Virtual Machine. Complete the form so that 

the appropriate cloud environment can be assigned according to your needs. 
  

 
 

If you want to repeat this tutorial (or any previous one) select the one(s) of your interest in the 

appropriate field. 

 

 
 

Complete the remaining steps, check the terms and conditions of the RUS Service and submit your 

request once you are finished. 
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Further to the acceptance of your request by the RUS Helpdesk, you will receive a notification email 

with all the details about your Virtual Machine. To access it, go to Your RUS Service → Your Dashboard 

and click on Access my Virtual Machine.  

 



8 
 

Fill in the login credentials that have been provided to you by the RUS Helpdesk via email to access 

your RUS Copernicus Virtual Machine.  

 

This is the remote desktop of your Virtual Machine. 

 

6 Step by step  

6.1 Data download – ESA SciHUB 

In this step, we will download a Sentinel-2 scene from the Copernicus Open Access Hub using the online 

interface (Applications → Network → Firefox Web Browser or click the link below). 

Go to https://scihub.copernicus.eu/   

https://scihub.copernicus.eu/
https://scihub.copernicus.eu/
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Go to “Open HUB”, if you do not have an account please register by going to “Sign-up” in the LOGIN 

menu in the upper right corner. 
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After you have filled in the registration form, you will receive an activation link by e-mail. Once your 

account is activated or if you already have an account, “LOGIN”.  

In the Full text search window type:  filename:*T33UUQ* 

Open search menu by clicking to the left part of the search bar and specify following parameters: 

Sensing period: From 2019/02/01 to 2019/03/31 

Check Mission: Sentinel-2 

Product Type: S2MSIL2A 

Cloud Cover %: [0 TO 15] 

 

 

Clock on the looking glass symbol to start the search. In our case the search returns 10 results, but not 

all are of interest to us. 

 

TIP: It may sometimes happen that the data used to create this exercise are temporarily unavailable. 

In such case, you can use other date period for the same location. 
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Go through the list and select these 4 full scenes by checking the box as shown above:  

• S2B_MSIL2A_20190218T101059_N0211_R022_T33UUQ_20190218T161620.zip 

• S2A_MSIL2A_20190223T101021_N0211_R022_T33UUQ_20190223T123814.zip 

• S2B_MSIL2A_20190228T101029_N0211_R022_T33UUQ_20190228T143058.zip 

• S2B_MSIL2A_20190320T101029_N0211_R022_T33UUQ_20190320T195148.zip 

Once they are all selected click on  to add the products to the cart. Then go to the cart by clicking on 

the green cart symbol left of the full text search. Finally, let’s download the cart in the form of .meta 

file. The file contains links to each of the files, we will need the file and download client to download 

the actual data.  

 

The products.meta4 file will be downloaded to your /home/rus folder. To download our data, we will 

use aria2 tool. To use the tool, we first need to move the products.meta4 file to the folder where we 

wish our data to be downloaded to - /shared/Training/CRYO03_SnowCover_Sumava/Original/ 

Then, let’s test our aria2 installation. To do this we open the Command Line  (in the bottom of your 

desktop window) and type: 

 
aria2c 
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The correct response should be as follows: 

 

 If the response is “-bash aria2c: command not found” (see  NOTE 1). 

 

If you have received the correct response, then we can run the tool by typing following commands in 

the command line (replace <username> and <password> with your login credentials for Copernicus 

Open Access Hub):  

 

The first line changes our directory to the target directory. The second line runs the download tool 

(Type the red text all in single line). All four products will be downloaded to the Original folder two 

products in parallel automatically (Note that the constraint of maximum two parallel downloads at a 

time is imposed by the Copernicus Access Hub, if you increase the number the download will fail). This 

might take some time.  

6.2 Data exploration 

Open the SNAP Toolbox by clicking the SNAP Desktop icon on the desktop. When the SNAP window 

opens, go to File → Sessions → Open session and navigate to:  

/shared/Training/CRYO03_SnowCover_Sumava/ORIGINAL_DATA.snap 

All four downloaded products should be loaded when the session opens. We can first investigate the 

structure of the Sentinel-2 Level 2A products. Click on the dot next to the first product name to expand 

the structure. The L2A products have been atmospherically and radiometrically corrected and contain 

(among others): 

• 13 surface (bottom-of-atmosphere) reflectance bands (see  NOTE 3)  

• cloud and snow probability bands (we will use the snow probability band to compare with our 

results) 

• scene classification (water, vegetation, cloud, snow/ice, shadow, unclassified) 

• masks derived from cloud and snow probability bands and scene classification 

 

 NOTE 1: If (and only if) the response is “-bash aria2c: command not found”. Then we have to install the 

tool, to do this in command line type: sudo apt-get install aria2 

When requested type: Y 

Then you can test your installation again.  

cd /shared/Training/CRYO03_SnowCover_Sumava/Original/ 

 

aria2c --http-user='<username>' --http-passwd='<password>' --check-

certificate=false --max-concurrent-downloads=2 -M products.meta4 

TIP: Level 2A have been systematically produced for products acquired over Europe since the spring 

of 2017, the coverage has increased through 2018 to reach global coverage in the beginning of 2019. 

If you need to run atmospheric correction on your data, see 7.2 Atmospheric correction. 
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Now, we can visualize the products. We could use the true (natural) colours but for distinguishing snow 

it is better to use the Short-Wave Infrared (SWIR) and Red bands as these provide the best separability 

between cloud and snow (for more explanation, check the graph in  NOTE 2). Right-click the first 

loaded product from 18 February and click Open RGB image window, a new window will open.  

Set:  Red:  B12      Green:  B11       Blue: B5 

 

When you have selected the correct bands, click on the Save icon and save the new profile in the 

default folder as Sentinel_2_MSI_Snow.rgb in the default folder. Now open the RGB view for the other 

three products as well, using the saved profile (in drop down menu). 

When you have all 4 Views opened, go to Navigation pane in the lower left and make sure the cursor 

 and the views  are linked. Then, go to Window -> Tile Evenly. Go back to Navigation tab and click 

 Zoom All to centre the Views. All snow-covered areas appear in bright blue colour, in the four views 

ordered by date of acquisition you can see the decreasing extent of snow cover between 18 February 

(upper left) and 20 March 2019 (lower right).  

 

The bright values of the cloud cover in the last image affect the visualization so it appears different 

than the other images (value distribution in the image affects the histogram stretch) but we can edit it 

to be visually comparable. Click on the “[4] Sentinel 2 MSI Snow RGB” window and go to Colour 

Manipulation tab, there you can edit the histogram stretch for each colour by moving the sliders. Move 

NOTE 2: This band combination provides a "natural-like" 

rendition while also penetrating atmospheric particles, 

smoke and haze. Vegetation appears dark and light 

green during the growing season, urban features are 

white, grey, cyan or purple, sands, soils. The almost 

complete absorption of Mid-IR bands in water, ice and 

snow causes snow and ice to appear as dark blue and 

water is black or dark blue. Hot surfaces such as forest 

fires and volcano calderas saturate the Mid-IR bands and 

appear in shades of red or yellow.   
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the red slider to 0.22, then change to green and move the green slider to 0.29, finally change to the 

blue histogram and move the blue slider to 0.63. Click on the Pan mode and zoom in to explore closer.  

 

6.3 STEP 1 – Pre-processing 

Processing the data one by one would be very time consuming and inconvenient. However, we can use 

the Batch Processing tool available in SNAP to process all images at the same time.  

To use the tool, we first need to define the process we want to apply and all its steps. We can do this 

using the GraphBuilder tool. Another advantage of the GraphBuilder is that only the final product will 

be physically saved, and we save valuable disk space.   

So, let’s build our graph. First, in the Product Explorer select the first loaded product (so it is 

highlighted), then go to Tools → GraphBuilder.  
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At the moment, the graph only has two operators: Read (to read the input) and Write (to write the 

output).  

The 13 bands in Sentinel-2 products do not all have same resolution (therefore size) as mentioned in 

NOTE 3. Many operators do not support products with bands of different sizes so first we need to 

resample the bands to equal resolution.   

To add the appropriate operator, right-click the white space between existing operators and go to Add 

→ Raster → Geometric → Resample   

 

A new operator rectangle appears in our graph and new tab appears below. Now connect the new 

Resample operator with the Read operator by clicking to the right side of the Read operator and 

dragging the red arrow towards the Resample operator.  

 

Now, we will add two BandMath operators from Add → Raster → BandMaths and then connect it to 

the Resample operator then repeat the operation to add BandMath(2).  

Next, we add BandMerge operator from Add → Raster → BandMerge. Connect the Resample 

operator and both the BandMaths operators, to the BandMerge operator as shown below.   

 

Next step will be to subset the images to the area of interest. Go to Add → Raster → Geometric → 

Subset and connect the Subset operator with the BandMerge operator. Finally, connect the 

BandMerge operator to the Write operator.  

Credits: ESA 2015 

NOTE 3: The input product 

contains 13 spectral bands 

in three different spatial 

resolutions (The surface 

area measured on the 

ground and represented by 

an individual pixel).  When 

we open the RGB view all 

our input bands have 20 m 

resolution, however, the 

view is displayed in the full 

10 m resolution.  
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At the moment, do not change anything in the parameter tabs, save the graph as Graph_Pre-

process.xml under /shared/Training/CRYO03_SnowCover_Sumava/Processing path by clicking Save 

at the bottom of the window and then close the GraphBuilder window.  

In the Product Explorer, make sure the product [1] (18 February 2019) is selected (highlighted). Now 

we can open the Batch Processing tool at Tools → Batch Processing. 

We will add all four opened products to be processed. In the I/O Parameters tab, click Add Opened on 

the upper right (second from top) and click Refresh. Deselect the Keep source product name. Then 

click Load Graph at the bottom of the window, navigate to our saved graph and open it. We see that 

new tabs have appeared at the top of window corresponding to our operators.  

 

Now, let’s set the parameters. In Resample tab we set:   

Under Define size of resampled product: Select the “By reference band from source product” and 

choose the B2 band (we will resample all the bands to 10m resolution).  

0

0

0 
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Next in the first BandMath tab, we set the expression for the calculation of a first preliminary cloud 

mask. The cloud mask will be based on the cloud confidence band (see  NOTE 4). In the BandMaths 

tab set: 

Target band: “Cloud_Class” 

No-Data Value: “NaN” 

Then go to Edit Expression … and type: 

 

 

 

Click OK to close the “Arithmetic Expression Editor” window. 

Next in the second BandMath tab, we set the expression for the calculation of the Normalized 

Difference Snow Index (NDSI, see  NOTE 5). In the BandMaths tab set: 

if quality_cloud_confidence > 90 then 2 else (if quality_cloud_confidence > 50 AND 

B8 > 0.3 then 1 else 0) 

 NOTE 4: The cloud masks derived by the L2A processing are very conservative because It is computed at 

coarser resolution and was developed to remove surface reflectance variations due to could 

contamination.  However, some clouds are semi-transparent in the SWIR band allowing snow detection. 

We will therefore use only very high confidence clouds > 90%, lower confidence clouds (50 - 90%) will be 

filtered by thresholding the NIR band. All other pixels will be considered cloud free. 
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Target band: “NDSI” 

No-Data Value: “NaN” 

Then go to Edit Expression … and type: 

 

 

In the BandMerge tab, keep the default parameters.  In the Subset tab we select bands: B3, B4, B11, 

B12, Cloud_Class and NDSI (to select multiple, hold Ctrl). Then click to select the Geographic 

Coordinates option and paste the area of interest definition in WKT (well know text) format to the text 

window below the map. Click Update and then click the Zoom-in icon  to see your subset on the 

map.  

 

 

 NOTE 5: When identifying the snow presence, green (~ 0.5 – 0.6 nm) and SWIR (~ 1.6mm) wavelengths 

are commonly used.  Snow generally appears very bright at optical wavelengths as do clouds, however 

unlike clouds (not all) it strongly absorbs radiation SWIR wavelengths. To identify snow cover and 

differentiate it from most clouds we can therefore use the Normalized Difference Snow Ratio (NDSI):   

𝑁𝐷𝑆𝐼 =  
𝐺𝑟𝑒𝑒𝑛 − 𝑆𝑊𝐼𝑅

𝐺𝑟𝑒𝑒𝑛 + 𝑆𝑊𝐼𝑅
 

 

POLYGON ((12.7505 49.3057, 13.7601 49.3057, 13.76011 48.7043, 12.7505 48.7043, 

12.7505 49.3057, 12.7505 49.3057)) 

(B3 – B11)/(B3 + B11) 



19 
 

In the Write tab, check that the name contains 20190218 but do not change anything. Set the output 

directory: /shared/Training/CRYO03_SnowCover_Sumava/Processing 

 

And let’s click Run. This might take approximately 4-5 minutes depending on your machine. 

Now, you should have four new products in the Product Explorer window. Let’s have a look at them. 

For that expand product [5] and in Bands folder, double click the NDSI band. When it opens move it by 

dragging the top of the tab to the corresponding RGB image window. Now do the same for products 

[6 – 8]. Then in Navigation tab at the lower left, click Zoom All  .  

 

You can also open the cloud mask in the same manner for each processed product.  

6.4 STEP 2 – snow detection 

The approach used in this exercise has been adapted and simplified from the method used for the 

Theia Snow collection (Gascoin et al. 2019). It is based on two pass detection using the NDSI: 

1) First pass – We use conservative threshold applied to NDSI. Some turbid waters can have 

similar high NDSI value, therefore we will use an additional criterion on the red reflectance to 

avoid false snow detection in these areas. Cloud-free pixel is then classified as snow when: 

(𝑁𝐷𝑆𝐼 <  𝑛1) 𝐴𝑁𝐷 (𝜌𝑟𝑒𝑑  <  𝑟1) 
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Where n1 and r1 are the selected thresholds, during the first pass they are set conservatively 

high to avoid false detections. If the above expression is not fulfilled, then the pixel is marked 

as “no snow” 

Minimum value of NDSI for the pass 1 snow test - n1 0.4 

Minimum value of the red band (B4) for the pass 1 snow test - r1 0.2 

2) Second pass – Now we can use the results from the first pass detection and a digital elevation 

model to estimate the elevation of the snow line (minimum snow elevation zs). Above the snow 

line we can then apply less conservative thresholds for the above criterion. The approach 

assumes there are no large altitudinal variations in the snow line position within the study 

area. We will also use: Forest Type (FTY) 2015 (High Resolution Layer) provided by European 

Environment Agency (available from Copernicus Land Service) to remove dense forest areas 

that may be misclassified as no-snow. (See  NOTE 5 p. 24) 

Minimum value of NDSI for the pass 2 snow test – n2 0.15 

Minimum value of the red band (B4) for the pass 2 snow test – r2 0.04 

Minimum detected snow cover percentage in elevation band to identify zs 35 % 

Size of the elevation band in the DEM used to define zs 50 

6.4.1 Snow detection – first pass  

In this step we will apply the conservative thresholds as well as load supporting data (DEM and Forest 

Type map) for the second pass detection. As in pre-processing we will use the graph builder to enable 

batch processing of our four products.  

So, let’s build our graph. First, in the Product Explorer, right-click on product [1] and go to Close 

Product, then click No (we do not want to save changes). Do the same for the other original data [2 - 

4]. So only the pre-processed products remain open.  

Then we select (highlight) the first product [5] (Subset 18 February 2019) and go to Tools → 

GraphBuilder. Add following operators and connect them as shown on the image: 

• Add → Raster → BandMaths 

• Add → Raster → BandMerge 

• Add → Input-Output → Read 

• Add → Raster → DEM Tools → AddElevation 

 

Important!!! Now go to the Read(2) tab below the graph and click on the , then navigate to the 

/shared/Training/CRYO03_SnowCover_Sumava/AuxData/ and select Forest_Type_CLS.tif  

 

TIP: We have to do this due a bug in the SNAP Batch processing which at the time of writing this 

tutorial it has not been fixed. The bug makes it impossible to see the second Read tab in the Batch 

processing window. We can however bypass this problem by setting this parameter in the graph 

and then saving it with it (only possible if the input of the second Read operator does not change). 
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When done, click Save at the bottom of the window and save the graph as Graph_pass1.xml in: 

/shared/Training/CRYO03_SnowCover_Sumava/Processing/ 

Now, we can close the GraphBuilder window and open the Batch Processing tool (Tools -> Batch 

Processing).  

We will add all opened products. In the I/O Parameters tab, click Add Opened on the upper right 

(second from top) and click Refresh. Deselect the Keep source product name. Then click Load Graph 

at the bottom of the window, navigate to our saved graph and open it.  

 

Now, let’s set the parameters. In the BandMaths tab, set: 

Target band: “Snow_pass1” 

No-Data Value: “NaN” 

Expression:  

 

Keep the default settings in the BandMerge tab and in the AddElevation tab select: 

Digital Elevation Model: SRTM 1Sec HGT (Auto Download) 

Elevation Band Name: “elevation” 

if (Cloud_Class < 2 AND NDSI > 0.4 AND B4 > 0.2) then 1 else 0 
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In the Write tab, you can notice that the Name of the output is identical to the name of input, 

unfortunately this is a problem of the software and in batch processing we can not change it. For this 

reason, we will use a different directory to save our outputs.  Click on the , then navigate to:  

/shared/Training/CRYO03_SnowCover_Sumava/Processing/Pass_1/ 

  Click Run.   

When the new products are created, let’s open the “Snow_pass1” band for each product. 
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6.4.2 Snow detection – second pass  

For the second pass it is not possible to use batch processing as the snow line must be estimated for 

each image separately. The graphical interface of SNAP is not ideal for this and script approach would 

be more convenient, but for the purposes of presenting the methodology we will use the graphical 

interface.  

First let’s close all opened views. Go to Window → Tile Single, then right-click on the tab of any view 

and select Close All. Then in Product Explorer, right-click on product [12] and go to Open RGB Image 

Window, choose the default profile (Red: B12, Green: B11, Blue: B4) 

In the Colour Manipulation tab, move the red slider to 0.22, then change to green and move the green 

slider to 0.29, finally change to the blue histogram and move the blue slider to 0.63. 

Then open views for bands:  Snow_pass1, Forest_Type, Elevation, Cloud_Class (in Colour 

Manipulation tab move the black slider to 0). Then go to Window → Tile Horizontally. 

 

Next, we will estimate the snow line elevation. We will do this by “dividing” the image into elevation 

bands of 50 m from 350 m to 1450 m. For each elevation band we calculate the percentage of snow 

coverage for non-forest surfaces (See  NOTE 5).  

 

First, we will load our elevation classes. Go to View → Tool Windows → Mask Manager. A tab will 

open on the right side of the SNAP window.  At the moment it should be empty, here you can either 

create masks from geometry or using pixel value thresholds and expressions or you can load mask 

prepared previously. We will use the last option.  

Click inside the [12] Snow_pass1 view and then in the Mask Manager click on  and open 

/shared/Training/CRYO03_SnowCover_Sumava/AuxData/masks_elevation_noforest.xml 

The new masks will appear, select all to be visible over the [12] Snow_pass1 view.  

 NOTE 5: In dense forest (mainly coniferous), new snow covers the branches and can be usually detected. 

However, as the snow gets older/heavier, it slides off the branches to the forest floor and is effectively 

hidden from view. Such areas are then incorrectly classified as no-snow. This can skew the snow line 

elevation estimate as well as cause errors in estimation of total snow cover.  
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These masks are created as an expression: elevation >= i AND elevation < j AND Forest_Type == 0 where 

i and j are the bounds of the elevation band.  

 

Now, click inside the [12] Snow_pass1 view again and then click on Statistics . A new window will 

open. Select Use ROI mask(s), then click Select All and Refresh .  

 

The calculation will take about a minute. Once it is finished you can see statistics of Snow_pass1 for 

each elevation band. Since our Snow_pass1 band is binary – snow (1)/no-snow (0) - we can use the 

Mean*100 as equivalent for percentage cover.  

By scrolling down, you can find which elevation band has Mean > 0.35. In the case of our selected 

image the elevation band with snow coverage > 35% is 950 m - 1000 m (statistics can also be exported 

to CSV format). We can now close the Statistics window.  

Export to CSV 
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Now, let’s run the second pass, here are the parameters for each product:  

Image date n2 r2 zs 

18 Feb. 2019 

0.15 0.04 

400 m 

23 Feb. 2019 400 m 

28 Feb. 2019 600 m 

20 Mar. 2019 950 m 

In Product Explorer, right-click on the product [12] and go to Band Maths…  

Target band: “Snow_cover” 

Expression:  

 

Deselect Virtual (save expression only, don’t store data) – we want the band to be stored! 

 

Click OK. A new band will be created and opened automatically.  

 

Let’s enhance the visualization a bit by loading prepared colour palette. In Colour Manipulation tab, 

click on  and open: 

if (Cloud_Class < 2 AND elevation > 950 AND NDSI > 0.150 AND B4 > 0.04) 

OR Snow_pass1 == 1 then 1 else (if Cloud_Class > 0 then 9 else (if 

Forest_Type == 2 then 2 else 0)) 
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/shared/Training/CRYO03_SnowCover_Sumava/AuxData/Snow_cover_map_palette.cpd 

Then click No in the dialog that appears – We do NOT want to automatically distribute the points of 

colour palette between min/max.  

 

The colours can then be interpreted as follows: 

 0 No-snow 

 1 Snow 

 2 Coniferous forest (protentional snow cover) 

 9 Cloud 

Now repeat the process for the products [9-11].  
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6.5 Snow cover area 

Now we can export our results to GeoTIFF for further processing or we can for example estimate the 

area of open snow cover (not dense forest).  

To do this let’s click inside the view of one of our results ([12] for example) and go to Mask Manager 

tab. Click on  , an expression window will open (same as for Band Math), type:  

A new mask will appear at the bottom of the list. We can change the name to “Snow”.  

 

Then in the main SNAP, window go to Raster → Masks → Mask Area …  and select the “Snow” mask.  

 

Click OK.  

 

 

THANK YOU FOR FOLLOWING THE EXERCISE! 

  

Snow_cover == 1 
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7 Extra steps  

7.1 Export as GeoTIFF 

To convert the results into GeoTIFF format, select (highlight) the product in Product Explorer and go 

to File → Export → GeoTIFF. Navigate to your desired folder and click Save.  

If you do not wish to save the whole product with all bands, you can use the Subset button to perform 

spatial and/or band subset.  

 

 

7.2 Atmospheric correction 

Solar radiation reflected by the Earth’s surface to satellite sensors is affected by its interaction with 

the atmosphere. The objective of applying an atmospheric correction is to determine true surface 

(Bottom-Of-Atmosphere, BOA) reflectance values from the Top-Of-Atmosphere (TOA) reflectance 

values, by removing atmospheric effects. (See  NOTE E1) Atmospheric correction is especially 

important in cases where multi-temporal images are compared and analysed as it is in our case. 

(Mousivand et al. 2015)  

Sen2Cor is a processor for Sentinel-2 Level 2A product generation and formatting; it performs the 

atmospheric, terrain and cirrus correction of Top-Of-Atmosphere Level 1C input data. Sen2Cor creates 

Bottom-Of-Atmosphere, optionally terrain and cirrus corrected reflectance images; additional, Aerosol 
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Optical Thickness, Water Vapour, Scene Classification Maps and Quality Indicators for cloud and snow 

probabilities.  

 

 

In the I/O Parameters, make sure product [1] is selected. In the Processing Parameters tab, change the 

resolution to 10 m. Click Run …  

 

This is rather a time demanding process and requires approximately 30 minutes per image (with 8GB 

RAM). 

 NOTE E1: The radiance reaching the sensor is a result of following components: 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

Credits: Mousivand et al., 20151  

1.  Radiation from the sun and, scattered into the field 

of view of the sensor by the atmosphere without 

reaching the surface. 

2. Direct radiation that goes through the atmosphere 

without being absorbed or scattered, reaches the 

sensor after being reflected by the target pixel. 

3. Radiation scattered by the atmosphere into the target 

pixel and reflected back towards the sensor. 

 4. & 5. Direct or diffuse radiation reflected or scattered by 

the surrounding areas into the field of view of the sensor. 

This effect is so called “adjacency effect” or “blurring effect”. 

6. Diffuse radiation coming from the adjacent features into 

the field of view of the sensor.  

7. So-called trapping effect and it is a part of the radiation 

reflected from the surface into the air column above the 

surface being scattered and ultimately reaches the sensor.  
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The process creates two new Level 2-A products in the “.SAFE” format in the input data folder. 

7.3 Downloading the outputs from VM 

Press Ctrl+Alt+Shift. A pop-up window will appear on the left side of the screen. Click on the bar below 

Devices, the folder structure of your VM will appear. Navigate to your Processing folder and double 

click any file you want to download.  
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