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1 Introduction 

The Research and User Support for Sentinel core products (RUS) service provides a free and open 

scalable platform in a powerful computing environment, hosting a suite of open source toolboxes pre-

installed on virtual machines, to handle and process data acquired by the Copernicus Sentinel satellites 

constellation.  

Greenland ice sheet is the second largest 

ice mass on Earth. As climate changes, the 

ice sheet surface melt is increasing and 

more and more fresh-water flows to the 

ocean, contributing to the global sea-level 

rise.  

Glacier velocity is a vital part of glacier 

monitoring and understanding the glacier 

system dynamics as well as its 

contribution to the global sea level. 

Satellite data is a perfect tool for 

monitoring glacier velocity over large 

areas. Two methods are commonly used 

to derive the speed of the ice flow from the satellite data: 1) SAR interferometry; 2) feature/speckle 

tracking (optical/SAR data) between consecutive acquisitions. In this tutorial we will use the second 

method applied to Sentinel-1 data. 

The Petermann Glacier is a large tidewater glacier draining more than 4% of the Greenland ice sheet 

through the 90 km long Petermann Fjord and terminating in a floating ice tongue, which currently 

covers an area of 900 km2. Estimated 12 billion tonnes of ice are drained to the ocean annually with 

estimated ice flow speed of 1 km/year.   

2 Training 

Approximate duration of this training session is one hour.  

The Training Code for this tutorial is CRYO02. If you wish to practice the exercise described below 

within the RUS Virtual Environment, register on the RUS portal and open a User Service request from 

Your RUS service → Your dashboard.  

2.1 Data used 

• Two Sentinel-1A IW GRDH images with HH & HV polarization acquired on 9 September 2017 and 

21 September 2017 [downloadable @ https://scihub.copernicus.eu/] 

S1A_IW_GRDH_1SDV_20170909T113539_20170909T113604_018298_01EC67_A5EC.zip 

S1A_IW_GRDH_1SDV_20170921T113539_20170909T113604_018473_01F1C7_1CE3.zip 

2.2 Software in RUS environment 

Internet browser, SNAP + Sentinel-1 Toolbox, (Extra steps: QGIS) 

  

Sentinel-2 image of Petermann Glacier tongue on 10 Sept. 2017 (Credits: 

contains modified Copernicus Sentinel data) 

https://rus-copernicus.eu/
https://scihub.copernicus.eu/
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3 Register to RUS Copernicus 

To repeat the exercise using a RUS Copernicus Virtual Machine (VM), you will first have to register as 

a RUS user. For that, go to the RUS Copernicus website (www.rus-copernicus.eu) and click on 

Login/Register in the upper right corner.  

 

Select the option Create my Copernicus SSO account and then fill in ALL the fields on the Copernicus 

Users’ Single Sign On Registration. Click Register. 

  

Within a few minutes you will receive an e-mail with activation link. Follow the instructions in the e-

mail to activate your account.  

You can now return to https://rus-copernicus.eu/, click on Login/Register, choose Login and enter 

your chosen credentials. 

http://www.rus-copernicus.eu/
https://rus-copernicus.eu/
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Upon your first login you will need to enter some details. You must fill all the fields.   

 

4 Request a RUS Copernicus Virtual Machine 

Once you are registered as a RUS user, you can request a RUS Virtual Machine to repeat this exercise 

or work on your own projects using Copernicus data. For that, log in and click on Your RUS Service → 

Your Dashboard.  
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Click on Request a new User Service to request your RUS Virtual Machine. Complete the form so that 

the appropriate cloud environment can be assigned according to your needs. 
  

 
 

If you want to repeat this tutorial (or any previous one) select the one(s) of your interest in the 

appropriate field. 

 

 
 

Complete the remaining steps, check the terms and conditions of the RUS Service and submit your 

request once you are finished. 
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Further to the acceptance of your request by the RUS Helpdesk, you will receive a notification email 

with all the details about your Virtual Machine. To access it, go to Your RUS Service → Your Dashboard 

and click on Access my Virtual Machine.  
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Fill in the login credentials that have been provided to you by the RUS Helpdesk via email to access 

your RUS Copernicus Virtual Machine.  

 

This is the remote desktop of your Virtual Machine. 

 

5 Step by step  

5.1 Data download – ESA SciHUB 

In this step, we will download the Sentinel-1 scenes from the Copernicus Open Access Hub using the 

online interface. Go to Applications → Network → Firefox Web Browser or click the link below. 

Go to https://scihub.copernicus.eu/   

https://scihub.copernicus.eu/
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Go to “Open HUB”, if you do not have an account please register by going to “Sign-up” in the LOGIN 

menu in the upper right corner. 
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After you have filled in the registration form, you will receive an activation link by e-mail. Once your 

account is activated or if you already have an account, “LOGIN”. 

Navigate to the north of Greenland (approximate area – blue rectangle).  Switch to drawing mode and 

draw a search rectangle approximately as indicated below. 

 

Open the search menu by clicking to the left part of the search bar and specify the following 

parameters: 

Sensing period: From 2017/09/09 to 2017/09/21 

Mission: Sentinel-1 

Satellite Platform: S1A* 

Product Type: GRD (Ground-range-detected product) 

Sensor Mode: IW 

Relative Orbit Number: 26 

 

In our case, the search returns 2 results, depending on the exact search area defined. Download 

scenes: 

S1A_IW_GRDH_1SDV_20170909T113539_20170909T113604_018298_01EC67_A5EC.zip 

S1A_IW_GRDH_1SDV_20170921T113539_20170909T113604_018473_01F1C7_1CE3.zip 
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Move downloaded scenes from desktop (/home/rus) to:   

/shared/Training/CRYO02_GlacierVelocity_Greenland_TutorialKit/Original  

 

5.2 SNAP – open and explore data 

Open SNAP Desktop (icon located on the desktop); click Open Product , navigate to:  

/shared/Training/CRYO02_GlacierVelocity_Greenland_TutorialKit/Original 

and open both downloaded products: 

S1A_IW_GRDH_1SDV_20170909T113539_20170909T113604_018298_01EC67_A5EC.zip 

S1A_IW_GRDH_1SDV_20170921T113539_20170909T113604_018473_01F1C7_1CE3.zip 

The opened products will appear in Product Explorer window. Click + to expand the contents of 

product [1] from 9 September 2017, then expand Bands folder and double click on Intensity_HH band 

to visualize it.  

 

 TIP 1: It may sometimes happen that the data used to create this exercise are temporarily unavailable. 

In such case, you can use other date period for the same location to find two images 12 days apart in 

the same orbit.  
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We can see that the view appears as if “mirrored”: this is because the scene was acquired during 

descending pass (the satellite was moving in direction from north to south, looking to the right (in this 

case west)) and the view shows the pixels in order of the data acquisition, as the image is not yet 

projected into cartographic coordinates. 

5.3 Pre-processing 

We need to apply identical pre-processing steps to both of our scenes. However, processing the data 

step by step and product by product would be time consuming and inconvenient, luckily, we can use 

the Batch Processing tool available in SNAP to apply all steps to both images in one go (this also saves 

disk space as only the final product is physically saved). 

To use the tool, we first need to define the process we want to apply and all its steps. We can do this 

using the GraphBuilder tool.  

So let’s build our graph. Go to Tools → GraphBuilder.  

 

At the moment, the graph has only two operators: Read (to read the input) and Write (to write the 

output).  

In the first step, we will update the orbit metadata (See  NOTE 1). To add the operator right-click 

the white space between the existing operators and go to Add → Radar → Apply-Orbit-File. 

 

A new operator rectangle appeared in our graph and new tab appeared below. Now connect the new 

Apply-Orbit-File operator with the Read operator by clicking to the right side of the Read operator and 

dragging the red arrow towards the Apply-Orbit-File operator.  

 

 NOTE 1: The orbit state vectors provided in the metadata of a SAR product are generally not accurate 

and can be refined with the precise orbit files which are available days-to-weeks after the generation of 

the product. The orbit file provides accurate satellite position and velocity information. Based on this 

information, the orbit state vectors in the abstract metadata of the product are updated. (SNAP Help) 
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In the next step we will remove the thermal noise (See  NOTE 2). We do this by right-clicking the 

white space somewhere left of the resample operator and going to Add → Radar → Radiometric → 

ThermalNoiseRemoval. Connect the ThermalNoiseRemoval operator with the Apply-Orbit-File 

operator.  

 

 

Now we can add the Calibration operator. The objective of SAR calibration is to provide imagery in 

which the pixel values can be directly related to the radar backscatter. Though uncalibrated SAR 

imagery is sufficient for qualitative use, calibrated SAR images are essential to quantitative use of SAR 

data (See  NOTE 3). To add the operator go to Add → Radar → Radiometric → Calibration. Connect 

the Calibration operator, to both the ThermalNoiseRemoval operator and Write operator. 

 

 

For the moment, do not change anything in the parameter tabs and save the graph as 

Graph_preprocess.xml to: 

/shared/Training/CRYO02_GlacierVelocity_Greenland_TutorialKit/Processing by clicking Save at the 

bottom of the window. After you have saved it, close the GraphBuilder window.  

In the Product Explorer window, select (highlight) the product [1] (9 September 2017). Open the Batch 

Processing tool (Tools → Batch Processing). 

We will add both opened products by clicking Add Opened on the upper right (second icon from the 

top) and then click Refresh (second icon from the bottom). Then we click Load Graph at the bottom of 

the window and navigate to our saved graph and open it. We see that new tabs have appeared at the 

top of window corresponding to our operators with the exception of Write; this is correct as these 

parameters will be set in the I/O Parameters tab.  

In the I/O Parameters tab set “Directory” to  

/shared/Training/CRYO02_GlacierVelocity_Greenland_TutorialKit/Processing and make sure the 

“Keep source product name” option is selected  (See  NOTE 4). 

 

 NOTE 2: Thermal noise in SAR imagery is the background energy that is generated by the receiver itself 

(SNAP Help). It skews the radar reflectivity to towards higher values and hampers the precision of radar 

reflectivity estimates. Level-1 products provide a noise LUT for each measurement dataset, provided in 

linear power, which can be used to remove the noise from the product. 

 NOTE 3: Typical SAR data processing, which produces level-1 images, does not include radiometric 

corrections and significant radiometric bias remains. The radiometric correction is necessary for the pixel 

values to truly represent the radar backscatter of the reflecting surface and therefore for comparison of 

SAR images acquired with different sensors or acquired from the same sensor but at different times, in 

different modes, or processed by different processors. (SNAP Help) 

 NOTE 4: The product file names will be identical to the input file names. If you set your output directory 

to the folder that contains your input data the input data will be overwritten. 
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In the Apply-Orbit-File tab we can accept the default settings.  

 

In the ThermalNoiseRemoval tab select HH polarization and make sure that the “Remove Thermal 

Noise” option is selected. 

 

In the Calibration tab we will also accept all default settings and then click Run.   
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You should have 2 new products in the Product Explorer window. Close the Batch Processing window. 

5.4 Coregistration and Offset tracking 

To simplify the process, we will also create a new graph for the next processing steps. Let’s open the 

Graph Builder again (Tools → Graph Builder).  

First, we need to delete the Write operator. Right click on it and select “Delete”. Then we need to add 

a second Read operator. Right-click in the white space and go to Add → Input-Output → Read. 

We will add the DEM-Assisted Coregistration operator by going to Add → Radar → Coregistration → 

DEM-Assisted-Coregistration and connect both Read operators to it.  

 

Next, we will add the Subset operator (Add → Raster → Geometric → Subset) and connect the DEM-

Assisted-Coregistration operator to it.  

Since we want to continue to Offset Tracking and save this subset separately as well, we will add the 

Offset-Tracking operator (Add → Radar → SAR Applications → Offset-Tracking) and the Write 

operator (Add → Input-Output → Write). Connect the Subset operator to both Offset-Tracking and 

Write operator. 

 

As the last step, we will add another Write operator (Add → Input-Output → Write) and connect the 

Offset-Tracking operator to it in order to save the final product (See  TIP 2).  
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Tabs corresponding to each of the operators have appeared below the graph. We will go through them 

one by one to set all the parameters.  

 

5.4.1 Read  

First let’s go to the first Read tab and make sure that the pre-processed product [3] from 9-Sept 2017 

is selected as the Source product. Then go to the Read(2) tab and set the pre-processed product [4] 

from 21-Sept 2017 as the Source product.  

 

 

5.4.2 DEM-assisted coregistration  

Image coregistration is the process of geometrically aligning two or more images so that corresponding 

pixels represent identical area on earth surface. It is possible to coregister two or more products using 

only orbit state vectors, however for the purpose of offset tracking we need more precise 

coregistration. Therefore, we use additional information provided by digital elevation model (DEM).  

Go to the DEM-Assisted-Coregistration tab and set “Digital Elevation Model”: ACE30 (Auto Download) 

 

5.4.3 Subset 

Since our Area of Interest (AOI) is quite small and there is no need to process the whole image, we 

start with sub-setting the scene to a more manageable size. This will reduce the processing time in 

 TIP 2: It may seem strange to write the two products separately, especially since we will stack them in 

the next step; however, the output of offset tracking is not only a raster but also a vector point layer 

containing the velocity at each Ground Control Point (GCP) and additional information that could be 

useful, such as heading (direction of the movement) and directional components. SNAP does not 

currently offer operator to export the vector layer in graph. If you do not need the vector layer, you can 

use the following graph set up.  
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further steps and is recommended when the analysis is focused only over a specific area and not at the 

complete scene. Go to the Subset tab and at “Pixel Coordinates” set: 

X: 1500  Width: 16000   Y: 5000  Height: 11000 

 

5.4.4 Offset Tracking 

Offset Tracking is used to estimate the motion of a feature between two acquisitions through cross-

correlation on selected Ground Control Point (GCP) in coregistered images (master and slave) in both 

slant-range and azimuth direction. The movement velocity is then computed based on the offsets 

estimated by the cross-correlation (See  NOTE 5). The velocities computed on the GCP grid are 

interpolated to create velocity map. It is a method frequently used for glacier motion estimation.  

 

To perform the Offset-Tracking, we need to set several parameters. First, we need to set the GCP grid 

spacing in pixels in range and azimuth directions (determines the resolution/level-of-detail of our 

velocity product). We will set the spacing to 60 pixels (600m) in both directions, this balance between 

the level of detail and smoothness of our output, is sufficient for our purposes (also: the higher the 

resolution => the longer the processing time). 

Next, we need to set the Registration Window dimensions; the size of the registration window depends 

on the maximum velocity of the glacier (from literature of historical data) and the period between the 

data acquisitions. Our images were acquired 12 days apart and the maximum speed of the Petermann 

Glacier is close to 5 m/day, this means that the glacier surface will shift by maximum 60 meters. This 

means that we can keep the default setting of 128 pixels (1280x1280m). To filter out false high values 

we also set the known maximum glacier velocity to 5 m/day. So, we need to set:  

Grid Azimuth Spacing (in pixels): 60 

Grid Range Spacing (in pixels): 60  

 NOTE 5: The Offset Tracking is performed in the following sub-steps (ESA Snap): 

• For each point in the user-specified GCP grid in master image, compute corresponding pixel position 

in slave image using normalized cross-correlation. 

• If the computed offset between master and slave GCP positions exceeds the maximum offset 

(computed from user specified maximum velocity), then the GCP point is marked as outlier. 

• Perform local average for the offset on valid GCP points. 

• Fill holes caused by the outliers. The offset at missing point will be replaced by a new offset computed 

by local weighted average. 

• Compute the velocities for all points on GCP grid from their offsets. 

• Finally, compute velocities for all pixels in the master image from the velocities on GCP grid by 

interpolation (final product has same pixel size as the input data).  
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Max Velocity (m/day): 5.0  

 

5.4.5 Write operators 

In the Write tab (connected to the Subset operator), set the product name to 

Subset_S1A_IW_GRDH_20170909_20170921_Stack and the target directory to 

 /shared/Training/CRYO02_GlacierVelocity_Greenland_TutorialKit/Processing. 

  

In the Write(2) tab (connected to the Offset-Tracking operator), set the product name to 

Subset_S1A_IW_GRDH_20170909_20170921_Stack_vel and the target directory to  

/shared/Training/CRYO02_GlacierVelocity_Greenland_TutorialKit/Processing.  

 

Click Save to save the graph with the name “Graph_offset_tracking”, at the following directory: 

/shared/Training/CRYO02_GlacierVelocity_Greenland_TutorialKit/Processing.  

Click Run. This might take a while. Approximate processing time: 35 minutes. 

After the processing is completed, close the Graph Builder window. Two new products [5] and [6] have 

appeared in the Product Explorer window. Expand the velocity product [5] and double click the 

Velocity_slv1_21Sep2017 band to open it in the View window. On top of the velocity map we can see 
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the geolocation point grid that obscures our view. We can hide it by going to Layer Manager on the 

right side (or go to Layer → Layer Manager to open it) and deselect the vector folder. 

 

5.5 Stack the products 

Let’s join the two outputs to a single product, for this we will use the Band Math function. Right-click 

product [5] and open BandMath dialog. Set “Name” to Sigma0_HH_09Sep2017 and deselect the 

Virtual (save expression only, don’t store data) option because we want to store the data.  

Then click on the Edit Expression… and a new dialog will open. Set Product to: 

 [6] Subset_S1A_IW_20170909_20170921_Stack.   

Then in Data Sources, click on $6.Sigma0_HH_mst_09Sep2017 band.  

 

Click OK in both windows. Repeat the process to add also the second band. This time set “Name” to 

Sigma0_HH_21Sep2017 and in Data Sources, click on $6.Sigma0_HH_slv1_21Sep2017 band. The new 

bands will automatically open in the view. Go to the Layer Manager in the upper right corner and 

deselect the Vector folder in both images. 
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In the Product Explorer Window, select products [1] to [4]; right-click and select Close 4 Products.  

5.6 Terrain correction 

Our data are still in radar geometry, moreover due to topographical variations of a scene and the tilt 

of the satellite sensor, the distances can be distorted in the SAR images. We need to apply Terrain 

Correction to compensate for the distortions and reproject the scene to geographic projection. (See 

 NOTE 6)  

 

Click Radar → Geometric → Terrain Correction → Range-Doppler Terrain Correction 

In the I/O Parameters tab set as “Source Product” the product [5] (velocity product). In “Target 

Product”, keep the default name and set the “Directory” to: 

 /shared/Training/CRYO02_GlacierVelocity_Greenland_TutorialKit/Processing.  

In the Processing Parameters tab set:  

Digital Elevation Model: ACE30 (Auto Download) 

Map Projection: Click on it, choose Predefined CRS and click on “Select”. In “Filter” search for 32621 

(EPSG: 32621 – WGS84 / UTM Zone 21N) and when you find it click OK to both windows. 

NOTE 6: The geometry of topographical distortions in SAR 

imagery is shown on the right.  Here we can see that point 

B with elevation h above the ellipsoid is imaged at position 

B’ in SAR image, though its real position is B".  The 

offset Δr between B' and B" exhibits the effect of 

topographic distortions. (SNAP Help) 
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Keep defaults values for the other parameters. Click Run. Approximate processing time: 2.5 minutes. 

5.7 Visualize 

Close Range Doppler Terrain Correction window. Let’s overlay the velocity data on top of the original 

data. Expand the new georeferenced product [7] and open the Sigma0_HH_21Sep2017 band in View 

window. We can stretch the histogram a little in the Colour Manipulation tab (move the white slider 

on the right, to approx. 0.45).  

Then go to the Layer Manager in the top right corner and in the Vector data folder deselect Velocity. 

Then click on  to add an overlay layer, select Image of Band / Tie-Point Grid and select the 

Velocity_slv1_21Sep2017_HH. Then click Finish.  
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Now, we can see the velocity band overlaid over the original image, we can adjust the transparency 

by going to the Layer Manager, selecting the Velocity_slv1_21Sep2017 and moving the transparency 

slider on the bottom of the tab.  

 

We can also make the layer semi-transparent. In Layer Manager, select the overlaid Velocity layer and 

move the transparency slider at the bottom of the tab. 

 

5.8 Compare to existing velocity datasets 

In the Auxdata folder you can find a CSV file (tab delimited) containing a velocity data from two 

external sources, both also based on Sentinel-1. Let’s see how our results compare to them. 

The first dataset was acquired from the CPOM Ice Sheet Outlet Glacier Velocity Service (Centre for Polar 

Observation and Modelling Data Portal), a portal providing near real-time velocity maps produced by 

tracking moving features (offset-tracking) in Sentinel-1 data between two consecutive acquisitions 

http://www.cpom.ucl.ac.uk/csopr/iv/index.html?glacier_number=2
http://www.cpom.ucl.ac.uk/csopr/iv/index.html?glacier_number=2
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(Hogg, Shepherd, & Gourmelen, 2015). The CPOM velocity data we will use here, correspond to period 

15 -21 September 2017 (our results correspond to 9-21 September 2017). 

The second dataset contains values extracted from the ENVEO Greenland ice velocity map 2016/2017 

from Sentinel-1 (ENVEO Cryoportal) also derived using feature tracking in Sentinel-1 data. Compared 

to the CPOM dataset, the ENVEO velocity uses 12 day period between image pairs and the final product 

is generated by pixel-scale averaging of velocities estimated from image pairs acquired between 23 

December 2016 and 22 February 2017 (Nagler, Rott, Hetzenecker, Wuite, & Potin, 2015).  

The final product is then resampled to 250m grid. Apart from the overall horizontal velocity product 

we will use, the dataset also includes separate velocity components (vx, vy, vz) valid pixel count and 

uncertainty estimates.  

We can load the CSV file by going to the Product Explorer window and selecting the product [7]. Then 

go to Vector → Import → Vector from CSV.  

Navigate to /shared/Training/CRYO02_GlacierVelocity_Greenland_TutorialKit/Auxdata and select 

PetemannGlacier_Velocity_points.csv 

In the Import CSV Data window selected Predefined CRS, click on “Select” and in the “Filter” search 

for “4326”, select “EPSG: 4326 - WGS 84” and click OK only to the 2 first windows.  

 

In the Point Data Interpretation window, select “Interpret each point as track point” and then click 

OK. 

 

http://cryoportal.enveo.at/data/
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Now let’s compare the profiles. In the Product Explorer window, in the product [7], highlight the 

Velocity_slv1_21Sep2017_HH band. Then go to Analysis and click on  Profile Plot. 

Select  the Use ROI mask and choose PetermannGlacier_Velocity_points  

Deselect Compute in-between points. 

Select  Use correlative data and set:  

Point data source: PetermannGlacier_Velocity_points 

Data field: CPOM_Vel_20170915_20170921 

 

We can see that the CPOM data show more variability but otherwise agree quite nicely with our 

estimation. The increased variability is likely a result of shorter time period between used acquisitions 

(6 days, compared to 12 days period for our input images) and much finer GCP grid spacing (100 m, 

compared to our 600 m). 

Now change the correlative Data field to ENVEO_Vel_20161223_20170222. 
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We can see that our estimation agrees with the ENVEO velocity almost perfectly. The ENVEO velocity 

uses the same time period between images (12 days), but the estimated velocities are averaged over 

3-month period which is likely responsible for the minor differences. Glacier velocity changes over time 

as it is partly driven by the melt, therefore we can expect that the velocity would be slightly lower 

during the winter months compared to early fall.    

6 Other suggested steps 

6.1 Export velocity  

Now we can export our results to an ESRI Shapefile (.shp) format that is more manageable and can be 

processed and visualized further in software such as QGIS. The shapefile will contain following 

information:  

• Coordinates of GCP point in master image (9 Sept) 

• Coordinates of corresponding point in slave image (21Sept) 

• The distance travelled  

• Velocity in m/day 

• Heading in degrees (East from North) 

• Range shift  

• Azimuth shift 

In order to view this, expand the “Vector Data” folder of the product [7] and double click on Velocity. 
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Depending on the version of SNAP you have there might be a reoccurring bug that prevents simple 

export of the detections to ESRI shapefile format. Outlined below is a method to export for versions 

without the bug (OPTION 1) and a work-around method for versions with the bug (OPTION 2).  

6.1.1 OPTION 1 – No error 

In Product Explorer window, expand the product [7] and open the Vector Data folder. Right-click on 

the Velocity layer and select Geometry as a Shapefile. Save the layer to the Processing folder with the 

name “Velocity.shp”. 

 

6.1.2 OPTION 2 – SNAP versions with error 

If the approach described in OPTION 1 does not work for you then the version of SNAP installed on 

your machine likely contains the mentioned error.  

 Click OK and make the following steps. 

The detections are stored in the output product folder as a CSV file. The CSV file can be loaded directly 

to QGIS and converted into shapefile.  

In your VM, go to Applications → Processing and open QGIS Desktop. Now, click on the “Add 

Delimited Text Layer”  in the vertical menu on the left of the window. In the window that opens, 

click Browse and navigate to: 

/shared/Training/CRYO02_GlacierVelocity_Greenland_TutorialKit/Processing/, open 

subset_S1A_IW_GRDH_1SDV_20170909_20170921_Stack_Vel_TC.data folder, then open 

vector_data folder, select Velocity.csv and click “Open”. 

A table will appear in the bottom of the window. Select Custom delimiters, and select Tab, unselect 

all other delimiters and in Other Delimiters type delete all.  

In Record options, set Number of header lines to discard to 3 and select the “First record has field 

names” option. Finally, in the Geometry definition, select “Well known text (WKT)” and set Geometry 

Field to “geometry:Point”.  
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Then, click OK. The following window will appear. In “Filter”, type 32621 and you will see that in the 

“Coordinate reference systems of the world” tab, the “WGS 84 / UTM zone 21N” Coordinate 

Reference System will appear. Select it and click OK. 

 

The new layer Velocity will appear in the Layers Panel. 
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Click OK. Then right-click on the layer again and go to Save as. In the window that opens, set: 

Format: ESRI Shapfile 

Filename: /shared/Training/CRYO02_GlacierVelocity_Greenland_TutorialKit/Processing/Velocity_ 

Point.shp (Click “Browse”, navigate to the following path: /shared/Training/CRYO02_GlacierVelocity_ 

Greenland_TutorialKit/Processing/, select the Velocity_Point.shp file and click Save.) 

CSR: Selected CRS (EPSG:32621, WGS 84 / UTM zone 21N) 

 Then click OK.  
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To the following window that appears, click “Overwrite file”. 

 

Now you have the layer saved as an ESRI Shapefile. Close QGIS. 

6.2 Visualize in QGIS 

Minimize the SNAP window and open or re-open QGIS (Applications → Processing → QGIS Desktop). 

Once the QGIS is loaded let’s open the Velocity raster band.  

Navigate to the Processing folder in the Browser Panel on the left side of the window, expand the 

Subset_S1A_IW_20170909_20170921_Stack_Vel_TC.data folder and double-click the 

Velocity_slv1_21Sept2017_HH.img.  

The raster layer will be opened and added to the Layers Panel below the Browser Panel.  

 

To change the appearance right-click the layer in Layer Panel, go to “Properties” and in Style tab set: 

Render type: “Singleband pseudocolor” 

You can select any colour pallet and adjust the classes to your liking, however for our purposes we will 

use predefined colour pallet and classes saved as a text file in the Auxdata folder. To load it, click  

“Load color map from file” (indicated on the image below), then navigate to 

/shared/Training/CRYO02_GlacierVelocity_Greenland_TutorialKit/Auxdata and select 

Glacier_velocity_ColourPallet.txt 

Click OK. 
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6.3 Add vector Velocity fields 

In the Browser Panel double click the Velocity_point.shp layer to load it. We need to filter the layer a 

little since the point grid is too dense for our purposes.  
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The simplest way to do this is to create subset with every nth point (or for example random selection). 

Select the Velocity_point.shp in the Layer Panel and in the upper tool panel click   (above) and set 

Expression: ($id % 30) = 0  

 

Click Select and then close the window. Go to the Processing Toolbox at the right side of the window, 

in the search box type “Save” and press Enter. Then double-click on the Save selected features tool 

and set “Selection” to /shared/Training/CRYO02_GlacierVelocity_Greenland_TutorialKit/Processing 

(choose “Save to file…”) and write as “File name”: Velocity_point_sel30.shp. Click Save and press Run.  

 

Set output directory 
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New point layer Selection appeared in Layers Panel. Deselect the original Velocity_point layer in the 

Layers Panel to hide it.  

 

To visualize the velocity vector fields, we need to use the Vector field renderer plug-in  or install it 

(if it is not already installed). We can do this by going to the Plugins menu on the top of the QGIS 

window (indicated above) and go to Manage and Install Plugins…   

In the Plugins dialog search for Vector field, select Vector field renderer and press Install plugin. 

 

Close the dialog. Now make sure the Selection layer is highlighted in the Layers Panel and then click 

on   Apply vector renderer to current layer in the toolbar at the top of the window. 

At the Vector field tab, set as: 

Vector field type: Polar (length, angle) field  

Length attribute: velocity 

Angle attribute: heading 

Arrow format: Size:  Head (relative): 0.20 and Shaft width: 0.20 

Base size: 0.20 

Scale: 1.5 

Plugins 
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Click OK.  

 

Now we can inspect the direction of the ice flow. As a last step we can add a base map. Go to Web → 

OpenLayers plugin → Bing Maps → Bing Aerial.  

Drag the Bing Aerial layer to the bottom of all layers in the Layers Panel to visualize the result.  

Click on the Display the vector scale box  icon, in Location choose “Top right", in Box deselect "Fill 

Box" and click OK. 
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THANK YOU FOR FOLLOWING THE EXERCISE! 
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7 Further reading and resources 

Hogg, A., Shepherd, A., & Gourmelen, N. (2015). A first look at the performance of Sentinel-1 over the 

West Antarctic Ice Sheet. Presented at the FRINGE 2015, Frascati, Italy. 

Nagler, T., Rott, H., Hetzenecker, M., Wuite, J., & Potin, P. (2015). The Sentinel-1 Mission: New 

Opportunities for Ice Sheet Observations. Remote Sensing, 7(7), 9371–9389. 

https://doi.org/10.3390/rs70709371 
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