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1 Introduction 

The Research and User Support for Sentinel core products (RUS) service provides a free and open 

scalable platform in a powerful computing environment, hosting a suite of open source toolboxes pre-

installed on virtual machines, to handle and process data derived from the Copernicus Sentinel 

satellites constellation.  

We will employ RUS to derive the 

nearshore bathymetry in the Gulf of 

Chania (Crete, Greece) using 

Sentinel-2 data. 

Recent advances in satellite 

technology in terms of higher spatial 

resolution, multi-spectral bands, 

open data access, etc. have 

enhanced the ability for the 

monitoring and management of 

coastal areas. Satellite images are to be one of the most potential alternatives to water depth 

estimation due to the wide area coverage, repeatability, and low cost. Depth retrieval using the 

Empirical Bathymetry method can follow the approach of: a) Lyzenga et al. (1978, 2006) proposing log-

linear correlation between multiband and water depth values, and focusing mainly on removing all 

other reflected parameters attenuating water bottom signals, and b) Stumpf et al. (2003) using a ratio 

of bands and the difference in attenuation of different bands in water.  

Sentinel-2 is a wide-swath, high-resolution, multi-spectral imaging mission, also supporting water 

cover monitoring. The acquired data, mission coverage and high revisit frequency are particularly 

effective for Satellite Derived Bathymetry (SDB) application.  

This exercise is focused on SDB using the ratio transform algorithm developed by Stumpf et al. (2003) 

and Sentinel-2 imagery for depth derivation.  

2 Training 

Approximate duration of this training session is three hours.  

2.1 Data used 

• One Sentinel-2 image Level 2A acquired on August 24, 2018.  

[downloadable @ https://scihub.copernicus.eu/]  

S2B_MSIL2A_20180824T090549_N0208_R050_T34SGE_20180824T151929  

 

• Auxiliary data stored locally at: 

/shared/Training/COAS01_BathymetryDerivation_Greece/AuxData 

  

2.2 Software in RUS environment 

Internet browser, SNAP + Sentinel-2 Toolbox 

 

 

Gulf of Chania, NW Crete, Greece. Mean Depth by EMODnet. 

https://scihub.copernicus.eu/
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3 Register to RUS Copernicus 

To repeat the exercise using a RUS Copernicus Virtual Machine (VM), you will first have to register as 

a RUS user. For that, go to the RUS Copernicus website (www.rus-copernicus.eu) and click on 

Login/Register in the upper right corner.  

 

Select the option Create my Copernicus SSO account and then fill in ALL the fields on the Copernicus 

Users’ Single Sign On Registration. Click Register. 

  

Within a few minutes you will receive an e-mail with activation link. Follow the instructions in the e-

mail to activate your account.  

You can now return to https://rus-copernicus.eu/, click on Login/Register, choose Login and enter 

your chosen credentials. 

http://www.rus-copernicus.eu/
https://rus-copernicus.eu/
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Upon your first login you will need to enter some details. You must fill all the fields.   

 

4 Request a RUS Copernicus Virtual Machine to repeat a Webinar  

Once you are registered as a RUS user, you can request a RUS Virtual Machine to repeat this exercise 

or work on your own projects using Copernicus data. For that, log in and click on Your RUS Service → 

Your training activities.  
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Select one or more webinars check the field “I have read and agree to the Terms and conditions of RUS 

Service” and then click on Request Webinar Training to request your RUS Virtual Machine.  

 

Further to the acceptance of your request by the RUS Helpdesk, you will receive a notification email 
with all the details about your Virtual Machine.  

To access it, go to Your RUS Service → Your Dashboard and click on Access my Virtual Machine.  

 

Fill in the login credentials that have been provided to you by the RUS Helpdesk via email to access 
your RUS Copernicus Virtual Machine.  
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This is the remote desktop of your Virtual Machine. 

 

5 Step by step  

5.1 Data download – ESA SciHUB 

In this step we will download one Sentinel-2 scene from the Copernicus Open Access Hub using the 

online interface (Applications → Network → Web Browser or click the link below). Go to 

https://scihub.copernicus.eu/   

https://scihub.copernicus.eu/
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Go to “Open HUB”, if you do not have an account please register by going to “Sign-up” in the LOGIN 

menu in the upper right corner. 
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Navigate to Greece (approximate area – green rectangle).  

 

Zoom in over Crete island, switch to “drawing mode” and draw a search rectangle approximately as 

indicated below. Open the search menu by clicking to the left part of the search bar and specify the 

following parameters: 

Sensing period:  From 2018/08/24 to 2018/08/24 

Select:    Mission: Sentinel-2 

Product Type:   S2MSI2A 

 

Then click on the “Search” icon .  

In our case, the search returns 2 results for the time period we set over our area of study. Select the 
westward one, the: S2B_MSIL2A_20180824T090549_N0208_R050_T34SGE_20180824T151929 and 
then click on the download icon below. 

The product will be downloaded to /home/rus as zip archive. Move it to the following folder: 

/shared/Training/COAS01_BathymetryDerivation_Greece/Original 
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For the case that you want to use a Level-1C product as mentioned in the Chapter 6.1, download the 
S2B_MSIL1C_20180824T090549_N0206_R050_T34SGE_20180824T132333 product. 

5.2 SNAP – open and explore data 

Launch SNAP (icon on desktop ). When SNAP opens, click Open Product , navigate to the folder 

in /shared/Training/COAS01_BathymetryDerivation_Greece/Original and open the Sentinel-2 

zipped image. To visualize the product, right click and select Open RGB Image Window.   

In the new window set the following parameters:  

Profile: Sentinel-2 MSI Natural Colors  

Red: B4  

Green: B3  

Blue: B2 

 

The Sentinel-2 MSI scene has 0% cloud cover and was acquired in Level-1C i.e. orthorectified (in 

cartographic projection), TOA (top-of-atmosphere) reflectance with spatial registration on a global 

reference system with sub-pixel accuracy.  
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In the context of this exercise, only bands with 10 meter spatial resolution will be used (See  NOTE 

1), the visible (VIS) Blue (band 2), Green (band 3), Red (band 4) and Near Infrared (NIR) band (band 8).  

The selection of bands was based on literature review (Stumpf et al., 2003; Drakopoulou et al., 2018), 

as the use of blue and green bands seems to be most common in SDB application with a strong linear 

correlation with depth. The NIR band is used for masking land.  

To display the different bands in the View Window, expand the Bands folder of the image and double 

click in on them (B2, B3, B4, B8). 

To synchronize the views, go to Navigation tab in the lower left (red arrow) and make sure the cursor 

   and the views   are linked.  

 

 NOTE 1: The Sentinel-2 Multispectral Instrument (MSI) samples 13 spectral bands: four bands at 10 
metres, six bands at 20 metres and three bands at 60 metres spatial resolution 
(https://sentinel.esa.int/web/sentinel/missions/sentinel-2/instrument-payload/resolution-and-swath). 
The Level-1C product is composed of 100x100 km2 tiles (ortho-images in UTM/WGS84 projection). The 
Level-1C product results from using a Digital Elevation Model (DEM) to project the image in cartographic 
geometry. Per-pixel radiometric measurements are provided in Top Of Atmosphere (TOA) reflectances 
along with the parameters to transform them into radiances. 
 

 
SENTINEL-2 and LANDSAT spectral bands - Source: USGS 

 

https://sentinel.esa.int/web/sentinel/missions/sentinel-2/instrument-payload/resolution-and-swath
https://sentinel.esa.int/web/sentinel/technical-guides/sentinel-2-msi/level-1c-processing
https://sentinel.esa.int/web/sentinel/user-guides/sentinel-2-msi/definitions
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5.3 Resample 

The 13 bands in Sentinel-2 products do not all have same resolution (therefore size, see  NOTE 2). 

Many operators in SNAP toolbox do not support products with bands of different sizes so first we need 

to resample the bands to equal resolution.  

Go to Raster → Geometric Operations → Resampling. 

In the I/O Parameters tab keep as “Source Product” the loaded on SNAP product, and under the 

“Target Product”, set as Name: S2_MSIL2A_20180824_resampled. 

Select “Save as” and under Directory: click on the , navigate to the folders and select the 

appropriate path as: /shared/Training/COAS01_BathymetryDerivation_Greece/Processing 

In the Resampling Parameters tab under “Define size of resampled product”, select: By reference 

band from source product: B2  

  

Click Run. After the process is completed, if a window appears, click OK. Close the Resampling Window. 

 

A new product [2], named S2_MSIL2A_20180824_resampled appeared in the Product Explorer 

Window.  

Credits: ESA 2015 

NOTE 2: The input product 

contains 13 spectral bands 

in three different spatial 

resolutions (The surface 

area measured on the 

ground and represented by 

an individual pixel).  When 

we open the RGB view all 

our input bands have 20 m 

resolution, however, the 

view is displayed in the full 

10 m resolution.  
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5.4 Subset 

Sentinel-2 Level-2A images cover an area of about 100x100 km2. To simplify our analysis and focus on 

the region of interest (ROI) that is of primary interest we can create a subset of the larger scene. 

Keep the resampled product selected and go to Raster → Subset.  

In the Spatial Subset tab select the Pixel Coordinates tab and set the following parameters: 

Scene start X: 4810 

Scene start Y: 4588 

Scene end X: 8066 

Scene end Y: 7030 

  

 

 

 

 

 

Click OK.  

Right click on the subset product that will appear at the Product Explorer Window and click on Save 

as. Navigate to /shared/Training/COAS01_BathymetryDerivation_Greece/Processing folder and save 

the product as Subset_S2_MSIL2A_20180824_resampled. When a dialogue window appears click YES. 

Right-click the product [3] and click Open RGB image window and from the dropdown menu select: 

Profile: Sentinel 2 MSI Natural Colors 

Click OK. We can see that it contains only the area we selected to subset. 
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Right click on it, close it, and load from the Processing folder the saved 

Subset_S2_MSIL2A_20180824_resampled product to continue with our processing steps. 

5.5 Land Mask 

To proceed with the next steps we have first to mask the land cover in all four bands (B2, B3, B4, B8). 

Therefore, we have to create a land mask with values consisting of 0 and 1 for land and sea, 

respectively. NIR band will be used to mask land from the image, since the water appears dark and 

facilitates to discriminate water from land, which looks much brighter. The mask can be created either 

with the use of a threshold value of the NIR band that separates land from sea, or a polygon which 

describes the land. Finally, by applying the land mask in each band we will create a masked image that 

contains only the aquatic elements.   

Right- click on Subset_S2_MSIL2A_20180824_resampled go to Band Maths and set Name: Land_mask 

Then click on Edit Expression and set at the Band maths expression: if B8  >  0.05 then NaN else 1  

 

Click OK. In the Product Explorer Window, the new band has been added, double click on it to visualize 

the land mask.  

 

Keep in mind that from now on we will use Band Maths a lot.  

To apply the land mask in each of the rest 3 bands we need to work with, right-click on this product 

Subset_S2_MSIL2A_20180824_resampled go to Band Maths and set the parameters for band B2: 
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Name: B2_Land_mask 

Band maths expression:  B2 * Land_mask  

 

Click OK. The new band has been added in Product Explorer Window.  

Repeat the process for bands B3, B4, B8, giving them the relative name each time: 

Name: B3_Land_mask 

Band maths expression:  B3 * Land_mask  

Name: B4_Land_mask 

Band maths expression:  B4 * Land_mask  

Name: B8_Land_mask 

Band maths expression:  B8 * Land_mask  

They will all appear at the product on the left, and they will also open in the View Window. Once you 

check that all of them have been created successfully, you can close the Views. Right click on the 

product and click Save, to store the new bands created. 

5.6 Sun Glint Correction 

Sun glint is a common phenomenon in satellite images and it essentially refers to the specular 

reflection of the sun on water surfaces. The water-leaving reflectance can be difficult to observe due 

to the reflection of direct sunlight on the air-water interface (sunglint) in the direction of the satellite. 

The viewing geometry of Sentinel-2 satellite makes it vulnerable to sunglint contamination. Sun glint 

removal is a pre-processing step of multispectral images which is necessary when the amount of sun 

glint prevents the visibility of the sea bottom, usually in cases of marine habitat mapping.   

There are several available sun glint removal methods for high resolution images and coastal 

applications. In this exercise we will apply the deglint methodology proposed by Hedley et al. (2005) 

that describes the linear relationships between NIR and visible bands using linear regression based on 

a sample of the image pixels. 

To apply the correction we have to use one or more image samples of sun glinted regions to scale the 

relationship between the NIR signal and sun glint. These regions are chosen to include a range of pixel 

glint levels, but an assumed consistent underlying brightness and very low water-leaving reflectance 

in the NIR, typically deep water areas (Kay et al., 2009). To establish the relationship a linear regression 

between the two bands is performed over a deep water area, where the contribution from below the 

water surface is assumed homogenous, and so the derived relationship is only based on the surface 

reflectance.  
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Double click on band B8_Land_mask and then go to Vector → Import → ESRI Shapefile to open the 

image samples geometry_Polygon shown below. You can find this file, if you navigate to the following 

path: /shared/Training/COAS01_BathymetryDerivation_Greece/AuxData. Once you select it, at the 

dialogue window that will appear, click No. 

Then go to the SNAP toolbar and select the Scatter Plot to plot the NIR band against the VIS bands. 

 

 

 

NOTE 3: The equation (1) described by Hedley et al. (2005) for the deglinting of a multispectral image is: 

R’
i = Ri – bi (RNIR – MinNIR) 

 

where R’
i is the deglinted pixel in band i, Ri is the reflectance from visible band i, bi is the regression slope, 

RNIR is the NIR band value and the MinNIR the minimum NIR value of the sample. 

 
To deglint a visible wavelength band, a regression is performed between the NIR brightness and the 

brightness in the visible band using a sample set of pixels, which would be homogeneous if not for the 

presence of sun glint (e.g. deep water). For other pixels, the slope of the regression is then used to predict 

the brightness in the visible band that would be expected if those pixels had a NIR value of MinNIR 

(equation (1)). MinNIR is the NIR value expected from a pixel with no sun glint, which can be estimated by 

the minimum NIR value found in the sample. 
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In the Scatter Plot set the following parameters, (Subset_S2_MSIL2A_20180824_resampled selected): 

Use ROI mask: geometry_Polygon 

X-Axis: B8_Land_mask 

Y-Axis: B2_Land_mask  

Then click the Refresh View  .  

The plot will be created. Right-click on the plot and select Copy Data to Clipboard. 

 

Go on the top left corner of the screen, go to Applications → Office → LibreOffice Calc open a new 

sheet and paste the data. Click OK to the window that will appear. 

Select all cells and go to Edit → Cell Protection (make sure the lock is removed, otherwise it will not 

allow you to perform any analysis on the data). Stretch a bit the columns of the cells if you want, for 

better visualization. 

Select Columns A and B. Those are the ones that contain the values we will work with. Go to Insert → 

Chart and select as Chart Type the XY (Scatter) of Points Only. 

  

Click Next until you reach the Data Series. Choose the Data Series having the NIR band (B8) values on 

X-axis and the VIS band (B2, then B3 and then B4) values on Y-axis.  

Set for X-axis: $Sheet1.$A$16:$A$718 and for Y-axis: $Sheet1.$B$16:$B$718. Then, click Finish. 
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Remember that what we need to set for X-axis, are the values on column A, when you will apply this 

in your case, you might have a different range than the A16-A718. The same logic applies for Y-axis. 

KEEP THIS IN MIND FOR ALL THE REST SHEETS YOU WILL WORK WITH, FOR EACH OCCASION. 

  

This is the initial chart. You can double click on the blue points and modify their colour or width for 

better visualization. 

  

We now need to perform the Regression Analysis to retrieve the slope of the regression and use the 

values from the R2 equation. Go to Data → Statistics → Regression… Under Data, set as before: 

For Independent variable(s) (X) range: $Sheet1.$A$16:$A$718 

For Independent variable(s) (Y) range: $Sheet1.$B$16:$B$718 

For Results to: $Sheet1.$E$1 

Make sure that as Output Regression Type, the Linear Regression is selected. Click OK. 
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The Regression results will appear on the Sheet. 

Click on the Data Points within the chart, once. Then right-click on them and select Insert Trend Line. 

You can also modify its colour and width if you double click on it. Then right click again and select 

Insert R2 and Trend Line Equation. The number in the red rectangle below, is the number we need for 

B2. 

 

When you have reached that step, you can Save the Sheet with the name B2_Land_mask under the 

/shared/Training/COAS01_BathymetryDerivation_Greece/Processing folder. 

Repeat the process from 5.6 chapter so far, for bands B3 and B4 as well. 



21 
 

Now let’s continue with the deglint steps in SNAP. Right-click again at the product we are working on, 

go to Band Maths and set the following parameters for deglinting band B2: 

Name: B2_deglint  

Band maths expression: B2_Land_mask - 0.91574 * (B8_Land_mask - 0.001) 

 

Accordingly, set the following parameters for deglinting band B3 and band B4:  

Name: B3_deglint 

Band maths expression: B3_Land_mask - 1.00116 * (B8_Land_mask - 0.001) 

Name: B4_deglint 

Band maths expression: B4_Land_mask - 1.0223 * (B8_Land_mask - 0.001) 

Right click and Save the product. 

To visualize the correction for sun glint, right-click on the Subset_S2_MSIL2A_20180824_resampled 

product and select Open RGB Image Window.   

Select the following parameters:  

Red: B4_deglint  

Green: B3_deglint  

Blue: B2_deglint 

 

 

 

 

 

Click OK. 
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You can open an RGB image if you want before applying the sunglint correction and compare them. 

5.7 Dark-Object Atmospheric Correction 

Dark Object Subtraction (DOS) is an empirical atmospheric correction method which assumes that 

reflectance from dark objects includes a substantial component of atmospheric scattering. This 

atmospheric offset generated from the image itself can be removed by subtracting this value from 

every pixel in the band. However, this value is different for each band and can be also estimated as 

the value of the histogram's cut-off point at the lower end (Chavez, 1998). The most effective dark 

target would be optically-deep water with expected zero reflectance.  

Right-click again on the Subset_S2_MSIL2A_20180824_resampled product, go to Band Maths and set 

the parameters for band B2_deglint: 

Name: B2_DOS  

Band maths expression: B2_deglint - 0.005 

 
Also, set the following parameters for only the band B3_deglint: 

Name: B3_DOS  

Band maths expression: B3_deglint - 0.001 

You can derive the 0.005 and 0.001 values if you create a histogram for each band, and just keep the 

minimum value it has. E.g.: 0.001 is the value for band B3_deglint. Right click the product and Save it. 
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5.8 Satellite Derived Bathymetry 

For the derivation of the bathymetry data from the Sentinel-2 image we will adopt the model 

developed by Stumpf et al. (2003), based on the principle that each band has a different absorption 

level over water and this diversity level theoretically will produce the ratio between bands. This ratio 

then will generate a simultaneous change when the depth changes. (See  NOTE 4).  

For this exercise, the ratio will be applied for the pair of Blue-Green (B2-B3) bands and for n = 1000. In 

order to define the constants of Equation 2 (See  NOTE 3), calibration dataset of points with known 

depths are also required. The available multi and single beam echo sounding data have been derived 

from the Hellenic Centre for Marine Research, Hellenic National Oceanographic Data Centre 

(HCMR/HNODC) (https://www.hcmr.gr/en/), published in Drakopoulou et al. (2018).  

 

 

 

 

 

Right click again on the product and go to Band Maths to calculate the band ratio of equation (2) by 

setting the following parameters: 

Name: B3B2  

Band maths expression: log (1000 * B3_DOS) / log (1000 * B2_DOS) 

 

Click OK.  

 NOTE 4: The ratio model of Stumpf et al. (2003) is given in the following equation (2): 

𝑍 = 𝑚1

ln(𝑛𝑅𝑤(𝜆𝑖))

ln(𝑛𝑅𝑤(𝜆𝑗))
− 𝑚0 

where Z is the estimated depth, m1 is a tunable constant to scale the ratio to depth, n is a fixed constant 

for all areas, Rw is the reflectance of water for bands i or j, and m0 is the offset for a depth of 0 m (Z=0). 

The fixed value of n is chosen to assure both that the logarithm will be positive under any condition and 

that the ratio will produce a linear response with depth. 

http://seadatanet.maris2.nl/v_edmo/print.asp?n_code=269
http://seadatanet.maris2.nl/v_edmo/print.asp?n_code=269
https://www.hcmr.gr/en/
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We now proceed with the automatic extraction of pixel values in both bands from geographical 

coordinates of all the bathymetric data points by using text/*.csv file. Go to Raster → Export → 

Extract Pixel Values.  

Check that the product at Source path is Subset_S2_MSIL2A_20180824_resampled and in the 

Input/Output tab define the Output directory as: /shared/Training/COAS01_BathymetryDerivation 

_GreeceProcessing 

In Parameters tab select Add measurements from CSV file in the upper right corner. Add the file 

bathy_coord from /shared/Training/COAS01_BathymetryDerivation_Greece/AuxData folder. In 

addition, unselect Tie-point grids and Masks boxes and check Include original input box. 

 

Click Extract.  

SNAP creates the following two files in the Processing folder: 

• pixEx_productIdMap.txt 

• pixEx_S2_MSI_Level-2A_measurements.txt 

Go to Applications → Office → LibreOffice Calc and go to File → Open: pixEx_S2_MSI_Level-

2A_measurements.txt, from /shared/Training/COAS01_BathymetryDerivation_Greece/Processing 

We will perform again a Regression Analysis, like we did before. This time select Columns BT and B.  

Go to Insert → Chart and select as Chart Type the XY (Scatter) of Points Only. Click Next until you 

reach the Data Series.  

Choose the Data Series, set the B3B2 band values on X-axis and the Depth (in meters) values on Y-

axis.  

Set for X-axis: $’pixEx_S2_MSI_Level-2A_measurements’$BT$8:$BT$54  

and for Y-axis: $’pixEx_S2_MSI_Level-2A_measurements’$B$8:$B$54 

Then, click Finish.  

By performing the regression analysis of the data we derive the constants m1 and m0 as per Stumpf et 

al. (2003), while the R2 indicates the correlation value.  

Go to Data → Statistics → Regression… Under Data, set as before: 

For Independent variable(s) (X) range: $’pixEx_S2_MSI_Level-2A_measurements’$BT$8:$BT$54  
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For Independent variable(s) (Y) range: $’pixEx_S2_MSI_Level-2A_measurements’$B$8:$B$54 

For Results to: $’pixEx_S2_MSI_Level-2A_measurements’$BV$1 

Make sure that as Output Regression Type, the Linear Regression is selected. Click OK. 

Click on the Data Points within the chart, once. Then right-click on them and select Insert Trend Line. 

You can also modify its colour and width if you double click on it. Then right click again and select 

Insert R2 and Trend Line Equation.  

From this equation, we keep as m1 = -37.118 and as m0 = +41.926 

 

To estimate the satellite bathymetry, right click on the Subset_S2_MSIL2A_20180824_resampled 

product and go to Band Maths.  

Set the following parameters for equation (2): 

Name: SDB  

Band maths expression: -37.118 * B3B2 + 41.926 

 

Click OK. Double click on the SDB band that had been created at the product on the left, to visualize 

it. 

Go to the Colour Manipulation tab and load a colour palette. Click on the  Import colour palette 

from text file icon, navigate to /shared/Training/COAS01_BathymetryDerivation_Greece/AuxData 

folder and select set the Bathymetry palette. Click Open. Then set the following data display range: 
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Min: 0.0 

Max: 24.0 

 

Go in the Pixel Info tab on the left, and the pixel information will be displayed while you move the 

mouse over the band image view.  

Save the product. 

We will now continue to the Sen2Coral Processor.  

5.9 Sen2Coral 

Sen2Coral plugin for SNAP toolbox is based on the exploitation of the Sentinel-2 mission for mapping 

(habitat, bathymetry, and water quality) and detection change for coral reef health assessment and 

monitoring. Sen2Coral includes the automatic processing for sun glint correction and Empirical 

Bathymetry Estimation: 

5.9.1 Deglint Processor 

Go to Optical → Thematic Water Processing → Sen2Coral → Processing modules → Deglint 

Processor.  

In the I/O Parameters tab, select the opened image Subset_S2_MSIL2A_20180824_resampled in the 

Source Product field and leave the default output name for the target product name. 

Define the directory as /shared/Training/COAS01_BathymetryDerivation_Greece/Processing 

In the Processing Parameters tab set the following parameters: 

Sun Glint Areas: geometry_Polygon (make sure you write it exactly like that, orelse, it will not be read) 

Source Bands: B2, B3, B4 

Reference Band: B8 



27 
 

  Click Run. 

5.9.2 Empirical Bathymetry Processor 

The Empirical Bathymetry processor maps bathymetry based on regression of log band ratio (Lyzenga 

method). Ancillary data are required of known bathymetry. 

Go to Optical → Thematic Water Processing → Sen2Coral → Processing modules → 

EmpiricalBathymetry Processor.  

In the I/O Parameters tab, select the same image again in the Source Product field and leave the 

default output name for the target product name. 

Define the directory: /shared/Training/COAS01_BathymetryDerivation_Greece/Processing 

In the Processing Parameters tab, the bands used to estimate the bathymetry have to be selected, as 

well as the full path to a file containing the set of bathymetry point data (latitude, longitude, depth). 

Set the following parameters: 

Bands to be used: B2_DOS, B3_DOS 

Bathymetry point data: /shared/Training/COAS01_BathymetryDerivation_Greece/AuxData/ 

bathy_points.csv 

N value: 10000.0 (default)  
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  Click Run. 

In the Product Explorer Window, the new product is created. Double click on its band to visualize it.  

Go to the Colour Manipulation tab and load a colour palette. Click on the  Import colour palette 

from text file icon, navigate to /shared/Training/COAS01_BathymetryDerivation_Greece/AuxData 

folder and select set the Bathymetry palette. Click Open. Then set the following data display range: 

Min: 0.0 

Max: 24.0 

 

 

 

THANK YOU FOR FOLLOWING THE EXERCISE! 
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6 Extra steps  

6.1 Atmospheric Image Correction 

This step refers to the case that you use a Level-1C image instead of a Level-2A. 

To atmospherically correct Sentinel-2 observation data over water bodies we will use iCOR Sentinel-2 

plugin for SNAP toolbox. iCOR allows the corrections for atmospheric effects for coastal and 

transitional waters, while it corrects adjacency effects and improves the image quality at the water-

land boundary. The iCOR algorithm (version 2.0) is an image-based correction which attempts to 

determine the aerosol optical thickness using the spectral variability of land pixels in the scene. You 

can find additional information in the existing literature (De Keukelaere et al., 2018). The generated 

output contains Bottom-Of-Atmospheric (BOA) reflectance, which are above water-leaving-

reflectance. (For more info about the installation of the plugin, click here) 

When the plugin is loaded in SNAP, the tool can be accessed through Optical → iCOR → iCOR-S-2.  

In the I/O Parameters tab, select the opened image in the source product field and leave the default 

output name for the target product name. 

 

In the Processing Parameters tab adapt the default parameters but also select the Simecoption to 
apply adjacency correction over water bodies. 

 Then click Run. 

https://cdn2.hubspot.net/hubfs/2834550/marketing/MAILS/iCOR/iCORpluginUserManual_OLCI_v1.0.pdf
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For Sentinel-2, three output files are created for each tile in the /tmp/ file: 

- *_60M.tif – containing all spectral information at 60 m spatial resolution 

- *_20M.tif – only bands with original spatial resolution of 20 m 

- *_10M.tif – only bands with original spatial resolution of 10 m  

For the purpose of this exercise we will use the output product of 10-meter spatial resolution. Open 

the product in SNAP and then expand the Bands folder. The product contains four bands which 

correspond accordingly to VIS bands B2, B3, B4, and NIR band B8.  

 

Save the product as S2B_MSIL1C_20180824_10M at the: 

 /shared/Training/COAS01_BathymetryDerivation_Greece/Processing folder and load it on SNAP. 

During this process some negatives reflectance values were created in the open sea due to water 

conditions. In this case we have to exclude them from the bands. Right click on the product and select 

Band Maths. Set the parameters: 

Name: B2 

Band maths expression: if band_1 < 0 then NaN else band_1  

  

Repeat the step for the rest of the bands, accordingly: 

Name: B3 

Band maths expression: if band_2 < 0 then NaN else band_2 

Name: B4 

Band maths expression: if band_3 < 0 then NaN else band_3 

Name: B8 

Band maths expression: if band_4 < 0 then NaN else band_4  

Finally, right click and Save the product. These will be the bands that you will use for the next steps. 

Then you can continue with the exercise applying all steps from Chapter 5.4 and on.  
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6.2 Downloading the outputs from the VM 

In your VM, press Ctrl+Alt+Shift.  

A pop-up window will appear on the left side of the screen. Click on the bar below Devices, navigate 

to the folders you have saved the files you want to download and double click on them. The 

downloading process to your local computer will start automatically.  

 

 

7 Further reading and resources  

SENTINEL-2 MSI Introduction – https://sentinel.esa.int/web/sentinel/user-guides/sentinel-2-msi/  

ESA Sentinel Online –  https://sentinel.esa.int/web/sentinel/missions/sentinel-2  

Science Toolbox Exploitation Platform (STEP) – http://step.esa.int/main/toolboxes/sentinel-2-

toolbox/  

iCOR plugin for SNAP for OLCI data – 

https://cdn2.hubspot.net/hubfs/2834550/marketing/MAILS/iCOR/iCORpluginUserManual_OLCI_v1.

0.pdf  
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