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1 Introduction to RUS 

The Research and User Support for Sentinel core products (RUS) service provides a free and open 

scalable platform in a powerful computing environment, hosting a suite of open source toolboxes 

pre-installed on virtual machines, to handle and process data derived from the Copernicus Sentinel 

satellites constellation.   

The Republic of Malawi declared a State of Disaster 

on 13 January 2015 in the 15 affected districts (out 

of a total of 28 districts). The southern districts of 

Nsanje, Chikwawa, Phalombe and Zomba were the 

most affected.  

The area experienced heavy rains, more than 150% 

of normal rainfall, throughout December and 

January,   partially   related  to  Cyclone   Bansi   and 

Tropical Storm Chedza, which led to severe 

flooding. The flood left 276 people dead and 

estimated 230 000 displaced with some areas completely inaccessible. It also caused extensive 

damage to crops, livestock and infrastructure with estimated 64 000 hectares of land damaged, 

further deepening the humanitarian disaster.  

2 Training 

Approximate duration of this training session is one hour.  

The Training Code for this tutorial is HAZA01. If you wish to practice the exercise described below 

within the RUS Virtual Environment, register on the RUS portal and open a User Service request 

from Your RUS service → Your dashboard. 

2.1 Data used 

• Four Sentinel-1A IW GRDH images with VV polarization acquired before the flood event on 29 

December 2014 and during the flood event on 22 January, 27 February and 23 March 2015 

[downloadable @ https://scihub.copernicus.eu/] 

S1A_IW_GRDH_1SSV_20150323T030724_20150323T030752_005153_0067F3_832F.zip 

S1A_IW_GRDH_1SSV_20150227T030723_20150227T030752_004803_005F89_DB68.zip 

S1A_IW_GRDH_1SSV_20150122T030723_20150122T030752_004278_005347_8809.zip 

S1A_IW_GRDH_1SSV_20141229T030724_20141229T030753_003928_004B86_DA25.zip 

• Sentinel-1 Precise Orbits (PODs) for the corresponding dates (auxiliary data) automatically 

downloaded [downloadable @ https://qc.sentinel1.eo.esa.int ]  

2.2 Software in RUS environment 

Internet browser, SNAP + Sentinel-1 Toolbox, QGIS 

 

Malawi floods January 2015 Credits: www.theguardian.com 

[February 10, 2015]  

https://rus-copernicus.eu/
https://scihub.copernicus.eu/
https://qc.sentinel1.eo.esa.int/
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3 Register to RUS Copernicus 

To repeat the exercise using a RUS Copernicus Virtual Machine (VM), you will first have to register as 

a RUS user. For that, go to the RUS Copernicus website (www.rus-copernicus.eu) and click on 

Login/Register in the upper right corner.  

 

Select the option Create my Copernicus SSO account and then fill in ALL the fields on the Copernicus 

Users’ Single Sign On Registration. Click Register. 

  

Within a few minutes you will receive an e-mail with activation link. Follow the instructions in the e-

mail to activate your account.  

You can now return to https://rus-copernicus.eu/, click on Login/Register, choose Login and enter 

your chosen credentials. 

http://www.rus-copernicus.eu/
https://rus-copernicus.eu/
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Upon your first login you will need to enter some details. You must fill all the fields.   

 

4 Request a RUS Copernicus Virtual Machine 

Once you are registered as a RUS user, you can request a RUS Virtual Machine to repeat this exercise 

or work on your own projects using Copernicus data. For that, log in and click on Your RUS Service → 

Your Dashboard.  
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Click on Request a new User Service to request your RUS Virtual Machine. Complete the form so that 

the appropriate cloud environment can be assigned according to your needs. 
 

 
 

If you want to repeat this tutorial (or any previous one) select the one(s) of your interest in the 

appropriate field. 

 

 
 

Complete the remaining steps, check the terms and conditions of the RUS Service and submit your 

request once you are finished. 
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Further to the acceptance of your request by the RUS Helpdesk, you will receive a notification email 

with all the details about your Virtual Machine. To access it, go to Your RUS Service → Your 

Dashboard and click on Access my Virtual Machine.  
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Fill in the login credentials that have been provided to you by the RUS Helpdesk via email to access 

your RUS Copernicus Virtual Machine.  

 

This is the remote desktop of your Virtual Machine. 

 

5 Step by step  

5.1 Data download – ESA SciHUB 

In this step, we will download Sentinel-1 scenes from the Copernicus Open Access Hub using the 

online interface (Applications → Network → Firefox Web Browser or click the link below). 

Go to https://scihub.copernicus.eu/   

https://scihub.copernicus.eu/
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Go to “Open HUB”, if you do not have an account please register by going to “Sign-up” in the LOGIN 

menu in the upper right corner. 

 

 
After you have filled in the registration form, you will receive an activation link by e-mail. Once your 

account is activated or if you already have an account, “LOGIN”.  
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Then click on the map and Navigate to the approximate location of south Malawi. Switch to drawing 

mode (green arrow) and draw search rectangle approximately as indicated below.  

 
Open the search menu by clicking to the left part of the search bar and specify the following 

parameters: 

Sensing period: From 2014/12/29 to 2015/03/23 

Check Mission: Sentinel-1 

Product Type: GRD (Ground-range-detected product) 

Relative Orbit number: 6 (to ensure identical acquisition geometry for all scenes)  

 
In our case, the search returns only 11 results but this will depend on the exact search area defined. 

Download the following scenes: 

S1A_IW_GRDH_1SSV_20150323T030724_20150323T030752_005153_0067F3_832F 

S1A_IW_GRDH_1SSV_20150227T030723_20150227T030752_004803_005F89_DB68 

S1A_IW_GRDH_1SSV_20150122T030723_20150122T030752_004278_005347_8809 

S1A_IW_GRDH_1SSV_20141229T030724_20141229T030753_003928_004B86_DA25 

Note that you can only download 2 scenes in parallel. To see the full name of the scene you can click 

the full screen view (indicated by blue circle below).  
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Move the downloaded scenes from the Downloads folder (/home/rus/Downloads) to: 

/shared/Training/HAZA01_FloodMapping_Malawi_TutorialKit/Original  

5.2 SNAP – open and explore data 

Open SNAP Desktop (icon located on the desktop); click Open product , navigate to: 

/shared/Training/HAZA01_FloodMapping_Malawi_TutorialKit/Original and open all the 

downloaded files.  

The opened products will appear in Product Explorer. Click + or the  to expand the contents of the 

file from December 2014, then expand Bands and double click Amplitude_VV to visualize the band. 

Then do the same for the image from 22 January 2015. To compare both images, go to Window → 

Tile Horizontally and zoom-in to the lower right corner of the image. 

 

 You can find instructions how to download larger numbers of products in the Copernicus Open Access 

Hub User Guide (https://scihub.copernicus.eu/userguide/GraphicalUserInterface) 

https://scihub.copernicus.eu/userguide/GraphicalUserInterface


12 
 

5.3 Pre-processing 

We need to apply identical pre-processing steps to all our scenes. However, processing the data step 

by step and product by product would be time consuming and inconvenient. Luckily, we can use the 

Batch Processing tool available in SNAP to apply all steps to both images in one go (this also saves 

disk space as only the final products are physically saved). 

5.3.1 Build the Graph 

To use the tool, we first need to define the process we want to apply and all its steps. We can do this 

using the GraphBuilder. To build our graph, go to Tools → GraphBuilder.  

 

At the moment, the graph only has two operators: Read (to read the input) and Write (to write the 

output).  

Since our Area of Interest (AOI) is quite small and there is no need to process the whole image, we 

start by adding a Subset operator. To add the operator right-click the white space in the graph 

builder and go to Add → Raster → Geometric → Subset.  

A new operator rectangle appears in our graph and a new tab appears below. Now connect the new 

Subset operator to the Read operator by clicking to the right side of the Read operator and dragging 

the red arrow towards the Subset. 

 

In the next step, we will update the orbit metadata (See  NOTE 1). To add the operator, right-click 

the white space between existing operators and go to Add → Radar → Apply-Orbit-File. Connect the 

new Apply-Orbit-File operator with the Subset operator. 

 

 NOTE 1: The orbit state vectors provided in the metadata of a SAR product are generally not accurate 

and can be refined with the precise orbit files which are available days-to-weeks after the generation of 

the product. The orbit file provides accurate satellite position and velocity information. Based on this 

information, the orbit state vectors in the abstract metadata of the product are updated. (SNAP Help) 
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The next step will remove the thermal noise (See  NOTE 2). We do this by right-clicking the white 

space and going to Add → Radar → Radiometric → ThermalNoiseRemoval. Connect the 

ThermalNoiseRemoval operator with the Apply-Orbit-File operator.  

 

 

Now, we can add the Calibration operator. The objective of SAR calibration is to provide imagery in 

which the pixel values can be directly related to the radar backscatter. Though uncalibrated SAR 

imagery is sufficient for qualitative use, calibrated SAR images are essential to quantitative use of 

SAR data (See  NOTE 3). To add the operator go to Add → Radar → Radiometric → Calibration. 

Connect the ThermalNoiseRemoval operator to the Calibration operator. 

 

 

SAR images have inherent salt and pepper like texturing called speckles which degrade the quality of 

the image and make interpretation of features more difficult (See  NOTE 4). To reduce the speckle 

effect and smooth the image we apply speckle filter. To add the operator, go to Radar → Speckle 

Filtering → Speckle-Filter then connect the Calibration operator to it. 

 

 

Our data are still in radar geometry, moreover due to topographical variations of a scene and the tilt 

of the satellite sensor, the distances can be distorted in the SAR images. Therefore, as the last step of 

our preprocessing, we will apply terrain correction to compensate for the distortions and reproject 

the scene to geographic projection (See  NOTE 5). To add the operator, go to Radar → Geometric 

→ Terrain Correction → Terrain-Correction and then connect the Speckle-Filter operator to it. 

Finally, connect the Terrain Correction operator to the Write operator.  

 NOTE 2: Thermal noise in SAR imagery is the background energy that is generated by the receiver itself.   

(SNAP Help) It skews the radar reflectivity to towards higher values and hampers the precision of radar 

reflectivity estimates. Level-1 products provide a noise LUT for each measurement dataset, provided in 

linear power, which can be used to remove the noise from the product. 

 NOTE 3: Typical SAR data processing, which produces level-1 images, does not include radiometric 

corrections and significant radiometric bias remains. The radiometric correction is necessary for the 

pixel values to truly represent the radar backscatter of the reflecting surface and therefore for 

comparison of SAR images acquired with different sensors or acquired from the same sensor but at 

different times, in different modes, or processed by different processors. (SNAP Help) 

 NOTE 4: Speckle is caused by random constructive and destructive interference of the de-phased but 

coherent return waves scattered by the elementary scatters within each resolution cell. Speckle noise 

reduction can be applied either by spatial filtering or multilook processing. (SNAP Help) 
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For the moment, do not change anything in the parameter tabs and save the graph as 

Graph_preprocess.xml to:  

/shared/Training/HAZA01_FloodMapping_Malawi_TutorialKit/Processing by clicking Save at the 

bottom of the window. After you save the graph, close the GraphBuilder window. 

5.3.2 Batch processing 

In the Product Explorer, we select (highlight) the product [1] (29 December 2014). Now we can open 

the Batch Processing tool at Tools → Batch Processing. 

We will add the opened products by clicking Add Opened on the upper right (second icon from the 

top) and click Refresh. Then click Load Graph at the bottom of the window and navigate to our saved 

graph and open it. We see that new tabs have appeared at the top of window corresponding to our 

operators except for Write; this is correct as these parameters will be set in the I/O Parameters tab.  

In the I/O Parameters tab, set directory to: 

/shared/Training/HAZA01_FloodMapping_Malawi_TutorialKit/Processing and make sure the 

“Keep source product name” option is selected (See  NOTE 6). 

 

 

NOTE 5: The geometry of topographical distortions in SAR 

imagery is shown on the right.  Here we can see that point B 

with elevation h above the ellipsoid is imaged at position B’ in 

SAR image, though its real position is B".  The offset Δr 

between B' and B" exhibits the effect of topographic 

distortions. (SNAP Help) 

 NOTE 6: The product file names will be identical to the input file names. If you set your output directory 

to the folder that contains your input data, the input data will be overwritten! 
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Now let’s set the parameters.  

In the Subset tab, set the extent of the AOI in pixel coordinates to:  

X: 20000  Y: 15500      Width: 5100  Height: 4000 

 

In the Apply-Orbit-File tab we well keep the default settings.  

 

In the ThermalNoiseRemoval tab, select VV polarization and make sure that the “Remove Thermal 

Noise” option is selected. 

 

In the Calibration tab, we will also keep all default settings.   
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Now we go to the Speckle-Filter tab. For this exercise we choose the simple Lee filter with Window 

Size of 7x7 pixels (See  NOTE 7).  

 

 

Last, we go in the Terrain-Correction tab, click on the Map Projection and set as Projection: UTM / 

WGS84 (Automatic).  

Click OK. At the “Map Projection” you will see: UTM Zone 36, South / World Geodetic System 1984. 

 NOTE 7: Lee Filter, introduced by Jong-Sen Lee in 1980, is a widely used local statistics filter for speckle 

noise reduction. It is a pointwise linear filter minimizing the mean square error using measurements of 

the sample mean and sample variance of the noisy image and knowledge of the type of detection and 

number of looks. 
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Leave all the other default settings and click Run to pre-process our images. Approximate processing 

time: 5 minutes 

Now you should have four new products in the Product Explorer. Select the original products [1-4], 

right-click and click Close 4 Products (Click No if asked to save).  

5.4 Binarization 

To separate water from non-water a threshold can be selected for each image. For this, we will 

analyze the histogram of the filtered backscatter coefficient. Low values of the backscatter will 

correspond to the water, and high values will correspond to the non-water class.  

Open the Sigma0_VV band from all four created products [5-8] in the View and then go to Window 

→ Tile Evenly. Click on the view [5] Sigma0_VV to activate it (a yellow boundary appears around it). 
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Then go to the left side panel, select the Color Manipulation tab and click once at the   (Stretch 

the histogram horizontally) on the left side of the tab.  

Then move the middle slider below on the histogram to approx. ~0.025 and click on . Now we 

can see the water bodies better. Let’s apply the same histogram stretch to other three images. To do 

this click on  and select all three bands and click OK. In next dialog click No (for each band).  
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To create a binary mask of water and non-water pixels we create a new band and apply a conditional 

expression based on our threshold. To obtain our threshold value we will check the values occurring 

over the open water.  

Go to Window → Tile Single. Go to View [5] Sigma0_VV. 

You can create your own water body mask, but for this tutorial we will use one that has been 

prepared in advance and saved in the Auxdata folder. We can import it by clicking on the Product [5] 

in Product Explorer and then going to Vector → Import → ESRI Shapefile.  

Navigate to /shared/Training/HAZA01_FloodMapping_Malawi_TutorialKit/Auxdata and open the 

shapefile Water_ROI_Polygon.shp.  

Click No in the Import Geometry dialog (import all features into single mask).  

 

 

Now let’s have a look at the statistics.  

In the Product Explorer window, expand the bands folder in product [5] and click on band 

Sigma0_VV so it is highlighted.  

Then go to Analysis → Statistics.   

A new window will appear. On the right side select  the “Use ROI Mask(s)”, select the 

Water_ROI_Polygon (See  TIP 1) and click  Refresh.  

 

 TIP 1: If the ROI/geometry does not appear in the window go to Product Explorer, expand the Vector 

Data folder in product [5] and click on Water_ROI_Polygon. Now it should appear in the statistics 

window as well and you can select it.  
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Now we can investigate the statistics. We can see that the maximum value in our Water polygons is 

0.0236, the statistics also produces 90% percentile which gives a value of 0.0117. For our purposes 

we will adopt a value close to the 99% percentile which is not provided but can be estimated from 

the histograms. Let’s choose 0.020 as our threshold (the statistics is of course always dependent on 

the ROI you choose and therefore can vary significantly). Now that we have the value of our 

threshold, we can close this window.  

Here we assume that our polygons cover only pure water pixels and are not contaminated by any 

mixed coastal pixels or objects in the water (ships), therefore, we conclude that all the values smaller 

than our maximum value will correspond to water as well. We are still considering 1% of potentially 

contaminated pixels when choosing the 99% percentile. We could be more conservative to avoid 

misclassification (choose lower value), but threshold selection always requires some testing.  

Now let’s apply the threshold. We will apply the same threshold to all our images, therefore we can 

use the Batch processing again.  

Firstly, let’s build a very simple graph. Go to Tools → Graph Builder.  

Add the Band Math operator (right-click on the white space and go to Raster → BandMaths) and 

connect the operators as shown below. At the bottom of the window Save the graph to the 

/shared/Training/HAZA01_FloodMapping_Malawi_TutorialKit/Processing/Bin folder with the 

name: Graph_binary.xml.  

  

Close the Graph Builder. 

Then go to Tools → Batch Processing and click Add Opened on the upper right (second icon from the 

top) and click Refresh. Click on the Load Graph button, navigate to our saved graph and open it. We 

can now see that the BandMaths tab has appeared at the top of window. 

In the I/O Parameters tab, under the Target Folder, make sure that: 

a) the format (Save as) is set to GeoTIFF,  

b) the directory is: /shared/Training/HAZA01_FloodMapping_Malawi_TutorialKit/Processing/Bin 

c) and the “Keep source product name” option is selected (See  NOTE 6 - Page 14). 
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In the BandMaths tab, rename the new band to Water_mask, open the “Edit Expression…” and 

enter the following expression: 

If Sigma0_VV < 0.02 AND Sigma0_VV > 0 then 1 else NaN 

If no errors are found, click OK to close the Arithmetic Expression Editor and then click Run. After the 

processing is completed, close the Batch Processing window.  

 

Four new products [9-12] have appeared in the Product Explorer. Close all opened view windows 

and open the Water_mask band for all the new products.  

Go to Window → Tile Evenly in order to see all products at the same time. 
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You can also compare the Sigma0_VV band to the Water_mask band of every product (29 December 

2014). 

 

Now we can close SNAP. To better visualize the output of our multi-temporal flood analysis, we will 

open the saved masks (GeoTIFF) in QGIS.  

5.5 Visualization (QGIS) 

Open QGIS from the desktop shortcut or go to Application → Processing → QGIS Desktop. Click on 

the Add Raster Layer button located in the left panel ( ), navigate to:  

/shared/Training/HAZA01_FloodMapping_Malawi_TutorialKit/Processing/Bin select the four 

water masks and click Open.  
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You can change the style of each layer in the Properties menu. Right-click on the product you want to 

change and select Properties.  

In the Style tab, under Band Rendering select “Singleband gray” as Render type.  

In the Color Rendering section, activate the Colorize option, select a color and click OK. 

 

Finally, we can add a base-map to link our water masks to GIS data. Click on Web → OpenLayers 

plugin → OpenStreetMap → OpenStreetMap (See  NOTE 8). 
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THANK YOU FOR FOLLOWING THE EXERCISE! 

 NOTE 8: In case the OpenLayers plugin is not installed, click on Plugins → Manage and Install Plugins. 

Select the “All” tab on the left-side panel and write “OpenLayers plugin” on the search box. Select the 

plugin on the list and click “Install Plugin”. Restart QGIS to finalize the installation.  

 

December 

January 

February 
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