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1 Introduction 

The Research and User Support for Sentinel core products (RUS) service provides a free and open 

scalable platform in a powerful computing environment, hosting a suite of open source toolboxes 

pre-installed on virtual machines, to handle and process data derived from the Copernicus Sentinel 

satellites constellation. 

The Great Barrier Reef (GBR) is the 

largest coral reef ecosystem on Earth. 

It stretches for thousands of 

kilometres along the coast of eastern 

Australia. The reef represents an 

immense natural and economic value 

and has been declared UNESCO World 

Heritage site in 1981.    

In recent decades, there has been a 

growing concern regarding the 

deterioration of the GBR ecosystem 

health. It has been reported that 

between 1985 and 2010 51% of the 

coral in the central and southern parts of the GBR has died as a result of combined effects of climate 

change-related causes such as severe heat waves, cyclones and invasive species outbreaks. 

Sentinel-2 allows to monitor the majority of the world’s coral reefs with increased temporal and 

spatial resolution. Sen2Coral toolbox available in SNAP has been specifically developed and validated 

for this purpose.   

2 Training 

Approximate duration of this training session is two hours.  

The Training Code for this tutorial is OCEA05. If you wish to practice the exercise described below 

within the RUS Virtual Environment, register on the RUS portal and open a User Service request 

from Your RUS service → Your dashboard. 

2.1 Data used 

• A cloud-free Sentinel-2A Level 1C tile (Tile ID: T55LCD) acquired on July 21, 2016 [downloadable 

@ https://scihub.copernicus.eu/] 

S2A_MSIL1C_20160721T004002_N0204_R059_T55LCD_20160721T003959 

• Bathymetry training and validation datasets provided by John Hedley and derived from the 20m 

DEM/DDM for Lizard island: 

Leon, Javier X; Phinn, Stuart R; Hamylton, Sarah; Saunders, Megan I (2012): A 20 m spatial resolution 

seamless multisource Digital Elevation/Depth Model for Lizard Island, northern Great Barrier Reef.  

2.2 Software in RUS environment 

Internet browser, SNAP + Sentinel-2 Toolbox, QGIS, (Extra steps: Sen2Cor, Google Earth) 

BEFORE AND AFTER Healthy coral are full of colour, like the fire coral seen on the 

left. But stressors, including overly warm ocean water, cause symbiotic algae to 

abandon coral tissues, bleaching them (right). Credits: sciencenews.org (XL CATLIN 

SEAVIEW SURVEY)  

https://scihub.copernicus.eu/
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3 Register to RUS Copernicus 

To repeat the exercise using a RUS Copernicus Virtual Machine (VM), you will first have to register as 

a RUS user. For that, go to the RUS Copernicus website (www.rus-copernicus.eu) and click on 

Login/Register in the upper right corner.  

 

Select the option Create my Copernicus SSO account and then fill in ALL the fields on the Copernicus 

Users’ Single Sign On Registration. Click Register. 

 

Within a few minutes you will receive an e-mail with activation link. Follow the instructions in the e-

mail to activate your account.  

You can now return to https://rus-copernicus.eu/, click on Login/Register, choose Login and enter 

your chosen credentials. 

http://www.rus-copernicus.eu/
https://rus-copernicus.eu/
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Upon your first login you will need to enter some details. You must fill all the fields.   

 

4 Request a RUS Copernicus Virtual Machine 
Once you are registered as a RUS user, you can request a RUS Virtual Machine to repeat this exercise 

or work on your own projects using Copernicus data. For that, log in and click on Your RUS Service → 

Your Dashboard.  
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Click on Request a new User Service to request your RUS Virtual Machine. Complete the form so that 

the appropriate cloud environment can be assigned according to your needs. 
  

 
 

If you want to repeat this tutorial (or any previous one) select the one(s) of your interest in the 

appropriate field. 

 

 
 

Complete the remaining steps, check the terms and conditions of the RUS Service and submit your 

request once you are finished. 
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Further to the acceptance of your request by the RUS Helpdesk, you will receive a notification email 

with all the details about your Virtual Machine. To access it, go to Your RUS Service → Your 

Dashboard and click on Access my Virtual Machine.  
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Fill in the login credentials that have been provided to you by the RUS Helpdesk via email to access 

your RUS Copernicus Virtual Machine.  

 

This is the remote desktop of your Virtual Machine. 

 

5 Sen2Coral 

The Sen2Coral toolbox has been developed in the scope of the ESA SEON Programme Sen2Coral the 

objective of which is the is the scientific exploitation and validation of Sentinel-2 imagery for coral 

reef mapping (habitat, bathymetry and water quality) and change monitoring. (Sen2coral User Guide) 

The toolbox contains six modules developed to support the four main processing chains designed by 

the Sen2Coral project. 
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We will explore each of the available modules and their purpose, with the exception of the Physics 

based model inversion (SWAM).  

6 Step by step  

6.1 Data download – ESA SciHUB 

In this step we will download a Sentinel-2 scene from the Copernicus Open Access Hub using the 

online interface (Applications → Network → Web Browser or click the link below). 

Go to https://scihub.copernicus.eu/   

 

Resampling, 
Subset, etc. 

Spatial 
registration 

Deglint 

Land, cloud and white cap mask 

Radiometric 
normalization 

via PIFs 

Depth Invariant 
indices 

Atmospheric 
correction 

Empirical 
bathymetry 

Physics based 
model inversion 

(SWAM) 

Change 
detection 

Classification 

• Change detection 
• Bleaching 

• Geomorphology 
• Habitat map 

• Bathymetry • Bathymetry 
• Bottom type 
• Water optical 

properties 
Mapping 

Change detection 

Pre-processing 

Sen2Coral modules 

Further processing  

https://scihub.copernicus.eu/
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Go to “Open HUB”, if you do not have an account please register by going to “Sign-up” in the LOGIN 

menu in the upper right corner. 

 

After you have filled in the registration form, you will receive an activation link by e-mail. Once your 

account is activated or if you already have an account, “LOGIN”.  

 

Switch the rectangle-drawing mode to pan mode by clicking on the “Pan” icon in the lower left 

corner of the map (Green arrow) and navigate over the Great Barrier reef (blue rectangle). 
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Switch to drawing mode and draw a search rectangle approximately as indicated below. Open the 

search menu (red arrow) and specify the following parameters: 

Sensing period:  From 2016/07/21 to 2016/07/21 

Check Mission:   Sentinel-2 

 

Press “Search” (red arrow below). In our case, the search returns a single result depending on the 

exact search area defined. Download the scene:  

S2A_MSIL1C_20160721T004002_N0204_R059_T55LCD_20160721T003959 

Data will be downloaded to /home/rus/Downloads as ZIP archive. Move the archives to 

/shared/Training/OCEA05_Sen2Coral_GBR_TutorialKit/Original.  

 

6.2 Atmospheric correction 

Solar radiation reflected by the Earth’s surface to satellite sensors is affected by its interaction with 

the atmosphere. The objective of applying an atmospheric correction is to determine true surface 

(Bottom-Of-Atmosphere, BOA) reflectance values from the Top-Of-Atmosphere (TOA) reflectance 
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values, by removing atmospheric effects. (See  NOTE 1) Atmospheric correction is especially 

important in cases where multi-temporal images are compared and analysed.  

 

In this tutorial, we are using the Sentinel-2 Level-1C data as Level 2A data are not yet available for 

our study area and acquisition date (July 2016). Level 2A have been systematically produced for 

newly acquired products over Europe since the spring of 2017, the coverage has been increasing 

through 2018 to reach global coverage in the beginning of 2019. (Mousivand et al., 2015) 

Therefore, we need to use the Sen2Cor processor for Sentinel-2 Level 2A product generation and 

formatting; it performs the atmospheric, terrain and cirrus correction of Top-Of-Atmosphere Level 1C 

input data. Sen2Cor creates Bottom-Of-Atmosphere, optionally terrain and cirrus corrected 

reflectance images; additional, Aerosol Optical Thickness, Water Vapor, Scene Classification Maps 

and Quality Indicators for cloud and snow probabilities.  

The Sen2Cor must be applied to data before any other processing steps. First, using a file manager go 

to /shared/Training/OCEA05_Sen2Coral_GBR_TutorialKit/Original  

and unzip the zipped product archive. Right-click on the product and select Extract Here. 

Sen2cor can be executed both via command line and via the graphical interface in SNAP. Here, we 

will use the command line. Inside the Original folder right click and select  Open Terminal Here. 

 NOTE 1: The radiance reaching the sensor is a result of following components: 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1.  Radiation from the sun and, scattered into the field 

of view of the sensor by the atmosphere without 

reaching the surface. 

2. Direct radiation that goes through the atmosphere 

without being absorbed or scattered, reaches the 

sensor after being reflected by the target pixel. 

3. Radiation scattered by the atmosphere into the 

target pixel and reflected back towards the sensor. 

 4. & 5. Direct or diffuse radiation reflected or scattered by 

the surrounding areas into the field of view of the sensor. 

This effect is so called “adjacency effect” or “blurring 

effect”. 

6. Diffuse radiation coming from the adjacent features into 

the field of view of the sensor.  

7. So-called trapping effect and it is a part of the radiation 

reflected from the surface into the air column above the 

surface being scattered and ultimately reaches the sensor.  

Credits: Mousivand et al. (2015) 
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In the command line window, type: 

 

Then press ENTER. 

 

 

The process creates three new Level 2-A products in the “.SAFE” format in the original folder: 

/shared/Training/OCEA05_Sen2Coral_GBR_TutorialKit/Original  

6.3 SNAP – open and explore data 

Launch SNAP (icon on desktop ). When the SNAP window opens click Open product  and 

navigate to:   /shared/Training/OCEA05_Sen2Coral_GBR_TutorialKit/Original  

Then open the Level-2A product folder and open the MTD_MSIL2A.xml 

L2A_Process ./S2A_MSIL1C_20160721T004002_N0204_R059_T55LCD_20160721T003959.SAFE  

-–resolution=10 

10 

http://pngimg.com/download/33233
http://pngimg.com/download/33233
http://pngimg.com/download/33233
http://pngimg.com/download/33233
http://pngimg.com/download/33233
http://pngimg.com/download/33233
http://pngimg.com/download/33233
http://pngimg.com/download/33233
http://pngimg.com/download/33233
http://pngimg.com/download/33233
https://creativecommons.org/licenses/by-nc/3.0/
https://creativecommons.org/licenses/by-nc/3.0/
https://creativecommons.org/licenses/by-nc/3.0/
https://creativecommons.org/licenses/by-nc/3.0/
https://creativecommons.org/licenses/by-nc/3.0/
https://creativecommons.org/licenses/by-nc/3.0/
https://creativecommons.org/licenses/by-nc/3.0/
https://creativecommons.org/licenses/by-nc/3.0/
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In the Product Explorer window, right-click the Level-2A product from 2018 and click Open RGB 

image window, a new window will open. From the drop-down menu select:   

Profile: Sentinel 2 MSI Natural Colors  

 

Now, let’s investigate the cloud cover over our area of interest. Zoom in to the area of interest as 

indicated above. We can see that our area of interest is cloudless.  

 

6.4 Resample 

The 13 bands in Sentinel-2 products do not all have same resolution (therefore size, see  NOTE 2). 

While the Sen2Coral toolbox supports the products with bands of different sizes, many other 

operators such as Subset, do not. Therefore, we need to resample the bands to equal resolution first.  

Go to Raster → Geometric Operations → Resampling (See  NOTE 3).  

Do not change anything in the I/O Parameters tab. 
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In the Resampling Parameters tab, under “Define size of resampled product”, choose: By reference 

band from source product: B2  

 
Click Run. 

After the process is completed, if a window appears, click Yes. 

 

A new product [2] appeared in the Product Explorer tab. Now we will have a look at the product. 

Close all the views we have open and expand the product structure by clicking the + sign on the left 

of the product name, then expand the Band folder and double click B8 (842nm) - (NIR).  

6.5 Subset  

In the next step, we will subset the image to our area of interest. Click on the resampled product in 

the Product Explorer tab, to highlight it. Then go to Raster → Subset and in the Spatial Subset tab, 

set Pixel coordinates to:    

 

 

Credits: ESA 2015 

NOTE 2: The input product 

contains 13 spectral bands 

in three different spatial 

resolutions (The surface 

area measured on the 

ground and represented by 

an individual pixel).  When 

we open the RGB view all 

our input bands have 20 m 

resolution, however, the 

view is displayed in the full 

10 m resolution.  

 NOTE 3: The resampling product appears in the Product Explorer window, but it is not physically saved. 

Therefore, it will be lost if you close it or if you close the source product. 
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Scene start X:  2900        

Scene start Y:  1820  

Scene end X:  4000      

Scene end Y:  2750 

 

 

 

 

 

Keep the other Subset tabs as by default. 

Click OK. 

A new product will appear in the Product Explorer tab [3]. Note that the resampling and the subset 

products are virtual products only and are not physically saved. 

Right-click the product [3] and click Open RGB image window and from the dropdown menu select 

“Sentinel 2 MSI Natural Colors”. Click OK. 

Then go to the Colour Manipulation tab and click on  “Reset to defaults”.   

 

6.6 Deglint 

Sun glint is a common phenomenon in satellite images and it essentially refers to the specular 

reflection of the sun on water surfaces. The water-leaving reflectance can be difficult to observe due 

to the reflection of direct sunlight on the air-water interface (sun glint) in the direction of the 

satellite. The viewing geometry of Sentinel-2 satellite makes it vulnerable to sun glint contamination. 

In the presence of sun glint, we need to apply a glint removal algorithm in order to be able to 

observe the sea floor for the purpose of habitat mapping or bathymetry derivation.  
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There are several available sun glint removal methods for high resolution images and coastal 

applications. The algorithm implemented as part of the Sen2Coral toolbox was developed by Hedley 

et al., (2005). (See  NOTE 4) While the algorithm gives reasonably good results, it is recommended 

to use images with minimal glint.  

 

First, we need to use the polygon drawing tool to create ROI polygons over areas of the image 

containing sun glint. These should be over deep-water areas where no bottom reflectance is 

expected and all NIR reflectance is attributed to sun glint.  

In the Product Explorer tab, double click on the B8 (NIR band) to open it in view. Then in the Colour 

Manipulation tab, drag the white slider to value of 3E-2. Now we see some brighter values over the 

deep-water areas.   

Then in the Product Explorer tab, select 

the subset product [3] and go to Vector 

→ New Vector Data Container. In the 

dialog that opens, set the name to 

“glint” and click OK. 

 NOTE 4: The equation (1) described by Hedley et al. (2005) for the deglinting of a multispectral image is:  

𝑅′𝑖 =  𝑅𝑖– 𝑏𝑖  (𝑅𝑁𝐼𝑅  – 𝑀𝑖𝑛𝑁𝐼𝑅) 

where R’i is the deglinted pixel in band i, Ri is the reflectance from visible band i, bi is the regression 

slope, RNIR is the NIR band value and the MinNIR the minimum NIR value of the sample.  

 

To deglint a visible wavelength band, a regression is performed between the NIR brightness and the 

brightness in the visible band using a sample set of pixels, which would be homogeneous if not for the 

presence of sun glint (e.g. deep water). For other pixels, the slope of the regression is then used to 

predict the brightness in the visible band that would be expected if those pixels had a NIR value of 

MinNIR (equation (1)). MinNIR is the NIR value expected from a pixel with no sun glint, which can be 

estimated by the minimum NIR value found in the sample. (SNAP Help) 



18 
 

Finally, click on the Rectangle drawing tool and draw polygons over the deep-water sun glint 

areas.  

 

Then go to Optical → Thematic Water Processing → Sen2Coral → Processing Modules → Deglint 

Processor.  

In the I/O Parameters tab, set the subset product [3] as Source Product. We can also change the 

Target Product name to something shorter and save the product to: 

/shared/Training/OCEA05_Sen2Coral_GBR_TutorialKit/Processing 

In the Processing Parameters tab, set:  Sun Glint areas: “glint” 

      Source Bands: B2, B3, B4, B5 

      Reference Band: B8  
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Leave other settings as default and click Run. When the processing is finished, a new product [4] will 

appear in the Product Explorer tab. Right-click on the product and open RGB view.  

 

The algorithm results in majority of the land areas to have negative value and therefore be 

automatically masked, however we still need to apply cloud, residual land and white cap mask.  

6.7 Land, Cloud and White Cap Mask 

Another essential pre-processing step is masking of the land, white caps (sea foam crest over the 

waves), clouds and cloud shadows. The first three refer to bright features that can identified due to 

the fact that the near infrared wavelengths do not penetrate into the water, so after deglint is 

applied, clear areas of water appear very dark. Clouds, white caps and land typically have high 

reflectance in the NIR, therefore we can set a threshold to mask them (see image below). 

 

In Sen2Cor, a tool is available to create the mask. To apply it go to Optical → Thematic Water 

Processing → Sen2Coral → Processing Modules → LandCloudWhiteCapMask Processor.  

In the I/O Parameters tab, set the subset deglint product [4] as Source Product. Save the product to: 

/shared/Training/OCEA05_Sen2Coral_GBR_TutorialKit/Processing 
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In the Processing Parameters tab, set:  Source Bands: B2, B3, B4, B5 

      Reference Band: B8  

Maximum valid value: 0.05 

 

Click Run. A new masked product [5] containing also the mask band has been created.  

However, the tool is unable to mask dark features such as cloud shadow or terrain shadow (can be 

seen on the above mask). The dark feature can be delineated manually, or we can use a threshold 

applied to band 2 to delineate them.  

In the Product Explorer, right-click on the new masked product [5] and go to BandMaths. In the band 

math dialog set:  

Name: Mask_All 

Replace NaN and identify results by: NaN 

Deselect Virtual (save expression only, don’t store data) 

Click on Edit Expression and set:  

Expression:  

 

if B2 > 0.01 && LandCloudWhiteCapMask_B8 == 1 then 1 else 0 
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Then click OK. Now we can proceed to the applications.  

 

We can turn off the visualization of the glint polygons by going to Layer Manager (right side of the 

screen or go to View → Tool Windows → Layer Manager) and deselecting Vector data → glint.  

6.8 Depth invariant indices 

The calculation of depth invariant indices is a water column correction step that is frequently a useful 

pre-processing step for benthic classification. (See  NOTE 5) (Green et al., 2000; Lyzenga, 1978) 

 

First, we need to define two groups of ROI polygons: 

• Deep water – ROI over deep-water regions. From this the deep-water reflectance value is 

estimated (see  NOTE 5 above). 

• Same bottom type at different depth – it is best to select areas of bright sand bottom as they 

can be identified easily and due to their brightness provide good signal-to-noise ratio. 

Right-click on the masked product [5] in the Product Explorer and go to Vector → New Vector Data 

Container. In the dialog that opens, set the name to “deep”. Click on the Rectangle drawing tool 

 NOTE 5: The implementation it Sen2Coral follows Lyzenga (1978) and Green et al. (2000). The basic ideal 

is that attenuation of the reflectance is approximately inverse exponential with water depth, therefore 

the transform, 

𝑋𝑖 = –  𝑙𝑛 (𝑅𝑖  – 𝑅𝑖
𝑑𝑒𝑒𝑝

) 

approximately linearizes the effect of depth on reflectance. Ri is the pixel reflectance in band i, and 

Ri
deep, is the deep-water reflectance in that band. A plot of the pixel values of two such transformed 

bands over a benthic type with constant reflectance but at different depths will lie on a line (following 

figure).  

In order to compute the depth invariant indices, we need to select two bands with sufficient water 

penetration to observe subsurface features of interest. For Sentinel-2 the bands 1-3 are the most useful, 

although 1-5 can fulfil the condition. We don’t need to know the individual water attenuation 

coefficients in the two selected input bands, but we do need to know their ratio. This can be calculated 

from sample pixels over the same bottom type at different depths. (SNAP Help) 
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and draw polygons over the deep-water, it is best to use the RGB View to identify suitable areas. 

Then create another New Vector Data Container and name it “same_type” and draw polygons over 

the bright sand areas. On the image below, you can see the “deep” polygons indicated in green and 

the “same_type” polygons indicated in red. 

 

Then to apply the processor, go to Optical → Thematic Water Processing → Sen2Coral → 

Processing Modules → DepthInvariantIndices Processor. 

In the I/O Parameters tab, set the masked product [5] as Source Product. Save the product to: 

/shared/Training/OCEA05_Sen2Coral_GBR_TutorialKit/Processing 

In the Processing Parameters tab, set:  Source Bands: B2, B3  

      Deep water area: “deep” 

Same bottom areas: “same_type” 
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Then click Run and when finished close the operator dialog. A new product [6] has appeared in the 

Product Explorer. It contains only one band, double click it to visualize it. Turn off the visualization of 

the polygons by going to Layer Manager and deselecting Vector data.  

You can also play with the sliders in the Colour Manipulation tab, to increase the contrast a bit more 

(  -2.5,  -1.5,  -0.5). We can also compare it with the original RGB image. To do this close all the 

except for the [5] Sentinel 2 MSI Natural RGB and the [6] DepthInvariantIndicesB2B3, then go to 

Tools → Tile Horizontally. 

 

We only see valid values over shallow areas where the solar radiation can penetrate to the sea floor 

and is reflected from the features of interest.  Over deep areas we only see noise values.  

We can now proceed to use the Depth Invariant Indices as an input to change detection or to habitat 

classification (see example of simple classification below – using depth invariant indices, bands 2-5 

and bathymetry as input). This however, is not the purpose of this training.  
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6.9 Empirical Bathymetry 

The next tool we will explore is the Empirical Bathymetry processor. Estimation of bathymetry by 

empirical regression is a commonly used method for mapping shallow water areas. However, this 

method is only applicable if in-situ data are availbale for the area of interest. These most commonly 

come from boat sonar system and in combination with cloudless and calm water image can be used 

as an input to simple regression method and calibration of the bathymetry retrieval algorithm.  

The algorithm implemented in the Sen2Coral toolbox follows the method developend by Stumpf et 

al. (2003). It is based on the principle that the water attenuation coefficients differ between 

wavelengths (bands) and we can determine the ratio between the two bands which will change with 

depth (similarly as for the Depth Invariant Indices calculation) (See  NOTE 6). 

 

Firstly, we need to go to Optical → Thematic Water Processing → Sen2Coral → Processing modules 

→ EmpiricalBathymetry Processor.  

In the I/O Parameters tab, select we select the pre-processed, deglinted and masked image [5] 

image as a source product field and save the product to: 

/shared/Training/OCEA05_Sen2Coral_GBR_TutorialKit/Processing 

In the Processing Parameters tab, we have to select two bands that will be used to estimate the 

bathymetry. Most commonly the bands 2 and 3 are used for Sentinel-2 as these offer the best 

combination of penetration depth and spatial resolution.  

We also have to provide the path to the in-situ bathymetry point data. The training and validation 

datasets used here are in fact not in-situ data but were derived by John Hedley using random 

sampling of the 20m multisource Digital Elevation/Depth Model for Lizard Island (Leon et al., 2012). 

Only points with maximum depth of 20m have been used for the algorithm calibration, as this can be 

assumed as the maximum depth to which the retrieval from satellite data is possible.  

The dataset must be in a CSV coma-

delimited format without headers and 

containing columns for latitude, longitude 

and depth.  

Bands to be used: B2, B3  

Bathymetry point data:  
/shared/Training/OCEA05_Sen2Coral_GBR_TutorialKit/AuxData/lizard_leonetal_dem_bathy

_training.csv 

N value: 1000.0 (default) 

 NOTE 6: The implementation in Sen2Coral follows by Stumpf et al. (2003). The basic ideal is that 

attenuation of the reflectance is approximately inverse exponential with water depth, i.e. we can 

estimate the depth z using following equation: 

𝑧 =  𝑚1

 𝑙𝑛 (𝑛𝑅𝑤 (𝜆𝑖))

𝑙𝑛(𝑛𝑅𝑤 (𝜆𝑗))
+  𝑚0 

where m1 is a tuneable constant to scale the ratio to depth, n is a fixed constant for all areas, Rw is the 

reflectance of water for bands i or j, and m0 is the offset for a depth of 0 m (z=0). The fixed value of n is 

chosen to assure both that the logarithm will be positive under any condition and that the ratio will 

produce a linear response with depth. (SNAP Help) 
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if $5.Mask_All == 1 then $7.EmpiricalBathymetry_B2_B3 else NaN 

 

Then click Run and when finished close the operator dialog. A new product [7] has appeared in the 

Product Explorer. It contains only one band. Go to Window → Tile Single and then double click the 

bathymetry band to visualize it. Turn off the visualization of the polygons by going to Layer Manager 

and deselecting Vector data.  

 

We can now use the “Mask_All” band to mask out all the residual land, cloud and cloud shadow. In 

the Product Explorer, right-click on the new bathymetry product [7] and go to BandMaths. In the 

band math dialog set:  

Name: EmpiricalBathymetry_B2_B3_masked 

Replace NaN and identify results by: NaN 

Deselect Virtual (save expression only, don’t store data)Click on Edit Expression and set:  

Expression:  

Note that we are using a band “Mask_All” from a different product, for this reason we can not use 

virtual band. We also have to pay attention to correct reference numbers in our expression.  



26 
 

 

Then click OK. Now we can visualize the band. In Product Explorer, go to the Vector data folder and 

delete the following: “glint”, “deep”, “same_type” (right-click → Delete) 

Then go to the Colour Manipulation tab and click on  Import Colour Palette, navigate to 

/shared/Training/OCEA05_Sen2Coral_GBR_TutorialKit/AuxData/ and open Bathymetry_Col.cpd In 

the dialog that opens click No.  
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6.9.1 Validation 

In SNAP we can also do a quick validation using a validation dataset also derived from the 20m 

multisource Digital Elevation/Depth Model for Lizard Island (Leon et al. 2012).  

First, we need to load this dataset to as a vector from CSV file (or shapefile). In this case we use tab-

delimited CSV with headers.  

 

In Product Explorer, select the bathymetry product, then go to Vector → Import → Vector from 

CSV. Navigate to /shared/Training/OCEA05_Sen2Coral_GBR_TutorialKit/AuxData/ and open 

lizard_leonetal_dem_bathy_validation_SNAP.csv 

In the Import CSV Data dialog, select Custom CRS → Geographic Lat/Lon (WGS 84). Click OK. In the 

next dialog accept the default option.  
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Then click on the  Correlative plot tool on the top panel. In the dialog, deselect Use ROI mask, and 

set:  Point data source: lizard_leonetal_dem_bathy_validation_SNAP 

 Data field: Depth  

In Y-Axis (EmpiricalBathymetry_B2_B3_masked) deselect Auto min/max and set Max: 50  

Select Show tolerance range and Show regression line.  

 

We can export the graph and the bathymetry data for further use for example as one of the inputs 

for benthic habitat classification. When you are done examining the graph, close the graph window. 

6.10 Radiometric Normalization via PIFs 

The last tool we will have a look at is the Radiometric Normalisation via PIFs. This tool enables us to 

apply radiometric normalisation to imagery so values corresponding to the same surface are 

comparable throughout a timeseries. The method is based on the use of pseudo invariant features 

corresponding to optically bright (sand) or optically dark (seagrass) targets, deep waters, human 

made infrastructures (roofs, roads, airstrips) to intercalibrate two different images.  

For this part of the exercise we will use a different study area – Adelaide reef - which shows some 

interesting results possibly related to the detection of bleaching event. The following pre-processing 

steps have already been applied to the images:  

• Atmospheric correction – Sen2Cor 

• Resampling  

• Subset 

• Deglint 

• Land Cloud and White Cap mask 

Click on Open product  and navigate to: 

 /shared/Training/OCEA05_Sen2Coral_GBR_TutorialKit/Original/Adelaide_Reef/ 
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and open the two images .dim files. Open the RGB view for both and then go to Window → Tile 

Horizontally.  

We will use the first image from 2016 as a master for the calibration of the second image from 2017. 

First, we need to draw polygons over features we expect not to change over time, such as bright 

sand, man made infrastructure or dark pelagic water.  

 

Once you are done drawing the polygons, go to Optical → Thematic Water Processing → Sen2Coral 

→ Processing modules → RadiometricNormalizationPIFs Processor. 

In the I/O Parameters tab, set the masked product [8] as Source Product. Save the product to: 

/shared/Training/OCEA05_Sen2Coral_GBR_TutorialKit/Processing 

In the Processing Parameters tab, set:  Source Bands: B1, B2, B3, B4, B5 

      Deep water area: geometry 
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$9. LandCloudWhiteCapMask_B8 

Click Run. A new product [10] had been created in the Product Explorer. If you try to visualize the 

image you will receive an error, this is due to a bug in the handling of the valid pixel expression. The 

visualization tool is searching for the LandCloudWhiteCapMask_B8 band that does not exist in the 

new product. We have to add it from the original pre-processed product [9]. 

In Product Explorer, right-click on the new normalized product [10] and go to BandMaths. In the 

band math dialog set:  

Name: LandCloudWhiteCapMask_B8 

Replace NaN and identify results by: NaN 

Deselect Virtual (save expression only, don’t store data) Click on Edit Expression and type:  

Expression:  

 

Click OK. Now we can visualize the result.  

Open and arrange windows so the image from 2016 and the new normalized image from 2017 are 

displayed side by side (close all the other views and then go to Window → Tile Vertically). Zoom-in 

to the area indicated below. 
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This image has been reported in Hedley et al. (2018) as it potentially captures a bleaching event. The 

coral in the second image appears much brighter, almost white. Bleaching is in general very difficult 

to capture in satellite images as the event generally occurs on the scale of weeks.  

7 Extra steps 

7.1 Downloading the outputs from VM 

On your keyboard, press Ctrl+Alt+Shift. A pop-up window will appear on the left side of the screen. 

Click on the bar below Devices, the folder structure of your VM will appear. Navigate to your 

Processing folder and double click any file you want to download.  
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