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1 Introduction 

The Research and User Support for Sentinel core products (RUS) service provides a free and open 

scalable platform in a powerful computing environment, hosting a suite of open source toolboxes pre-

installed on virtual machines, to handle and process data acquired by the Copernicus Sentinel satellites 

constellation.  

In this tutorial we will employ RUS for 

ship detection (marine surveillance) in 

the Gulf of Trieste using Sentinel-1 

Satellite-borne synthetic aperture 

radar (SAR). Marine surveillance can be 

done using different methodologies. A 

first option consists of cooperative 

systems in which ships themselves 

report their identities and positions. 

The three most common options are 

Automatic Identification System (AIS), 

Long Range Identification and Tracking 

(LRIT) and Vessel Monitoring System (VMS). While the first one is in fact available continuously and 

globally, the two others are not. Another option is the non-cooperative systems which do not require 

cooperation on the side of the vessel. These systems most commonly use cameras and radars located 

on a variety of platforms (ships, airplanes, satellites, etc.).  

Ship detection with Sentinel-1 falls into the non-cooperative category and enables detection of vessels 

not carrying AIS or other tracking system on board such as smaller fishing ships or ships that are in the 

surveyed area illegally (illegal fishing, piracy etc.). Moreover, SAR is not reliant on solar illumination 

and is rather independent of weather conditions, therefore enabling frequent monitoring.  

2 Training 

Approximate duration of this training session is one hour.  

The Training Code for this tutorial is OCEA01. If you wish to practice the exercise described below 

within the RUS Virtual Environment, register on the RUS portal and open a User Service request from 

Your RUS service → Your dashboard. 

2.1 Data used 

• One Sentinel-1A IW GRDH image with VH & VV polarization acquired on 9 October 2016 

[downloadable @ https://scihub.copernicus.eu/] 

S1A_IW_GRDH_1SDV_20161009T165807_20161009T165832_013416_0156B9_4550.zip 

• Vector Sea mask as ESRI Shapefile stored in:  

 /shared/Training/OCEA01_ShipDetection_Trieste_TutorialKit/Auxdata 

2.2 Software in RUS environment 

Internet browser, SNAP + Sentinel-1 Toolbox, QGIS (Extra steps: Google Earth Web) 

AIS real time marine traffic – 27 Jun. 2017 3:27 PM 

https://rus-copernicus.eu/
https://scihub.copernicus.eu/
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3 Register to RUS Copernicus 

To repeat the exercise using a RUS Copernicus Virtual Machine (VM), you will first have to register as 

a RUS user. For that, go to the RUS Copernicus website (www.rus-copernicus.eu) and click on 

Login/Register in the upper right corner.  

 

Select the option Create my Copernicus SSO account and then fill in ALL the fields on the Copernicus 

Users’ Single Sign On Registration. Click Register. 

  

Within a few minutes you will receive an e-mail with activation link. Follow the instructions in the e-

mail to activate your account.  

You can now return to https://rus-copernicus.eu/, click on Login/Register, choose Login and enter 

your chosen credentials. 

http://www.rus-copernicus.eu/
https://rus-copernicus.eu/
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Upon your first login you will need to enter some details. You must fill all the fields.   

 

4 Request a RUS Copernicus Virtual Machine 
Once you are registered as a RUS user, you can request a RUS Virtual Machine to repeat this exercise 

or work on your own projects using Copernicus data. For that, log in and click on Your RUS Service → 

Your Dashboard.  
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Click on Request a new User Service to request your RUS Virtual Machine. Complete the form so that 

the appropriate cloud environment can be assigned according to your needs. 
 

 
 

If you want to repeat this tutorial (or any previous one) select the one(s) of your interest in the 

appropriate field. 

 
 

Complete the remaining steps, check the terms and conditions of the RUS Service and submit your 

request once you are finished. 
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Further to the acceptance of your request by the RUS Helpdesk, you will receive a notification email 

with all the details about your Virtual Machine. To access it, go to Your RUS Service → Your Dashboard 

and click on Access my Virtual Machine.  
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Fill in the login credentials that have been provided to you by the RUS Helpdesk via email to access 

your RUS Copernicus Virtual Machine.  

 

This is the remote desktop of your Virtual Machine. 

 

5 Step by step  

5.1 Data download – ESA SciHUB 

In this step we will download a Sentinel-1 scene from the Copernicus Open Access Hub using the online 

interface.  

Go to https://scihub.copernicus.eu/   

https://scihub.copernicus.eu/
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Go to “Open HUB”, if you do not have an account please register by going to “Sign-up” in the Login 

menu in the upper right corner and click register. 
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After you have filled in the registration form, you will receive an activation link by e-mail. Once your 

account is activated or if you already have an account, “LOGIN”.  

Then click on the map and Navigate to the approximate location of Trieste. Switch to drawing mode 

(green arrow) and draw search rectangle approximately as indicated below.  

 

Open the search menu by clicking to the left part of the search bar (red arrow) and specify the following 

parameters: 

Sensing period: From 2016/10/08 to 2016/10/10 

Check Mission: Sentinel-1 

Satellite Platform: S1A* 

Product Type: GRD (Ground-range-detected product) 

 

In our case, the search returns approximately 4 results depending on the exact search area defined. 

Download scene S1A_IW_GRDH_1SDV_20161009T165807_20161009T165832_013416_0156B9_4550. 
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Move downloaded scene from the Downloads folder (/home/rus/Downloads) to:   
/shared/Training/OCEA01_ShipDetection_Trieste_TutorialKit/Original  

 

5.2 SNAP – open and explore data 

Open SNAP Desktop (icon located on the desktop); click Open product , navigate to:  
/shared/Training/OCEA01_ShipDetection_Trieste_TutorialKit/Original 
and open S1A_IW_GRDH_1SDV_20161009T165807_20161009T165832_013416_0156B9_4550.zip 

The opened product will appear in Product Explorer. Click on the + or the to expand the contents of 
the file, then expand Bands and double click Amplitude_VH to visualize the band.  

We can see that the view appears “upside down”: this is because the scene was acquired during 
ascending pass (the satellite was moving in south to north direction looking to the east) and the view 
shows the pixels in order of data acquisition as the image is not yet projected into cartographic 
coordinates. 

 

 TIP 1: It may happen that the data used to create this exercise are temporarily unavailable or has been 
moved to the offline archive. In such case, you can use other image for the same location or request the 
data from the archive which may take some time.  

 

 



12 
 

  

5.3 Subset 

Since our Area of Interest (AOI) is quite small and there is no need to process the whole image, we 

start with sub-setting the scene to a more manageable size (See  NOTE 1). This will reduce the 

processing time in further steps and is recommended when the analysis is focused only over a specific 

area and not the complete scene.  

 
Click Raster → Subset.  

 
In the Subset menu at the “Spatial Subset” tab, set the extent of the AOI in pixel coordinates to:  

Scene start X: 500 Scene start Y: 500 Scene end X: 15300 Scene end Y: 16600 

Keep the default settings at the rest tabs and click OK. A new product has appeared in the Product 

Explorer Window. Expand the products structure go to “Bands” and double-click the Amplitude_HV 

to open it in View. 

 

 NOTE 1: The subset product appears in the Product Explorer but is not physically saved.  
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5.4 Apply orbit file 

Next, we will apply precise orbit to the subset. (See  NOTE 2) 

 

Click Radar → Apply Orbit file  

 

We can shorten the output name a bit to:  

subset_S1A_IW_GRDH_1SDV_20161009T165807_4550_Orb  

and set output folder to:   

/shared/Training/OCEA01_ShipDetection_Trieste_TutorialKit/Processing 

Use this folder to save all the following processing products. All other settings remain set to default 

values.  

Click Run.  Approximate processing time: 22sec 

5.5 Add vector mask 

In order to avoid detection of false targets (ships) on land, the SNAP “Ocean Object detection” includes 

a land masking function. By default, the SRTM 3sec digital elevation model is used to identify and mask 

out areas with positive elevation. This method however can sometimes introduce false targets along 

complicated coastlines such as the Gulf of Trieste; therefore, here we choose to use our own vector 

mask. To do this we first need to import the mask into our product.  

Open the Amplitude_VH band of the newly created product [3] and close all other views. Then select 

the S1A_IW_GRDH_1SDV_20161009T165807_4550_Orb by clicking once on it (whole product, not 

single band).  

Click Vector → Import → ESRI Shapefile  

Navigate to:  /shared/Training/OCEA01_ShipDetection_Trieste_TutorialKit/Auxdata  

Open: Gulf_Of_Trieste_seamask_UTM33.shp 

 NOTE 2: The orbit state vectors provided in the metadata of a SAR product are generally not accurate and 

can be refined with the precise orbit files which are available days-to-weeks after the generation of the 

product. The orbit file provides accurate satellite position and velocity information. Based on this 

information, the orbit state vectors in the abstract metadata of the product are updated. (SNAP Help) 
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Now you can see a coloured overlay (that can differ every time you import it) on top of your open 

product and a new vector layer added into you Vector Data folder in the product. (See  TIP 1) 

 

5.6 Run ship detection 

Now we will run the ship detection algorithm. It consists of several steps: Land-Sea Mask, Calibration, 

Adaptive Thresholding and Object Discrimination. We will go through each step separately.  

Click Radar → SAR Applications → Ocean Applications → Ocean Object Detection 

In the processing window we see all steps as tabs.  

In the “Read” tab set the subset product with updated orbit information as an input. 

([3]S1A_IW_GRDH_1SDV_20161009T165807_4550_Orb)  

 TIP 1: Visualization of the vector overlay: To change the appearance of the added vector layer we can go 

to View → Tool Windows → Layer Manager. A new pane will open, and we can see all layers in our 

currently selected product. Expand the Vector data tab, select the “Gulf_Of_Trieste_seamask_UTM33” 

and click on Layer editor       .. In Layer editor you can change the colour, transparency, outline width etc. 
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5.6.1 Land-Sea-Mask 

The first step is masking the land areas to avoid false target detections on land. Here we will use loaded 

vector mask Gulf_Of_Trieste_seamask_UTM33 and mask out areas that are not overlaid.   

Unclick the “Use SRTM 3 sec” and select “Use Vector as Mask”. The loaded vector layer will appear in 

the text box. If no source band/s is/are selected, all bands will be used by default.  

 

5.6.2 Calibration 

In the next step we will apply radiometric calibration. The objective of SAR calibration is to provide 

imagery in which the pixel values can be directly related to the radar backscatter of the scene. Though 

uncalibrated SAR imagery is sufficient for qualitative use, calibrated SAR images are essential to 

quantitative use of SAR data. (See  NOTE 3)  

 

 

 NOTE 3: Typical SAR data processing, which produces level-1 images, does not include radiometric 

corrections and significant radiometric bias remains. The radiometric correction is necessary for the pixel 

values to truly represent the radar backscatter of the reflecting surface and therefore for comparison of 

SAR images acquired with different sensors or acquired from the same sensor but at different times, in 

different modes, or processed by different processors. (SNAP Help) 
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Keep all the default settings.   

 
On the image above, we can see the effect of radiometric correction.  

5.6.3 Adaptive Thresholding 

Adaptive thresholding is a frequently used method for target detection in SAR imagery. The underlying 
assumption is that targets appear bright on dark background. The adaptive thresholding algorithm is 
applied in moving window. For each pixel under test (central pixel) a new threshold value is calculated 
based on the statistical characteristics of its local background: if the pixel value is above the threshold 

the pixel is classified as target pixel (for more info see  NOTE 4).  

 NOTE 4: The specific type of adaptive thresholding algorithm used in the 

SNAP Ocean Object Detection tool is a Two-Parameter Constant False Alarm 

Rate (CFAR) Detector. The user defines the parameters of the moving 

window (image on the right) where the Target window corresponds to one 

or multiple pixels under test; the Guard window prevents contamination of 

the background values by the target pixels; the values within the Background 

window represent the local background and are used to determine the 

probability distribution function (PDF) of fitted Gaussian distribution. 

                     

Then the PDF and user defined probability of false alarm (PFA) are used to determine the detection design 

parameter t as follows: 

𝑃𝐹𝐴 =
1

2
−

1

2
𝑒𝑟𝑓 (

𝑡

√2
) 

The decision criterion is then expressed as:   𝑥𝑡 >  𝜇𝑏 +  𝜎𝑏         𝑡𝑎𝑟𝑔𝑒𝑡  (target window is single pixel) or  

as:    𝜇𝑡 >  𝜇𝑏 + 𝜎𝑏         𝑡𝑎𝑟𝑔𝑒𝑡  (target window contains multiple pixels), where xt is value of target pixel 

or µt is mean value of target window; µb is background mean and  σb is background standard deviation.  

(SNAP Help)  

Specify the following parameters: 
Target Window Size (m): 30 (the target window size in metres; length of smallest target to detect, See 

 TIP 2)  

BEFORE AFTER 

Credits: SNAP Help 
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Guard Window Size (m): 500 (the guard window size in metres; size of the largest target to detect)  

Background Window Size (m): 800 (the background window size in metres; larger than the guard 

window size to ensure accurate calculation of the background statistics) 

PFA (10^ (-x)): 12.5 (positive number for parameter x)  

 

 

5.6.4 Object Discrimination 

This step is used to filter out false targets based on minimum and maximum size limits. Set the 

following parameters: 

Minimum Target Size (m): 30 (target with dimension smaller than this threshold is eliminated) 

Maximum Target Size (m): 600 (target with dimension larger than this threshold is eliminated)  

 

In the last tab of the processor we set the location of the product to our “Processing” folder 

(/shared/Training/OCEA01_ShipDetection_Trieste_TutorialKit/Processing). Click Run.  

 
Approximate processing time: 5.38 minutes. 

 TIP 2: The size of the smallest detectable object is dependent on the data resolution. The Sentinel-1 IW 

GRDH Product that we are using here has a resolution of 20x22 metres (but pixel spacing 10x10 metres). 

Therefore, to avoid excessive numbers of false targets we set the smallest detectable target to 30 m, value 

larger than the spatial resolution. 
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In Product Explorer, expand the newly created product: 

subset_0_of_S1A_IW_GRDH_1SDV_20161009T165807_Orb_Cal_THR_SHP  

and open band Sigma_VH  

 

We can see the red circles representing targets but in the current visualization we cannot assess their 

accuracy. Let’s enhance the view a little.  

First, go to the Layer Manager pane on the right side of the SNAP window (or View → Tool Windows 

→ Layer Manager), expand the Vector data folder and deselect Gulf_of_Trieste_seamask_UTM33.  

Then go to Colour Manipulation tab also in the lower left corner and drag the white slider to the right 

close to the end of the histogram (i.e. approximatelly to value 6.6E-2).  

Now, we can actually see the bright targets (ships) within the red circles. Zoom-in to have better look. 
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Upon close inspection you can notice a few very small targets were missed. Target detection is all 

about optimizing the parameters to your data to achieve the lowest number of false detections and 

simultaneously the lowest number of missed targets. (See TIP 3) 

 

5.7 Export the results to Shapefile 

Now we can export our results to an ESRI Shapefile (.shp) format that is more manageable and can be 

processed and visualized further in software such as QGIS.  

Depending on the version of SNAP you have, there might be a reoccurring bug that prevents simple 

export of the detections to ESRI shapefile format. Outlined below is a method to export for versions 

without the bug (OPTION 1) and a work-around method for versions with the bug (OPTION 2).  

5.7.1 OPTION 1 – No error 

In Product Explorer, expand the ship detection product [4] and open the Vector Data folder. Right-

click on the ShipDetections layer and select Geometry as a Shapefile. 

 

Save the Shapefile to:  /shared/Training/OCEA01_ShipDetection_Trieste_TutorialKit/Processing.  

5.7.2 OPTION 2 – SNAP versions with error 

If the approach described in OPTION 1 does not work for you then the version of SNAP installed on 

your machine likely contains the mentioned error.  

 

 TIP 3: Try running the detection again with different parameters. Generally, the lower the PFA exponent, 

the more targets (false and real) you will capture. The same applies to the Target window size: the smaller 

target window, the more detection (detection of smaller targets but also for example two detections 

within a large target).  

Combinations to try: 

1. Adaptive thresholding: TW: 15; GW: 500; BW: 800; PFA: 12.5;  

Object-Discrimination: MinTS: 15; MaxTS: 600 

2. Adaptive thresholding: TW: 30; GW: 500; BW: 800; PFA: 9.0;  

Object-Discrimination: MinTS: 30; MaxTS: 600 
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The detections are stored in the output product folder as a CSV:  

/shared/Training/OCEA01_ShipDetection_Trieste_TutorialKit/Processing/ 

subset_S1A_IW_GRDH_1SDV_20161009T165807_Orb_Cal_THR_SHP.data/vector_data/ShipDetecti

ons.csv  

However, since our data is still not projected to a known projection such as WGS84, the table only 

contains pixel coordinates of the detections. We can get the detections and their lat/lon positions from 

the processing log. To do this, you need to open the File Explorer.  

 

In the top of the file explorer window, go to View → Show hidden files. Then navigate to 

/home/rus/.snap6/var/log.   

Here you can find a file named: 

subset_S1A_IW_GRDH_1SDV_20161009T165807__4550_Orb_Cal_THR_object_detection_report.xml 

Right click the file and go to Open With → Open With “Mousepad”. 

When the file opens in a text editor delete first three and last three lines (including the empty line) as 

shown below. 

 
… 

 

Then go to File → Save as, and save the file to the Processing folder as object_detection_report.txt 

Now, we can open QGIS.  

Go to Applications → Processing and open QGIS Desktop. Navigate to 

/shared/Training/OCEA01_ShipDetection_Trieste_TutorialKit/Auxdata in the Browser Panel on the 

left and double click the Gulf_Of_Trieste_seamask_UTM33.shp (see TIP 4). 

 

Now, click on the “Add Delimited Text Layer”  in the vertical menu on the left of the window.  

 TIP 4:  To change the appearance of the layer right-click the layer in the Layers Panel in lower left and go 

to Properties. Click on Simple fill and edit the appearance or select one of the predefined settings on the 

right. Click OK. 
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In the window that opens, click Browse and navigate to the saved object_detecion_report.txt 

A table will appear in the bottom of the window. Select Custom delimiters, unselect all other delimiters 

and in Other Delimiters type: “.  

Make sure that the “First record has field names” in NOT selected. 

Keep the remaining options and set the X and Y fields exactly as shown below (X field: field_8 and Y 

field: field_6) (x field = Longitude, y field = Latitude).  

  

Then, click OK and the Window “Coordinate Reference System Selector” should pop up. 

At the “Coordinate Reference Systems of the World”, under the “Coordinate Reference System” tab, 

expand the “Geographic Coordinate Systems” and choose the WGS84 with ID: EPSG: 4326. Click OK. 
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In case the Window “Coordinate Reference System Selector” will not pop up, we need to check the 

coordinate reference system of the data.  

Right-click the new layer and go to Properties → General.  

Check that the Coordinate reference system is set to EPSG 4326 which corresponds to WGS 84 

geographic coordinate system. Click OK. 

 

We can now right click the “object_detection_report” layer and go to Save as.  

A variety of formats including shapefile and SHP are available.  

Let’s choose ESRI Shapefile format, click on “Browse” and save the layer to the “Processing folder” 

with the name “ShipDetection_Points.shp” (Check CRS is set to EPSG: 4326, WGS 84). Click OK.  

5.8 Visualization in QGIS 

Now, we can proceed with visualization of our results in QGIS. If not already opened, go to Applications 

→ Processing and open QGIS Desktop. Navigate to:  

/shared/Training/OCEA01_ShipDetection_Trieste_TutorialKit/Processing folder in the Browser Panel 

on the left and double click the “ShipDetection_Points.shp”. (see TIP 5) 

 

To visualize the location better, let’s open a basemap from the Open Layers plugin (see TIP 6). Go 

to Web → OpenLayers plugin → Google Maps → Google Physical.   

 TIP 5: To change the appearance of the layer, right-click the layer in the Layers Panel in lower left and go 

to Properties. Click on Simple fill and edit the appearance or select one of the predefined settings on the 

right. Click OK. 

You can also set labels to show, such as the estimated length of the target in Properties → Labels.  
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 In case this message appears, choose another basemap (e.g. Bing).  

 

We can then enhance the visualization by adding label containing the length of the detected object. 

The length value is stored in “field_12” of the attribute table. Right-click the layer and go to Properties 

→ Labels. Select “Show labels for this layer” and Label with: field_12. 

You can also change the Color. Click OK. 

 

 

 TIP 6: If you do not have the OpenLayers plugin installed you can do so by going to Plugins → Manage 

and Install Plugins. Search for OpenLayers and then click Install.  
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6 Other suggested steps 

6.1 Downloading the outputs from VM and visualization in Google Earth 

We can also visualize the detections in Google Earth by exporting them to KML format.  We can do this 

by right-clicking on the the “ShipDetection_Points.shp” and go to Save as.  

Choose KML format, click on “Browse” and save the layer to the “Processing” folder with the name 

“ShipDetection_Points.kml” (Check CRS is set to EPSG:4326, WGS 84).   

Expand Datasource Options. At the NameField write: “field_12” (contains the length of the targets). 

Click OK. 
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Close the QGIS without saving and then press Ctrl+Alt+Shift. A pop-up window will appear on the left 

side of the screen.  

 

Click on bar below Devices, the folder structure of your VM will appear.  

Navigate to your Processing folder and double click the created KML file “Ship_detection_Trieste.kml” 

to download it to your local computer.  

Once the KML file has been downloaded you can visualize in your local Google Earth installation or 

upload it to Google Earth Web.  
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THANK YOU FOR FOLLOWING THE EXERCISE! 

 

7 Further reading and resources 

Stasolla, M., Fernandez Arguedas, V., Argentieri P., Alvarez, M., Santamaria, C., Greidanus, H. (2015). 

Sentinel-1 Maritime Surveillance. European Commission, Joint Research Centre, Institute for Institute 

for the Protection and Security of the Citizen, doi:10.2788/090400.  

Barale, V. and Gade, M. (2008). Remote Sensing of the European Seas. Springer Science & Business 

Media. doi: 10.1007/978-1-4020-6772-3 
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