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Practical on the Thermal Environment in urban areas 

(with emphasis to the Urban Heat Island) 

Constantinos Cartalis and A. Polydoros 

University of Athens 

 

Exercise 

A. Assessing the thermal environment in Athens and Budapest using satellite images 

with special emphasis given to the surface urban heat island (UHI) 

 

This exercise is a step-by-step guide for the estimation of Land Surface Temperature (LST) 

using the SNAP toolbox as well as Landsat 8 and Sentinel 3 images acquired over Athens 

(Greece) and Budapest (Hungary). Thermal infrared bands are particularly useful for 

assessing the temperature difference between the city and the surrounding rural areas, thus 

assessing the urban heat island phenomenon. The Sea and Land Surface Temperature 

Radiometer (SLSTR) on board Sentinel 3 covers 9 spectral bands (550–12 000 nm), with 

swath widths of 1420 km (nadir) and 750 km (backwards). The Landsat 8 Thermal Infrared 

Sensor (TIRS) provides two adjacent thermal bands (10.6-11.19 and 11.5-12.51 μm).    

Like many metropolitan areas, Athens and Budapest are affected by an Urban Heat Island 

(UHI), which is caused by the large urban areas becoming warmer than the natural rural areas. 

In several cases, the intensity of UHI reaches 4-6 degrees Celsius, whereas intensities of the 

order of 12 degrees Celsius have been also observed. By its nature, concrete, asphalt and 

buildings found in urban areas tend to absorb heat, and a lack of trees as well as other plant 

life prevents natural cooling from occurring.  

It should be mentioned that in terms of the use of TIRS data, a single channel algorithm for 

the LST estimation is applied as based to band 10 of Landsat 8. Although there is a second 

thermal infrared band (band 11), the use of a split-window algorithm is not recommended yet 

due to the calibration uncertainty associated with Band 11 (from 

http://landsat.usgs.gov/calibration_notices.php). More info about LST retrieval methods for 

Landsat 8 can be found in [1]. 

  Calculation steps 

1) Locate the exercise data in your PC (freely available from the U.S. Geological Survey: 

http://earthexplorer.usgs.gov/).  

 C:\....\Data 

The data consists of two folders, one for Athens and one for Budapest. 

 C:\....\Data\Athens 

 C:\....\Data\Budapest 

 

2) Open the SNAP Toolbox and import the Landsat 8 data (choose either Athens or 

Budapest) (Figure 1). 

 File→ Import→ Optical Sensors→ Landsat→ Landsat (Geotiff) 
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Figure 1 

 Select the ….MTL.txt file in the Athens or Budapest folder and click on “Import 

Product” in the dialog box (Figure 2). 

 

Figure 2 
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 Now you have imported your data to SNAP toolbox. In the “Product Explorer” 

window (Figure 3) you can see the metadata files and the bands. Familiarize yourself 

with the toolbox. Double click on any band to open the image data. 

 

 

Figure 4 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 3 

3) Calculation of Normalized Difference Vegetation Index (NDVI) 

The vegetation density can be detected using the reflection values from the red band (Band 4) 

and the infrared band (Band 5). Green vegetation reflects more energy in the near- infrared 

band than in the visible range. Vegetation absorbs more radiation from the red band for the 

photosynthesis process. Leaves reflect less in the near-infrared region when they are stressed, 

diseased or dead. Features like clouds, water and snow show better reflection in the visible 

range then the near-infrared range, while the difference is almost zero for rock and bare soil. 

Values close to zero represent rock and bare soil and negative values represent water, snow 

and clouds. Taking ratio or difference of two bands makes the vegetation growth signal 

differentiated from the background signal. 

 

𝑵𝑫𝑽𝑰 =  
(𝑵𝑰𝑹 –  𝑹𝑬𝑫) 

(𝑵𝑰𝑹 +  𝑹𝑬𝑫)
 

 

The SNAP toolbox automatically converts the Digital Numbers (DN) from the raw Landsat 8 

data to the physical measure of Top of Atmosphere (TOA) radiance (Lλ). To calculate NDVI 

we have to convert radiance to reflectance. 
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Conversion TOA radiance to reflectance for Band 4 (RED) and band 5 (NIR)  

& simple Atmospheric Correction 

 

Calculate the at-surface reflectivity with the following equation: 

ρλ=[π·(Lλ - Lp)·d
2 

/ (ESUNλ·cosθs) 

where: 

ρλ = the surface reflectance, which is “the ratio of reflected versus total power energy”  

Lλ = Spectral radiance  

Lp= the path radiance  

d = Earth-Sun distance in astronomical units (provided with Landsat 8 metadata) 

ESUNλ = Mean solar exo-atmospheric irradiances 

ESUNλ= π·d
2
·RADIANCE_MAXIMUM / REFLECTANCE_MAXIMUM 

θs = Solar zenith angle in degrees, which is equal to θs = 90° - θe where θe is the Sun 

elevation (provided with Landsat 8 metadata) 

The path radiance Lp is the radiance resulted from the interaction of the electromagnetic 

radiance with the atmospheric components and it can be calculated with the following 

equation: 

Lp= Lmin – [0.01·ESUNλ·cosθs/(π·d
2
)] 

Where Lmin is the minimum radiance and it can be estimated from the histogram. (Figure 8). 

 Open the metadata file (e.g. OPEN ATTRIBUTES, MIN – MAX_RADIANCE, MIN-

MAX_REFLECTANCE, etc.) to find the data you need: d, θe, 

RADIANCE_MAXIMUM, REFLECTANCE_MAXIMUM (Figure 4). To calculate 

Lmin open the near_infrared band and select the tab Analysis→Histogram (Figure 5). 

Click on the refresh button, wait for the histogram to appear and finally zoom in the 

left-down corner of the histogram, by pressing left click while drawing a square over 

the preferred area, in order to estimate the value for Lmin  (Figure 6). Repeat this step to 

find the Lmin for the red band. 

 

Figure 4 
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Make sure you click on the refresh button to calculate the histogram 

 

Figure 5 

 

 

Figure 6 
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 Fill out the table for Budapest 

 Athens Budapest 

d 1.017  

θe 66.755  

θs=90-θe 23.245  

cosθs 0.9188  

RADIANCE_MAX Band 4: 585.192   Band 5: 358.108 Band 4: Band 5: 

REFLECTANCE 

_MAX 

Band 4: 1.211  Band 5: 1.211 Band 4: Band 5: 

ESUNλ Band 4:1570.16 Band 5: 960.86 Band 4: Band 5: 

Lmin Band 4: 13.75  Band 5: 4.3 Band 4: Band 5: 

Lp Band 4: 9.31 Band 5: 1.583 Band 4: Band 5: 

 

 Next we will calculate the reflectance for Band 4 (Name the file refl_red). Select 

Raster→ Band maths…→ Edit Expression… (Figure 7). Be careful to uncheck the 

Virtual box. 

 

 

 

Figure 7 
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 Create the equation refl_red=[π·(Lred - Lp)·d
2
 / (ESUNλ·cosθs)  in the Band maths 

Expression Editor (Figure 8). 

 

Figure 8 

 Repeat the above step (using Bands maths) to calculate the reflectance for band 5 

(name it refl_nir ) and then calculate NDVI (using Band maths again) (Figure 9) 

[ Use the following equations: refl_nir=[π·(Lnir - Lp)·d
2 

/ (ESUNλ·cosθs) and 𝑵𝑫𝑽𝑰 =
𝒓𝒆𝒇𝒍_𝒏𝒊𝒓− 𝒓𝒆𝒇𝒍_𝒓𝒆𝒅

𝒓𝒆𝒇𝒍_𝒏𝒊𝒓+𝒓𝒆𝒇𝒍_𝒓𝒆𝒅
 ] 

 

 

Figure 9 
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4) Use NDVI to estimate Land Surface Emissivity (LSE) 

We will use certain NDVI values (NDVI thresholds method from [2]) to distinguish between 

soil pixels (NDVI < NDVIs) and pixels of full vegetation (NDVI > NDVIv).  

For those pixels composed of soil and vegetation (mixed pixels, NDVIs ≤ NDVI ≤ NDVIv), 

the method uses the following simplified equation: 

ελ = εvλPV + εsλ(1 − PV ) + Cλ 

where εv and εs are, respectively, the soil and vegetation emissivities, PV is the proportion of 

vegetation and C is a term which takes into account the cavity effect due to surface roughness 

(C = 0 for flat surfaces). Pv can be obtained from NDVI using the following equation 

Pv = [(NDVI – NDVIs) / (NDVIv-NDVIs)] 
2
 

Values of NDVIv = 0.5 and NDVIs = 0.2 will be used in this exercise. In order to obtain 

consistent values  we set the NDVI value to 0.2 for all pixels with NDVI<0.2 and to 0.5 for all 

pixels with NDVI>0.5. 

LSE will be calculated using the following equations 

i. For NDVI≤ 0.2 : LSEs=0.98-0.042·refl_red 

ii. For 0.2<NDVI<0.5 : LSEmixed=0.971·(1-Pv)+0.987·Pv 

iii. For NDVI≥0.5 : LSEv= 0.99 

 Use the Band Maths to create the new NDVI image (you will need a two steps 

procedure)  

 Create NDVI_2 image by setting the NDVI values to 0.2 for all pixels with 

NDVI<0.2  (Figure 10)  

[Select the “Operators” option and select the “if@ then @ else @” option. Use the 

following expression: if NDVI<0.2 then 0.2 else NDVI] 

 Create NDVI_3 image from the NDVI_2 image by setting the NDVI value to 

0.5 for all pixels with NDVI_2 >0.5  

[use the following expression: if NDVI_2>0.5 then 0.5 else NDVI] 

 

Figure 10 
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 Use the Band Maths to calculate the proportion of vegetation Pv from the NDVI_3 

image (Figure 11) 

[Remember that Pv = [(NDVI – NDVIs) / (NDVIv-NDVIs)] 
2
, so use the following expression: 

 ((NDVI_3-0.2)/0.3)* ((NDVI_3-0.2)/0.3) ] 

 

Figure 11 

 Use the Band maths to create the Land Surface emissivity (LSE) image from the 

NDVI_3 image (you will need a five steps procedure) (Figure 12) 

1. create LSEs image  

[use the following expression: 0.98-0.042*refl_red ] 

 

2. create LSEmixed image 

[use the following expression: 0.971*(1-Pv)+0.987*Pv ] 

 

3. create LSE_1 by replacing the values of NDVI_3 <0.201  with the LSEs values (be 

careful to use 0.201 instead of 0.2) 

[use the following expression: if NDVI_3<0.201 then LSEs else NDVI_3 ] 

 

4. create LSE_2 by replacing the values of LSE_1=0.5  to 0.99  

[use the following expression: if LSE_1==0.5 then 0.99 else LSE_1 ] 

 

5. create LSE by replacing the values of LSE_2<0.5 to LSEmixed  

[use the following expression: if LSE_2<0.5 then LSEmixed else LSE_2 ] 
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Figure 12 

 

5) Land surface temperature (LST) calculation 

The Single Channel algorithm developed by Jiménez-Muñoz et al. [3] retrieves land surface 

temperature (LST) using the following general equation: 

LST= γ·[1/LSE·(ψ1·Lsen + ψ2) + ψ3] + δ 

where LSE is the surface emissivity, and γ (gamma) and δ (delta) are two parameters given by  

γ ≈ 
𝑻𝒔𝒆𝒏

𝟐

𝒃𝜸𝑳𝝀
                δ ≈ 𝑻𝒔𝒆𝒏 −

𝑻𝒔𝒆𝒏
𝟐

𝒃𝜸
 

where Tsen is the at-sensor brightness temperature of the thermal band, bγ = c2/λ (bγ=1324 for 

band 10); and ψ1, ψ2, and ψ3 are the so-called atmospheric functions, given by 

ψ1=
𝟏

𝝉
          ψ2=−𝑳𝒅 −

𝑳𝒖

𝝉
          ψ3=𝑳𝒅 

where τ is the atmospheric transmission, , Lu is the upwelling or atmospheric path radiance, Ld 

is the downwelling or sky radiance. These parameters can be estimated using the Atmospheric 

Correction Parameter Calculator which can be found in: http://atmcorr.gsfc.nasa.gov/. 

 

Using the calculator the following results for Athens and Budapest are obtained for the dates 

of our data: 

Athens 

Date (yyyy-mm-dd):                       2017-06-28 

Input Lat/Long:                              37.980/ 23.730  

GMT Time:                                    9:04 

L8 TIRS Band 10 Spectral Response Curve 

Mid-latitude summer standard atmosphere  

Band average atmospheric transmission:    0.74 

Effective bandpass upwelling radiance:    2.19 W/m^2/sr/μm 

Effective bandpass downwelling radiance:  3.57 W/m^2/sr/μm 
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Budapest 

 

Date (yyyy-mm-dd):                       2017-05-30 

Input Lat/Long:                             47.480/19.030  

GMT Time:                                   9:32 

L8 TIRS Band 10 Spectral Response Curve 

Mid-latitude summer standard atmosphere  

Band average atmospheric transmission:    0.73 

Effective bandpass upwelling radiance:    2.08 W/m^2/sr/μm 

Effective bandpass downwelling radiance:  3.40 W/m^2/sr/μm 

 

The table below provides the ψ1, ψ2 and ψ3 values (use them in your calculations): 

 Athens Budapest 

τ 0.74 0.73 

Lu 2.19 2.08 

Ld 3.57 3.40 

Ψ1 1.3513 1.3698 

Ψ2 -6.53 -6.25 

Ψ3 3.57 3.4 

Conversion to At-Satellite Brightness Temperature 

TIRS band data can be converted from spectral radiance to brightness temperature using the 

thermal constants provided in the metadata file and the following equation: 

𝑇
𝑠𝑒𝑛=

𝑘2

ln (
𝑘1
𝐿𝜆

+1)

 

where:               

Tsen        = At-satellite brightness temperature (K) 

Lλ          = TOA spectral radiance (Watts/( m
2
 * srad * μm)) 

K1          = Band-specific thermal conversion constant from the metadata 

(K1_CONSTANT_BAND_x, where x is the thermal band number) 

K2          = Band-specific thermal conversion constant from the metadata 

(K2_CONSTANT_BAND_x, where x is the thermal band number) 

 Use the Create Band from Math Expressions to calculate LST (you will need a four 

step procedure) 

1.  Create the brightness temperature (name it Tsen ) for band 10 (TIRS_1) 

[Use the expression: 1321.0789/(log((774.8853/’thermal_infrared_(tirs)_1’)+1)). Find the 

log in the “Functions”] (Figure 13). 
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Figure 13 

 

2. Create γ (name it gamma). ( Remember that γ ≈ 
𝑻𝒔𝒆𝒏

𝟐

𝒃𝜸
    )     

[use the following expression: (Tsen*Tsen)/(1324*’thermal_infrared_(tirs)_1’)]  

3. Create δ (name it delta). ( Remember that δ ≈ 𝑻𝒔𝒆𝒏 −
𝑻𝒔𝒆𝒏

𝟐

𝒃𝜸
 ) 

[ use the following expression: Tsen-((Tsen*Tsen)/1324) ] 

 

4.  Create the land surface temperature image (name it LST). (Remember that LST= 

γ·[1/LSE·(ψ1·Lsen + ψ2) + ψ3] + δ) 

[use the following expression: 

 gamma*((1/LSE)*(1.3513*’thermal_infrared_(tirs)_1’-6.53)+3.57)+delta ] 

 

Finally use the colour manipulation tool to colour your LST image (Figure 14). You can 

zoom in your area of interest (Athens or Budapest) (Figure 15). 
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Figure 14 

 

 

Figure 15 
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B. Monitoring the urban heat island of Athens and Budapest with the use of 

Sentinel 3 data 

The Sentinel-3 (S3) mission of ESA is one of the elements of the GMES (Global Monitoring 

for Environment and Security) program, which responds to the requirements for operational 

and near-real-time monitoring of ocean, land and ice surfaces over a period of 20 years. The 

Sentinel-3 mission is designed as a constellation of two identical polar orbiting satellites, 

separated by 180º, for the provision of long-term operational marine and land monitoring 

services. The operational character of this mission implies a high level of availability of the 

data products and fast delivery time, which have been important design drivers for the 

mission. The Sentinel-3A spacecraft was launched on February 16, 2016. 

The satellite, designed for a minimum lifetime of 7 years, is carrying a payload which 

includes: 

 The Sea and Land Surface Temperature Radiometer (SLSTR), with strong heritage 

from AATSR instrument on Envisat, will monitor the impact of climate changes on 

the temperature of our oceans as well as of the emerged land, and improve 

meteorological forecasts by fostering a better understanding of the relationship 

between oceans and the atmosphere. 

SLSTR is a dual scan temperature radiometer, which has been selected for the low Earth orbit 

(800 - 830 km altitude) ESA Sentinel-3 operational mission as a part of the Copernicus 

(Global Monitoring for Environment and Security) programme. The principal objective of 

SLSTR products is to provide global and regional Sea and Land Surface Temperature (SST, 

LST) to a very high level of accuracy (better than 0.3 K for SST) for both climatological and 

meteorological applications.To achieve near-global coverage and meet all scientific 

requirements, Sentinel-3 will be placed in a high-inclination, sun-synchronous polar orbit. 

Near-realtime data processing and delivery will allow operational services to continuously 

profit from the mission. 

In this exercise we will use the SLSTR Level-2 LST product which provides land surface 

parameters generated on the wide 1 km measurement grid. It contains measurement files with 

Land Surface Temperature (LST) values with associated parameters (LST parameters are 

computed and provided for each pixel included in the 1 km measurement grid. It also contains 

data of Normalized Difference Vegetation Index (NDVI), GlobCover surface classification 

code (noted biome), fractional vegetation cover and total column water vapour. 
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Exercise steps 

1) Open the SNAP Toolbox and import the Sentinel 3 data 

 Select File→ Import→ Optical sensors→ Sentinel-3→ Sentinel-3 (Figure 16) 

 

Figure 16 

• Select the first file in the Sentinel 3 folder of Athens (Figure 17), open the 

xfdumanifest.xml file that is inside it and click on “Import Product” in the dialog box (Figure 

18). This image was acquired on 12 July 2017 at 08:42 UTC as it can be extracted from the 

filename “S3A_SL_2_LST__20170712T084222…” so it is suitable for the monitoring of the 

daytime urban heat island. 

 

Figure 17 
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Figure 18 

 Now you have imported the Sentinel 3 data to SNAP toolbox. In the “Product 

Explorer” window you can see the metadata files and the bands. Double click on the 

LST band to open the image data. In the “Pixel info” window you can see that the 

LST is given in Kelvin (Figure 19). Notice the wide spatial coverage of the Sentinel 3 

data compared to the Landsat 8 data. 

 

 
Figure 19 
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2) Next we will reproject the Sentinel 3 data to the coordinates reference system of Landsat 8 

(EPSG:32634) 

 Select Raster→ Geometric Operations→ Reprojection (Figure 20). 

 

Figure 20 

 In the Reprojection window select the Reprojection parameters tab and select the 

“Predefined CRS” option (Figure 21). “Select” the EPSG:32634 by typing the 

number 32634 in the Filter section. In the I/O Parameters tab select a folder to save 

the reprojected data. 

 

Figure 21 
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3) Your reprojected data will appear in the “Product Explorer” window. Open the LST band 

of the new image [indexed as (2)] and zoom in the wider Athens area. Right-click in the 

image and select “Spatial Subset from View…” (Figure 22). 

 

Figure 22 

 

 In the “Specify Product Subset” window select the “Band Subset” tab and select 

only the LST, NDVI, biome and fraction bands (Figure 23). Press “OK” and then 

“NO” in the message that pops up about the flags. 
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Figure 23 

 

 Choose the newly estimated image (named as subset) and use the colour manipulation 

tool to colour your subset image (Figure 24). 

 

Figure 24 
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4) In order to monitor the nighttime urban heat island we should repeat the same steps for the 

nighttime image. To save computational time we have already processed the nighttime image. 

You can open it by selecting File→ Open Product and opening the file 

“subset_Athens_night.dim” that you will find in the Athens→ Sentinel 3 folder of your data 

(Figure 25). 

 

Figure 25 

5) Colour your nighttime image and compare the LST distribution of the daytime and 

nighttime data.  

In addition you can find a subset daytime image of the LST of Budapest in the Budapest→ 

Sentinel 3 folder (Unfortunately no nighttime cloud free image of Budapest was available 

during the development of this tutorial). 
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