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Instructions for practical
Summary

The Urban Mapping Practical introduces students to the practical work with remote sensing data from
urban areas. Students work with Sentinel-2 data from Berlin, Germany, and detailed reference
information on urban vegetation and impervious cover. At first, the limited potential of the traditional
normalized difference vegetation index (NDVI) to predict vegetation cover accurately is explored by
statistical measures and scatter plots. Students will then generate quantitative vegetation maps using
the full spectral information in a machine learning regression approach. Afterwards, the complementary
cover type impervious will be mapped. Students gain a deeper insight into the value of Sentinel-2’s
spectral characteristics for mapping urban environments and into machine learning for empirical
mapping

Data sets

The Sentinel-2 data set Berlin_Sentinel-2_image.bsq was downloaded and pre-processed using Sen2Cor.
The provided product consists of bottom-of-atmosphere reflectance data. It is in a 20 m raster in UTM
projection, GCS WGS-84 date/spheroid. Upper left corner is 377115 E, 5831335.350 N in UTM 33N. The
data includes 9 spectral bands at 490 nm, 560 nm, 665 nm, 705 nm, 740 nm, 783 nm, 865 nm, 1610 nm,
2190 nm. The 60 m resolution bands at 443 nm, 945 nm, and 1375 nm as well as the 10 m near infrared
band have been removed. Pixel size is 20 m for all remaining bands, after aggregating the 10 m red,
green and blue bands to the spatial resolution of the 20 m bands. Data is stored in an ENVI style band
sequential file format with header file.

Reference information on vegetation cover and impervious cover fractions per pixel is provided. The
reference information is based on overlaying layers from the municipal urban environmental atlas and
the cadaster. Afterwards, soil surfaces were manually digitized from very high resolution ortho-
photographs. In Berlin_Sentinel-2_vegetation_reference.bsq tree and low vegetation cover fractions are
summed into a single vegetation value and aggregated to Sentinel-2 resolution. Information on built-up
and non built-up impervious surfaces are provided in Berlin_Sentinel-2_impervious_reference.bsq. (For
possible individual work, the tree and low vegetation bands are also provided).

A binary mask exists for the reference data sets, Berlin_Sentinel-2_reference_mask.bsq, which is needed
when generating training and validation samples.

Furthermore, layers for stratifying the reference data are provided, i.e. Berlin_Sentinel-
2_vegetation_reference_strata.bsq and Berlin_Sentinel-2_impervious_reference_strata.bsq. These
include 7 classes for 0%, < 20%, < 40%, < 60%, < 80%, < 100%, 100% vegetation/impervious cover
fractions.
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First steps

Analysis is performed in the EnMAP-Box [1], a freely available software package for the analysis of
spectral image data that is being developed as part of the EnMAP mission preparation activities [2,3].
Among other machine learning methods the EnMAP-Box offers the imageSVM suite for support vector
based image analysis.

Start the EnMAP-Box by double clicking the EnMAP-Box.exe from D3P2b\EnMAP-Box\. After answering
to two splash screens, you will see the single-frame graphical user interface (GUI) of the EnNMAP-Box. In
order to visualize Sentinel-2 data from Berlin select File > Open > Open all images in directory and
navigate to the Berlin Sentinel-2 directory of the D3P2b session. Six image data sets will be loaded to the
File list frame.

Move the Sentinel-2 image into the large data frame to the right (drag-n-drop) and the image will be
displayed in a false color composite together with a 9 band spectral preview for the currently selected
pixel (red cross). Use the left, center and right mouse buttons as well as the mouse wheel to explore the
handling of image data in the EnMAP-Box. The context menu (right-click) offers all functionality for
visualization, e.g. to select displayed bands. In order to hide the overview and spectral preview, click into
the image and press “o” and “p”.

Initialize a second image frame right of your current frame by using the second icon at the top of the
main panel. Display the vegetation reference in this frame. Link both frames using the second last icon at
the top of the main panel. Select both images for linking Zooming and Position. Zoom into an area with
high tree fractions. Your screen should look similar to this screenshot:

" EnMAP-Box2.11 o)==
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53 images
-\, Berin_Sentinel-2_image bsq o
Map: 386662.22, 5617493 52
Data: 2503, 1574, 664
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Explore urban vegetation cover

The probably most common feature to analyze vegetation is the NDVI as a normalized difference
between the red (665 nm) and near infrared (around 865 nm). To calculate the NDVI use the imageMath
tool (Applications > imageMath Calculator). Type ((1.0*b1)-b2)/(b1+b2) and hit “=". You are
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then asked to specify the Sentinel image and the respective spectral bands. Please select the band 7 nIR
and band 3 red and select Berlin_Sentinel_NDVI as filename to store the file in the Berlin_Sentinel-2
directory.

Initialize a third image frame and display the NDVI calculation. (Please note that the vegetation
reference only covers selected polygons along the nadir line, while the NDVI is calculated for the full
image area and shows grey values where the reference appears black. This may be confusing!)

Use Tools > Scatter Plot to visualize the relation between the vegetation reference (x) and NDVI (y).
Choose both files in the respective order and select the mask to avoid areas without reference
information. Use Draw in the next window. Inspect the resulting plot and discuss ranges and scattering
of NDVI values. Use the respective button to transfer the plot into an HTML report and keep it for later
discussions.

Repeat the previous step using the impervious reference and compare both scatter plots.

Discussion:

How well does the NDVI correlate with vegetation fractions?

How are impervious surfaces related to NDVI?

How are the reference points distributed over the range from 0 to 1°?

Model vegetation fraction with support vector regression (SVR)

In order to use the full spectral information (instead of a single band or index) a support vector
regression is performed. At first, you need to generate training and validation data from the reference
file. Therefore, select Tools > Random sampling and select Berlin_Sentinel-2_vegetation_reference.bsq
and Berlin_Sentinel-2_ vegetation_reference_strata.bsq for stratification, followed by Accept. The
stratification with seven intervals ensures that the entire range of reference values gains similar weights.
In the following dialogue, select Equalized Sampling and enter 100 points to create subset of the original
data. Then, check Complement to store the remaining reference data for independent validation and set
useful filenames to store the data in the Berlin_Sentinel-2 directory. Accept.

Before generating a map, the SVR model must be parameterized: based on the training data and internal
cross validation a range of possible parameter pairs for the SVR is tested and the best performing
parameters are used to train the final model. Select Applications > Regression > imageSVM regression >
Parameterize SV regression. Then select the Sentinel-2 image and the 100-point-per interval sample set
from the reference data. We will not use the Advanced options to change the parameter search. Store
the model as Berlin_Sentinel-2_vegetation.svr in the Berlin_Sentinel-2 directory. Apply. The model
training may take a couple of minutes.

When the training process is over you will see an HTML report, showing the cross validation error (mean
absolute error for hold-out sample) for all tested parameter pairs of the grid search. When you are
satisfied with the training error, you may choose to apply the model to the full image. Specify the
filename (Berlin_Sentinel-2_vegetation_prediction.svr) for the estimate and select the directory. YES.
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After a short time, the SVR based vegetation map will appear in the file list. When displayed and
compared to the NDVI image, both may look quite similar at first sight. Detailed analysis shows
differences, though, especially concerning the data range.

To get a better idea of the map quality you will now perform a quantitative accuracy assessment. Select
Applications > Accuracy Assessment > Regression and insert the name of the regression estimate and
the sample complement for validation (reference pixel complement from training data). Soon, an HTML-
report with the following information will appear:

Performance metrics

Metric Abbr. Value
Mumber of sample pairs n 13405
Mean absolute error MAE | 0.122915861
Mean squared error MSE | 0.022181772
Raot mean squared error RMSE | 0.14393546
Pearson correlation r 0.90
Squared pearson correlation | 12 0.81
Mash-Sutcliffe efficiency NSE | 0.77

Histogram settings
Axis Bins Min Max
X - Reference | 256 | 0.00000000 | 1.0000000
Y - Estimation | 256 | 0.040270537 | 0.85941574

Discussion:

Present your statistical accuracy assessment to the group. What do single measures mean?
Why do different groups have differing results?

How do you judge the quality of the map?

Where do you see problems? (Related to map; related to accuracy assessment)

How do you judge the quality of the Sentinel-2 data set for the exercise?

Model fraction impervious cover with support vector regression (SVR)

Repeat all steps from the previous exercise to generate a complementary map for the impervious
fraction using the Berlin_Sentinel-2_impervious_reference.bsq reference data set.

Start with random sampling and remember to give new file names to avoid overwriting existing results.

Now perform the model parameterization. Again, inspect the result from the training step in the first
HTML report that appears. Please write down the values for gamma (g) and C that are used for the final
SVR model. Now repeat the model parameterization. This time we use the advanced options (button at
the bottom) to perform a denser grid search. So change the multiplier to 4, while adjusting both
min/max values closer to the present values for g and C. Compare the cross validation error of both
trainings. Do they differ? How about the selected model parameters g and C?
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This time, proceed by selecting yes when asked to apply the model.

To assess the quality of results, repeat the accuracy assessment as done before, yet selecting the
impervious validation data, i.e. the complement of the 100 reference pixels. Make sure you change the
default filenames, which still show the files from vegetation and not tree estimates and reference.
Compare the scatter plot to that from the previous assessment. How would you rate the new result?
How do the MAE and r? differ?

Display the original image and the two model results.

Discussion:

Are model accuracies comparable for vegetation and impervious?

Do the two maps show the complementarity of the mapped surface types?
How can you assess, where they do not constitute complements?

For fast people

1) The accuracy assessment is biased towards 0 and 1-values. To avoid this, you may draw and equalized
sample from the current complement set of reference points. Select for example 300 points per stratum
and repeat the assessment. How do the measures develop?

2) Repeat the previous impervious mapping using an imageRF random forest regression with default
parameters.
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Summary of achievements

During the present course you have learned how to use the EnMAP-Box for image visualization, band
arithmetic and support vector regression. You have gotten to know urban Sentinel-2 data from Berlin,
Germany. You have got insights into the parameterization of support vector machines. Based on the
discussion of results you have learned about the relevance of vegetation and impervious surfaces in
urban areas.
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