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1 Introduction 

The Research and User Support for Sentinel core products (RUS) service provides a free and open 

scalable platform in a powerful computing environment, hosting a suite of open source toolboxes 

pre-installed on virtual machines, to handle and process data derived from the Copernicus Sentinel 

satellites constellation. 

The health of the forests around the world is 

declining due to climate change, air pollution 

and increase in human activities. Remote 

sensing has been considered an important 

tool for wide coverage monitoring of forested 

areas.  

Some of the most commonly used techniques 

include calculation of various Vegetation 

Indices (VIs) from optical data (such as 

Sentinel-2 or -3). The VIs are generally 

calculated as a combination of surface 

reflectance at two or more wavelengths; they 

are designed to highlight certain property of 

the vegetation (Tuominen et al. 2009).  

In many areas of the world, the use of the optical data is limited due to persistent cloud cover and 

SAR sensors are employed to monitor the changes in vegetation or increase the frequency of the 

observations. The characteristics of optical and SAR sensors are very different and require different 

processing steps. In this exercise, we will look at both and see how they can help us assess the 

damage caused by a bark beetle infestation in Jeseníky foothills in the northeast of Czech Republic. 

2 Training 

Approximate duration of this training session is two hours.  

2.1 Data used 

• Three Sentinel-1A IW GRDH products acquired in May 2016, 2017 and 2018 [downloadable @ 

https://scihub.copernicus.eu/] 

S1A_IW_GRDH_1SDV_20180514T050109_20180514T050134_021896_025D35_E395 

S1A_IW_GRDH_1SDV_20170519T050103_20170519T050128_016646_01BA02_07F0  

S1A_IW_GRDH_1SDV_20160524T050046_20160524T050111_011396_01152F_FED2 

• One cloud-free Sentinel-2A Level-1C product acquired on 24 May 2016 [downloadable @ 

https://scihub.copernicus.eu/] 

S2A_OPER_PRD_MSIL1C_PDMC_20160523T143616_R079_V20160523T095404_20160523T095404 

• One cloud-free Sentinel-2A Level-2A tile (Tile ID: T33UXR) acquired on 13 May 2018 

[downloadable @ https://scihub.copernicus.eu/] 

S2A_MSIL2A_20180513T095031_N0207_R079_T33UXR_20180513T115612 

Forests destroyed by bark beetle infestation, Credits: silvarium.cz 

https://scihub.copernicus.eu/
https://scihub.copernicus.eu/
https://scihub.copernicus.eu/
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/shared/Training/TAT0618_Forestry_S1S2S3_TutorialKit 

Code 

Sentinel-3 

Processing 

S3A_OL_2_LFR____20160523T093911_20160523T094211_20180213T011706_0179_004_250_2160_LR2_R_NT_002  

S3A_OL_1_EFR____20160523T093911_20160523T094211_20180213T012820_0179_004_250_2160_LR2_R_NT_002  

Original 

Subset_projected_S3A_OL_1_EFR____20160523T093911.dim 

Subset_projected_S3A_OL_2_LFR____20160523T093911.dim  

Auxdata AOI_Sentinel3_WGS84.shp 

AOI_UTM33.shp 

Moravskoslezky_kraj_CZE_UTM33.shp 

clc12_cz_forest_subset_UTM33_dis.shp 

Expressions.txt 

S2_diff_colour_palette.cpd 

S3_veg_index.cpd 

Original Sentinel-1 

Processing 

S1A_IW_GRDH_1SDV_20180514T050109_20180514T050134_021896_025D35_E395.zip 
 

S1A_IW_GRDH_1SDV_20170519T050103_20170519T050128_016646_01BA02_07F0.zip 
 

S1A_IW_GRDH_1SDV_20160524T050046_20160524T050111_011396_01152F_FED2.zip 
 

Sentinel-2 

Processing 

S2A_OPER_PRD_MSIL1C_PDMC_20160523T143616_R079_V20160523T095404_20160523T095404  

S2A_MSIL2A_20180513T095031_N0207_R079_T33UXR_20180513T115612.zip 
 

Original 

Subset_S2A_MSIL2A_20180513T095031_N0207_R079_T33UXR_20180513T115612_resampled.dim 
 

Subset_S2A_SAFL2A_20160523T143616_R079_T33UXR_V20160523T095404_resampled.dim 
 

Graph_VIs_Calculation.xml 

Sentinel_Preprocessing_sim.ipynb 

• Two partly cloud-free Sentinel-3A OLCI products (Level-1 EFR and Level-2 LFR) acquired on 13 

May 2018 [downloadable @ https://scihub.copernicus.eu/s3] 

S3A_OL_2_LFR____20160523T093911_20160523T094211_20180213T011706_0179_004_250_2160_LR2_R_NT_002 

S3A_OL_1_EFR____20160523T093911_20160523T094211_20180213T012820_0179_004_250_2160_LR2_R_NT_002 

2.2 Software in RUS environment 

Internet browser, SNAP + Sentinel-1 and -2 Toolbox, QGIS (Extra steps: Sen2Cor, Google Earth) 

2.3 Contents of the Exercise folder 

 

 

  

  

https://scihub.copernicus.eu/s3
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3 Step by step  

3.1 SAR data – Sentinel-1 

3.1.1 SNAP – open and explore data 

Launch SNAP (icon on desktop ). When the SNAP window opens click Open product , navigate 

to /shared/Training/TAT0618_Forestry_S1S2S3_TutorialKit/Sentinel-1/Original and open the three S1 

products. Right-click the product from 2018 and expand the Bands folder. Then, double click the 

Intensity_VV band (for data download, see section 4.1 Data download). 

 

3.1.2 Build step-by step processing chain 

We will now need to pre-process all three images but doing this one-by-one would be quite time 

consuming. Luckily, we can use the Batch Processing tool available in SNAP to process all three 

images at the same time.  
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To use the tool, we first need to define the process we want to apply and all its steps. We can do this 

using the GraphBuilder tool. The advantage of the GraphBuilder is that no intermediate product will 

be physically saved, only the end product, which saves valuable disk space.  

Go to Tools -> GraphBuilder. At the moment, the graph only has two operators: Read (to read the 

input) and Write (to write the output).  

Since our Area of Interest (AOI) is quite small and there is no need to process the whole image, we 

start by adding a Subset operator. To add the operator right-click the white space in the graph 

builder and go to Add -> Raster -> Geometric -> Subset. 

A new operator rectangle appears in our graph and a new tab appears below. Now, connect the new 

Subset operator to the Read operator by clicking to the right side of the Read operator and dragging 

the red arrow towards the Subset. 

 

In the next step, we will update the orbit metadata (See  NOTE 1). To add the operator, right-click 

the white space between existing operators and go to Add -> Radar -> Apply-Orbit-File. Connect the 

new Apply-Orbit-File operator with the Subset operator. 

 

 

The next step will remove the thermal noise (See  NOTE 2). We do this by right-clicking the white 

space somewhere left of the resample operator and going to Add -> Radar -> Radiometric -> 

ThermalNoiseRemoval. Connect the ThermalNoiseRemoval operator with the Apply-Orbit-File 

operator.  

 

Now, we can add the Calibration operator. The objective of SAR calibration is to provide imagery in 

which the pixel values can be directly related to the radar backscatter. Though uncalibrated SAR 

imagery is sufficient for qualitative use, calibrated SAR images are essential to quantitative use of 

SAR data (See  NOTE 3). To add the operator go to Add -> Radar -> Radiometric -> Calibration. 

Connect the ThermalNoiseRemoval operator to the Calibration operator. 

 NOTE 1: The orbit state vectors provided in the metadata of a SAR product are generally not accurate 

and can be refined with the precise orbit files, which are available days-to-weeks after the generation 

of the product. The orbit file provides accurate satellite position and velocity information. Based on this 

information, the orbit state vectors in the abstract metadata of the product are updated. (SNAP Help) 

 NOTE 2: Thermal noise in SAR imagery is the background energy that is generated by the receiver itself.   

(SNAP Help) It skews the radar reflectivity to towards higher values and hampers the precision of radar 

reflectivity estimates. Level-1 products provide a noise LUT for each measurement dataset, provided in 

linear power, which can be used to remove the noise from the product. 
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SAR images have inherent salt and pepper like texturing called speckle, which degrade the quality of 

the image and make interpretation of features more difficult (See  NOTE 4). To reduce the speckle 

effect and smooth the image we apply speckle filter. To add the operator, go to Radar -> Speckle 

Filtering -> Speckle-Filter then connect the Calibration operator to it. 

 

Our data are still in radar geometry, moreover due to topographical variations of a scene and the tilt 

of the satellite sensor, the distances can be distorted in the SAR images. Therefore, as the last step of 

our pre-processing, we will apply terrain correction to compensate for the distortions and reproject 

the scene to geographic projection (See  NOTE 5). To add the operator, go to Radar -> Geometric -

> Terrain Correction -> Terrain-Correction then connect the Calibration operator to it. At last, 

connect the Terrain-Correction to Write operator. 

 

 

At the moment, do not change anything in the parameter tabs and save the graph as 

Graph_preprocess.xml to:  

/shared/Training/TAT0618_Forestry_S1S2S3_TutorialKit/Sentinel-1/Processing by clicking Save at the 

bottom of the window.  

3.1.3 OPTION 1 - Batch processing in GUI 

In the Product Explorer, we select (highlight) the product with index [1]. Now, we can close the 

GraphBuilder window and open the Batch Processing tool (Tools -> Batch Processing). 

We will add the opened products by clicking Add Opened on the upper right (second icon from the 

top) and click refresh. Then, we click Load Graph at the bottom of the window, navigate to our saved 

 NOTE 3: Typical SAR data processing, which produces level-1 images, does not include radiometric 

corrections and significant radiometric bias remains. The radiometric correction is necessary for the 

pixel values to truly represent the radar backscatter of the reflecting surface and therefore for 

comparison of SAR images acquired with different sensors, or acquired from the same sensor but at 

different times, in different modes, or processed by different processors. (SNAP Help) 

 NOTE 4: Speckle is caused by random constructive and destructive interference of the de-phased but 

coherent return waves scattered by the elementary scatters within each resolution cell. Speckle noise 

reduction can be applied by either spatial filtering or multilook processing. (SNAP Help) 

NOTE 5: The geometry of topographical distortions in SAR 

imagery is shown on the right.  Here we can see that point 

B with elevation h above the ellipsoid is imaged at position 

B’ in SAR image, though its real position is B".  The offset Δr 

between B' and B" exhibits the effect of topographic 

distortions. (SNAP Help) 
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graph, and open it. We see that new tabs have appeared at the top of window corresponding to our 

operators with the exception of Write; this is correct, as these parameters will be set in the I/O 

Parameters tab.  

In the I/O Parameters tab set directory to:    

/shared/Training/TAT0618_Forestry_S1S2S3_TutorialKit/Sentinel-1/Processing.  

  

Now, let’s set the parameters. In the Subset tab, press Shift and select bands Amplitude_VV and 

Intensity_VV then click to select the Geographic Coordinates option and paste the area of interest 

definition in WKT (well know text) format to the text window below the map.  

 

 

Click Update and then click the Zoom-in icon  to see your subset on the map.  

POLYGON ((17.27494 50.27427, 17.52966 50.26901, 17.52134 50.11134, 

17.26746 50.11658, 17.27494 50.27427)) 

TIP: All expressions you will be using during this tutorial are available to copy-paste from the 

Expressions.txt file in /shared/Training/TAT0618_Forestry_S1S2S3_TutorialKit/Auxdata 
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In Apply-Orbit-File tab, we can accept the default settings. In the ThermalNoiseRemoval tab select 

VH polarization and make sure that “Remove Thermal Noise” option is selected. 

 

In the Calibration tab we will also accept all default settings.   

  

In the Speckle Filter tab,  set:  

Filter: Gamma Map 

Filter size X: 5 

Filter Size Y: 5  
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In the Terrain-Correction tab set: 

Image Resampling Method -> Nearest Neighbour.  

Map Projection -> Custom CRS: UTM Zone -> Click on Projection Parameters… Set Zone to 33.  

Leave all the other default settings.  

 

Finally, click Run to pre-process our images.  

Approximate processing time: 3 minutes depending on machine 

Now, you should have three new products in the Product Explorer. Select the original products [1-3], 

right-click and click Close 3 Products. 

3.1.4 OPTION 2 - Batch processing in using GPT and Python (Jupyter Notebook) 

To use this method we must first prepare graph template file, where all parameters will be pre-set 

except the input and output file path and name. The Graph Builder window should still be open or 

we can reopen it and load the Graph_preprocess.xml file we have saved in the previous step. Now, 
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we will set all the processing parameters in the tabs below the graph. For the parameters - Subset, 

Apply Orbit File, ThermalNoiseRemoval, Calibration and Terrain Correction - see the section above. 

Leave the Read and Write tabs unchanged.  

Save the graph (Save button at the bottom of the window) with filled in parameters as 

Graph_preprocess_template.xml to: 

/shared/Training/TAT0618_Forestry_S1S2S3_TutorialKit/Sentinel-1/Processing 

Then, in the file explorer, (outside SNAP) navigate to the folder and right-click on the saved file. 

Select Open with -> Open with “Mousepad”. When the file is open, go to View -> Line Numbers for 

easier navigation.  

Now, we need to replace the input and output file path with a pattern that will allow the python 

code to recognize and replace it within the template file before processing.  

In line 7 (in the node with id=’Read’) replace the path to input file with (between <file> and </file>): 

$InputFile  

 

In line 127 (in the node with id=’Write’) replace the path to output file with (between <file> and 

</file>):  $OutputFile  

 

Save the file and close it. Then go to the Desktop and open the Jupyter Notebook application. A 

command line terminal will open and then a Firefox browser window will open with a home folder 

directory. In the browser, navigate to   /shared/Training/TAT0618_Forestry_S1S2S3_TutorialKit/Code 

and double click the Sentinel_Preprocessing_sim.ipynb to open it.  
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In section 1. Import Packages and set I/O Parameters (first cell), all the necessary inputs are defined. 

The parameters have been predefined for you but you should check them again to make sure and to 

understand them better.  

SNAP GPT path – do not change this parameter it provides the code with the path to the GPT 

installation.  

 

Directory with input products - path to the directory where the downloaded Sentinel-1 products are 

placed.  

 

Path to the graph template XML file we have edited 

 

Our input folder only contains zipped S1 products; therefore, the filter pattern is not strictly 

necessary. It is used to filer files, which should be processed. We can also define the prefix and/or 

suffix to add to the original file name.  

Now we can run the process. Click on the In [1] (or around it but not inside the cell), a blue line will 

appear next to the cell then click Shift+Enter to execute the cell (See  TIP). 

 

If the cell was executed successfully a “Done!” will be printed below it and the next cell will be 

highlighted.  

gpt_path = "/usr/local/snap6/bin/gpt"   

 

original_dir = "/shared/Training/TAT0618_Forestry_S1S2S3_TutorialKit/Sentinel-1/Processing"   

 

graph_file_path = "/shared/Training/TAT0618_Forestry_S1S2S3_TutorialKit/Sentinel-1/Processing 

/Graph_preprocess_template.xml"   

 

      TIP: Check the available keyboard shortcuts. You can find them in Help -> Keyboard Shortcuts.  
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Press the Shift+Enter again to move to the next code cell. The second code cell (2. Define Sub-

functions) contains sub-functions necessary to run the process. Do not change anything and press 

Shift+Enter to execute the cell and again to move the highlight to the last code cell. The last cell (3. 

Process data) is responsible for processing the data. Again, do not change anything and press 

Shift+Enter.  

 

All the files in the Original folder will be processed one-by-one. You can monitor the process in the 

Terminal. When all the input files are processed, “Finished!” will be printed below the cell.  

Go back to the SNAP window and open the processed products. Select the original products [1-3], 

right-click and click Close 3 Products.   

3.1.5 Coregistration 

Now, we need to add all our pre-processed products to a single coregistered stack so we can visualize 

the changes in backscatter. Unfortunately, coregistration is rather heavy and time consuming, so be 

patient.  
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Go to Radar -> Coregistration. We will add the opened products by clicking Add Opened on the 

upper right (second icon from the top) and click Refresh. Use the arrows to order products by date 

from 2018 to 2016.  

  

In the CreateStack tab, set Resampling Type as Nearest Neighbour and set Output Extents to 

Minimum. 

 

In the Cross-Correlation and Warp tabs, leave the defaults.  

In Write tab, change the name to S1A_IW_May2016_2018_Stack and make sure that the output 

directory is: /shared/Training/TAT0618_Forestry_S1S2S3_TutorialKit/Sentinel-1/Processing  

 

Click Run. Approximate processing time: 3.5 minutes depending on machine 
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A new product [7] has appeared in the Product Explorer. Expand it and have look at the contents of 

the Bands folder. It contains three bands each corresponding to one acquisition date. Double click 

the first band to open it in View.  

 

We have selected the first subset larger than our final subset (marked in green above) because we 

have applied it before the terrain correction in order to minimize processing time. However, to 

ensure the exact extent that we want, we should only perform the subset after the terrain correction 

when the data are converted from the SAR geometry to a geographic projection. Above you can see 

the final AOI indicated in green. We will use a simple subset again to acquire or final AOI. Go to 

Raster -> Subset.  

In the Spatial Subset tab click on the Geo Coordinates and set: 

North latitude bound: 50.26272 

West longitude bound: 17.29581 

South latitude bound: 50.12339 

East longitude bound: 17.49995 

Click OK. New product [8] has appeared in the product explorer. Right-click the product and go to 

Open RGB Image Window.  

Set:  Red:      $8.Sigma0_VV_mst_14May2018 

         Green:  $8.Sigma0_VV_slv1_19May2017 

         Blue:     $8.Sigma0_VV_slv2_24May2016 
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3.1.6 Conversion to dB and mask 

To enhance the contrast, let us convert the data to decibel. Go to Raster -> Data Conversion -> 

Convert bands to/from dB. Set the source to the subset product with index number [8] and output 

Directory: /shared/Training/TAT0618_Forestry_S1S2S3_TutorialKit/Sentinel-1/Processing 

Leave the other default parameters and click Run. A new product [9] was created. Open RGB view of 

the newly created product.  

 

Next, we need to assign the NoData value. Go to Raster -> Data Conversion -> Set No-Data Value. 

Select  No Data Value Used, and set No Data Value to 0.0. Click yes to Overwrite the existing file.  

In Product Explorer, click on the last product [9] to highlight it, then go to Vector -> Import -> ESRI 

Shapefile. Navigate to /shared/Training/TAT0618_Forestry_S1S2S3_TutorialKit/Auxdata and open 

the clc12_cz_forest_subset_UTM33_dis.shp.  
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A vector overlay appeared over the view; we could edit the appearance by going to Layer Manager 

(on the left side panel or in View -> Tool Windows). In the Layer Manager, expand the Vector data 

folder and select clc12_cz_forest_subset_UTM33_dis and click on   Layer Editor.  

 

The vector layer presents forest areas. It was derived from the Corine Land Cover 2012 for Czech 

Republic (provided by the CENIA - Czech Environmental Information Agency) by aggregating classes 

311 to 313. The RGB composite is a good indicator of forest damage – change in backscatter. Let us 

mask the out the non-forest areas and save the layer as GeoTIFF so we can inspect it in QGIS over 

aerial orthophoto. Go to Raster -> Masks -> Land/Water Mask.  

In the I/O Parameters, set: Save as: GeoTIFF.  

In the Processing Parameters, tab set: Use Vector as Mask. Then click Run.  

 

3.1.7 Visualization (QGIS) and comparison 

Let’s inspect the product in QGIS. Go to Application -> Processing -> QGIS Desktop. Click on the Add 

Raster Layer button located in the left panel ( ), navigate to:  
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/shared/Training/TAT0618_Forestry_S1S2S3_TutorialKit/Sentinel-1/Processing select the saved 

Subset_S1A_IW_May2016_2018_Stack_dB_msk.tif and click Open.  

Right-click the Subset_S1A_IW_May2016_2018_Stack_dB_msk in the Layers Panel and then go to 

Properties - in the Transparency tab set:  Additional no data value: 0 

  

 

Disturbed areas appear in bluish colours. In this case, the method cannot be confidently used to 

delineate the structurally damaged areas but can serve as an indicator of the locations (See  TIP).  

 

TIP: The orthophoto can be added to your QGIS project as WMS service provided by the Czech 

National Geoportal INSPIRE. In the Browser Panel, scroll down and right-click at the WMS. Go to 

New Connection… In the Connection details set:  

Name: Orthophoto_2016 

URL: http://geoportal.cuzk.cz/WMS_ORTOFOTO_PUB/WMService.aspx  

Click OK. Then add another WMS with  

Name: Archive_orthophoto 

URL: http://geoportal.cuzk.cz/WMS_ORTOFOTO_ARCHIV/WMService.asp? 

   

 

 

 

http://geoportal.cuzk.cz/WMS_ORTOFOTO_PUB/WMService.aspx
http://geoportal.cuzk.cz/WMS_ORTOFOTO_ARCHIV/WMService.asp?
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3.2 Optical data – Sentinel-2 MSI 

3.2.1 SNAP – open and explore data 

Launch SNAP (icon on desktop ). When the SNAP window opens click Open product , navigate 

to:   /shared/Training/TAT0618_Forestry_S1S2S3_TutorialKit/Sentinel-2/Original 

Open the S2 product from 2018. Then open the Level-2A product from 2016 by navigating inside the 

folder to GRANULE/S2A_USER_MSI_L2A_TL_MPS__20160523T133345_A004795_T33UXR_N02.00 

and selecting the .xml file (see  NOTE 6). 

 

Right-click the product and click Open RGB image window, a new window will open. From the drop 

down menu select:  

Profile: Sentinel 2 MSI Natural Colors 

Investigate the change visually in areas indicated by purple ellipses below.  

 

3.2.2 Resample & subset 

To avoid processing the datasets one by one we will use the Batch processing and Graph Builder 

again. Go to Tools -> GraphBuilder. At the moment, the graph only has two operators: Read (to read 

the input) and Write (to write the output).  

The 13 bands in Sentinel-2 products do not all have the same resolution (= size, see  NOTE 7). 

Many operators in SNAP toolbox do not support products with bands of different sizes, so first we 

need to resample the bands to equal resolution. Right-click on the white space between the 

operators and go to Add -> Raster -> Geometric -> Resample (See  NOTE 8).  

 NOTE 6: The product from 2016 we have downloaded is a Level-1C product - not atmospherically 

corrected (for data download, see section 4.1 Data download). Before opening the product in SNAP we 

will run the atmospheric correction using the Sen2Cor algorithm. The steps are described in section 4.2 

Atmospheric correction for S2.  
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Then, we need to subset our data to our area of interest (AOI). Go to Add -> Raster -> Geometric -> 

Subset. Then right-click again and go to Connect Graph.   

 

 

Save the graph to /shared/Training/TAT0618_Forestry_S1S2S3_TutorialKit/Sentinel-2/Processing 

Go to Tools -> Batch Processing. We will add the opened products by clicking Add Opened on the 

upper right (second icon from the top) and click refresh. Then, we click Load Graph at the bottom of 

the window, navigate to our saved graph, and open it. We see that new tabs have appeared at the 

top of window corresponding to our operators with the exception of Write; this is correct, as these 

parameters will be set in the I/O Parameters tab.   

 

Credits: ESA 2015 

NOTE 7: The input product 

contains 13 spectral bands 

in three different spatial 

resolutions (The surface 

area measured on the 

ground and represented by 

an individual pixel). When 

we open the RGB view all 

our input bands have 20 m 

resolution, however, the 

view is displayed in the full 

10 m resolution.  

 NOTE 8: The resampling product appears in the Product explorer but it is not physically saved. 

Therefore, it will be lost if you close it or if you close the source product. 
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Se the target Directory to:  

/shared/Training/TAT0618_Forestry_S1S2S3_TutorialKit/Sentinel-2/Processing 

In the Resample tab, set: Define size of resampled product:  

By reference band from source product: B2  

 

In the Subset tab, click to select the Geographic Coordinates option and paste the area of interest 

definition in WKT (well know text) format to the text window below the map.  

 

Click Update and then click the Zoom-in icon  to see your subset on the map.  

 

POLYGON ((17.29581 50.26272, 17.50702 50.25835, 17.49995 50.12339, 

17.28933 50.12773, 17.29581 50.26272)) 
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Click Run. Two new products will appear in your Products Explorer tab. Now close the two original 

products [1] and [2]. 

3.2.3 Cloud cover 

First, let’s investigate the cloud cover bands that are generated as a by-product of atmospheric 

correction applied to the Level-2A products. Expand the product in the Product Explorer and go to 

Masks -> scl. Open masks scl_cloud_high_proba (pixels with high cloud probability) and 

scl_thin_cirrus (thin cirrus clouds). 

Now you should have four bands open. Go to Window -> Tile Evenly and then go to the Navigation 

tab, click Zoom All . We can see that as expected our image is cloudless.  

 

3.2.4 Vegetation indices (VIs) 

Vegetation indices are usually an arithmetic combination of surface reflectance at two or more 

wavelengths, designed to highlight a particular property of the vegetation.  Below you will find a list 

of selected VIs. Select two VIs that you find most interesting/relevant plus NDVI.  

S-2 Band 1 2 3 4 5 6 7 8 8A 9 10 11 12 

Central 
wavelength (nm) 

443 490 560 665 705 740 783 842 865 945 1375 1610 2190 

Bandwidth (nm) 20 65 35 30 15 15 20 115 20 20 30 90 180 

Spatial res. (m) 60 10 10 10 20 20 20 10 20 60 60 20 20 

Name Equation (Sentinel-2 bands) Notes 

NDVI (Rouse 
1974) 

𝑁𝐼𝑅842 − 𝑅𝑒𝑑665

𝑁𝐼𝑅78842 + 𝑅𝑒𝑑665

=  
𝐵8 − 𝐵4

𝐵8 + 𝐵4
 

The Normalized Difference Vegetation Index algorithms 
exploit the strength and the vitality of the vegetation on 
the earth's surface. Indicates amount of vegetation, 
distinguishes veg from soil and minimizes topographic 
effects. 
Range: -1 to 1 
Values: A zero means no vegetation and close to +1 (0.8 
- 0.9) indicates the highest possible density of green 
leaves. 



 

23 
 

RVI (Blackburn 
1998) 

𝑁𝐼𝑅842

𝑅𝑒𝑑665

=  
𝐵8

𝐵4
 

The Ratio Vegetation Index algorithm is the simplest 
ratio-based one. The simplest ratio-based index is also 
called the Simple Ratio (SR or PSSR). Indicates amount 
of vegetation and reduces the effects of atmosphere 
and topography. 
Values: high values for vegetation, low for soil, ice, 
water, etc.     

TNDVI (Baret 
and Guyot 1991) 

√
𝑁𝐼𝑅842 − 𝑅𝑒𝑑665

𝑁𝐼𝑅842 + 𝑅𝑒𝑑665

+ 0.5 

=  √
𝐵8 − 𝐵4

𝐵8 + 𝐵4
+ 0.5 

The Transformed Normalized Difference Vegetation 
Index algorithm indicates the amount of green biomass 
that is found in a pixel. TNDVI is the square root of the 
NDVI. 
It has higher coefficient of determination for the same 
variable. The formula of TNDVI has always-positive 
values and the variances of the ratio are proportional to 
mean values.  

NDVI45 
(Delegido et al. 
2011) 

𝑅𝑒𝑑705 − 𝑅𝑒𝑑665

𝑅𝑒𝑑705 + 𝑅𝑒𝑑665

=
𝐵5 − 𝐵4

𝐵5 + 𝐵4
 

The Normalized Difference Index 45 algorithm is linear, 
with less saturation at higher values than the NDVI. 
Specifically designed for Sentinel-2 data.  
Range: -1 to 1 

MTCI (Dash and 
Curran 2004) 

𝑁𝐼𝑅740 − 𝑅𝑒𝑑705

𝑅𝑒𝑑705 −  𝑅𝑒𝑑665

=
𝐵6 − 𝐵5

𝐵5 − 𝐵4
 

The Meris Terrestrial Chlorophyll Index algorithm was 
developed for estimating chlorophyll content from 
MERIS (Medium Resolution Imaging Spectrometer) 
data. 

The MTCI aims at estimating the Red Edge Position 
(REP) - the maximum slant point in the red and NIR 
region of the vegetation spectral reflectance. 
It is useful for observing the chlorophyll contents, 
vegetation senescence, and stress for water and 
nutritional deficiencies, but it is less suitable for land 
classification.  

IRECI (Clevers 
1988) 

𝑁𝐼𝑅783 − 𝑅𝑒𝑑665

𝑅𝑒𝑑705/ 𝑁𝐼𝑅740

=  
𝐵7 − 𝐵4

𝐵5/𝐵6
 

The Inverted Red-Edge Chlorophyll Index algorithm 
incorporates the reflectance in four bands to estimate 
canopy chlorophyll content.  

MCARI 
(Daughtry et al. 
2000) 

[(𝑅𝑒𝑑705 − 𝑅𝑒𝑑665) −  0.2 ∗
(𝑅𝑒𝑑705 − 𝐺560) ] ∗

 (𝑅𝑒𝑑705 − 𝑅𝑒𝑑665) = 
[(𝐵5 −  𝐵4) −  0.2 ∗

(𝐵5 −  𝐵3) ] ∗  (𝐵5 − 𝐵4) 

The Modified Chlorophyll Absorption Ratio Index 
algorithm was developed to be responsive to 
chlorophyll variation. This algorithm is responsive to 
both leaf chlorophyll concentrations and ground 
reflectance.  

GNDVI (Gitelson, 
Kaufman, and 
Merzlyak 1996) 

𝑅𝑒𝑑783 − 𝐺560

𝑅𝑒𝑑783 + 𝐺560

=
𝐵7 − 𝐵3

𝐵7 + 𝐵3
 

The Green Normalized Difference Vegetation Index 
algorithm was developed to be more sensitive than 
NDVI to identify chlorophyll concentration, which is 
highly correlated with nitrogen. 
The use of green spectral band was more efficient than 
the red spectral band to discriminate nitrogen.  
Range: -1 to 1 

S2REP 
(Frampton et al. 
2013) 

705 + 35 ∗ (
(

𝑁𝐼𝑅783 + 𝑅𝑒𝑑665

2
) − 𝑅𝑒𝑑705

𝑁𝐼𝑅740 −  𝑅𝑒𝑑705

) 

=  705 + 35 ∗ (
(

𝐵7 + 𝐵4
2

) −  𝐵5

𝐵6 −   𝐵5
) 

The Sentinel-2 Red-Edge Position Index algorithm is 
based on linear interpolation. Red edge, as the 
inflection point of the strong red absorption to near 
infrared reflectance, includes the information of both 
chlorophyll content (Nitrogen) and growth status. 

Now we will use a graph that has been provided for you in the Processing folder - 

Graph_Vis_Calculation.xml.  
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In Step 1, we import vector forest mask to mask out all non-forest areas. The vector layer has been 

created based on the Corine Land Cover 2012 for Czech Republic (provided by the CENIA - Czech 

Environmental Information Agency) by aggregating classes 311 to 313.  

In Step 2, we use the BandMaths to calculate three VIs (NDVI + two selected VIs).  

Then in Step 3, we use the BandMerge to merge the calculated VI bands to single output product.  

To use the graph, go to Tools -> Batch Processing. We will add the opened products by clicking Add 

Opened on the upper right (second icon from the top) and click refresh.  

Then, deselect the  Keep source product name! 

Next, click Load Graph at the bottom of the window; navigate to 

/shared/Training/TAT0618_Forestry_S1S2S3_TutorialKit/Sentinel-2/Processing/ and open 

Graph_VIs_Calculation.xml. We see that new tabs have appeared at the top of the window 

corresponding to our operators.  

 

In the Import-Vector tab, go to /shared/Training/TAT0618_Forestry_S1S2S3_TutorialKit/Auxdata and 

open clc12_cz_forest_subset_UTM33_dis.shp. In the first BandMaths tab, set following parameters: 

Target Band: NDVI 

No-Data Value: NaN 

1 2 3 
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Expression:  

 

Repeat the same for the next two BandMaths tabs with your selected VIs.  

Target Band: <name> 

No-Data Value: NaN 

Expression:  

 

In the Write tab, set the target Directory to:  

/shared/Training/TAT0618_Forestry_S1S2S3_TutorialKit/Sentinel-2/Processing 

 

Click Run. Two products will be created and added in the Product Explorer. Now, click on the + sign 

to expand the product in the Product Explorer, go to the Vector Data and delete the 

clc12_cz_forest_subset_UTM33_dis_1. Do the same for the second product.  

Open the Bands folder and explore the calculated VI bands.  

TIP: All expressions you will be using during this tutorial are available to copy-paste from the 

Expressions.txt file in /shared/Training/TAT0618_Forestry_S1S2S3_TutorialKit/Auxdata. 

if clc12_cz_forest_subset_UTM33_dis_1 then (B8 - B4)/(B8 + B4) else NaN  

if clc12_cz_forest_subset_UTM33_dis_1 then <equation> else NaN  
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3.2.5 Collocation  

Now, we will use the collocation tool to add both products to a single one in order to calculate the 

change in the NDVI (and other VIs). Go to Raster -> Geometric Operations -> Collocation. In the 

menu that appears, in the Source Products set the VI product from 2018 as Master and the product 

from 2016 as a Slave. In the Target Products: 

Name:  S2A_May2016_2018_<names of the VIs>  

Format: GeoTIFF 

Directory: /shared/Training/TAT0618_Forestry_S1S2S3_TutorialKit/Sentinel-2/Processing 

In the Renaming of Source Product Components section:  

Rename master components: replace “M” with “2018” 

Rename slave components: replace “S” with “2016” 

  

Click Run.  
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3.2.6 Calculate change between 2016 and 2018 and visualize 

A new product with index number [5] was added to the Product Explorer containing all the 

calculated VIs for 2016 and 2018. Now we can use the BandMath operator to calculate the change. 

Right-click the product and select Band Math … and for each VI calculate the difference between 

2018 and 2016. Set: 

Name: <VI name>_2018_2016 

Deselect Virtual as we want our calculated bands to be physically saved.  

 

Investigate the difference bands. In the Colour Manipulation tab, click  Import colour pallete 

from text file. Navigate to: /shared/Training/TAT0618_Forestry_S1S2S3_TutorialKit/Auxdata and 

open S2_diff_colour_palette.cpd. In the next dialogue click No (Do not distribute from min to max) 

for NDVI (select Yes for other VIs).  

 

Compare your results from the three VIs. Do you see differences? What are they? Can you explain 

them based on what you know about the indices? Right-click on the product and click Save Product 

to save our changes and calculated bands.   
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3.3 Optical data – Sentinel-3 OLCI 

3.3.1 SNAP – open and explore data 

Re-Launch SNAP (icon on desktop ). When the SNAP window opens, click Open product , 

navigate to:   /shared/Training/TAT0618_Forestry_S1S2S3_TutorialKit/Sentinel-3/Processing  

Open both .dim files. We have two products, Level-1 and Level-2 from 23 May 2016 (See  NOTE 9). 

Both have already been reprojected and subset to the area of the administrative region 

Moravskoslezký Kraj (for details see section 4.3 Sentinel-3 OLCI pre-processing steps). Unfortunately, 

it was not possible to find a cloudless image for 2018 (before May 15, 2018) and therefore, we will 

only have a look at the situation in 2016.  

 

First, let’s open the RGB View of the Level-1 product. Right-click the product and select Open RGB 

Image Window and set: 

Red: Oa09_radiance (673.75 nm) 

Green: Oa06_radiance (560 nm) 

Blue: Oa04_radiance (490 nm) 

 

 

 

 

 NOTE 9: Level-1 products include Top-Of-Atmosphere (TOA) radiometric measurements, radiometrically 

corrected, calibrated and spectrally characterised. It is quality controlled, ortho-geolocated (latitude and 

longitude coordinates, altitude) and annotated with satellite position and pointing, landmarks and 

preliminary pixel classification (e.g. land/water/cloud masks). Products are generated in FR (300 m) and 

in RR (1.2 km) for the whole globe with the same coverage (ESA, 2018). 

Level-2 products consist of geophysical quantities derived from the processing of measurement data 

provided in the Level-1 product. Level-2 products specifically for marine and land application domains 

are generated separately by the SENTINEL-3 PDGS, with each containing the parameter relevant for the 

specific field of application (Land/Water). Level-2 atmospheric information relevant for both application 

domains, such as water vapour, is reported in both types (ESA, 2018). 

https://sentinels.copernicus.eu/web/sentinel/user-guides/sentinel-3-olci/processing-levels/level-1
https://sentinels.copernicus.eu/web/sentinel/user-guides/sentinel-3-olci/processing-levels/level-2
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The Level-1 data are not atmospherically corrected and at this moment, no atmospheric correction 

for S3 data is available in SNAP. We can see cirrus contamination in our scene, which can severely 

distort the calculation of VI indices for our location. Luckily, the Level-2 Land processing product (LFR) 

is available (for general Level-2 product description see  NOTE 9). 

In the LFR, product includes following parameters calculated from the radiometrically, geometrically 

and atmospherically corrected data:  

 OLCI Global Vegetation Index – OGVI (See  NOTE 10) 

 Rectified reflectances at 681 and 685 nm - RC681, RC865 

 OLCI Terrestrial Chlorophyll Index - OTCI (See  NOTE 11) 

 

𝑁𝐼𝑅753 − 𝑅𝑒𝑑709

𝑅𝑒𝑑709 − 𝑅𝑒𝑑681

=
𝐵12 − 𝐵11

𝐵11 − 𝐵10
 

 NOTE 10: OGVI - Before computing the OLCI Global Vegetation Index (OGVI), a spectral test is 

performed on every land pixel to flag any pixels that are not vegetated. On vegetated pixels, the OGVI is 

estimated in two steps. The information contained in the blue band at 443 nm is combined with the 

information in the bands at 681 and 865 nm, traditionally used to monitor vegetation, to generate 

"rectified channels" at these latter two wavelengths. The OGVI has been optimised to assess the 

presence on the ground of healthy, live, green vegetation. The optimisation procedure has been 

constrained to provide an estimate of the Fraction of Absorbed Photosynthetically Active Radiation 

(FAPAR) in the plant canopy, although the index is expected to be used in a wide range of applications - 

(ESA, 2018). 

 NOTE 11: OTCI - The OLCI Terrestrial Chlorophyll Index (OTCI) is produced globally at 300 m spatial 

resolution for land from OLCI data on the SENTINEL-3 mission and is designed to be a continuation of 

the MERIS Terrestrial Chlorophyll Index derived from MERIS data. The ENVISAT MERIS Terrestrial 

Chlorophyll Index (MTCI) was designed to monitor vegetation condition through an estimation of 

chlorophyll content using reflectance in the red edge region of the reflectance spectra. The use of red 

shift allows the MTCI product to remain responsive to high chlorophyll content, which would saturate 

conventional vegetation indices. The OTCI is a chlorophyll index similar to the MTCI (ESA, 2018). 
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Expand the Level-2 product in Product Explorer and go to Bands -> OTCI to open the view. We can 

enhance the view by going to the Colour Manipulation tab and loading a colour palette (  Import 

colour pallete from text file) S3_veg_index.cpd  from:  

/shared/Training/TAT0618_Forestry_S1S2S3_TutorialKit/Auxdata  

We can use the Colour Manipulation -> Table menu to adapt the values to better represent our data. 

For example, stretch the values from 1 to 3.5 by 0.5 steps as seen below.  

 

We could do many more things with these data. For example, we could create time series to see how 

the index values in the area changed over the last years (since the availability of S3 OLCI LFR data) 

but we could also look at previous MERIS Level-2 data, which would extend our time series to 2001.  

 

 

 

 

THANK YOU FOR FOLLOWING THE EXERCISE!  
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4 Extra steps 

4.1 Data download 

4.1.1 ESA SciHUB – Sentinel-1 and -2 

In this step, we will download a Sentinel-2 scene from the Copernicus Open Access Hub using the 

online interface (Applications -> Network -> Web Browser, or click the link below). 

Go to https://scihub.copernicus.eu/   

 

Go to Open HUB, if you do not have an account please register in upper right corner. 

 

After you’ve filled in the registration form, you will receive an activation link by e-mail. Once your 

account is activated or if you already have an account, log in.  

https://scihub.copernicus.eu/
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Switch the rectangle-drawing mode to pan mode by clicking on the ‘Pan’ icon in the lower left corner 

of the map (Green arrow) and navigate over Portugal (approximate area – blue rectangle). 

 

Switch to drawing mode and draw a search rectangle approximately as indicated below north of the 

town of Bruntál. Open the search menu (red arrow) and specify the following parameters: 

Sensing period:  From 2016/05/24 to 2018/05/14 

Check Mission:   Sentinel-1  

Satellite Platform: S1A* 

Product Type:   GRD 

Sensor Mode:   IW  

Relative Orbit:   124 
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In our case, the search returns 61 results depending on the exact search area defined. Search 

through the results for datasets from following dates (14 May 2018, 19 May 2017 and 24 May 2016): 

S1A_IW_GRDH_1SDV_20180514T050109_20180514T050134_021896_025D35_E395 

S1A_IW_GRDH_1SDV_20170519T050103_20170519T050128_016646_01BA02_07F0  

S1A_IW_GRDH_1SDV_20160524T050046_20160524T050111_011396_01152F_FED2 

You can also identify them by the unique product code – above in blue. 

Then open the search menu again and reset the parameters as defined below, do not forget to 

deselect Mission: Sentinel-1 as this time we will search for Sentinel-2 data (See  TIP): 

Sensing period:  From 2016/05/23 to 2016/05/23 

Check Mission:   Sentinel-2  

 

TIP: For 2016, only Level-1C products are available and we will have to perform atmospheric 

correction – pre-processing of Level-1C product to a Level-2A is described in section 4.1. For 2018, 

the Level-2A products are available and the atmospheric correction has already been applied. 

Since April 2017, the Level-2A products have been operationally generated and are available to 

download for acquisitions over Europe.  
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In our case, the search returns single result. Using the icon, import the following product to Cart:  

S2A_OPER_PRD_MSIL1C_PDMC_20160523T143616_R079_V20160523T095404_20160523T095404 

Go back to the search and set following parameters find the S2 product from May 2018: 

Sensing period:  From 2018/05/13 to 2018/05/13 

Check Mission:   Sentinel-2  

Satellite Platform:  S2A_*  

Product Type:   S2MSI2A  

Again a single product was found for our criteria, using the icon, import the following product to 

Cart:  S2A_MSIL2A_20180513T095031_N0207_R079_T33UXR_20180513T115612 

Once all our S1 and S2 data are in the cart, click on the Profile icon in the upper left corner (marked 

with green circle above) and go to Cart. You should now have five products in your cart. Click 

Download Cart.  

 

A products.meta4 file will be downloaded to your /home/rus folder. To download our data we will 

use aria2 tool. To use the tool, we first need to place the products.meta4 file to the folder where we 

wish our data to be downloaded to:  /shared/ TAT0618_Forestry_S1S2S3_TutorialKit/ 
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First, let’s test our aria2 installation. To do this we open the Command Line  (in the bottom of 

your desktop window) and type: 

 

The correct response should be as follows: 

 

 If the response is “-bash aria2c: command not found” (see  NOTE E1). 

 

If you have received the correct response then we can run the tool by typing following commands in 

the command line (replace <username> and <password> with your login credentials for Copernicus 

Open Access Hub):  

 

The first line changes our directory to the target directory. The second line runs the download tool 

(Type the red text all in single line). All six products will be downloaded to the Original folder two 

products in parallel automatically (Note that the constraint of maximum two parallel downloads at a 

time is imposed by the Copernicus Access Hub, if you increase the number the download will fail). 

This might take some time.  

Once they are downloaded, move the products to the appropriate folder. The three Sentinel-1 

products should be moved to: 

/shared/TAT0618_Forestry_S1S2S3_TutorialKit/Sentinel-1/Original  

The two Sentinel-2 products should be moved to:  

/shared/TAT0618_Forestry_S1S2S3_TutorialKit/Sentinel-2/Original 

4.1.2 ESA Sentinel-3 Pre-Operations Data Hub 

The Sentinel-3 OLCI data cannot be downloaded from the Copernicus Open Access Hub now of 

preparation of this tutorial, they are available only from the Sentinel-3 Pre-Operations Data Hub. It 

can be navigated the same way as the Copernicus Open Access Hub. You can login using the 

credentials provided on top of the login window (username: s3guest; password: s3guest). 

aria2c 

 NOTE E1: If (and only if) the response is “-bash aria2c: command not found”. Then we have to install the 

tool, to do this in command line type: sudo apt-get install aria2 

When requested type: Y 

Then you can test you installation again.  

cd /shared/Training/TAT0618_Forestry_S1S2S3_TutorialKit/ 

 

aria2c --http-user='<username>' --http-passwd='<password>' --check-

certificate=false --max-concurrent-downloads=2 -M products.meta4 
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Go back to the search and set following parameters: 

Sensing period:  From 2016/05/23 to 2016/05/23 

Check Mission:   Sentinel-3  

Instrument:   OLCI  

 

 

 

 

No cart is available in the Pre-Operations hub so we have to download the products manually.  

S3A_OL_2_LFR____20160523T093911_20160523T094211_20180213T011706_0179_004_250_2160_LR2_R_NT_002 

S3A_OL_1_EFR____20160523T093911_20160523T094211_20180213T012820_0179_004_250_2160_LR2_R_NT_002 

When downloaded move the products from /home/rus to: /shared/ 

TAT0618_Forestry_S1S2S3_TutorialKit/Sentinel-3/Original 
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4.2 Atmospheric correction for S2 

Solar radiation reflected by the Earth’s surface to satellite sensors is affected by its interaction with 

the atmosphere. The objective of applying an atmospheric correction is to determine true surface 

(Bottom-Of-Atmosphere, BOA) reflectance values from the Top-Of-Atmosphere (TOA) reflectance 

values, by removing atmospheric effects. (See  NOTE E2) Atmospheric correction is especially 

important in cases where multi-temporal images are compared and analysed as it is in our case (pre-

fire and post-fire images).(Mousivand et al. 2015)  

 

In this tutorial, we will use the Sen2Cor processor. Sen2Cor is a processor for Sentinel-2 Level-2A 

product generation and formatting; it performs the atmospheric, terrain and cirrus correction of Top-

Of-Atmosphere Level-1C input data. Sen2Cor creates Bottom-Of-Atmosphere, optionally terrain and 

cirrus corrected reflectance images; additional, Aerosol Optical Thickness, Water Vapour, Scene 

Classification Maps and Quality Indicators for cloud and snow probabilities.  

We can run the algorithm in two ways: in the SNAP GUI or in the command line. In this tutorial, we 

will use the command line. You can also run the process on a single tile or on the whole product (if 

the product is not cut to tiles). We will run the process on full product. 

First, we need to unzip the Level-1C product in the Original folder. Then we test our Sen2Cor 

installation, to do this we open the Command Line  (in the bottom of your desktop window) and 

type: 

 NOTE E2: The radiance reaching the sensor is a result of following components: 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1.  Radiation from the sun and, scattered into the field 

of view of the sensor by the atmosphere without 

reaching the surface. 

2. Direct radiation that goes through the atmosphere 

without being absorbed or scattered, reaches the 

sensor after being reflected by the target pixel. 

3. Radiation scattered by the atmosphere into the 

target pixel and reflected back towards the sensor. 

 4. & 5. Direct or diffuse radiation reflected or scattered by 

the surrounding areas into the field of view of the sensor. 

This effect is so called “adjacency effect” or “blurring 

effect”. 

6. Diffuse radiation coming from the adjacent features into 

the field of view of the sensor.  

7. So-called trapping effect and it is a part of the radiation 

reflected from the surface into the air column above the 

surface being scattered and ultimately reaches the sensor.  

Credits: Mousivand et al., 2015
1
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The correct response should be as follows: 

 

If you have received the correct response, then we can run the tool by typing following commands in 

the command line: 

 

The first line changes our directory to the input directory. The second line runs the tool on the 

defined product in the input directory (Type the red text all in single line). 

The process creates new Level-2A product in the .SAFE format in the input directory:  

/shared/ TAT0618_Forestry_S1S2S3_TutorialKit/Sentinel-2/Original  

The process can be very time consuming – several hours if run on full product. You can also run the 

product on a single tile by navigating to the GRANULE folder inside the input product directory.  

We are using the tile T33UXR therefore; the command would then be as follows: 

 

The process creates new Level-2A product in the SAFE format in the input GRANULE directory inside 

the original product. It is recommended to move the created folder out of the original product 

directory to the main input folder. 

4.3 Sentinel-3 OLCI pre-processing steps 

First, we need to unzip the two products we have downloaded. Then we launch SNAP (icon on 

desktop ). When the SNAP window opens, click Open product , navigate to:   

/shared/Training/TAT0618_Forestry_S1S2S3_TutorialKit/Sentinel-3/Original. 

Open the S3 OLCI products one by one by going inside the unzipped folder and opening the 

xfdumanifest.xml file. Both products are derived from the same acquisition; therefore they have the 

same extent and geometry. Go to Product Explorer, right click the Level-1 product, and open RGB 

view. We can accept the default Profile: OLCI L1 – Tristimulus 

L2A_Process 

cd /shared/TAT0618_Forestry_S1S2S3_TutorialKit/Sentinel-2/Original 

 

L2A_Process 

S2A_OPER_PRD_MSIL1C_PDMC_20160523T143616_R079_V20160523T095404_20160523T095404.SA

FE  

cd /shared/TAT0618_Forestry_S1S2S3_TutorialKit/Sentinel-2/Original/ 

S2A_OPER_PRD_MSIL1C_PDMC_20160523T143616_R079_V20160523T095404_20160523T095404.SA

FE/GRANULE/ 

 

L2A_Process S2A_USER_MSI_L2A_TL_MPS__20160523T133345_A004795_T33UXR_N02.00 
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The swath width of the product is 1270 km, which makes the OLCI the ideal tool for monitoring 

regional to global scale. For our purposes, we will subset the data to the administrative region in the 

east of Czech Republic. We will also reproject the data to WGS84 UTM Zone 33 projection.  

To avoid processing the datasets one by one, we will use the Batch processing and Graph Builder 

again. Go to Tools -> GraphBuilder. At the moment, the graph only has two operators: Read (to read 

the input) and Write (to write the output).  

First, we will reproject the data. Right-click on the white space between the operators and go to Add 

-> Raster -> Geometric -> Reproject. Then we need to subset our data to our area of interest (AOI). 

Go to Add -> Raster -> Geometric -> Subset.   

Our area of interest is within the boundaries of the region, the subset produces a rectangular output. 

For this reason, we will also use a vector mask to mask out areas outside the region boundaries. First, 

we need to import the vector layer (Add -> Vector -> Import Vector) and then, use the Land-Sea-

Mask operator. Finally, right-click again and go to Connect Graph.   

 

Save the graph to /shared/Training/TAT0618_Forestry_S1S2S3_TutorialKit/Sentinel-3/Processing 

Go to Tools -> Batch Processing. We will add the opened products by clicking Add Opened on the 

upper right (second icon from the top) and click refresh.  

Then, deselect the  Keep source product name! 

Click Load Graph at the bottom of the window, navigate to our saved graph, and open it. We see that 

new tabs have appeared at the top of window corresponding to our operators. 
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In the Reproject tab, set Coordinate Reference System (CSR) -> Custom CRS -> Projection to UTM 

Zone. In Projection Parameters set Zone 33 North.   

 

In the Subset tab, click to select the Geographic Coordinates option and paste the area of interest 

definition in WKT (well know text) format to the text window below the map (you can copy the WKT 

from Expressions.txt in the Auxdata folder).  
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Click Update and then click the Zoom-in icon  to see your subset on the map.  

 

In the Import-Vector tab, go to /shared/Training/TAT0618_Forestry_S1S2S3_TutorialKit/Auxdata and 

the Moravskoslezky_kraj_CZE_UTM33.shp.  

In the Land-Sea-Mask tab, set Use Vector as Mask, the imported vector will automatically be 

selected as the mask.  

Lastly, in the Write tab, set the Directory to: 

/shared/Training/TAT0618_Forestry_S1S2S3_TutorialKit/Sentinel-3/Processing 

Click Run. Two new products will appear in your Products Explorer tab. Now close the two original 

products [1] and [2]. 

4.4 Downloading the outputs from VM 

On your keyboard, press Ctrl+Alt+Shift. A pop-up window will appear on the left side of the screen. 

Click on the bar below Devices, the folder structure of your VM will appear. Navigate to your 

Processing folder and double click any file you want to download.  

POLYGON ((17.12653 49.42411, 17.16711 50.33883, 18.91914 50.29293, 

18.84590 49.37966, 17.12653 49.42411)) 
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