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Exercise 1: Generate high resolution binary and fractional snow maps from 

Sentinel-2 data over the Alps 

The daily generation of hemispheric or global snow cover extent products is usually based on 

medium resolution optical satellite data, such as Sentinel-3 SLSTR/OLCI, Terra/Aqua MODIS or 

NPP VIIRS. For assessing the quality of these products, snow maps generated from high 

resolution optical satellite data, as available from Sentinel-2 MSI or Landsat 8 OLI, can be used. 

In this exercise, you will generate binary and fractional snow cover products from a Sentinel-

2 scene over the Alps acquired on 29th April 2016. You will test two approaches, both based 

on the Normalized Difference Snow Index (NDSI): 

𝑁𝐷𝑆𝐼 =  
𝜌(𝑉𝐼𝑆) −  𝜌(𝑆𝑊𝐼𝑅)

𝜌(𝑉𝐼𝑆) +  𝜌(𝑆𝑊𝐼𝑅)
 

ρ = Top of atmosphere reflectance 

VIS = Visible band (0.56 µm) 

SWIR = Short-Wave Infrared Band (1.6 µm) 

A binary snow classification (snow / no snow) can be performed by the approach after Dozier 

and Painter (2004), applying thresholds on the NDSI and a Near Infrared band (NIR, e.g. 0.842 

µm): 

IF NDSI > 0.40 AND ρ(NIR) > 0.11 THEN snow in open land 

IF 0.1 < NDSI < 0.4 THEN snow in forest 

In forested areas, this approach aims on detecting the snow on ground. Use the treecover 

mask providing tree canopy cover in per cent scaled between 0 and 100 and consider all pixels 

with more than 25% tree cover as forest to discriminate forested areas and open land. 

Fractional snow cover (FSC, 0 % - 100% snow) can be detected by the approach of Salomonson 

and Appel (2004, 2006), which was originally developed for MODIS data: 

FSC = –0.01 + 1.45 * NDSI 

In forested areas, this approach aims on detecting the viewable snow, i.e. the snow on top of 

the forest canopy. 
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1. Get an overview on the region and the data base 

1.1 In the input data directory of Exercise1_Optical, unzip the Sentinel-2 raw data set 

1.2 In the directory S2A_OPER_PRD_MSIL1C_PDMC_20160429T214911_R022_V20160429 

T101028_20160429T101028.SAFE, have a look on the preview (S2A[..].png).  

1.3 Enter the directory GRANULE. Here, you find multiple subdirectories, including the Sentinel-2 

data split into tiles of about 100 km x 100 km. Each tile is uniquely identified by 6 characters, in 

the form “TXXYYY”, with TXX identifying the UTM zone, and YYY representing the grid ID giving 

the location of the tile. For this exercise, focus on the tiles TPT and TPS in UTM zone 32. Enter 

the directory of one of these tiles and browse through the sub-directories to make yourself 

familiar with the data. 

2. Analyse spectral profiles of different surface classes using QGIS 

2.1 Start QGIS, and load the bands B03 (0.56 µm, VIS), B08 (0.84 µm, NIR) and B11 (1.6 µm, SWIR) 

of the tile T32TPT as raster layers for the test site Alps (Main Menu → Layer  → Add Layer → 

Add Raster Layer → navigate to the input data directory and select the data set → Open) 

2.2 To display the images in the correct map projection, right click on one of the layers and select 

“Set Project CRS from Layer”. 

2.3 Stretch the minimum and maximum value ranges in all cases between 0 and 10000 and use the 

Contrast enhancement “Stretch to MinMax” (double left click or right click on one layer → 

Properties).  

TIP: When you have completed the correct display characteristics for one layer and want to 

apply exactly the same style on another layer, right click on the adjusted layer → Styles → Copy 

Style; then right click on the other layer → Styles → Paste Style. You can also paste the same 

style on multiple other layers if needed, by pressing the shift key during selection of multiple 

layers, then right click on one of the selected layers → Paste Style. 

2.4 Get familiar with the spectral signatures of different bands (VIS, NIR, SWIR) over different 

surface classes (forest, open water, cities, cultivated land, grassland) and over snow and clouds.  

a) Enable the “Value tool” to see the pixel values of all activated layers at the current mouse 

position. 

b) Use the Profile tool (Terrain Profile) in Plugins to get the spectral top of atmosphere 

reflectance for the green (0.56 µm), the near infrared band (0.84 µm) and the shortwave 

infrared band (1.6 µm) along temporary polylines and save the resulting profiles as figures 

(.PNG). Double click on the colour in the layer list of the profile tool to change the colour of 

the layer showing the reflectance along the polyline in the profile display.  

OPTIONAL: If you are unsure about the surface, use the GDAL command Merge in the Main 

Menu Processing → Toolbox → GDAL/OGR → [GDAL] Miscellaneous → Merge: Select all 

layers as input, have a look on the order of the listed input files as in this order the bands are 

written to the output file, activate the box “Place each input file into a separate band”, and 

optionally save the merged data into an output file to be created (include the order of the 

bands in the file name!). Load the generated output as multi-layer image using the false 

colour RGB composite 11/8/3. 

3. Get an impression on the overall snow conditions on 29 April 2016 over Europe and 

import and prepare the Sentinel-2 datasets in SNAP: 

3.1 Get a first overview of the snow and cloud conditions on the 29 April 2016 over Europe using 

true- and false colour composite previews from MODIS data in the auxiliary data directory (open 

with any standard graphic viewer program):  
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RGB123_0.005deg_201604290650_201604291155_MOD_panEU_ENVEOV2.1.00.jpeg and 

RGB651_0.005deg_201604290650_201604291155_MOD_panEU_ENVEOV2.1.00.jpeg 

3.2 Start SNAP and import the Sentinel-2 data set and the land classification map: Sentinel-2 data 

set: File → Import → Optical Sensor → Sentinel-2 → S2 MSI L1C → Navigate to the S2 directory 

in the input data directory (S2A_OPER_PRD_MSIL1C_PDMC_20160429T214911_R022_ 

V20160429T101028_20160429T101028.SAFE) and select the XML file (S2A_OPER_MTD_ 

SAFL1C_PDMC_20160429T214911_R022_V20160429T101028_20160429T101028.xml). The 

Sentinel-2 scene extends over two UTM zones. When importing the data, a pop-up window 

appears and you can select one UTM zone. Select the UTM zone 32N. 

3.3 Open the file structure of the Sentinel-2 scene by double left click on the scene name. Click on 

the menu Metadata, double click on Level-1C_User_Product and get familiar with the basic 

information associated to the data set. Find the spectral information for the bands needed for 

the snow mapping approaches: physical band numbers, resolution (pixel size). 

4. Resample the SWIR (1.6 µm) band to the pixel size of the VIS bands, create spatial and 

spectral subsets and calculate the NDSI in SNAP 

4.1 In the main SNAP menu, select Optical → Geometric → S2 Resampling Processor 

Define the Processing Parameters, using 10 m as output resolution. Do NOT save the output file, 

i.e. in the I/O Parameters tab, disable the box “Safe as:”. The loaded data set includes the full 

scene (~ 8 GB raw input data!), which would take way too long for saving this file. 

4.2 Click on the resampled main layer name, go to the main SNAP menu, select Raster → Subset…: 

Create a subset with the following settings (please use exactly this spatial subset, otherwise the 

snow map processing with the provided auxiliary data will fail in SNAP!):  

• Spatial subset: Scene start X: 10980, Scene start Y: 10980, Scene end X: 21959, Scene end Y: 

30977 

• Band subset (each in a separate file!): B03, B08, B11 

4.3 Save the created subsets in the BEAM format: Right click on created layer → Save Product As… 

→ Confirm that the file should be saved in the BEAM format → adapt the file name to be saved 

and/or change to the directory to be used for storing the data as needed and click on Save. 

4.4 In the main SNAP menu, select Raster → Band Maths (unlock the box “Virtual”) 

From the created subsets, calculate the NDSI using the 1.6 µm and the 0.56 µm bands and save 

the output. 

5. Generate and compare the binary and fractional snow maps from the Sentinel-2 scene 

5.1 Import the required auxiliary data: File → Import → Generic Formats → GeoTIFF → Navigate to 

auxiliary data directory and select the following files: 

• Hansen_GFC2013_water_land_mask_Alps_subset_UTM32WGS84_10m.tif 

• Treecover2010_Alps_subset_UTM32WGS84_10m.tif 

5.2 Calculate the binary snow map using the approach of Dozier and Painter and use the land/water 

mask (Hansen_GFC2013_water_land_mask_[…].tif, LWM) to exclude water bodies from the 

classification (land = 1, water = 2), and the forest canopy mask (Treecover2010_[…].tif, TC) to 

differentiate the snow classification for open land and forested areas (TC > 25): 

Main Menu → Raster → Band Maths… (unlock the band “Virtual”, define output layer name):  

For the method after Dozier and Painter, use Operators to define conditional calculations. In the 

output, set the following values: water bodies = 20, snow free areas = 100, snow areas = 200: 

if (LWM == 2) then 20 else if (LWM == 1 and TC >= 25 and 0.10 < NDSI < 0.40) then 200 

else if (LWM == 1 and TC < 25 and NDSI > 0.40 and NIR > 0.11) then 200 else 100 
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5.3 Calculate the fractional snow cover map using the approach of Salomonson and Appel for all 

land areas, and set value range between 100 (snow free) and 200 (100 % snow covered): 

if (LWM = 2) then 20 else (-0.01 + 1.45 * NDSI) * 100 + 100 

5.4 Export snow layers into GeoTIFF Files. The output file name must be different from the source 

file name!  

If direct export does not work, save the snow layers in single files and export them afterwards 

into GeoTIFF files: Select the data set with the snow maps → Main Menu → Raster → Subset → 

In Tab Band Subset, select one layer → OK. 

CONGRATULATIONS!!! 

YOU SUCCESSFULLY COMPLETED ALL PROCESSING STEPS OF THE FIRST EXERCISE!!! 

Now, take a deep breath, because it’s time to start the real work:  

let’s interpret the results… 

6. Compare the results with a fractional snow cover map from MODIS data with about  

500 m pixel size in QGIS 

6.1 Start QGIS and load the generated binary and fractional snow maps (output of Step 5.4) as well 

as following raster files from the auxiliary data directory: 

• Sentinel-2 top of atmosphere reflectance data layer (bands value range: 0 – 10000): 

RGB3811_subset_of_S2A_MTD_SAFL1C_PDMC_20160429T214911_[…].tif 

• MODIS based snow and RGB maps: 

o FSC_0.005deg_201604290650_201604291155_MOD_panEU_ENVEOV2.1.00.tif 

o RGB123_FSC_0.005deg_201604290650_201604291155_MOD_panEU_ENVEOV2.1.00.tif 

o RGB651_FSC_0.005deg_201604290650_201604291155_MOD_panEU_ENVEOV2.1.00.tif 

6.2 Load specific colour styles from the auxiliary data directory for the different layers (Right Click 

on layer → Properties → Style → Tab Style in the lower left part → Load Style → navigate to 

auxiliary data and load style): 

• Sentinel-2 based snow products: FSCBIN_SNOW_color_LUT.qml 

• MODIS based snow map: FSC_panEU_color_LUT.qml 

6.3 Sort the layers into the following order: 
Top: Fractional snow map from Sentinel-2 

  Binary snow map from Sentinel-2 

RGB1183 composite of Sentinel-2 

MODIS based snow map 

  RGB651 composite of MODIS 

Bottom:  RGB321 composite of MODIS 

6.4 Intercompare (visually) the RGB composites and the high-resolution snow maps from Sentinel-

2 with these from MODIS data of the same date. 
6.5 Where are major problems (e.g. yellow or green coloured areas in the Salomonson snow map)? 

Where are major differences between the different snow products (clouds, pixel size, fractional 

vs. binary information, what is the approximate sensitivity of the binary snow detection 

approach, i.e. which fraction of snow is classified)? What are the reasons for these problems and 

differences? 
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Exercise 2: Generated wet snow maps from Sentinel-1 data over the Alps 

SAR data are independent on cloud cover or day light, but can only be used to detect wet snow cover 

extent in high alpine terrain. The method is based on the backscatter ratio of SAR images acquired at 

melting snow and at dry snow / snow free conditions (Nagler and Rott, 1999): 

𝐼𝐹 
𝜎𝑠𝑛𝑜𝑤

0

𝜎𝑟𝑒𝑓
0 < 𝑡ℎ𝑟𝑒𝑠ℎ𝑜𝑙𝑑 𝑇𝐻𝐸𝑁 𝑤𝑒𝑡 𝑠𝑛𝑜𝑤 

The method has been widely used in mountain areas above the tree line to get maps of melting snow 

cover from C- or X-band SAR data.  

In this exercise, you will use Sentinel-1 Interferometric Wide swath (IW) data over the Alps acquired 

on 29th April 2016 (melting conditions) and 30th January 2017 (dry snow conditions) with full resolution 

to detect the extent of melting snow end of April 2016. For simplicity, this exercise is based on ground 

range detection data (GRD) instead of usually used Single Look Complex (SLC) data from Sentinel-1.  

1. Import Sentinel-1 data into SNAP 

Unzip the Sentinel-1 raw file of 29th April 2016 and the subset of the Sentinel-1 file of 30th January 2017 

in the input data directory. Then start SNAP, import the Sentinel-1 data set, and get familiar with the 

radar data over the Alpine area 

1.1 Import data sets of 29th April 2016: File → Import → SAR Sensor → SENTINEL-1 → Navigate to 

the raw S1 data in the input data directory and select the manifest.safe file). 

1.2 Open the Abstracted metadata, and the amplitude and intensity bands (VV and VH) as image 

windows (right click on band → Open Image Window) 

1.3 Acquaint yourself with the SAR data set: from which side is Sentinel-1 looking at the surface? 

Which features (e.g. water bodies, cities, mountains, anything else???) can you identify? What 

are the characteristics of these features? How do regions with layover/foreshortening look like? 

TIP: Click on Main Menu → View → Synchronise Image Views to get for all open images the same 

subset in the display window. 

2. Prepare and calibrate the radar data 

Before you do anything else with radar data in SNAP, apply the orbit file and calibrate the data. 

2.1 Apply orbit file (for improved geometric accuracy) on the Sentinel-1 data: Main Menu → Radar 

→ Apply Orbit File: use the predefined processing parameters 

2.2 Calibrate the orbit corrected data of 29th April 2016: Main Menu → Radar → Radiometric → 

Calibrate → in the tab Processing Parameters, select as output the radar backscatter coefficient 

σ0 and select both, VV (co-) and VH (cross-) polarizations (STRG + left click on VV and VH) 

σ0 = RADAR BACKSCATTER COEFFICIENT:  
The normalised measure of the radar return from a 
distributed target, defined as per unit area on the 
ground. 

γ0 = RADAR BACKSCATTER COEFFICIENT:  
The normalised measure of the radar return from a 
distributed target, defined as per unit area 
perpendicular to the line of sight. 

β0 = RADAR BRIGHTNESS COEFFICIENT:  
The reflectivity per unit area in slant range.  
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3. Coregister and filter the SAR data 

3.1 Load the orbit corrected and calibrated subset of 30 January 2017 from the input directory: Main 

Menu → File → Open Product → navigate to directory with the extracted input data and select 

the file subset_0_of_S1A_IW_GRDH_1SDV_20170130T170640_[…]_Orb_Cal.dim → Open 

3.2 Coregister the data using a DEM: Main Menu → Radar → Coregistration → DEM-Assisted 

Coregistration → DEM Assisted Coregistration:  

a) Load the orbit corrected calibrated data of 29 April 2016 and 30 January 2017 

b) Select the data of 30 January 2017 as master (move on the top of the list using the arrows on 

the right side) 

c) In Tab DEM-Assisted-Coregistration, open the drop-down menu of Digital Elevation Model 

and select External DEM 

d) Click on the dots right of the External DEM field, navigate to the auxiliary data directory and 

select the EU DEM file EUDEM_ATWest_utm32wgs84_100m.tif 

e) In the tab Write, check/adapt as needed the output file name and the storage directory 

f) Click Run. 

3.3 Reduce speckle by filtering the coregistered data: Main Menu → Radar → Speckle Filtering → 

Single Product Speckle Filter. In the Processing Parameters, select all source bands, select the 

Frost filter, and test two different filter window sizes:  

a) Filter size x/y: 3 x 3, dumping factor: 2. 

b) Filter size x/y: 7 x 7, dumping factor: 2. 

3.4 Compare the filtered co- and cross-pol images with each other and with the unfiltered bands. 

4. Generate ratio images 

From the filtered bands (7x7 filter window), generate co- and cross-polarized (VV and VH) σ0 ratio 

images of the image acquired at melting conditions (29 April 2016) and the reference image acquired 

on a cold winter day (30 January 2017):  

4.1 Calculate ratios, separately for co- and cross-pol: Raster → Band Maths → define name of 

output layer and unlock “Virtual” → Edit Expression → σ0
SNOW / σ0

REFERENCE 
4.2 Compare the resulting maps. 

4.3 Convert σ0 ratios into dB: Right click on layer → Linear to/from dB → Confirm 

4.4 Convert virtual band to real layer: right click on layer → Convert band 

Save the product file! 

5. Generate layover/shadow mask and geolocate all necessary data sets 

5.1 Generate layover/shadow masks: Main Menu → Radar → Geometric → Terrain Correction → 

SAR-Simulation:  

a) Tab I/O Parameters:  

• select Speckle filtered data set with band ratios (output from Step 4.1) 

• adapt name of target product 

b) Tab Processing Parameters:  

• Select the Sigma0_VH layer of 29 April 2016 

• Digital Elevation Model: select “External DEM” from Drop-Down Menu 

• External DEM: Navigate to the data directory and select the DEM file 

EUDEM_ATWest_utm32wgs84_100m.tif 

• DEM Resampling Method: BILINEAR_INTERPOLATION 

• Activate box “Save Layover-Shadow Mask” 

c) Click Run 
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5.2 Geolocate layover/shadow mask: Main Menu → Radar → Geometric → Terrain Correction → 

Range Doppler Terrain Correction: 

a) Tab I/O Parameters: select input data set and adapt target product name 

b) Tab Processing Parameters: 

• Select the layover_shadow_mask layer 

• Digital Elevation Model: select “External DEM” from Drop-Down Menu 

• External DEM: Navigate to the data directory and select the DEM file 

EUDEM_ATWest_utm32wgs84_100m.tif 

• DEM Resampling Method: BILINEAR_INTERPOLATION 

• Map Projection: Custom CRS: Drop Down the Projection Menu, select UTM Zone 

(Geodetic Datum: WGS84); set the Projection Parameters: Zone: 32, Hemisphere: North. 

c) Click Run. 

5.3 Export shadow/layover layer into GeoTIFF: Select geolocated layover/shadow mask layer, then 

go to Main Menu → Export → GeoTIFF and save file on local disk. 

5.4 Geolocate the ratio images in dB (output from Step 4.4): Main Menu → Radar → Geometric → 

Terrain Correction → Range Doppler Terrain Correction: 

a) Tab I/O Parameters: select input data set and adapt target product name 

b) Tab Processing Parameters: 

• Select the band ratios in dB 

• Digital Elevation Model: select “External DEM” from Drop-Down Menu 

• External DEM: Navigate to the data directory and select the DEM file 

EUDEM_ATWest_utm32wgs84_100m.tif 

• DEM Resampling Method: BILINEAR_INTERPOLATION 

• Map Projection: Custom CRS: Drop Down the Projection Menu, select UTM Zone 

(Geodetic Datum: WGS84); set Projection Parameters: Zone: 32, Hemisphere: North. 

c) Click Run. 

6. Generate wet snow map 

6.1 Create histograms from the geolocated co- and cross-pol band ratios in dB: Main Menu → 

Analysis → Histogram. Set the value range between –5 and +5, using 1000 bins. 

6.2 Generate wet snow maps from geolocated co- and cross-pol band ratios in dB (output from Step 

5.4): Main Menu → Raster → Band Maths… (in the output layer, set wet snow areas = 200, dry 

snow or snow free areas = 100): 

if RATIO_POL_IN_dB < –3 then WETSNOW else SNOWFREE 

6.3 Export the wet snow maps into GeoTIFF file (if direct export does not work, or if you want to 

save the different wet snow maps in single files, follow the procedure described in Ex1 – Step 

5.4). 

 

CONGRATULATIONS!!! 

YOU SUCCESSFULLY COMPLETED ALL PROCESSING STEPS!!! 

Now, it’s time to do the real work, so let’s interpret the results… 
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7. Load generated wet snow product and FSC from optical data in QGIS and intercompare 

results 

7.1 Start QGIS and load the following raster files: 

• Wet snow maps (VH and VV) from Sentinel-1 (exported from SNAP as GeoTIFF files) 

• Radar layover/shadow mask (VH) from Sentinel-1 (exported from SNAP as GeoTIFF file) 

• From the auxiliary data directory: 

o MODIS based snow map (FSC_0.005deg_201604290650_201604291155_MOD_ 

panEU_ENVEOV2.1.00_EPSG32632_Alps_500m.tif) 

o MODIS RGB651 false colour composite (RGB651_0.005deg_201604290650_[…].tif) 

o Sentinel-2 based binary snow map (output from Exercise 1: SEB_Dozier_[…].tif) 

o Surface classification map from ESA Land Cover CCI (ESACCI_LC_L4_LCCS_Map_ 

300m_PIY_2015_v207_EPSG32632_Alps_10m.tif) 

7.2 Load specific colour styles for the different layers (Right Click on layer → Properties → Style → 

Tab Style in the lower left part → Load Style → navigate to auxiliary data and load style): 

• Wet snow maps: WET_SNOW_color_LUT.qml 

• Radar shadow/layover mask: RADAR_SHADOW_color_LUT.qml 

• Sentinel-2 based snow product: FSCBIN_SNOW_color_LUT.qml 

• MODIS based snow map: FSC_panEU_color_LUT.qml 

• Surface classification map: ESA_LC_color_LUT.qml 

For the surface classification map, set the following value ranges transparent: 0 – 49, 101 – 

209, 221 – 255 (Double click on layer, Transparency, add value ranges using the plus sign). 

You should now see only the following classes: 50 – 100: forest, 210: water, 220: permanent 

snow and ice (=glaciers). 

7.3 Sort the layers into the following order: 
Top: Surface classification map 

Radar shadow/layover mask 

Wet Snow maps from Sentinel-1 

Sentinel-2 based snow maps 

MODIS based snow map 

Bottom:  MODIS RGB651 false colour composite 

7.4 Intercompare (visually) the resulting wet snow cover products from Sentinel-1 with high-

resolution snow maps from Sentinel-2 and the medium resolution fractional snow cover map 

from MODIS data of the same date. 
Which thematic information do you get from the SAR based and the optical based snow maps? 

What are advantages / disadvantages of the SAR based snow maps compared to optical snow 

maps? How could an end user benefit from combining the SAR based and optical based snow 

maps? 

 


